CONT.SE (Função CONT.SE)

Use CONT.SE, uma das funções estatísticas, para contar o número de células que atendem a um critério; por exemplo, para contar o número de vezes que uma cidade específica aparece em uma lista de clientes.

Sintaxe

CONT.SE(intervalo, critério)

Por exemplo:

  • =CONT.SE(A2:A5;"maçãs")

  • =CONT.SE(A2:A5,A4)

Nome do argumento

Descrição

intervalo    (obrigatório)

O grupo de células que você deseja contar. Intervalo podem conter números, matrizes ou referências que contenham números. Valores em branco e de texto são ignorados.

Saiba como selecionar intervalos em uma planilha.

critérios    (obrigatório)

Um número, expressão, referência de célula ou cadeia de texto que determina quais células serão contadas.

Por exemplo, você pode usar um número como 32, uma comparação, como "> 32", uma célula como B4 ou uma palavra como "maçãs".

CONT.SE usa apenas um único critério. Use CONT.SES se você quiser usar vários critérios.

Exemplos

Para usar estes exemplos no Excel, copie os dados na tabela abaixo e cole-os na célula A1 de uma nova planilha.

Dados

Dados

maçãs

32

laranjas

54

pêssegos

75

maçãs

86

Fórmula

Descrição

=CONT.SE(A2:A5;"maçãs")

Conta o número de células com maçãs nas células A2 a A5. O resultado é 2.

=CONT.SE(A2:A5,A4)

Conta o número de células com pêssegos (usando o critério em A4) nas células A2 a A5. O resultado é 1.

=CONT.SE(A2:A5,A3)+CONT.SE(A2:A5,A2)

Conta o número com laranjas (usando o critério em A3) e maçãs (usando o critério em A2) nas células A2 a A5. O resultado é 3.

=CONT.SE(B2:B5;">55")

Conta o número de células com um valor maior do que 55 nas células B2 a B5. O resultado é 2.

=CONT.SE(B2:B5,"<>"&B4)

Conta o número de células com um valor não igual a 75 nas células B2 a B5. O E comercial (&) mescla o operador de comparação de “não é igual a” (<>) e o valor em B4 para ler =CONT.SE(B2:B5,"<> 75"). O resultado é 3.

=CONT.SE(B2:B5,">=32")-CONT.SE(B2:B5,">85")

Conta o número de células com um valor maior (>) ou igual a (=) 32 e menor ou igual a 85 nas células B2 a B5. O resultado é 3.

=CONT.SE(A2:A5,"*")

Conta o número de células contendo qualquer texto nas células A2 a A5. O asterisco (*) é usado como caractere curinga para corresponder a qualquer caractere. O resultado é 4.

=COUNT.SE(A2:A5,"?????es")

Conta o número de células que têm exatamente 7 caracteres que terminam com as letras “es” nas células A2 a A5. O ponto de interrogação (?) é usado como caractere curinga para corresponder a caracteres individuais. O resultado é 2.

Problemas comuns

Problema

O que deu errado

Valor errado retornado para cadeias de caracteres longas.

A função CONT.SE retorna valores incorretos quando você a utiliza para corresponder cadeias de caracteres com mais de 255 caracteres.

Para corresponder cadeias de caracteres de mais de 255 caracteres, use a função CONCATENAR ou o operador de concatenação &. Por exemplo, =CONT.SE (A2:A5, "texto longo" & "outra cadeia longa").

Nenhum valor retorna quando você espera um valor.

Coloque o argumento critérios entre aspas.

Práticas recomendadas

Siga este procedimento

Por quê?

Lembre-se de que CONT.SE ignora maiúsculas e minúsculas em cadeias de texto.

Critérios não fazem distinção entre maiúsculas e minúsculas. Em outras palavras, a cadeia "maçãs" e a cadeia "MAÇÃS" corresponderão às mesmas células.

Use caracteres curinga.

Caracteres curinga: o ponto de interrogação (?) e o asterisco (*) podem ser usados em critérios. Um ponto de interrogação determina qualquer caractere simples. Um asterisco determina qualquer sequência de caracteres. Se você quiser localizar um ponto de interrogação ou asterisco real, digite um til (~) antes do caractere.

Por exemplo, =CONT.SE(A2:A5,"maça?") contará todas as instâncias de "maça" com uma última letra poderia variar.

Verifique se seus dados não contêm caracteres equivocados.

Ao contar valores de texto, verifique se os dados não contêm espaços à esquerda, à direita, se usam de modo inconsistente as aspas normais e as curvas ou têm caracteres não imprimíveis. Nesses casos, a função CONT.SE poderá retornar um valor inesperado.

Talvez seja necessário remover espaços à direita em uma célula depois dos valores da tabela para obter resultados precisos. Tente usar a função TIRAR ou a função ARRUMAR.

Relacionado

Aplicável a:



Essas informações foram úteis?

Sim Não

Como podemos melhorá-lo?

255 caracteres restantes

Para proteger sua privacidade, não inclua informações de contato em seus comentários. Avalie nosso política de privacidade.

Obrigado por seus comentários!

Recursos de suporte

Alterar idioma