Avaliar uma fórmula aninhada uma etapa de cada vez

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Às vezes, é difícil entender como uma formula aninhada calcula o resultado final, pois existem diversos cálculos intermediários e testes lógicos. No entanto, usando a caixa de diálogo Avaliar Fórmula, você pode conferir as várias partes de uma fórmula aninhada, avaliada na ordem em que a fórmula é calculada. Por exemplo, a fórmula =SE(MÉDIA(F2:F5)>50,SOMA(G2:G5),0) é mais fácil entender quando você pode ver os seguintes resultados intermediários:

Etapas mostradas na caixa de diálogo

Descrição

=SE(MÉDIA(F2:F5)>50,SOMA(G2:G5),0)

A fórmula aninhada é exibida inicialmente. As funções MÉDIA e SOMA são aninhas dentro da função SE.

=SE(40>50,SOMA(G2:G5),0)

O intervalo de células F2:F5 contém os valores 55, 35, 45 e 25; portanto, o resultado da função MÉDIA(F2:F5) é 40.

=SE(FALSO,SOMA(G2:G5),0)

40 não é maior do que 50, portanto, a expressão no primeiro argumento da função se (o argumento teste_lógico) é falsa.

0

A função se retorna o valor do terceiro argumento (o argumento valor_se_falso). A função soma não será avaliada porque ele é o segundo argumento da função se (argumento valor_se_verdadeiro) e é retornado somente quando a expressão for verdadeira.

  1. Selecione a célula que deseja avaliar. Apenas uma célula por vez pode ser avaliada.

  2. Na guia Fórmulas, vá até o grupo Auditoria de Fórmulas e clique em Avaliar Fórmula.

    The Formula Auditing group on the Formulas tab

  3. Clique em Avaliar para examinar o valor da referência sublinhada. O resultado da avaliação é mostrado em itálico.

    Se a parte sublinhada da fórmula for uma referência a outra fórmula, clique em Depuração total para exibir a outra fórmula na caixa Avaliação. Clique em Depuração circular para retornar à célula e fórmula anteriores.

    Observação : O botão Depuração total não estará disponível na segunda vez em que a referência for exibida na fórmula ou se a fórmula fizer referência a uma célula em uma pasta de trabalho separada.

  4. Continue até que todas as partes da fórmula sejam avaliadas.

  5. Para conferir novamente a avaliação, clique em Reiniciar.

    Para finalizar a avaliação, clique em Fechar.

    Observações : 

    • Algumas partes de fórmulas que usá-lo e escolha funções não são avaliadas e # n/d é exibido na caixa avaliação.

    • Quando a referência estiver em branco, o valor zero (0) é exibido na caixa de Avaliação.

    • As funções a seguir são recalculadas cada vez que a planilha é alterada e podem causar a Avaliar fórmula forneça resultados diferentes dos que são exibidos na célula: aleatório, áreas, índice, DESLOC, CÉLULA, indireto, LINS, cols, agora, hoje, ALEATÓRIOENTRE.

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×