Avaliar uma fórmula aninhada uma etapa de cada vez

Às vezes, é difícil entender como uma fórmula aninhada calcula o resultado final, pois existem diversos cálculos intermediários e testes lógicos. No entanto, usando a caixa de diálogo Avaliar Fórmula, você pode conferir as várias partes de uma fórmula aninhada, avaliada na ordem em que a fórmula é calculada. Por exemplo, a fórmula = se (média (F2: F5) >50, soma (G2: G5), 0) é mais fácil de entender quando você pode ver os seguintes resultados intermediários:

Etapas mostradas na caixa de diálogo

Descrição

=SE(MÉDIA(F2:F5)>50;SOMA(G2:G5);0)

A fórmula aninhada é exibida inicialmente. As funções MÉDIA e SOMA são aninhas dentro da função SE.

=SE(40>50;SOMA(G2:G5);0)

O intervalo de células F2:F5 contém os valores 55, 35, 45 e 25; portanto, o resultado da função MÉDIA(F2:F5) é 40.

=SE(FALSOSOMA(G2:G5);0)

40 não é maior do que 50, portanto, a expressão no primeiro argumento da função se (o argumento teste_lógico) é falsa.

0

A função se retorna o valor do terceiro argumento (o argumento valor_se_falso). A função soma não é avaliada porque é o segundo argumento da função se (argumento valor_se_verdadeiro) e é retornada apenas quando a expressão é verdadeira.

  1. Selecione a célula que deseja avaliar. Apenas uma célula por vez pode ser avaliada.

  2. Na guia Fórmulas, vá até o grupo Auditoria de Fórmulas e clique em Avaliar Fórmula.

    O grupo Auditoria de Fórmulas na guia Fórmulas

  3. Clique em Avaliar para examinar o valor da referência sublinhada. O resultado da avaliação é mostrado em itálico.

    Se a parte sublinhada da fórmula for uma referência a outra fórmula, clique em Depuração total para exibir a outra fórmula na caixa Avaliação. Clique em Depuração circular para retornar à célula e fórmula anteriores.

    Observação: O botão Depuração total não estará disponível na segunda vez em que a referência for exibida na fórmula ou se a fórmula fizer referência a uma célula em uma pasta de trabalho separada.

  4. Continue até que todas as partes da fórmula sejam avaliadas.

  5. Para conferir novamente a avaliação, clique em Reiniciar.

    Para finalizar a avaliação, clique em Fechar.

    Observações: 

    • Algumas partes de fórmulas que usam as funções se e escolher não são avaliadas e #N/A é exibido na caixa de avaliação .

    • Quando a referência estiver em branco, o valor zero (0) é exibido na caixa Avaliação.

    • Fórmulas com referências circulares podem não ser avaliadas como esperado. Se forem desejadas referências circulares, você poderá habilitar o cálculo iterativo.

    • As funções a seguir são recalculadas cada vez que a planilha é alterada e podem fazer com que a ferramenta avaliar fórmula forneça resultados diferentes dos exibidos na célula: aleatório, offset, célula, indireto, agora, hoje, RANDBETWEEN, informações e SOMASE (em alguns cenários).

Observação:  Esta página foi traduzida automaticamente e pode apresentar erros gramaticais ou imprecisões. Nosso objetivo é que este conteúdo seja útil para você. Você pode nos dizer se as informações foram úteis? Use o artigo em inglês como referência.​

Consulte Também

Como evitar fórmulas quebradas

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×