Atualizar uma conexão de dados externos

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Você pode conectar a sua pasta de trabalho do Excel a uma fonte de dados externas, como um banco de dados do SQL Server, um cubo OLAP ou até mesmo outra pasta de trabalho do Excel. Esta conexão pode ser exibida na pasta de trabalho como uma tabela, relatório de Tabela Dinâmica ou de Gráfico Dinâmico.

Você pode manter os dados da sua pasta de trabalho atualizados ao "atualizar" o link da fonte. Todas as vezes em que a conexão for atualizada, você verá os dados mais recentes, incluindo tudo o que for novo ou tiver sido excluído.

Início da página

Atualizar dados de uma consulta do Microsoft Query, do Assistente para Conexão de Dados ou de uma consulta à Web

  1. Clique em qualquer célula do intervalo ou tabela que contenha o link para dos dados externos.

  2. Clique em dados > conexões e clique na seta ao lado de Atualizar tudo.

Atualizar Conexão de Dados

  1. Para atualizar apenas os dados selecionados, clique em Atualizar.

Você também pode clicar com o botão direito do mouse em uma célula no intervalo ou tabela e clicar em Atualizar.

  1. Para atualizar todas as conexões de dados na pasta de trabalho, clique em Atualizar Tudo.

Observação : Se você tiver mais de uma pasta de trabalho aberta, deverá repetir a operação em cada uma delas.

Início da página

Atualizar dados de um arquivo de texto importado

  1. Clique em qualquer célula no intervalo ou tabela que contenha o link para o arquivo de texto importado.

  2. Na guia Dados , no grupo Conexões , clique na seta ao lado de Atualizar Tudo.

Atualizar Conexão de Dados

  1. Para atualizar apenas os dados selecionados, clique em Atualizar.

  2. Para atualizar todas as conexões de dados na pasta de trabalho, clique em Atualizar Tudo.

Você também pode clicar com o botão direito do mouse em uma célula no intervalo ou tabela e clicar em Atualizar.

  1. Na caixa de diálogo Importar Arquivo de Texto, navegue pelo arquivo de texto e clique em Importar..

Início da página

Atualizar dados do Power Pivot

  1. Na guia Dados , no grupo Conexões , clique em Conexões.

conexões de dados

  1. Na caixa de diálogo Conexões da Pasta de Trabalho , escolha a conexão para os dados do Power Pivot e clique em Atualizar.

Início da página

Atualizar um arquivo de cubo offline

Atualizar um arquivo de cubo offline, operação que recria o arquivo com os dados mais recentes do cubo do servidor, pode ser demorado e exigir muito espaço temporário no disco. Inicie o processo em um momento em que você não precise de acesso imediato a outros arquivos no Excel e verifique se existe espaço adequado no disco para salvar o arquivo novamente.

  1. Clique na Tabela Dinâmica conectada ao arquivo de cubo offline.

  2. Na guia Dados e Conexões, clique na seta ao lado de Atualizar Tudo e clique em Atualizar.

    Atualizar Conexão de Dados

Início da página

Atualizar dados em um arquivo XML importado

  1. Na planilha, clique em uma célula mapeada para selecionar o mapa XML que você deseja atualizar.

  2. Se a guia Desenvolvedor não estiver disponível, faça o seguinte para exibi-la:

    1. Clique na guia Arquivo e Opções.

    2. Clique em Personalizar Faixa de Opções, e em Guias Principais, marque a caixa de seleção Desenvolvedor.

    3. Clique em OK.

  3. Na guia Desenvolvedor, no grupo XML, clique em Atualizar Dados.

    Atualizar Dados XML

Início da página

Atualizar dados automaticamente ao abrir uma pasta de trabalho

Você pode atualizar um intervalo de dados externos automaticamente ao abrir a pasta de trabalho. Opcionalmente, pode salvar a pasta de trabalho sem salvar os dados externos para encolher o tamanho do arquivo.

  1. Clique em uma célula no intervalo de dados externos.

  2. Clique em dados > conexões, clique na seta ao lado de Atualizar tudo e clique em Propriedades da Conexão.

Propriedades da Conexão

  1. Clique na guia Uso.

  2. Em Controle de atualização, marque a caixa de seleção Atualizar dados ao abrir o arquivo.

  3. Se desejar salvar a pasta de trabalho com a definição da consulta, mas sem os dados externos, marque a caixa de seleção Remover dados do intervalo de dados externos antes de salvar a pasta de trabalho.

Início da página

Atualizar dados automaticamente a intervalos regulares

  1. Clique em uma célula no intervalo de dados externos.

  2. Clique em Dados e Conexões, clique na seta ao lado de Atualizar Tudo e clique em Propriedades da Conexão.

Propriedades da Conexão

  1. Clique na guia Uso.

  2. Marque a caixa de seleção Atualizar a cada e insira o número de minutos entre cada operação de atualização.

Início da página

Exigir uma senha para atualizar um intervalo de dados externos

As senhas armazenadas não são criptografadas e não são recomendadas. Caso a sua fonte de dados necessite de uma password para conexão, você pode solicitar que os usuários digitem a senha antes que possam atualizar o intervalo de dados externos. O procedimento a seguir não se aplica a dados recuperados de um arquivo de texto (.txt) ou de uma consulta à Web (.iqy).

Use senhas fortes que combinem letras maiúsculas e minúsculas, números e símbolos. Senhas fracas não misturam esse elementos. Senha forte: Y6dh!et5. Senha fraca: Casa27. As senhas devem ter 8 ou mais caracteres. Uma frase secreta com 14 ou mais caracteres é melhor.

É fundamental que você se lembre da sua senha. Caso você a esqueça, a Microsoft não poderá recuperá-la. Guarde as senhas que anotar por escrito em um lugar seguro, longe das informações que elas ajudam a proteger.

  1. Clique em uma célula no intervalo de dados externos.

  2. Clique em Dados e Conexões, clique na seta ao lado de Atualizar Tudo e clique em Propriedades da Conexão.

Propriedades da Conexão

  1. Clique na guia Definição.

  2. Desmarque a caixa de seleção Salvar senha.

Observação : O Excel solicita a senha apenas na primeira vez que o intervalo de dados externos é atualizado em cada sessão do Excel. Na próxima vez que você iniciar o Excel, a senha será solicitada novamente se você abrir a pasta de trabalho que contém a consulta e tentar executar uma operação de atualização.

Início da página

Executar uma consulta em segundo plano ou enquanto você aguarda

Para conjuntos de dados muito grandes, considere a possibilidade de executar uma atualização em segundo plano. Isso retornará o controle do Excel a você em vez de fazê-lo esperar vários minutos até a atualização ser concluída.

  1. Clique em uma célula no intervalo de dados externos.

  2. Clique em Dados e Conexões, clique na seta ao lado de Atualizar Tudo e clique em Propriedades da Conexão.

    Observações : 

    • Não é possível executar uma consulta OLAP em segundo plano.

    • Não é possível executar uma consulta em qualquer tipo de conexão que recupe dados do Modelo de Dados.

Propriedades da Conexão

  1. Clique na guia Uso.

  2. Marque a caixa de seleção Habilitar atualização em segundo plano para executar a consulta em segundo plano. Desmarque-a para executar a consulta enquanto você espera.

Observação : Enquanto você grava uma macro que inclui uma consulta, o Excel não executa a consulta em segundo plano. Para alterar a macro gravada para que a consulta é executado em segundo plano, edite a macro a Visual Basic Editor. Alterar o método de atualização do objeto deBackgroundQuery: = False para BackgroundQuery: = True. Para obter informações sobre como editar macros, consulte Visual Basic para Applications ajuda.

Início da página

Cancelar ou verificar o status de uma atualização

Se sua pasta de trabalho estiver conectada a uma fonte de dados grande, a atualização poderá demorar um pouco mais do que você espera. Para conferir como está a atualização ou cancelá-la, siga um destes procedimentos:

  • Verificar o status de uma consulta    Uma mensagem aparece na barra de status do Excel para indicar que a consulta está sendo executada. Clique duas vezes na mensagem para verificar o status da consulta.

  • Interromper uma atualização em segundo plano    Para interromper uma consulta que está sendo executada em segundo plano, clique duas vezes na mensagem de status da consulta na barra de status para exibir a caixa de diálogo Status da atualização de dados externos e clique em Parar Atualização.

  • Interromper uma consulta    Para interromper a execução de uma consulta quando a atualização em segundo plano estiver desativada, pressione a tecla Esc.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×