Assinar digitalmente o projeto de macro

Este artigo descreve como você pode assinar digitalmente as macros usando um certificado. Caso ainda não tenha um certificado digital, deverá obter um. Para testar os projetos de macro em seu próprio computador, crie seu próprio certificado de autenticação usando a ferramenta Selfcert.exe.

Você pode obter um certificado digital de uma Autoridade de Certificação (CA), comercial, do administrador de segurança interno ou do profissional de tecnologia da informação (TI).

Para saber mais sobre as Autoridades de Certificação que oferecem serviços para produtos da Microsoft, consulte a lista de membros do Microsoft Root Certificate Program.

Início da Página

Como um certificado digital criado por você não é emitido por uma autoridade de certificação oficial, os projetos de macro assinados usando esse tipo de certificado são denominados projetos autoassinados. O Microsoft Office confia em um certificado autoassinado somente em um computador que tenha esse certificado adicionado à pasta Trusted Root Certificação Raiz Confiável no repositório Certificados – Usuário Atual.

Para saber como criar certificados de autoassinatura, veja a seção a seguir.

  1. Vá para C:\Arquivos de Programas (x86)\Microsoft Office\raiz\.

  2. Clique em SelfCert.exe. A caixa de diálogo Criar Certificado Digital é exibida.

  3. Na caixa O nome do seu certificado, digite um nome descritivo para o certificado.

  4. Clique em OK.

  5. Quando a mensagem Êxito ao Criar SelfCert for exibida, clique em OK.

  1. Vá para C:\Arquivos de Programas\Microsoft Office\<versão do Office>\.

  2. Clique em SelfCert.exe. A caixa de diálogo Criar Certificado Digital é exibida.

  3. Na caixa O nome do seu certificado, digite um nome descritivo para o certificado.

  4. Clique em OK.

  5. Quando a mensagem Êxito ao Criar SelfCert for exibida, clique em OK.

  1. Clique em Iniciar, passe o cursor sobre Todos os Programas, clique em Microsoft Office, em Ferramentas do Microsoft Office e em Certificado Digital para Projetos do VBA.
    A caixa de diálogo Criar Certificado Digital é exibida.

  2. Na caixa O nome do seu certificado, digite um nome descritivo para o certificado.

  3. Clique em OK.

  4. Quando a mensagem Êxito ao Criar SelfCert for exibida, clique em OK.

Caixa de diálogo Criar Assinatura Digital

Para exibir o certificado no repositório Certificados Pessoais, siga este procedimento:

  1. Abra o Internet Explorer.

  2. No menu Ferramentas, clique em Opções da Internet e, em seguida, clique na guia Conteúdo.

  3. Clique em Certificados e, em seguida, clique na guia Pessoal.

Início da Página

  1. Abra o arquivo que contém o projeto de macro que você deseja assinar.

  2. Na guia Desenvolvedor, no grupo Código, clique em Visual Basic.

    Observação : Se a guia Desenvolvedor não estiver disponível: clique na guia Arquivo. Clique em Opções. Clique em Personalizar Faixa de Opções. Na lista Personalizar a Faixa de Opções, clique em Desenvolvedor e em OK.

  3. No Visual Basic, no menu Ferramentas, clique em Assinatura Digital.

  4. A caixa de diálogo Assinatura Digital será exibida.

  5. Selecione um certificado e clique em OK.

    Observação : Se você não tiver selecionado um certificado digital ou desejar usar outro, clique em Escolher. Selecione um certificado e clique em OK.

    Observações : 

    • É recomendável que você assine macros apenas depois que a sua solução tiver sido testada e estiver pronta para distribuição: quando o código em um projeto de macro assinado é alterado de qualquer maneira, sua assinatura digital é removida. Entretanto, se você tiver o certificado digital válido que foi usado anteriormente para assinar o projeto no computador, o projeto de macro será automaticamente assinado outra vez, quando for salvo.

    • Se desejar impedir que os usuários de sua solução alterem acidentalmente seu projeto de macro e invalidem sua assinatura, bloqueie o projeto antes de assiná-lo. Sua assinatura digital indica apenas que você garante que o projeto não foi adulterado desde a assinatura. Ela não prova que você criou o projeto. Portanto, o bloqueio do projeto de macro não impedirá que outros usuários substituam sua assinatura digital por outra. Os administradores corporativos vão poder assinar novamente os modelos e os suplementos para poderem controlar aquilo que os usuários executam nos computadores.

    • Se você criar um suplemento que adicione código a um projeto de macro, o código deverá determinar se o projeto será assinado digitalmente e notificar os usuários das consequências de qualquer alteração em um projeto assinado antes que eles prossigam.

    • Ao assinar macros digitalmente, é importante obter um carimbo de data/hora para que outros usuários possam verificar sua assinatura se o certificado usado para a assinatura tiver expirado ou revogado depois da assinatura. Se você assinar as macros sem o carimbo, a assinatura permanecerá válida somente durante o período de validade do certificado.

Início da Página

Você pode obter um certificado digital de uma AC (Autoridade de Certificação) comercial ou de um administrador de segurança.

Para saber mais sobre as Autoridades de Certificação que oferecem serviços para produtos da Microsoft, consulte a lista de membros do Microsoft Root Certificate Program.

Início da Página

Como um certificado digital criado por você não é emitido por uma autoridade de certificação oficial, os projetos de macro assinados através da utilização desse tipo de certificado são denominados projetos autoassinados. O Microsoft Office confia em certificados autoassinados somente em computadores que tenham esses certificados adicionados no repositório Certificados Pessoais.

  1. Clique no botão Iniciar, passe o cursor sobre Todos os Programas, clique em Microsoft Office, em Ferramentas do Microsoft Office e em Certificado Digital para Projetos do VBA. Na caixa O nome do seu certificado, digite um nome descritivo para o certificado.

  2. Quando a mensagem de confirmação do certificado for exibida, clique em OK.

Para exibir o certificado no repositório Certificados Pessoais, siga este procedimento:

  1. Abra o Internet Explorer.

  2. No menu Ferramentas, clique em Opções da Internet e, em seguida, clique na guia Conteúdo.

  3. Clique em Certificados e, em seguida, clique na guia Pessoal.

Início da Página

  1. Clique no botão Iniciar, passe o cursor sobre Todos os Programas, Microsoft Office, Ferramentas do Microsoft Office e clique em Certificado Digital para Projetos do VBA. Na caixa O nome do seu certificado, digite um nome descritivo para o certificado.

  2. Quando a mensagem de confirmação do certificado for exibida, clique em OK.

Para exibir o certificado no repositório Certificados Pessoais, siga este procedimento:

  1. Abra o Internet Explorer

  2. No menu Ferramentas, clique em Opções da Internet e, em seguida, clique na guia Conteúdo.

  3. Clique em Certificados e, em seguida, clique na guia Pessoal.

Início da Página

  1. Abra o arquivo que contém o projeto de macro que você deseja assinar.

    • Na guia Desenvolvedor, no grupo Código, clique em Visual Basic.

      Caso a guia Desenvolvedor não esteja disponível, clique no Botão do Microsoft Office Imagem do botão Office e em Opções do Excel. Em seguida, clique em Preencher e marque a caixa de seleção Mostrar a guia Desenvolvedor na Faixa de Opções.

      Observação : A Faixa de Opções faz parte da Interface de usuário do Microsoft Office Fluent.

  2. No Explorador do Projeto do Visual Basic, escolha o projeto que deseja assinar.

  3. No menu Ferramentas, clique em Assinatura Digital.

  4. Siga um destes procedimentos:

    • Se não selecionou um certificado digital ou se desejar usar um outro, clique em Escolher, escolha um certificado e clique em OK duas vezes.

    • Para usar o certificado atual, clique em OK.

      Observações : 

      • Assine as macros apenas quando a solução for testada e estiver pronta para distribuição, pois sempre que o código é alterado de qualquer maneira em um projeto de macro assinado, a assinatura digital é removida. No entanto, se você tiver o certificado digital válido que foi usado anteriormente para assinar o projeto no computador, o projeto de macro será automaticamente assinado novamente quando salvá-lo.

      • Caso pretenda impedir os usuários da solução de alterar acidentalmente o projeto de macro e invalidar a assinatura, bloqueie o projeto antes de assiná-lo. A assinatura digital indica apenas que você garante que o projeto não foi adulterado após a assinatura. Ela não prova que você criou o projeto. Portanto, o bloqueio do projeto de macro não impedirá que outros usuários substituam a assinatura digital por uma outra. Os administradores corporativos podem assinar novamente os modelos e os suplementos a fim de controlar com precisão aquilo que os usuários executam nos computadores.

      • Se você criar um suplemento que adicione código a um projeto de macro, o código deverá determinar se o projeto será assinado digitalmente e notificar os usuários das consequências de qualquer alteração em um projeto assinado antes que eles prossigam.

      • Ao assinar macros digitalmente, é importante obter um carimbo de data/hora para que outros usuários possam verificar a assinatura, mesmo que o certificado usado para a assinatura tenha expirado. Quando você assina as macros sem o carimbo, a assinatura permanece válida somente durante o período de validade do certificado.

  1. Abra o arquivo que contém o projeto de macro que você deseja assinar.

    • No menu Ferramentas, passe o cursor sobre Macro e clique em Editor do Visual Basic.

  2. No Explorador do Projeto do Visual Basic, escolha o projeto que deseja assinar.

  3. No menu Ferramentas, clique em Assinatura Digital.

  4. Siga um destes procedimentos:

    • Se não selecionou um certificado digital ou se desejar usar um outro, clique em Escolher, escolha um certificado e clique em OK duas vezes.

    • Para usar o certificado atual, clique em OK.

      Observações : 

      • Assine as macros apenas quando a solução for testada e estiver pronta para distribuição, pois sempre que o código é alterado de qualquer maneira em um projeto de macro assinado, a assinatura digital é removida. No entanto, se você tiver o certificado digital válido que foi usado anteriormente para assinar o projeto no computador, o projeto de macro será automaticamente assinado novamente quando salvá-lo.

      • Caso pretenda impedir os usuários da solução de alterar acidentalmente o projeto de macro e invalidar a assinatura, bloqueie o projeto antes de assiná-lo. A assinatura digital indica apenas que você garante que o projeto não foi adulterado após a assinatura. Ela não prova que você criou o projeto. Portanto, o bloqueio do projeto de macro não impedirá que outros usuários substituam a assinatura digital por uma outra. Os administradores corporativos podem assinar novamente os modelos e os suplementos a fim de controlar com precisão aquilo que os usuários executam nos computadores.

      • Se você criar um suplemento que adicione código a um projeto de macro, o código deverá determinar se o projeto será assinado digitalmente e notificar os usuários das consequências de qualquer alteração em um projeto assinado antes que eles prossigam.

      • Ao assinar macros digitalmente, é importante obter um carimbo de data/hora para que outros usuários possam verificar a assinatura, mesmo que o certificado usado para a assinatura tenha expirado. Quando você assina as macros sem o carimbo, a assinatura permanece válida somente durante o período de validade do certificado.

Início da Página

  1. Abra o arquivo que contém o projeto de macro que você deseja assinar.

    • Na guia Desenvolvedor, no grupo Código, clique em Visual Basic.

      Caso a guia Desenvolvedor não esteja disponível, clique no Botão do Microsoft Office Imagem do botão Office e em Opções do PowerPoint. Em seguida, clique em Preencher e marque a caixa de seleção Mostrar a guia Desenvolvedor na Faixa de Opções.

      Observação : A Faixa de Opções faz parte da Interface de usuário do Microsoft Office Fluent.

  2. No Explorador do Projeto do Visual Basic, escolha o projeto que deseja assinar.

  3. No menu Ferramentas, clique em Assinatura Digital.

  4. Siga um destes procedimentos:

    • Se não selecionou um certificado digital ou se desejar usar um outro, clique em Escolher, escolha um certificado e clique em OK duas vezes.

    • Para usar o certificado atual, clique em OK.

      Observações : 

      • Assine as macros apenas quando a solução for testada e estiver pronta para distribuição, pois sempre que o código é alterado de qualquer maneira em um projeto de macro assinado, a assinatura digital é removida. No entanto, se você tiver o certificado digital válido que foi usado anteriormente para assinar o projeto no computador, o projeto de macro será automaticamente assinado novamente quando salvá-lo.

      • Caso pretenda impedir os usuários da solução de alterar acidentalmente o projeto de macro e invalidar a assinatura, bloqueie o projeto antes de assiná-lo. A assinatura digital indica apenas que você garante que o projeto não foi adulterado após a assinatura. Ela não prova que você criou o projeto. Portanto, o bloqueio do projeto de macro não impedirá que outros usuários substituam a assinatura digital por uma outra. Os administradores corporativos podem assinar novamente os modelos e os suplementos a fim de controlar com precisão aquilo que os usuários executam nos computadores.

      • Se você criar um suplemento que adicione código a um projeto de macro, o código deverá determinar se o projeto será assinado digitalmente e notificar os usuários das consequências de qualquer alteração em um projeto assinado antes que eles prossigam.

      • Ao assinar macros digitalmente, é importante obter um carimbo de data/hora para que outros usuários possam verificar a assinatura, mesmo que o certificado usado para a assinatura tenha expirado. Quando você assina as macros sem o carimbo, a assinatura permanece válida somente durante o período de validade do certificado.

Início da Página

  1. Abra o arquivo que contém o projeto de macro que você deseja assinar.

    • No menu Ferramentas, passe o cursor sobre Macro e clique em Editor do Visual Basic.

  2. No Explorador do Projeto do Visual Basic, escolha o projeto que deseja assinar.

  3. No menu Ferramentas, clique em Assinatura Digital.

  4. Siga um destes procedimentos:

    • Se não selecionou um certificado digital ou se desejar usar um outro, clique em Escolher, escolha um certificado e clique em OK duas vezes.

    • Para usar o certificado atual, clique em OK.

      Observações : 

      • Assine as macros apenas quando a solução for testada e estiver pronta para distribuição, pois sempre que o código é alterado de qualquer maneira em um projeto de macro assinado, a assinatura digital é removida. No entanto, se você tiver o certificado digital válido que foi usado anteriormente para assinar o projeto no computador, o projeto de macro será automaticamente assinado novamente quando salvá-lo.

      • Caso pretenda impedir os usuários da solução de alterar acidentalmente o projeto de macro e invalidar a assinatura, bloqueie o projeto antes de assiná-lo. A assinatura digital indica apenas que você garante que o projeto não foi adulterado após a assinatura. Ela não prova que você criou o projeto. Portanto, o bloqueio do projeto de macro não impedirá que outros usuários substituam a assinatura digital por uma outra. Os administradores corporativos podem assinar novamente os modelos e os suplementos a fim de controlar com precisão aquilo que os usuários executam nos computadores.

      • Se você criar um suplemento que adicione código a um projeto de macro, o código deverá determinar se o projeto será assinado digitalmente e notificar os usuários das consequências de qualquer alteração em um projeto assinado antes que eles prossigam.

      • Ao assinar macros digitalmente, é importante obter um carimbo de data/hora para que outros usuários possam verificar a assinatura, mesmo que o certificado usado para a assinatura tenha expirado. Quando você assina as macros sem o carimbo, a assinatura permanece válida somente durante o período de validade do certificado.

Início da Página

  1. Abra o arquivo que contém o projeto de macro que você deseja assinar.

    • No menu Ferramentas, passe o cursor sobre Macro e clique em Editor do Visual Basic.

  2. No Explorador do Projeto do Visual Basic, escolha o projeto que deseja assinar.

  3. No menu Ferramentas, clique em Assinatura Digital.

  4. Siga um destes procedimentos:

    • Se não selecionou um certificado digital ou se desejar usar um outro, clique em Escolher, escolha um certificado e clique em OK duas vezes.

    • Para usar o certificado atual, clique em OK.

      Observações : 

      • Assine as macros apenas quando a solução for testada e estiver pronta para distribuição, pois sempre que o código é alterado de qualquer maneira em um projeto de macro assinado, a assinatura digital é removida. No entanto, se você tiver o certificado digital válido que foi usado anteriormente para assinar o projeto no computador, o projeto de macro será automaticamente assinado novamente quando salvá-lo.

      • Caso pretenda impedir os usuários da solução de alterar acidentalmente o projeto de macro e invalidar a assinatura, bloqueie o projeto antes de assiná-lo. A assinatura digital indica apenas que você garante que o projeto não foi adulterado após a assinatura. Ela não prova que você criou o projeto. Portanto, o bloqueio do projeto de macro não impedirá que outros usuários substituam a assinatura digital por uma outra. Os administradores corporativos podem assinar novamente os modelos e os suplementos a fim de controlar com precisão aquilo que os usuários executam nos computadores.

      • Se você criar um suplemento que adicione código a um projeto de macro, o código deverá determinar se o projeto será assinado digitalmente e notificar os usuários das consequências de qualquer alteração em um projeto assinado antes que eles prossigam.

      • Ao assinar macros digitalmente, é importante obter um carimbo de data/hora para que outros usuários possam verificar a assinatura, mesmo que o certificado usado para a assinatura tenha expirado. Quando você assina as macros sem o carimbo, a assinatura permanece válida somente durante o período de validade do certificado.

  1. Abra o arquivo que contém o projeto de macro que você deseja assinar.

    • Na guia Desenvolvedor, no grupo Código, clique em Visual Basic.

      Caso a guia Desenvolvedor não esteja disponível, clique no Botão do Microsoft Office Imagem do botão Office e em Opções do Word. Em seguida, clique em Preencher e marque a caixa de seleção Mostrar a guia Desenvolvedor na Faixa de Opções.

      Observação : A Faixa de Opções faz parte da Interface de usuário do Microsoft Office Fluent.

  2. No Explorador do Projeto do Visual Basic, escolha o projeto que deseja assinar.

  3. No menu Ferramentas, clique em Assinatura Digital.

  4. Siga um destes procedimentos:

    • Se não selecionou um certificado digital ou se desejar usar um outro, clique em Escolher, escolha um certificado e clique em OK duas vezes.

    • Para usar o certificado atual, clique em OK.

      Observações : 

      • Assine as macros apenas quando a solução for testada e estiver pronta para distribuição, pois sempre que o código é alterado de qualquer maneira em um projeto de macro assinado, a assinatura digital é removida. No entanto, se você tiver o certificado digital válido que foi usado anteriormente para assinar o projeto no computador, o projeto de macro será automaticamente assinado novamente quando salvá-lo.

      • Caso pretenda impedir os usuários da solução de alterar acidentalmente o projeto de macro e invalidar a assinatura, bloqueie o projeto antes de assiná-lo. A assinatura digital indica apenas que você garante que o projeto não foi adulterado após a assinatura. Ela não prova que você criou o projeto. Portanto, o bloqueio do projeto de macro não impedirá que outros usuários substituam a assinatura digital por uma outra. Os administradores corporativos podem assinar novamente os modelos e os suplementos a fim de controlar com precisão aquilo que os usuários executam nos computadores.

      • Se você criar um suplemento que adicione código a um projeto de macro, o código deverá determinar se o projeto será assinado digitalmente e notificar os usuários das consequências de qualquer alteração em um projeto assinado antes que eles prossigam.

      • Ao assinar macros digitalmente, é importante obter um carimbo de data/hora para que outros usuários possam verificar a assinatura, mesmo que o certificado usado para a assinatura tenha expirado. Quando você assina as macros sem o carimbo, a assinatura permanece válida somente durante o período de validade do certificado.

Início da Página

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×