Aninhar uma função dentro de uma função

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Quando você cria uma fórmula usando uma função, você pode aninhar funções dentro de outras funções. Quando você fizer, você estiver usando os resultados das funções aninhadas como argumentos— partes de dados a primeira função precisa ser executado corretamente. Você sempre pode saber quando uma função estiver aninhada porque ele é dentro dos parênteses.

Aqui está um exemplo. A função SE usa as funções aninhadas MÉDIA e SOMA como argumentos.

=SE(MÉDIA(F2:F5)>50,SOMA(G2:G5),0)

Você pode ler essa fórmula da esquerda para a direita. SE o valor médio das células F2 a F5 for maior que 50, a SOMA será os valores nas células de G2 a G5. Caso contrário, 0 será retornado.

Você pode aninhar até 64 níveis de funções e inseri-las como qualquer outra função:

  1. Clique na célula que conterá a fórmula.

  2. Insira a fórmula na barra de fórmulas e pressione Enter.

Veja outro exemplo. Aqui, uma função SE é aninhada dentro de outra função SE para calcular deduções com base no nível de renda.

=SE(A5<31500,A5*15%,SE(A5<72500,A5*25%,A5*28%))

Você também pode ler esse exemplo da esquerda para a direita. SE o valor na célula A5 for menor que 31.500, multiplique-o por 15%. Mas, SE não for, verifique se ele é menor que 72.500. SE for menor, multiplique-o por 25%, caso contrário, multiplique por 28%.

Observe que níveis de renda não usam vírgulas. Se usassem, a função SE tentaria usá-las como argumentos, e a fórmula ficaria corrompida.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×