Adicionar uma conexão de dados a uma biblioteca ou lista de documentos SharePoint

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

Você pode adicionar uma ou mais conexões de dados secundária para o modelo de formulário que pode tanto dados de consulta de uma lista ou biblioteca de documentos ou enviar dados para uma biblioteca de documentos em um servidor executando o Microsoft Windows SharePoint Services.

Neste artigo

Visão Geral

Antes de começar

Adicionar uma conexão de dados de consulta

Adicionar uma conexão de dados de envio

Visão Geral

Uma conexão de dados secundária é qualquer conexão de dados a uma fonte de dados externos que você adiciona a um modelo de formulário. Esta conexão de dados é diferente da conexão de dados principal que é criada quando você cria um modelo de formulário com base em um banco de dados, serviço da Web ou configurações em uma biblioteca de conexão. Você adiciona uma conexão de dados secundária somente se você não pode consultar ou enviar dados através da conexão de dados principal.

Quando você adiciona uma conexão de dados secundária para seu modelo de formulário que dados de consultas, o Microsoft Office InfoPath criam um secundário fonte de dados com grupos e campos de dados que corresponde da maneira que os dados são armazenados na biblioteca de documentos ou lista. Ícone conceitual da seção Iniciar

Como a estrutura de dados na fonte de dados secundária deve corresponder a maneira que os dados são armazenados na lista ou biblioteca de documentos, você não pode modificar campos ou grupos na fonte de dados secundária existentes.

Uma conexão de dados que os dados de consultas do SharePoint a biblioteca de documentos ou listam automaticamente retorna todos os itens dessa biblioteca de documentos ou lista. Se você estiver usando uma conexão de dados de consulta para preencher uma lista de caixa, caixa de listagem suspensa, ou controle de caixa de combinação e o controle contém muitos itens ou que você deseja exibir somente os itens que correspondem ao critério especificado, você pode usar um filtro no controle para limitar o número de itens. Encontre links para obter mais informações sobre como filtrar os dados exibidos em um controle na seção Consulte também.

Também é possível configurar cada conexão de dados de consulta para salvar seus resultados de modo que os usuários tenham acesso a esses dados quando seus formulários não estiverem conectados a uma rede. Dependendo da natureza dos dados, convém exibir os resultados da consulta somente quando os usuários estiverem conectados a uma rede.

Observação de segurança : Se você estiver usando uma conexão de dados secundária para recuperar dados confidenciais de uma fonte de dados externos, talvez você queira desabilitar esse recurso para ajudar a proteger os dados de uso não autorizado, caso o computador seja perdido ou roubado. Se você desabilitar esse recurso, os dados estará disponíveis somente se o usuário estiver conectado à rede.

Quando você adiciona uma conexão de dados de consulta a um modelo de formulário, por padrão os formulários baseados nesse modelo de formulário usarão a conexão de dados quando forem abertos por um usuário. Também é possível configurar seu modelo de formulário para usar a conexão de dados de consulta de uma destas maneiras:

  • Adicionar uma regra    Você pode configurar uma regra para usar a conexão de dados de consulta sempre que ocorrer a condição na regra.

  • Adicionar um botão    Você pode adicionar um botão ao modelo de formulário que os usuários podem clicar para obter dados usando a conexão de dados de consulta.

  • Usar o código personalizado    Se você não pode adicionar uma regra ou um botão, você pode usar o código personalizado para obter dados usando a conexão de dados de consulta. Usando código personalizado requer um desenvolvedor criar o código personalizado.

Ao adicionar uma conexão de dados de envio ao seu modelo de formulário, é possível configurar o modelo de formulário para permitir que os usuários enviem seus dados de formulário e é possível configurar as opções de envio para formulários que têm base no seu modelo de formulário.

Início da página

Antes de começar

Antes de adicionar uma conexão de dados secundária ao seu modelo de formulário, você precisa das seguintes informações do administrador do seu site:

  • O local do site SharePoint e as permissões necessárias para acessá-lo

  • Verificação se o site está configurado de modo que seus usuários possam obter dados da biblioteca ou lista de documentos

  • Verificação se é possível armazenar os dados da biblioteca ou lista de documentos nos computadores dos seus usuários para uso offline

Início da página

Adicionar uma conexão de dados de consulta

Para permitir que os usuários consultem dados de uma biblioteca ou lista de documentos em um site localizado em um servidor executando o Microsoft Windows SharePoint Services, você precisa fazer o seguinte no modelo de formulário:

  1. Adicionar uma conexão de dados secundária.

  2. Configurar o modelo de formulário para usar a conexão de dados secundária.

Etapa 1: Adicionar uma conexão de dados secundária

  1. No menu Ferramentas, clique em Conexões de Dados.

  2. Na caixa de diálogo Conexões de dados, clique em Adicionar.

  3. No Assistente para Conexão de Dados, clique em Criar uma nova conexão para, clique em Receber dados e, em seguida, clique em Avançar.

  4. Na próxima página do assistente, clique em Biblioteca ou lista do SharePoint e, em seguida, clique em Avançar.

    Página no Assistente de conexão de dados para especificar um site do SharePoint como fonte de dados.

  5. Na próxima página do assistente, digite a URL do site do SharePoint com a biblioteca de documentos ou lista e clique em Avançar. Por exemplo, para usar uma lista de documentos em um site do SharePoint com a URL http://www.adventureworks.com/EmployeeList, digite http://www.adventureworks.com/EmployeeList.

  6. Na próxima página do assistente, na lista Selecione uma lista ou biblioteca, clique na lista ou na biblioteca que deseja usar e, em seguida, clique em Avançar.

  7. Na próxima página do assistente, marque as caixas de seleção ao lado dos valores que deseja receber. Se o modelo de formulário for publicado na biblioteca de documentos e você quiser que os formulários com base nesse modelo de formulário obtenham metadados sobre o formulário, marque a caixa de seleção Incluir dados apenas para o formulário ativo.

  8. Clique em Avançar.

  9. Se você quiser armazenar os resultados da consulta com o modelo de formulário, marque a caixa de seleção Armazenar uma cópia dos dados no modelo de formulário. Marcar essa caixa de seleção armazena os resultados da consulta de modo que tenham acesso a esses dados se seus computadores não estiverem conectados a uma rede.

    Observação de segurança : Marcar esta caixa de seleção armazena os resultados da consulta no modelo de formulário. Como os dados são armazenados no modelo de formulário, ele está disponível nos formulários que os usuários preencherem, mesmo se seus computadores não estiver conectados a uma rede. Se você estiver recebendo dados confidenciais desta conexão de dados, talvez você queira desabilitar esse recurso para ajudar a proteger os dados, caso o computador seja perdido ou roubado.

  10. Clique em Avançar.

  11. Na próxima página do assistente, na caixa Digite um nome para esta conexão de dados, digite um nome descritivo para esta conexão de dados secundária. Este é o nome que aparece na lista fonte de dados no painel de tarefas fonte de dados. Se você quiser essa consulta para ser executada automaticamente sempre que o formulário for aberto por um usuário, marque a caixa de seleção recuperar dados automaticamente quando o formulário é aberto.

Etapa 2: Configurar o modelo de formulário para usar a conexão de dados secundária

Se você quiser formulários que são baseados no seu modelo de formulário para usar esta conexão de dados depois que o usuário abre o formulário, você pode adicionar uma regra para o modelo de formulário que usa esta conexão de dados em uma determinada condição ou você pode adicionar um botão ao modelo de formulário que os usuários podem clicar para usar esta conexão de dados.

Adicionar uma regra

É possível adicionar uma regra ao modelo de formulário para obter dados da conexão de dados de consulta sempre que a condição para a regra for atendida. O seguinte procedimento presume que você criou uma conexão de dados de consulta para o seu modelo de formulário e que você configurou um controle no seu modelo de formulário para exibir os dados dessa conexão de dados.

  1. Se o modelo de formulário tiver vários modos de exibição, clique em nome de exibição no menu Exibir para ir para o modo de exibição com o controle onde você deseja exibir os dados da fonte de dados secundária.

  2. Clique duas vezes no controle que deseja exibir nos resultados da consulta.

  3. Clique na guia Dados.

  4. Em Validação e Regras, clique em Regras.

  5. Na caixa de diálogo Regras, clique em Adicionar.

  6. Na caixa Nome, digite um nome para a regra.

  7. Para especificar uma condição quando executar a regra, clique em Definir condição e insira a condição. A regra será executada quando ocorre a condição. Se você não definir uma condição, a regra será executada sempre que o usuário altera o valor no controle e, em seguida, move o cursor de sua longe de controle.

  8. Clique em Adicionar Ação.

  9. Na lista Ação, clique em Consultar usando uma conexão de dados.

  10. Na lista Conexão de dados, clique na conexão de dados de consulta que deseja usar e, em seguida, clique em OK para fechar cada caixa de diálogo aberta.

  11. Para testar as alterações, clique Visualizar na barra de ferramentas Padrão ou pressione CTRL+SHIFT+B.

Adicionar um botão

É possível adicionar um controle de botão ao seu modelo de formulário no qual os usuários podem clicar para usar essa conexão de dados de consulta. O seguinte procedimento presume que você criou uma conexão de dados de consulta para o seu modelo de formulário.

  1. Se o modelo de formulário tiver vários modos de exibição, clique em nome de exibição no menu Exibir para ir para o modo de exibição com o controle onde você deseja exibir os dados da fonte de dados secundária.

  2. Se o painel de tarefas Controles não estiver visível, clique em Mais Controles no menu Inserir, ou pressione ALT+I, C.

  3. Arraste um controle de botão no seu modelo de formulário.

  4. Clique duas vezes no controle de botão que acabou de adicionar ao seu modelo de formulário.

  5. Clique na guia Geral.

  6. Na lista Ação, clique em Atualizar.

  7. Na caixa Rótulo, digite o nome que deseja exibir no botão no seu modelo de formulário.

  8. Clique em Configurações.

  9. Na caixa de diálogo Atualizar, clique em Uma fonte de dados secundária.

  10. Na lista Escolha a fonte de dados secundária, clique na fonte de dados secundária associada à conexão de dados de consulta e, em seguida, clique em OK para fechar cada caixa de diálogo aberta.

  11. Para testar as alterações, clique Visualizar na barra de ferramentas Padrão ou pressione CTRL+SHIFT+B.

Início da página

Adicionar uma conexão de envio de dados

Para permitir que os usuários enviem formulários que têm base no seu modelo de formulário para uma biblioteca de documentos, é necessário fazer o seguinte:

  1. Adicionar uma conexão de dados secundária que envie os dados para o seu modelo de formulário.

  2. Configurar o modelo de formulário para permitir que os seus usuários enviem seus dados de formulário à biblioteca de documentos.

Etapa 1: Adicionar uma conexão de dados secundária

  1. No menu Ferramentas, clique em Conexões de Dados.

  2. Na caixa de diálogo Conexões de dados, clique em Adicionar.

  3. No Assistente para Conexão de Dados, clique em Criar uma nova conexão para, em Enviar dados e, em seguida, clique em Avançar.

  4. Em Como deseja enviar os dados, clique em Para uma biblioteca de documentos em um site do SharePoint e, em seguida, clique em Avançar.

  5. No Assistente para Conexão de Dados, na caixa Biblioteca de documentos, digite a URL da biblioteca de documentos do SharePoint.

  6. Na caixa Nome do arquivo, digite o nome que será usado para identificar o formulário na biblioteca de documentos.

    Dica : Você também pode usar uma fórmula para garantir que cada nome de formulário seja exclusivo.

    Como?

    1. Clique em Inserir Fórmula imagem do botão .

    2. Na caixa de diálogo Inserir Fórmula, execute uma das seguintes ações:

      • Para usar um campo na fórmula, clique em Inserir Campo ou Grupo, clique no campo que deseja usar na caixa de diálogo Selecione um Campo ou Grupo e, em seguida, clique em OK.

      • Para usar uma função na fórmula, clique em Inserir Função, selecione a função que deseja usar na caixa de diálogo Inserir Função e, em seguida, clique em OK.

        Dica : Se a função requer parâmetros, selecione a função na caixa de diálogo Inserir função, clique em OK e, em seguida, na caixa fórmula na caixa de diálogo Inserir Fórmula, clique duas vezes na função que você adicionou e clique em um campo ou grupo. Encontre links para mais informações sobre funções na seção Consulte também.

      • Para inserir um valor ou operador matemático na fórmula, digite o valor ou símbolo da operação matemática na caixa Fórmula.

    Operação

    Símbolo

    Adicionar

    +

    Subtrair

    -

    Multiplicar

    *

    Dividir

    /

    • Observação : Se sua fórmula usa o operador de divisão (/), verifique se há um espaço antes e depois do operador de divisão. Se o operador de divisão não tem um espaço antes e depois dela, o InfoPath pode interpretar "/" como um separador de etapas de local XPath em vez de como um operador de divisão.

    • Para verificar se a sintaxe da fórmula está correta, na caixa de diálogo Inserir Fórmula, clique em Verificar Fórmula.

      Encontre links para informações adicionais sobre fórmulas na seção Consulte Também.

  7. Para sobrescrever quaisquer formulários existentes na biblioteca de documentos que tenham o mesmo nome, marque a caixa de seleção Permitir que o arquivo seja substituído caso já exista.

  8. Clique em Avançar.

  9. Na próxima página do assistente, na caixa Digite um nome para esta conexão de dados, digite um nome descritivo para esta conexão de dados de envio.

Após você adicionar a conexão de dados de envio secundária, será necessário configurar seu modelo de formulário para permitir que os usuários enviem seus dados de formulário usando essa conexão de dados de envio.

Etapa 2: Habilitar o envio no formulário

Ao configurar o modelo de formulário para permitir que os usuários enviem seus dados de formulário, o InfoPath adiciona um botão Enviar à barra de ferramentas Padrão e um comando Enviar no menu Arquivo no formulário. Também é possível personalizar as opções de envio para o seu modelo de formulário das seguintes maneiras:

  • Altere o texto que aparece no botão Enviar.

  • Altere o atalho do teclado do botão Enviar.

  • Crie mensagens personalizadas para exibir para os seus usuários quando eles enviarem seus formulários.

  • Especifique se deseja deixar o formulário aberto, fechá-lo ou abrir outro formulário em branco após o formulário ser enviado.

  • No menu Ferramentas, clique em Opções de envio.

  • Na caixa de diálogo Opções de envio, marque a caixa de seleção Permitir que os usuários enviarem este formulário, clique em Enviar dados de formulário para um único destino e, em seguida, na lista, clique em biblioteca de documentos do SharePoint.

  • Na lista Escolha uma conexão de dados para envio, clique no nome da conexão de dados de envio com a biblioteca SharePoint.

    1. Para alterar o nome do botão Enviar que aparece na barra de ferramentas padrão e o comando Enviar que aparece no menu arquivo, quando os usuários preencherem o formulário, digite o novo nome na caixa legenda na caixa de diálogo Opções de envio.

      Dica : Se você quiser atribuir um atalho de teclado para este botão e o comando, digite um e comercial (&) antes do caractere que você deseja usar como um atalho de teclado. Por exemplo, para atribuir ALT + B como o atalho de teclado para o comando e o botão Enviar, digite & botão Enviar.

  • Se não quiser que as pessoas para usar um comando Enviar ou no botão Enviar na barra de ferramentas padrão, quando preencherem seu formulário, desmarque a caixa de seleção Mostrar o item de menu Enviar e o botão Enviar.

    1. Por padrão, depois que os usuários enviarem um formulário, o InfoPath mantém o formulário aberto e exibe uma mensagem para indicar se o formulário foi enviado com êxito. Para alterar esse comportamento padrão, clique em Avançado e, em seguida, siga um destes procedimentos:

      • Para fechar o formulário ou criar um novo formulário em branco depois que o usuário envia um formulário preenchido, clique na opção desejada na lista após enviar.

      • Para criar uma mensagem personalizada para indicar se o formulário foi enviado com êxito, marque a caixa de seleção mensagens personalizadas de uso e digite suas mensagens nas caixas no sucesso e de falha.

        Dica : Usar uma mensagem na caixa em falha para informar aos usuários o que fazer se eles não podem enviar seus formulários. Por exemplo, você pode sugerir que os usuários salvem o formulário e entre em contato com alguém para instruções adicionais.

      • Se você não deseja exibir uma mensagem após o usuário envia um formulário, desmarque a caixa de seleção Mostrar mensagens de sucesso e falha.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×