Adicionar uma conexão de dados a um serviço da Web

Importante :  Este artigo foi traduzido por um sistema de tradução automática, leia o aviso de isenção de responsabilidade. Para sua referência, veja a versão em inglês deste artigo aqui.

É possível adicionar uma ou mais conexões de dados secundárias ao seu modelo de formulário que pode consultar ou enviar dados a um serviço da Web.

Neste artigo

Visão Geral

Considerações sobre compatibilidade

Antes de começar

Adicionar uma conexão de dados de consulta

Adicionar uma conexão de dados de envio

Visão Geral

Uma conexão de dados secundária é qualquer conexão de dados a uma fonte de dados externos que você adiciona a um modelo de formulário. Esta conexão de dados é diferente da conexão de dados principal que é criada quando você cria um modelo de formulário com base em um banco de dados, serviço da Web ou configurações em uma biblioteca de conexão. Você adiciona uma conexão de dados secundária somente se você não pode consultar ou enviar dados através da conexão de dados principal.

Quando você adiciona uma conexão de dados secundária para seu modelo de formulário que dados de consultas, o Microsoft Office InfoPath criam um secundário data source com grupos e campos de dados que corresponde à XML Schema do serviço da Web. Como a estrutura de dados na fonte de dados secundária deve corresponder o esquema XML, você não pode modificar campos ou grupos na fonte de dados secundária existentes. Quando você adiciona uma conexão de dados de envio para seu modelo de formulário, você configura o modelo de formulário para permitir que usuários enviar seus dados de formulário, e você configurar as opções de envio para os formulários que são baseados no seu modelo de formulário.

Início da página

Considerações sobre compatibilidade

Não é possível configurar a conexão de dados de envio em um browser-compatible form template para permitir que os usuários enviem informações sobre alterações junto com seus dados de formulário a um serviço da Web que aceita um Microsoft ADO.NET DataSet. As informações sobre alterações consistem das modificações feitas por um usuário aos dados armazenados em um banco de dados. O banco de dados usa um serviço da Web para conectar os usuários ao banco de dados. O ADO.NET pode usar informações sobre alterações para determinar como atualizar os dados no banco de dados. Pergunte ao administrador do seu serviço da Web se o serviço precisa das informações sobre alterações para atualizar um banco de dados. Se precisar, você deverá criar um modelo de formulário do qual os formulários possam ser preenchidos usando apenas o InfoPath.

Início da página

Antes de começar

Antes de adicionar uma conexão de dados secundária ao seu modelo de formulário, você precisa das seguintes informações do administrador do serviço da Web:

  • O local do serviço da Web.

  • Verificação se o serviço da Web usa a codificação de estilo documento/literal. O InfoPath pode usar apenas os serviços da Web de estilo documento/literal.

  • O nome da operação do serviço da Web que enviará ou receberá dados dos formulários que têm base nesse modelo de formulário.

Início da página

Adicionar uma conexão de dados de consulta

Para permitir que os usuários consultem dados de um serviço da Web usando seu modelo de formulário, você precisa do seguinte no modelo de formulário:

  1. Adicionar uma conexão de dados secundária.

  2. Configurar o modelo de formulário para usar a conexão de dados secundária.

Etapa 1: Adicionar uma conexão de dados secundária

  1. No menu Ferramentas, clique em Conexões de Dados.

  2. Na caixa de diálogo Conexões de dados, clique em Adicionar.

  3. No Assistente para Conexão de Dados, clique em Criar uma nova conexão para, clique em Receber dados e, em seguida, clique em Avançar.

  4. Em De que lugar deseja receber os dados, clique em Serviço da Web e, em seguida, clique em Avançar.

  5. Na próxima página do assistente, digite o local do serviço da Web e, em seguida, clique em Avançar.

    Observação : Se você quiser procurar um serviço Web usando um servidor Universal Description Discovery and Integration (UDDI), clique em Pesquisar UDDI, insira a URL do servidor UDDI que você deseja pesquisar, especifique se deseja pesquisar por provedor ou por um serviço que é fornecido, digite uma palavra-chave de pesquisa e clique em Pesquisar. Serviços Web que coincidem com a palavra-chave de pesquisa serão exibido na lista de resultados de pesquisa. Selecione o serviço da Web que você deseja usar e clique em OK.

  6. Na lista Selecione uma operação na próxima página do assistente, clique na operação do serviço da Web que retorna os dados do formulário e, em seguida, clique em Avançar.

  7. Se o Assistente para Conexão de Dados encontrar um elemento desconhecido no esquema do serviço da Web, a próxima página do assistente pode pedir a especificação dos valores de exemplo para cada parâmetro para determinar quais campos ou grupos adicionar à fonte de dados principal.

    Como?

    1. Selecione um parâmetro na tabela parâmetros e clique em Definir valor de exemplo.

    2. Na caixa valor de amostra, digite um valor que o usuário pode usar para esse campo e clique em OK.

    3. Repita essas etapas para cada parâmetro na tabela parâmetros e clique em Avançar.

    Detalhes técnicos

    Quando você configura uma conexão de dados a um serviço Web no Assistente de conexão de dados, o Microsoft Office InfoPath se conecta ao serviço da Web e solicita o arquivo de idioma de descrição de serviço da Web (WSDL). O arquivo WSDL contém o esquema usado pelo serviço da Web. O serviço Web responde à solicitação enviando esse arquivo ao InfoPath. Para adicionar os campos apropriados e grupos à fonte de dados secundária no modelo de formulário, o InfoPath usa as informações neste arquivo. Se o InfoPath encontrar um tipo de elemento desconhecido no arquivo WSDL, o InfoPath usa dados de exemplo para determinar a definição do tipo de elemento desconhecido e depois adiciona os campos apropriados e grupos com a fonte de dados secundária.

  8. Se quiser que os resultados da consulta estejam disponíveis quando o formulário não estiver conectado à uma rede, marque a caixa de seleção Armazenar uma cópia dos dados no modelo de formulário.

    Observação de segurança : Marcar esta caixa de seleção armazena os resultados da consulta no modelo de formulário. Como os dados são armazenados no modelo de formulário, ele está disponível nos formulários que os usuários preencherem, mesmo se seus computadores não estiver conectados a uma rede. Se você estiver recebendo dados confidenciais desta conexão de dados, talvez você queira desabilitar esse recurso para ajudar a proteger os dados, caso o computador seja perdido ou roubado.

  9. Clique em Avançar.

  10. Na próxima página do assistente, digite um nome descritivo para a conexão de dados de consulta.

  11. Para permitir que os formulários que têm base nesse modelo de formulário recebam automaticamente os dados quando forem abertos, marque a caixa de seleção Recuperar dados automaticamente quando o formulário é aberto.

  12. Verifique se as informações na seção Resumo estão corretas e clique em Concluir.

  13. Clique em Fechar.

Etapa 2: Configurar o modelo de formulário para usar a conexão de dados secundária

Quando você adiciona uma conexão de dados de consulta a um modelo de formulário, por padrão os formulários baseados nesse modelo de formulário usarão a conexão de dados quando forem abertos por um usuário. Também é possível configurar seu modelo de formulário para usar a conexão de dados de consulta de uma destas maneiras:

  • Adicionar uma regra    Você pode configurar uma regra para usar a conexão de dados de consulta sempre que ocorrer a condição na regra.

  • Adicionar um botão    Você pode adicionar um botão ao modelo de formulário que os usuários podem clicar para obter dados usando a conexão de dados de consulta.

  • Usar o código personalizado    Se você não pode adicionar uma regra ou um botão, você pode usar o código personalizado para obter dados usando a conexão de dados de consulta. Usando código personalizado requer um desenvolvedor criar o código personalizado.

Adicionar uma regra

É possível adicionar uma regra ao modelo de formulário para obter dados da conexão de dados de consulta sempre que a condição para a regra for atendida. O seguinte procedimento presume que você criou uma conexão de dados de consulta para o seu modelo de formulário e que você configurou um controle no seu modelo de formulário para exibir os dados dessa conexão de dados.

  1. Se o modelo de formulário tiver vários modos de exibição, clique em nome de exibição no menu Exibir para ir para o modo de exibição com o controle onde você deseja exibir os dados da fonte de dados secundária.

  2. Clique duas vezes no controle ao qual deseja adicionar uma regra.

  3. Clique na guia Dados.

  4. Em Validação e Regras, clique em Regras.

  5. Na caixa de diálogo Regras, clique em Adicionar.

  6. Na caixa Nome, digite um nome para a regra.

  7. Para especificar uma condição quando executar a regra, clique em Definir condição e insira a condição. A regra será executada quando ocorre a condição. Se você não definir uma condição, a regra será executada sempre que o usuário altera o valor no controle e, em seguida, move o cursor de sua longe de controle.

  8. Clique em Adicionar Ação.

  9. Na lista Ação, clique em Consultar usando uma conexão de dados.

  10. Na lista Conexão de dados, clique na conexão de dados de consulta que deseja usar e, em seguida, clique em OK para fechar cada caixa de diálogo aberta.

  11. Para testar as alterações, clique Visualizar na barra de ferramentas Padrão ou pressione CTRL+SHIFT+B.

Adicionar um botão

É possível adicionar um controle de botão ao seu modelo de formulário no qual os usuários podem clicar para obter dados da conexão de dados de consulta. O seguinte procedimento presume que você criou uma conexão de dados de consulta para o seu modelo de formulário.

  1. Se o modelo de formulário tiver vários modos de exibição, clique em nome de exibição no menu Exibir para ir para o modo de exibição com o controle onde você deseja exibir os dados da fonte de dados secundária.

  2. Se o painel de tarefas Controles não estiver visível, clique em Mais Controles no menu Inserir, ou pressione ALT+I, C.

  3. Arraste um controle de botão no seu modelo de formulário.

  4. Clique duas vezes no botão adicionado ao seu modelo de formulário.

  5. Clique na guia Geral.

  6. Na lista Ação, clique em Atualizar.

  7. Na caixa Rótulo, digite o nome que deseja exibir no botão no seu modelo de formulário.

  8. Clique em Configurações.

  9. Na caixa de diálogo Atualizar, clique em Uma fonte de dados secundária.

  10. Na lista Escolha a fonte de dados secundária, clique na fonte de dados secundária associada à conexão de dados de consulta e, em seguida, clique em OK para fechar cada caixa de diálogo aberta.

  11. Para testar as alterações, clique Visualizar na barra de ferramentas Padrão ou pressione CTRL+SHIFT+B.

Início da página

Adicionar uma conexão de envio de dados

Para permitir que os usuários enviem formulários que têm base no seu modelo de formulário a um serviço da Web, adicione uma conexão de dados secundária ao seu modelo de formulário que envia dados e, em seguida, configure o modelo de formulário para permitir que seus usuários enviem seus dados de formulário.

Etapa 1: Adicionar uma conexão de dados secundária

  1. No menu Ferramentas, clique em Conexões de Dados.

  2. Na caixa de diálogo Conexões de dados, clique em Adicionar.

  3. No Assistente para Conexão de Dados, clique em Criar uma nova conexão para, em Enviar dados e, em seguida, clique em Avançar.

  4. Em Como deseja enviar os dados, clique em Para um serviço da Web e, em seguida, clique em Avançar.

  5. Na próxima página do assistente, digite o local do serviço da Web no qual seus usuários enviarão os dados e, em seguida, clique em Avançar.

    Observação : Se você quiser procurar um serviço Web usando um servidor Universal Description Discovery and Integration (UDDI), clique em Pesquisar UDDI, insira a URL do servidor UDDI que você deseja pesquisar, especifique se deseja pesquisar por provedor ou por um serviço que é fornecido, digite uma palavra-chave de pesquisa e clique em Pesquisar. Serviços Web que coincidem com a palavra-chave de pesquisa serão exibido na lista de resultados de pesquisa. Selecione o serviço da Web que você deseja usar e clique em OK.

  6. Na lista Selecione uma operação, clique na operação do serviço da Web que receberá o formulário e, em seguida, clique em Avançar.

  7. Na próxima página do assistente, para selecionar quais dados no formulário enviar para cada parâmetro no serviço da Web, execute um dos seguintes procedimentos:

    Envie os dados em um campo ou grupo

    1. Na lista Parâmetros, clique no parâmetro do serviço da Web que receberá os dados do formulário.

    2. Em Opções de parâmetro, clique em Campo ou grupo.

    3. Clique em Modificar Imagem do botão .

    4. Na caixa de diálogo Selecionar Campo ou Grupo, clique no campo ou no grupo do qual os dados você deseja enviar e, em seguida, clique em OK.

    5. Na caixa Incluir, clique em Somente texto e elementos filho para enviar somente os dados nesse campo e os elementos filho do campo ou do grupo, ou clique em Subárvore XML, incluindo o elemento selecionado para enviar o nome do campo, os dados no campo e os elementos campos no grupo ou campo selecionado.

    Envie todos os dados no formulário

    1. Na lista Parâmetros, clique no parâmetro do serviço da Web que receberá os dados do formulário.

    2. Em Opções de parâmetro, clique em formulário inteiro (documento XML, incluindo instruções de processamento).

    Envie os dados como uma seqüência de caracteres

    1. Na lista Parâmetros, clique no parâmetro do serviço da Web que receberá os dados do formulário.

    2. Em Opções de parâmetro, clique em formulário inteiro (documento XML, incluindo instruções de processamento).

    3. Marque a caixa de seleção Enviar dados como uma seqüência de caracteres.

      Observação : Normalmente, você marca essa caixa de seleção para enviar dados assinados digitalmente. Na maioria dos casos, desmarque essa caixa de seleção.

    Observação técnica sobre os objetos DataSet ADO.NET

    Se o serviço da Web exigir um objeto DataSet ADO.NET, selecione um nó de conjunto de dados ao configurar essa conexão de dados. Se você usar outro tipo de nó para uma conexão de dados com um serviço da Web que requer um objeto DataSet ADO.NET, a ação de envio irá falhar.

  8. Clique em Avançar.

  9. Na próxima página do assistente, digite um nome para a conexão de dados de envio.

  10. Verifique se as informações na seção Resumo estão corretas e clique em Concluir.

  11. Clique em Fechar.

Após você adicionar a conexão de dados de envio secundária, será necessário configurar seu modelo de formulário para permitir que os usuários enviem seus dados de formulário usando essa conexão de dados de envio.

Etapa 2: Habilitar o envio no formulário

Ao configurar o modelo de formulário para permitir que os usuários enviem seus dados de formulário, o InfoPath adiciona um botão Enviar à barra de ferramentas Padrão e um comando Enviar ao menu Arquivo no formulário. Também é possível personalizar as opções de envio para o seu modelo de formulário das seguintes maneiras:

  • Altere o texto que aparece no botão Enviar e o comando Enviar.

  • Altere o atalho do teclado do botão Enviar e o comando Enviar.

  • Crie mensagens personalizadas para exibir para os seus usuários quando eles enviarem seus formulários.

  • Especifique se deseja deixar o formulário aberto, fechá-lo ou abrir outro formulário em branco após o formulário ser enviado.

  • No menu Ferramentas, clique em Opções de envio.

  • Na caixa de diálogo Opções de Envio, marque a caixa de seleção Permitir que os usuários enviem este formulário, clique em Enviar dados de formulário para um único destino e, em seguida, na lista, clique em Serviços da Web.

  • Na lista Escolha uma conexão de dados para envio, clique no nome da conexão de dados de envio em Serviços da Web que você criou nas etapas anteriores.

    1. Para alterar o nome do botão Enviar que aparece na barra de ferramentas padrão e o comando Enviar que aparece no menu arquivo, quando os usuários preencherem o formulário, digite o novo nome na caixa legenda na caixa de diálogo Opções de envio.

      Dica : Se você quiser atribuir um atalho de teclado para este botão e o comando, digite um e comercial (&) antes do caractere que você deseja usar como um atalho de teclado. Por exemplo, para atribuir ALT + B como o atalho de teclado para o comando e o botão Enviar, digite & botão Enviar.

  • Se não quiser que as pessoas para usar um comando Enviar ou no botão Enviar na barra de ferramentas padrão, quando preencherem seu formulário, desmarque a caixa de seleção Mostrar o item de menu Enviar e o botão Enviar.

    1. Por padrão, depois que os usuários enviarem um formulário, o InfoPath mantém o formulário aberto e exibe uma mensagem para indicar se o formulário foi enviado com êxito. Para alterar esse comportamento padrão, clique em Avançado e, em seguida, siga um destes procedimentos:

      • Para fechar o formulário ou criar um novo formulário em branco depois que o usuário envia um formulário preenchido, clique na opção desejada na lista após enviar.

      • Para criar uma mensagem personalizada para indicar se o formulário foi enviado com êxito, marque a caixa de seleção mensagens personalizadas de uso e digite suas mensagens nas caixas no sucesso e de falha.

        Dica : Usar uma mensagem na caixa em falha para informar aos usuários o que fazer se eles não podem enviar seus formulários. Por exemplo, você pode sugerir que os usuários salvem o formulário e entre em contato com alguém para instruções adicionais.

      • Se você não deseja exibir uma mensagem após o usuário envia um formulário, desmarque a caixa de seleção Mostrar mensagens de sucesso e falha.

Início da página

Observação : Aviso de Isenção de Tradução Automática: Este artigo foi traduzido por computador, sem intervenção humana. A Microsoft oferece essas traduções automáticas para ajudar as pessoas que não falam inglês a aproveitar os textos escritos sobre produtos, serviços e tecnologias da Microsoft. Como este artigo foi traduzido automaticamente, é possível que contenha erros de vocabulário, sintaxe ou gramática.

Expanda suas habilidades
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×