Adicionar ou remover suplementos no Excel

Observação: Desejamos fornecer o conteúdo da Ajuda mais recente no seu idioma da forma mais rápida possível. Esta página foi traduzida de forma automatizada e pode conter imprecisões ou erros gramaticais. Nosso objetivo é que este conteúdo seja útil para você. No final da página, deixe sua opinião se estas informações foram úteis para você. Aqui está o artigo em inglês para facilitar a referência.

Suplementos fornecem comandos e recursos opcionais para o Microsoft Excel. Por padrão, os suplementos não estão disponíveis imediatamente no Excel, portanto, você deve primeiro instalar e (em alguns casos) ativar esses suplementos para poder usá-los.

Você está procurando informações sobre os suplementos do Office com base em HTML, CSS e JS? Se estiver, consulte obter um suplemento do Office para o Excel.

Alguns suplementos são incorporados ao Excel, como o solver e as ferramentas de análise. Outros suplementos estão disponíveis no centro de download e devem ser baixados e instalados primeiro. Por fim, há suplementos criados por terceiros, como um programador em sua organização ou um provedor de soluções de software. Eles podem ser suplementos COM (Component Object Model), suplementos do Visual Basic for Applications (VBA) e suplementos DLL. Esses suplementos também devem ser instalados para usá-los.

A maioria dos suplementos pode ser categorizada em três tipos diferentes:

  • Suplementos do Excel    Elas normalmente incluem arquivos de suplemento do Excel (. xlam), suplemento do Excel 97-2003 (. xla) ou DLL (. XLL) ou são suplementos de automação. Alguns suplementos do Excel, como o solver e as ferramentas de análise, podem estar disponíveis após a instalação do Excel ou do Microsoft Office. Geralmente, você só precisa ativar estes suplementos para usá-los.

  • Suplementos para download    Suplementos adicionais para o Excel podem ser baixados e instalados a partir de downloads em Office.com.

  • Suplementos personalizados    Desenvolvedores e provedores de soluções normalmente criam suplementos COM (modelo de objeto componente personalizado) personalizados, suplementos de automação, suplementos do VBA e suplementos XLL. Eles devem ser instalados para que você os use.

Depois de instalar ou ativar um suplemento, o suplemento e seus comandos podem estar disponíveis em um dos seguintes locais:

  • Guia dados . Depois de instalar e ativar as ferramentas de análise e os suplementos do Solver, os comandos análise de dados e Solver estão disponíveis no grupo análise .

    Botão Análise de Dados no grupo Análise de Dados

  • Guia fórmulas. Depois de instalar e ativar as ferramentas de moeda euro, os comandos de formatação do euro e de conversão do euro são exibidos no grupo soluções .

    Conversão do Euro e Formatação do Euro

  • Guia suplementos . Outros suplementos podem ser adicionados à guia suplementos . Esta guia será adicionada à faixa de opções quando você instalar e ativar o primeiro suplemento mostrado na guia suplementos . Se você não vir a guia suplementos , saia e reinicie o Excel.

Outros suplementos, como a guia introdução , estão disponíveis em outros locais do Excel, como uma guia na faixa de opções ou em macros ou menus personalizados.

Importante: Se você for um desenvolvedor de software, poderá usar esse procedimento para instalar ou remover um programa de automação antes de criar programas de instalação e remoção para o suplemento.

Para ativar um suplemento do Excel    

  1. Clique na guia Arquivo, em Opções e depois na categoria Suplementos.

  2. Na caixa Gerenciar, clique em Suplementos do Excel e, em seguida, clique em Ir.

    A caixa de diálogo suplementos será exibida.

  3. Na caixa suplementos disponíveis , marque a caixa de seleção ao lado do suplemento que você deseja ativar e clique em OK.

Se você não conseguir localizar o suplemento que deseja ativar na caixa suplementos disponíveis , talvez seja necessário instalá-lo.

Para instalar um suplemento do Excel    

  • Para instalar um suplemento que é normalmente instalado com o Excel, como o Solver ou as ferramentas de análise, execute o programa de instalação do Excel ou do Microsoft Office e escolha a opção alterar para instalar o suplemento. Depois de reiniciar o Excel, o suplemento deve aparecer na caixa suplementos disponíveis .

  • Alguns suplementos do Excel estão localizados em seu computador e podem ser instalados ou ativados clicando em procurar (na caixa de diálogo suplementos) para localizar o suplemento e, em seguida, clicando em OK.

  • Alguns suplementos do Excel exigem a execução de um pacote de instalação. Talvez seja necessário baixar ou copiar o pacote de instalação no seu computador (um pacote de instalação geralmente é um arquivo com uma extensão de nome de arquivo. msi) e o executa.

  • Outros suplementos que não estão disponíveis no seu computador podem ser baixados e instalados por meio de um navegador da Web a partir de downloads ou de outros sites na Internet ou de um servidor em sua organização. Siga as instruções de configuração para o download conforme necessário.

Para desativar um suplemento do Excel    

  1. Clique na guia Arquivo, em Opções e depois na categoria Suplementos.

  2. Na caixa Gerenciar, clique em Suplementos do Excel e, em seguida, clique em Ir.

  3. Na caixa suplementos disponíveis , desmarque a caixa de seleção ao lado do suplemento que você deseja desativar e clique em OK.

    Em muitos casos, quando você desativa um suplemento, ele é removido de seu grupo na faixa de opções. Em outros casos, para remover o suplemento da faixa de opções, talvez seja necessário reiniciar o Excel.

    Observação    A desativação de um suplemento não remove o suplemento do seu computador. Para remover o suplemento do seu computador, você deve desinstalá-lo.

Para remover um suplemento do Excel    

Importante: Se você instalou originalmente o suplemento do Excel a partir de um servidor de arquivos de rede ou de uma pasta compartilhada, talvez seja necessário remover o suplemento desse local. Se você tiver instalado o suplemento do Excel a partir de um CD e tiver mapeado sua unidade de CD para uma nova letra de unidade após a instalação do suplemento, será necessário reinstalar o suplemento do CD. Se você estiver executando suplementos do Excel a partir do CD, será necessário desinstalar os suplementos do Excel e reinstalá-los do CD.

  1. Clique na guia arquivo e, em seguida, clique em sair.

  2. No painel de controle, clique em programas e recursos (Windows 7 e Windows Vista) ou Adicionar/remover programas (Windows XP).

  3. Siga um destes procedimentos:

    • Se você tiver instalado o Excel como parte do Microsoft Office, clique em Microsoft Office na lista de programas instalados e clique no botão alterar .

    • Se você tiver instalado o Excel individualmente, clique no nome do programa na lista de programas instalados e clique no botão alterar .

    • Se você instalou o suplemento a partir do centro de download, clique no nome do programa na lista de programas instalados e clique no botão desinstalar .

  4. Siga as instruções no programa de instalação.

Importante: Se você for um desenvolvedor de software, poderá usar esse procedimento para instalar ou remover um programa de automação antes de criar programas de instalação e remoção para o suplemento. Se não for um desenvolvedor, você não precisará usar este procedimento. Entre em contato com o administrador do sistema que forneceu o suplemento se você quiser instruções de instalação e remoção.

Adicionar um suplemento de COM

  1. Clique na guia Arquivo, em Opções e depois na categoria Suplementos.

  2. Na caixa gerenciar , clique em suplementos de come, em seguida, clique em ir.

    A caixa de diálogo suplementos de com será exibida.

  3. Na caixa suplementos disponíveis , marque a caixa de seleção ao lado do suplemento que você deseja instalar e clique em OK.

    Dica    Se o suplemento que você deseja usar não estiver listado na caixa suplementos disponíveis , clique em Adicionare, em seguida, localize o suplemento.

Remover um suplemento COM

  1. Clique na guia Arquivo, em Opções e depois na categoria Suplementos.

  2. Na caixa gerenciar , clique em suplementos de come, em seguida, clique em ir.

    A caixa de diálogo suplementos de com será exibida.

  3. Na caixa suplementos disponíveis , desmarque a caixa de seleção ao lado do suplemento que você deseja remover e clique em OK.

    Observação    Isso remove o suplemento da memória, mas mantém seu nome na lista de suplementos disponíveis. Ele não exclui o suplemento do seu computador.

  4. Para remover um suplemento de COM da lista de suplementos disponíveis e excluir o suplemento do seu computador, clique em seu nome na caixa suplementos disponíveis e, em seguida, clique em remover.

Observação: Se você for um desenvolvedor de software, poderá usar esse procedimento para instalar ou remover um programa de automação antes de criar programas de instalação e remoção para o suplemento. Se não for um desenvolvedor, você não precisará usar este procedimento. Entre em contato com o administrador do sistema que forneceu o suplemento se você quiser instruções de instalação e remoção.

  1. Clique na guia Arquivo, em Opções e depois na categoria Suplementos.

  2. Na caixa Gerenciar, clique em Suplementos do Excel e, em seguida, clique em Ir.

    A caixa de diálogo suplementos será exibida.

  3. Para instalar um suplemento de automação, na caixa servidores de automação disponíveis , clique em automaçãoe, em seguida, clique no suplemento desejado.

    Dica    Se o suplemento desejado não estiver na lista, clique em procurar, localize o suplemento e, em seguida, clique em OK.

  4. Para remover um suplemento de automação, você deve removê-lo do registro. Consulte o administrador do sistema para obter detalhes.

Alguns suplementos são incorporados ao Excel, como o solver e as ferramentas de análise. Outros suplementos estão disponíveis no centro de download e devem ser baixados e instalados primeiro. Por fim, há suplementos criados por terceiros, como um programador em sua organização ou um provedor de soluções de software. Eles podem ser suplementos COM (Component Object Model), suplementos do Visual Basic for Applications (VBA) e suplementos DLL. Esses suplementos também devem ser instalados para usá-los.

A maioria dos suplementos pode ser categorizada em três tipos diferentes:

  • Suplementos do Excel    Elas normalmente incluem arquivos de suplemento do Excel (. xlam), suplemento do Excel 97-2003 (. xla) ou DLL (. XLL) ou são suplementos de automação. Alguns suplementos do Excel, como o solver e as ferramentas de análise, podem estar disponíveis após a instalação do Excel ou do Microsoft Office. Geralmente, você só precisa ativar estes suplementos para usá-los.

  • Suplementos para download    Suplementos adicionais para o Excel podem ser baixados e instalados a partir de downloads em Office.com.

  • Suplementos personalizados    Desenvolvedores e provedores de soluções normalmente criam suplementos COM (modelo de objeto componente personalizado) personalizados, suplementos de automação, suplementos do VBA e suplementos XLL. Eles devem ser instalados para que você os use.

Depois de instalar ou ativar um suplemento, o suplemento e seus comandos podem estar disponíveis em um dos seguintes locais:

  • Guia dados . Depois de instalar e ativar as ferramentas de análise e os suplementos do Solver, os comandos análise de dados e Solver estão disponíveis na guia dados da faixa de opções.

  • Guia página inicial . Outros suplementos podem ser adicionados à guia página inicial .

Outros suplementos, como a guia introdução , estão disponíveis em outros locais do Excel, como uma guia na faixa de opções ou em macros ou menus personalizados.

Importante: Se você for um desenvolvedor de software, poderá usar esse procedimento para instalar ou remover um programa de automação antes de criar programas de instalação e remoção para o suplemento.

Para ativar um suplemento pré-instalado do Excel    

  1. No menu ferramentas , selecione suplementos.

  2. Na caixa suplementos disponíveis , marque a caixa de seleção do suplemento que você deseja ativar e clique em OK.

Para instalar um suplemento do Excel    

  • Alguns suplementos do Excel estão localizados no computador e podem ser instalados ou ativados clicando em procurar (na caixa de diálogo suplementos acima) para localizar o suplemento e clicando em OK.

  • Alguns suplementos do Excel exigem a execução de um pacote de instalação. Talvez seja necessário baixar ou copiar o pacote de instalação no seu computador (um pacote de instalação geralmente é um arquivo com uma extensão de nome de arquivo. msi) e o executa.

  • Outros suplementos que não estão disponíveis em seu computador podem ser baixados e instalados por meio de um navegador da Web ou de outros sites na Internet, de um servidor em sua organização ou usando a opção de loja interna do Excel. Siga as instruções de configuração para o download conforme necessário.

    Para instalar suplementos da loja

    1. Clique na guia Inserir na faixa de opções.

    2. Clique no botão da loja .

    3. Use as categorias ou o campo de pesquisa para localizar suplementos.

    4. Clique em Adicionar para instalar o suplemento.

      Observação: Alguns suplementos precisam ser comprados.

Para remover um suplemento do Excel    

  1. Clique na guia Inserir e, em seguida, clique em meussuplementos.

  2. Em suplementos do Office, clique no menu de 3 pontos ao lado do suplemento.

  3. Clique em Remover.

  4. Leia o aviso que é exibido em relação a outros dispositivos e clique em remover.

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×