ÍNDICE (Função ÍNDICE)

A função ÍNDICE retorna um valor ou a referência a um valor de dentro de uma tabela ou intervalo.

Seu navegador não oferece suporte a vídeo. Instale o Microsoft Silverlight, o Adobe Flash Player ou o Internet Explorer 9.

Há duas maneiras de usar a função ÍNDICE:

  • Se você deseja retornar o valor de uma célula especificada ou uma matriz de células, consulte Forma matricial.

  • Se você deseja retornar uma referência a células especificadas, consulte o Formulário de referência.

Forma matricial

Descrição

Retorna o valor de um elemento em uma tabela ou uma matriz, selecionado pelos índices de número de linha e coluna.

Use a forma de matriz se o primeiro argumento de ÍNDICE for uma constante de matriz.

Sintaxe

ÍNDICE(matriz; núm_linha; [núm_coluna])

A forma de matriz da função índice tem os seguintes argumentos:

  • matriz    Obrigatório. Um intervalo de células ou uma constante de matriz.

    • Se a matriz contiver apenas uma linha ou coluna, o argumento núm_linha ou núm_coluna correspondente é opcional.

    • Se a matriz tiver mais de uma linha e mais de uma coluna e somente núm_linha ou núm_coluna forem usados, índice retornará uma matriz de toda a linha ou coluna na matriz.

  • núm_linha    Obrigatório. Seleciona a linha na matriz a partir da qual um valor deverá ser retornado. Se núm_linha for omitido, núm_coluna será necessário.

  • núm_coluna    Opcional. Seleciona a coluna na matriz a partir da qual um valor deverá ser retornado. Se núm_coluna for omitido, núm_linha será necessário.

Comentários

  • Se os argumentos núm_linha e núm_coluna forem usados, índice retornará o valor na célula na interseção de núm_linha e núm_coluna.

  • núm_linha e núm_coluna devem apontar para uma célula dentro de uma matriz; caso contrário, índice retornará um #REF! erro.

  • Se você definir núm_linha ou núm_coluna como 0 (zero), índice retornará a matriz de valores para a coluna ou linha inteira, respectivamente. Para usar valores retornados como uma matriz, insira a função índice como uma fórmula de matriz.

    Observação: Se você tiver uma versão atual do Office 365, poderá inserir a fórmula na parte superior esquerda do intervalo de saída e, em seguida, pressionar Enter para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula deve ser inserida como uma fórmula de matriz herdada primeiro selecionando o intervalo de saída, inserindo a fórmula na célula superior esquerda do intervalo de saída e, em seguida, pressione Ctrl + Shift + Enter para confirmá-la. O Excel insere chaves no início e no final da fórmula para você. Para obter mais informações sobre fórmulas de matriz, confira Diretrizes e exemplos de fórmulas de matriz.

Exemplos

Exemplo 1

Esses exemplos usam a função ÍNDICE para localizar o valor em uma célula em interseção onde a linha e a coluna se encontram.

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para que as fórmulas mostrem resultados, selecione-as, pressione F2 e pressione Enter.

Dados

Dados

Maçãs

Limões

Bananas

Peras

Fórmula

Descrição

Resultado

=ÍNDICE(A2:B3;2;2)

O valor na interseção da segunda linha com a segunda coluna no intervalo A2:B3.

Peras

=ÍNDICE(A2:B3;2;1)

O valor na interseção da segunda linha com a primeira coluna no intervalo A2:B3.

Bananas

Exemplo 2

Esse exemplo usa a função ÍNDICE em uma fórmula matriz para localizar os valores em duas células especificadas em uma matriz 2x2.  

Observação: Se você tiver uma versão atual do Office 365, poderá inserir a fórmula na parte superior esquerda do intervalo de saída e, em seguida, pressionar Enter para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula deve ser inserida como uma fórmula de matriz herdada selecionando duas células em branco, inserindo a fórmula na parte superior esquerda da célula do intervalo de saída e, em seguida, pressione Ctrl + Shift + Enter para confirmá-la. O Excel insere chaves no início e no final da fórmula para você. Para obter mais informações sobre fórmulas de matriz, confira Diretrizes e exemplos de fórmulas de matriz.

Fórmula

Descrição

Resultado

=ÍNDICE({1;2;3;4};0;2)

Valor encontrado na primeira linha, segunda coluna da matriz. A matriz contém 1 e 2 na primeira linha e 3 e 4 na segunda linha.

2

Valor encontrado na segunda linha, segunda coluna da matriz (mesma matriz do exemplo acima).

4

Início da página


Formulário de referência

Descrição

Retorna a referência da célula na interseção de linha e coluna específicas. Se a referência for composta de seleções não adjacentes, você poderá escolher a seleção que deseja examinar.

Sintaxe

ÍNDICE (referência, núm_linha, [núm_coluna], [núm_área])

A forma de referência da função índice tem os seguintes argumentos:

  • Referencie    Obrigatório. Uma referência a um ou mais intervalos de célula.

    • Se você estiver inserindo um intervalo não adjacente para a referência, coloque ref entre parênteses.

    • Se cada área na referência contiver apenas uma linha ou coluna, o argumento núm_linha ou núm_coluna, respectivamente, é opcional. Por exemplo, para uma referência de linha única, use ÍNDICE(ref;;núm_coluna).

  • núm_linha    Obrigatório. É o número da linha em ref de onde será fornecida uma referência.

  • núm_coluna    Opcional. É o número da coluna em ref de onde será fornecida uma referência.

  • Núm_área    Opcional. Seleciona um intervalo em referência a partir do qual você deve retornar a interseção entre núm_linha e núm_coluna. A primeira área selecionada ou inserida é numerada como 1, a segunda é 2 e assim por diante. Se Núm_área for omitido, índice usará a área 1.  As áreas listadas aqui devem estar todas localizadas em uma planilha.  Se você especificar áreas que não estão na mesma planilha, isso causará uma #VALUE! erro.  Se você precisar usar intervalos localizados em diferentes planilhas, é recomendável que você use a forma de matriz da função índice e use outra função para calcular o intervalo que compõe a matriz.  Por exemplo, você pode usar a função escolher para calcular qual intervalo será usado.

Por exemplo, se ref descrever as células (a1: B4; D1: E4, G1: H4), Núm_área 1 é o intervalo a1: B4, Núm_área 2 é o intervalo D1: E4 e Núm_área 3 é o intervalo G1: H4.

Comentários

  • Após ref e Núm_área selecionar um intervalo específico, núm_linha e núm_coluna, selecione uma determinada célula: núm_linha 1 é a primeira linha do intervalo, núm_coluna 1 é a primeira coluna e assim por diante. A referência retornada pelo índice é a interseção entre núm_linha e núm_coluna.

  • Se você definir núm_linha ou núm_coluna como 0 (zero), índice retornará a referência para a coluna ou linha inteira, respectivamente.

  • núm_linha, núm_coluna e Núm_área devem apontar para uma célula na referência; caso contrário, índice retornará um #REF! erro. Se núm_linha e núm_coluna forem omitidos, índice retornará a área em referência especificada por Núm_área.

  • O resultado da função ÍNDICE é uma referência e é interpretado como tal por outras fórmulas. Dependendo da fórmula, o valor retornado por ÍNDICE pode ser usado como uma referência ou como um valor. Por exemplo, a fórmula de macro CÉL("largura";ÍNDICE(A1:B2;1;2)) é equivalente a CÉL("largura";B1). A função CÉL usa o valor retornado por ÍNDICE como uma referência de célula. Por outro lado, uma fórmula tal como 2*ÍNDICE(A1:B2;1;2) traduz o valor retornado por ÍNDICE no número da célula B1.

Exemplos

Copie os dados de exemplo da tabela a seguir e cole-os na célula A1 de uma nova planilha do Excel. Para as fórmulas mostrarem resultados, selecione-as, pressione F2 e pressione Enter.

Fruta

Andrade

Contagem

Maçãs

$0,69

40

Bananas

$0,34

38

Limões

$0,55

15

Laranjas

$0,25

25

Peras

$0,59

40

Amêndoas

$2,80

10

Cajus

$3,55

16

Amendoins

$1,25

20

Nozes

$1,75

12

Fórmula

Descrição

Resultado

=ÍNDICE(A2:C6;2;3)

A interseção da segunda linha com a terceira coluna no intervalo A2:C6, que é o conteúdo da célula C3.

38

=ÍNDICE((A1:C6;A8:C11);2;2;2)

A interseção da segunda linha com a segunda coluna na segunda área de A8:C11, que é o conteúdo da célula B9.

1,25

=SOMA(ÍNDICE(A1:C11;0;3;1))

A soma da terceira coluna na primeira área do intervalo A1:C11, que é a soma de C1:C11.

216

=SOMA(B2:ÍNDICE(A2:C6;5;2))

A soma do intervalo que começa em B2 e termina na interseção da quinta linha com a segunda coluna no intervalo A2:A6, que é a soma de B2:B6.

2,42

Início da página

Confira também

Função PROCV

CORRESP (Função CORRESP)

Função INDIRETO

Diretrizes e exemplos de fórmulas de matriz

Funções de pesquisa e referência (referência)

Observação:  Esta página foi traduzida automaticamente e pode apresentar erros gramaticais ou imprecisões. Nosso objetivo é que este conteúdo seja útil para você. Você pode nos dizer se as informações foram úteis? Use o artigo em inglês como referência.​

Expanda suas habilidades no Office
Explore o treinamento
Obtenha novos recursos primeiro
Ingressar no Office Insider

Essas informações foram úteis?

Obrigado por seus comentários!

Agradecemos pelos seus comentários! Parece que pode ser útil conectar você a um de nossos agentes de suporte do Office.

×