Znajdowanie elementów użytkownika w usłudze Project Online i programu Project Server użytkownika eksportowanie danych

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Ten artykuł zawiera opis sposobu wyszukiwania dla określonych użytkowników dostosowane elementy (widoki, filtry, załączników, tabel i makr) w projekcie, podczas eksportowania danych użytkowników w usłudze Project Online lub programu Project Server. Ta opcja uwzględnia:

Procedury przedstawione w tym artykule, trzeba mieć następujące czynności:

  • Plik MPP dla projektu

  • Plik XML dla projektu

Dla usługi Project Online oba pliki zostały uzyskanych po wyeksportowaniu danych użytkownika za pomocą procedury eksportowania danych użytkownika z usługi Project Online.

Dla programu Project Server należy zapisać plik określonego projektu do formatu XML, aby utworzyć plik XML.

Uwaga: Podczas zapisywania pliku projektu w formacie XML w programie Project Professional, upewnij się, że zastosowano najnowsze aktualizacje.

Aby znaleźć i zapisywanie niestandardowych widoków

  1. Otwórz plik XML określonego projektu w edytorze tekstów.

  2. W polu Tekst Wyszukaj < Widoki > znaleźć listę widoków użytkownika dla projektu.

  3. Na liście Widoki Znajdź wszystkie widoki, których właściwości IsCustomized ustawiona na wartość true. Na przykład następujących środków widok o nazwie aktywnych zadań została dostosowana na podstawie szablonu globalnego domyślnego:

    <View>
    <Name>Task Sheet</Name>
    <IsCustomized>true</IsCustomized>
    </View>
    
  4. Teraz można otworzyć pliku MPP projektu Project Online klienta pulpitu lub w programie Project Professional 2016.

  5. Kliknij menu Widok , aby otworzyć Wstążkę, a na Wstążce wybierz pozycję menu rozwijanego Inny widok , a następnie kliknij polecenie Więcej widoków.

  6. W oknie Więcej widoków na liście widoki zaznacz widok, Wyszukaj, a następnie kliknij przycisk Zastosuj.

    Więcej filtrów
  7. Wybrany widok będzie wyświetlany. Utwórz zrzut ekranu przedstawiający widok, a następnie zapisz go.

  8. Za pomocą tej samej procedury dla wszystkich pozostałych widoków niestandardowych, który znajdziesz w pliku XML.

Czy Powtórz tę procedurę dla każdego projektu, w którym chcesz przeszukać niestandardowych widoków użytkownika.

Aby znaleźć i zapisywanie filtrów niestandardowych

  1. Otwórz plik XML określonego projektu w edytorze tekstów.

  2. W polu Tekst Wyszukaj < Filtry > znaleźć listę filtry użytkownika dla projektu.

  3. Na liście filtrów Znajdź wszystkie filtry, których właściwości IsCustomized ustawiona na wartość true. Na przykład następujących środków filtru o nazwie aktywnych zadań została dostosowana na podstawie szablonu globalnego domyślnego:

    <Filters>
    <Name>Active Tasks</Name>
    <IsCustomized>true</IsCustomized>
    </Filter>
    
  4. Aby zapisać widok, otwórz plik MPP projektu Project Online klienta pulpitu lub w programie Project Professional 2016.

  5. Kliknij menu Widok , a następnie w menu rozwijanym Filtry , wybierz pozycję Więcej filtrów.

  6. W menu Więcej filtrów wybierz filtr szukasz, a następnie kliknij przycisk Edytuj.

    Więcej filtrów
  7. Definiowanie filtru dla wybranego filtru będą wyświetlane. Możesz wykonać zrzut ekranu przedstawiający Definiowanie filtru i zapisz go.

  8. Użyj tej samej procedury dla wszystkich pozostałych filtry niestandardowe znalezionych w pliku XML.

Czy Powtórz tę procedurę dla każdego projektu, w którym chcesz przeszukać dla użytkownika dostosować filtry.

Aby znaleźć i zapisywanie załączników

  1. Otwórz plik XML określonego projektu w edytorze tekstów.

  2. W polu Tekst Wyszukaj < zadania > znaleźć listę zadań użytkownika dla projektu.

  3. Na liście zadań Znajdź wszystkie zadania, które mają właściwość NoteContainsObjects ustawiona na wartość true. Na przykład następujące oznacza, że zadanie 18 zawiera załącznik:

    <Task>
    <UID>18</UID>
    <NoteContainsObjects>true</NoteContainsObjects>
    </Task>
    
  4. Aby zapisać załącznik, otwórz plik MPP projektu Project Online klienta pulpitu lub w programie Project Professional 2016.

  5. Kliknij menu zadania , a następnie otwórz zadania skojarzone z załącznikiem (na przykład zadanie #18).

  6. Na ekranie Informacje o zadaniu wybierz kartę Uwagi . Powinien zostać wyświetlony załącznik element na liście.

    Załączniki do zadań
  7. Otwórz element załącznik, a następnie zapisz go.

  8. Za pomocą tej samej procedury dla wszystkich pozostałych załączników, który został znaleziony w pliku XML.

Czy Powtórz tę procedurę dla każdego projektu, w którym chcesz przeszukać załączników użytkownika.

Aby znaleźć i zapisać dostosowany tabel

  1. Otwórz plik XML określonego projektu w edytorze tekstów.

  2. W polu Tekst Wyszukaj < tabele > znaleźć tabele w projekcie.

  3. Na liście tabel Znajdź wszystkie tabele, których właściwości IsCustomized ustawiona na wartość true. Na przykład następujących środków tabeli Zapis została dostosowana na podstawie szablonu globalnego domyślnego:

    <Tables>
    <Table>Entry</Name>
    <IsCustomized>true</IsCustomized>
    </Table>
    
  4. Teraz można otworzyć pliku MPP projektu Project Online klienta pulpitu lub w programie Project Professional 2016.

  5. Kliknij menu Widok , aby otworzyć Wstążkę, a na Wstążce wybierz menu rozwijane tabele , a następnie kliknij przycisk Więcej tabel.

  6. W oknie Więcej tabel na liście tabel zaznacz tabelę, Wyszukaj, a następnie kliknij przycisk Edytuj.

    Definicja tabeli
  7. Definicja tabeli są wyświetlane dla wybranej tabeli. Utwórz zrzut ekranu przedstawiający wszystkie informacje w oknie definicji i zapisz go.

  8. Za pomocą tej samej procedury dla wszystkich pozostałych tabel niestandardowych znalezionych w pliku XML.

Czy Powtórz tę procedurę dla każdego projektu, w którym chcesz przeszukać tabele dostosowane do użytkowników.

Aby znaleźć i zapisywanie makr użytkownika

Uwaga: Pliki XML programu project nie oznaczy zawiera makra języka VBA. Będzie konieczne ręczne otwieranie projekty użytkownika, aby sprawdzić, czy zawiera makra języka VBA.

  1. Otwórz plik MPP projektu Project Online klienta pulpitu lub w programie Project Professional 2016.

  2. Kliknij menu Widok , aby otworzyć Wstążkę, a na Wstążce wybierz menu rozwijane makra , a następnie kliknij polecenie Wyświetl makra.

  3. Na stronie makra zaznacz języka Visual Basic, aby otworzyć Edytor Visual Basic.

  4. W Edytorze Visual Basic możesz zapisać użytkownicy niestandardowe pliki języka VBA.

Czy Powtórz tę procedurę dla każdego projektu, w którym chcesz przeszukać dla użytkownika dostosować makra.

Zobacz też

Eksportowanie danych użytkownika z usługi Project Online

Eksportowanie danych użytkownika z programu Project Server

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×