Zmienianie rozmiaru tabeli przez dodawanie lub usuwanie wierszy i kolumn

Zmienianie rozmiaru tabeli przez dodawanie lub usuwanie wierszy i kolumn

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Po utworzeniu tabeli programu Excel w arkuszu, można łatwo Dodawanie lub usuwanie wierszy i kolumn tabeli.

Aby dodać wiersze i kolumny do tabeli w programie Excel, można użyć polecenia Zmień rozmiar:

  1. Kliknij dowolne miejsce w tabeli, a zostanie wyświetlona opcja Narzędzia tabel.

  2. Kliknij pozycję Projektowanie > Zmień rozmiar tabeli.

    Używanie opcji zmiany rozmiaru tabeli na karcie Narzędzia tabel

  3. Zaznacz cały zakres komórek, który chcesz dodać do tabeli, zaczynając od komórki w lewym górnym rogu.

    W poniższym przykładzie pierwotna tabela obejmuje zakres A1:C5. Po zmianie rozmiaru w celu dodania dwóch kolumn i trzech wierszy tabela obejmuje zakres A1:E8.

    Zmienianie rozmiaru tabeli

    Porada: Możesz także kliknąć pozycję Zwiń okno dialogowe Obraz przycisku , aby tymczasowo ukryć okno Zmienianie rozmiaru tabeli, zaznaczyć zakres w arkuszu, a następnie kliknąć pozycję Rozwiń okno dialogowe Obraz przycisku .

  4. Po zaznaczeniu odpowiedniego zakresu dla tabeli kliknij przycisk OK.

Wiersz lub kolumnę można dodać do tabeli, wpisując tekst w komórce tuż poniżej ostatniego wiersza lub po prawej stronie ostatniej kolumny, wklejając dane w komórce lub wstawiając wiersze lub kolumny między istniejącymi wierszami lub kolumnami.

Rozpoczynanie wpisywania tekstu   

  • Aby dodać wiersz u dołu tabeli, zacznij wpisywać tekst w komórce poniżej ostatniego wiersza tabeli. Tabela zostanie powiększone, aby uwzględnić nowy wiersz. Aby dodać kolumnę z prawej strony tabeli, zacznij wpisywać tekst w komórce obok ostatniej kolumny tabeli.

W poniższym przykładzie dla wiersza wpisanie wartości w komórce A4 powoduje rozszerzenie tabeli w celu uwzględnienia tej komórki wraz z sąsiednią komórką w kolumnie B.

Dodawanie wiersza przez wpisanie tekstu w pierwszym wierszu poniżej tabeli

W poniższym przykładzie dla kolumny wpisanie wartości w komórce C2 powoduje rozszerzenie tabeli w celu uwzględnienia kolumny C. Program Excel nadaje jej nazwę Kw 3 ze względu na wzorzec nazewnictwa wynikający z nazw Kw 1 i Kw 2.

Wpisanie wartości w komórce po prawej stronie tabeli powoduje dodanie kolumny

Wklejanie danych   

  • Aby dodać wiersz przez wklejenie, Wklej dane w skrajnej lewej komórki poniżej ostatniego wiersza tabeli. Aby dodać kolumnę przez wklejenie, Wklej dane po prawej stronie kolumny po prawej stronie tabeli.

Jeśli dane wklejane w nowym wierszu mają tyle samo kolumn co tabela lub mniej, tabela zostanie rozszerzona, aby uwzględnić wszystkie komórki we wklejonym zakresie. Jeśli wklejane dane mają więcej kolumn niż tabela, dodatkowe kolumny nie będą częścią tabeli — należy użyć polecenia Zmień rozmiar, aby rozszerzyć tabelę w celu ich uwzględnienia.

W poniższym przykładzie dla wierszy wklejenie wartości z zakresu A10:B12 w pierwszym wierszu poniżej tabeli (wiersz 5) powoduje rozszerzenie tabeli w celu uwzględnienia wklejonych danych.

Wklejenie danych poniżej tabeli powoduje rozszerzenie tej tabeli w celu uwzględnienia danych

W poniższym przykładzie dla kolumn wklejenie wartości z zakresu C7:C9 w pierwszej kolumnie po prawej stronie tabeli (kolumna C) powoduje rozszerzenie tabeli w celu uwzględnienia wklejonych danych i dodanie nagłówka Kw 3.

Wklejenie danych kolumny powoduje rozszerzenie tabeli i dodanie nagłówka

Dodawanie wiersza przy użyciu polecenia Wstaw   

  1. Aby wstawić wiersz, wybierz komórkę lub wiersz, który nie jest wiersz nagłówka, a następnie kliknij prawym przyciskiem myszy. Aby wstawić kolumnę, wybierz dowolną komórkę w tabeli, a następnie kliknij prawym przyciskiem myszy.

  2. Wskaż polecenie Wstaw i wybierz pozycję Wiersze tabeli powyżej, aby wstawić nowy wiersz, lub pozycję Kolumny tabeli po lewej, aby wstawić nową kolumnę.

Jeśli jesteś w ostatnim wierszu, możesz wybrać pozycję Wiersze tabeli powyżej lub Wiersze tabeli poniżej.

W poniższym przykładzie dla wierszy zostanie wstawiony wiersz powyżej wiersza 3.

Polecenie Wstaw > Wiersze tabeli powyżej

W przypadku kolumn, jeśli została zaznaczona komórka w skrajnie prawej kolumnie tabeli, możesz wybrać pozycję Kolumny tabeli po lewej lub Kolumny tabeli po prawej.

W poniższym przykładzie dla kolumn zostanie wstawiona kolumna po lewej stronie kolumny 1.

Wstawianie kolumny tabeli

  1. Zaznacz wiersze tabeli lub kolumny tabeli, które chcesz usunąć.

    Możesz też po prostu wybrać jedną lub więcej komórek w tabeli wiersze lub kolumny tabeli, które chcesz usunąć.

  2. Na karcie Narzędzia główne w grupie komórki kliknij strzałkę obok przycisku Usuń, a następnie kliknij pozycję Usuń wiersze tabeli lub Usuń kolumny tabeli.

    Grupa Komórki na karcie Narzędzia główne

    Możesz również kliknąć prawym przyciskiem myszy lub więcej wierszy lub kolumn, w menu skrótów wskaż polecenie Usuń, a następnie kliknij Tabelę kolumny lub Wiersze tabeli. Kliknij prawym przyciskiem jedną lub więcej komórek w tabeli Wiersz lub kolumnę tabeli, wskaż polecenie Usuń, a następnie kliknij Tabelę Wiersze lub Kolumny tabeli.

Tak, jak można usunąć duplikaty z wszystkie zaznaczone dane w programie Excel, możesz łatwo usunąć duplikaty z tabeli.

  1. Kliknij w dowolnym miejscu tabeli.

    Zostanie wyświetlony obszar Narzędzia tabel wraz z kartą Projektowanie.

  2. Na karcie Projektowanie w grupie Narzędzia kliknij przycisk Usuń duplikaty.

    Obraz Wstążki programu Excel

  3. W oknie dialogowym Usuwanie duplikatów w obszarze kolumny zaznacz kolumny, które zawierają duplikaty, które chcesz usunąć.

    Można również kliknąć pozycję Usuń zaznaczenie, a następnie wybierz pozycję kolumn, lub kliknij przycisk Zaznacz wszystko zaznacz wszystkie kolumny.

Uwaga: Usunięcie duplikatów są usuwane z arkusza. Jeśli przypadkowo usunąć dane, które chcesz zachować, możesz za pomocą Klawiszy Ctrl + Z lub przycisk Cofnij Przycisk Cofnij na pasku Narzędzi Szybki dostęp przywrócenie danych usuniętych. Można również używać formatowania warunkowego do wyróżnienia zduplikowanych wartości, przed usunięciem ich. Aby uzyskać więcej informacji zobacz temat Dodawanie, zmienianie lub czyszczenie formatów warunkowych.

  1. Upewnij się, że aktywna komórka znajduje się w kolumnie tabeli.

  2. Kliknij strzałkę Strzałka listy rozwijanej filtru w nagłówku kolumny.

  3. Do filtrowania z uwzględnieniem pustych komórek, w menu Autofiltr u góry listy wartości, wyczyść pole wyboru (Zaznacz wszystko), a następnie u dołu listy wartości, wybierz pozycję (puste).

    Uwaga: Pole wyboru (puste) jest dostępna tylko wtedy, gdy zakres komórek lub kolumnie tabeli zawiera co najmniej jedną pustą komórkę.

  4. Wybierz pozycję puste wiersze w tabeli i naciśnij klawisze CTRL + - (łącznika).

Za pomocą procedury podobne do filtrowania i usuwania wierszy pustego arkusza. Aby uzyskać więcej informacji na temat filtrowania z uwzględnieniem pustych wierszy w arkuszu zobacz Filtrowanie danych w zakresie lub tabeli.

Początek strony

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Zmienianie rozmiaru tabeli w aplikacji Excel Online

Jak można scalić dwie lub większą liczbę tabel?

Tworzenie tabeli programu Excel w arkuszu

Używanie odwołań strukturalnych w formułach tabeli programu Excel

Formatowanie tabeli programu Excel

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×