Przejdź do głównej zawartości

WYBIERZ, funkcja

Ten artykuł zawiera opis składni formuły i zastosowania funkcji WYBIERZ w programie Microsoft Excel.

Opis

Funkcja używa argumentu nr_arg, aby zwrócić wartość z listy argumentów wartości. Funkcja WYBIERZ służy do wybierania jednej z maksymalnie 254 wartości na podstawie numeru argumentu. Jeśli na przykład argumenty od wartość1 do wartość7 to dni tygodnia, funkcja WYBIERZ zwróci jeden z dni, gdy jako argument nr_arg zostanie użyta liczba z przedziału między 1 a 7.

Składnia

WYBIERZ(nr_arg;wartość1;[wartość2];...)

W składni funkcji WYBIERZ występują następujące argumenty:

  • Nr_arg    Argument wymagany. Określa, który z argumentów wartości zostanie wybrany. Argument nr_arg musi być liczbą za zakresu od 1 do 254 lub formułą albo odwołaniem do komórki zawierającej liczbę z tego zakresu.

    • Jeśli nr_arg jest równy 1, to funkcja WYBIERZ zwraca wartość1, jeśli nr_arg jest równy 2, to funkcja WYBIERZ zwraca wartość2 itd.

    • Jeśli index_num jest mniejsza niż 1 lub większa niż numer ostatniej wartości na liście, wybierz pozycję zwraca #VALUE! #ADR!.

    • Gdy nr_arg to ułamek, wówczas argument zostaje przed użyciem przycięty do najmniejszej liczby całkowitej.

  • Wartość1; wartość2;...     Argument wartość1 jest wymagany, pozostałe są opcjonalne. Od 1 do 254 argumentów wartości, spośród których funkcja WYBIERZ wybiera wartość lub akcję do wykonania na podstawie argumentu nr_arg. Argumentami mogą być liczby, odwołania do komórek, zdefiniowane nazwy, formuły, funkcje lub tekst.

Spostrzeżenia

  • Jeśli nr_arg to tablica, to każda wartość jest szacowana, gdy szacowana jest funkcja WYBIERZ.

  • Argumenty wartości funkcji WYBIERZ mogą być zarówno odwołaniami do zakresów, jak i pojedynczymi wartościami.

    Na przykład formuła:

= SUMA(WYBIERZ(2;A1:A10;B1: B10;C1:C10))

jest szacowana jako:

=SUMA(B1:B10)

która następnie zwraca wartość na podstawie wartości z zakresu B1:B10.

Funkcja WYBIERZ jest szacowana jako pierwsza i zwraca odwołanie B1:B10. Funkcja SUMA jest wówczas szacowana przy użyciu odwołania B1:B10, wyniku funkcji WYBIERZ, jako argumentu.

Przykłady

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

Dane

 

Pierwszy

Gwoździe

Drugi

Wkręty

Trzeci

Nakrętki

Skończone

Śruby

Formuła

Opis

Wynik

=WYBIERZ(2;A2;A3;A4;A5)

Wartość drugiego argumentu z listy (wartość komórki A3)

Drugi

=WYBIERZ(4;B2;B3;B4;B5)

Wartość czwartego argumentu z listy (wartość komórki B5)

Śruby

=WYBIERZ(3;"Szerokie";115;"świat";8)

Wartość trzeciego argumentu z listy

świat

Przykład 2

Dane

23

45

12

10

Formuła

Opis (wynik)

Wynik

=SUMA(A2:WYBIERZ(2;A3;A4;A5))

Sumuje zakres A2:A4. Funkcja WYBIERZ zwraca komórkę A4 jako drugą część zakresu dla funkcji SUMA.

80

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×