Wprowadzenie do tabel

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Dane w bazie danych są przechowywane w tabelach — powiązanych tematycznie listach zawierających informacje rozmieszczone w rekordach. Można na przykład utworzyć tabelę Kontakty, w której będzie przechowywana lista nazwisk, adresów e-mail i numerów telefonów.

Ten artykuł zawiera omówienie tabel w Microsoft Access 2010 i przedstawiono funkcje nowej lub usunięte tabeli. W tym artykule wyjaśniono również umożliwiające utworzenie tabeli, jak dodać pola do tabeli, jak ustawić tabeli klucz podstawowy i ustawiania właściwości pól i tabel.

Należy uruchomić, projektowaniu bazy danych przez wszystkich jej tabel planowania i określanie, jak są powiązane ze sobą. Przed utworzeniem tabel starannie należy rozważyć, czy z wymaganiami i oznaczyć wszystkie tabele, które są potrzebne. Wprowadzenie do planowania i projektowania bazy danych zobacz artykuł podstawowe informacje o projekcie bazy danychi łączy w sekcji Zobacz też.

Uwaga: Widok projektu nie jest dostępna dla tabel sieci web. Czy należy używać funkcji projektowania, które znajdują się teraz w widoku arkusza danych. Aby uzyskać więcej informacji o projektowaniu bazy danych sieci web zobacz artykuł Tworzenie bazy danych udostępnianej w sieci Web.

W tym artykule

Omówienie

Specyfikacje tabeli

Co nowego

Tworzenie nowej tabeli

Ustawianie klucza podstawowego tabeli

Ustawianie właściwości tabeli

Dodawanie pola do tabeli

Tworzenie pola obliczeniowego

Ustawianie właściwości pola

Omówienie

Tabela jest obiektem bazy danych używanym do przechowywania danych związanych z określonym tematem, takim jak pracownicy czy produkty. Tabela składa się z rekordów i pól.

Każdy rekord zawiera dane o jednym wystąpieniu elementu związanego z danym tematem, na przykład o konkretnym pracowniku. Rekord jest też często określany jako wiersz lub wystąpienie.

Każde pole zawiera dane dotyczące jednego aspektu tematu tabeli, na przykład imienia lub adresu e-mail. Pole jest również często nazywane kolumną lub atrybutem.

Rekord składa się z wartości pól, na przykład Contoso Ltd. czy osoba@example.com. Wartość pola nazywa się także faktem.

Tabela Klienci w programie Access, na przykładzie której pokazano układ rekordów i pól

1. Rekord

2. Pole

3. Wartość pola

Baza danych może zawierać wiele tabel przechowujących informacje dotyczące różnych tematów. Każda tabela może zawierać wiele pól różnych typów danych, takich jak tekst, liczby, daty i hiperłącza.

Dane zewnętrzne

Użytkownik może tworzyć łącza do różnych zewnętrznych źródeł danych, takich jak inne bazy danych, pliki tekstowe i skoroszyty programu Excel. Łącza z danymi zewnętrznymi mogą być używane w programie Access tak samo jak tabele. W zależności od zewnętrznego źródła danych i sposobu, w jaki utworzono łącze, mogą być dostępne funkcje edytowania danych w połączonej tabeli i tworzenia relacji obejmujących połączoną tabelę. Za pomocą utworzonego łącza nie można jednak zmieniać projektu danych zewnętrznych.

Właściwości tabel i pól

Tabele i pola mają właściwości umożliwiające definiowanie ich cech lub zachowania.

Arkusze właściwości tabeli i pola
Tabela otwarta w widoku projektu.

1. Właściwości tabeli

2. Właściwości pola

W bazie danych programu Access właściwości tabeli są atrybutami tabeli, które mają wpływ na wygląd lub zachowanie tabeli jako całości. Właściwości tabeli są ustawiane w arkuszu właściwości tej tabeli w widoku projektu. Na przykład właściwość tabeli Widok domyślny można ustawić w taki sposób, aby określała domyślny sposób wyświetlania tabeli.

Właściwość pola dotyczy określonego pola w tabeli i definiuje jedną z cech tego pola lub jeden aspekt jego zachowania. Określenie niektórych właściwości pól umożliwia widok arkusza danych. Natomiast w widoku projektu można określić dowolne właściwości pól, korzystając z okienka Właściwości pola.

Typy danych

Każde pole ma określony typ danych. Typ danych pola wskazuje rodzaj danych przechowywanych w polu, na przykład duże ilości tekstu lub załączone pliki.

Ustawienie typu danych

Typ danych jest właściwością pola, ale różni się od innych właściwości pól w następujący sposób:

  • Typ danych pola jest ustawiany w siatce projektu tabeli, a nie w okienku Właściwości pola.

  • Typ danych pola określa, jakie inne właściwości pola są dostępne.

  • Podczas tworzenia pola należy ustawić jego typ danych.

    Uwaga: Nowe pole w programie Access można utworzyć, wprowadzając dane w nowej kolumnie w widoku arkusza danych. W przypadku utworzenia pola przez wprowadzenie danych w widoku arkusza danych program Access automatycznie przypisuje do tego pola typ danych na podstawie wprowadzonej wartości. Jeśli z wprowadzonych danych nie wynika żaden inny typ danych, program Access ustawia typ danych Tekst. W razie potrzeby można zmienić to ustawienie za pomocą Wstążki, którą zawiera nowy interfejs użytkownika Microsoft Office Fluent.

Przykłady automatycznego wykrywania typu danych

W poniższej tabeli przedstawiono sposób działania automatycznego wykrywania typu danych w widoku arkusza danych.

Po wprowadzeniu:

Typ danych pola tworzonego przez program Office Access 2007

Joanna

Tekst

http://www.contoso.com

Można użyć dowolnego prefiksu protokołu internetowego, na przykład http://, https:// i mailto:.

Hiperłącze

2,54

Liczba całkowita długa

50 000

Liczba całkowita długa

50 000,99

Liczba (Podwójna precyzja)

50000,389

Liczba (Podwójna precyzja)

1967-12

Formaty daty i godziny są rozpoznawane zgodnie z ustawieniami lokalnymi użytkownika.

Data/Godzina

31 grudnia 2006

Data/Godzina

10:50:23

Data/Godzina

10:50 AM

Data/Godzina

17:50

Data/Godzina

12,50 zł

Program rozpoznaje symbol waluty określony w ustawieniach lokalnych użytkownika.

Waluta

21,75

Liczba (Podwójna precyzja)

123,00%

Liczba (Podwójna precyzja)

3,46E+03

Liczba (Podwójna precyzja)

Relacje między tabelami

Mimo że w każdej tabeli są przechowywane dane dotyczące innego tematu, tabele baz danych zwykle zawierają dane dotyczące tematów, które są ze sobą powiązane. Baza danych może na przykład zawierać:

  • tabelę klientów obejmującą klientów firmy oraz ich adresy;

  • tabelę produktów obejmującą sprzedawane produkty, w tym ceny i zdjęcia każdego z nich;

  • tabelę zamówień umożliwiającą śledzenie zamówień klientów.

W związku z tym, że dane dotyczące różnych tematów są przechowywane w osobnych tabelach, potrzebna jest możliwość łatwego łączenia powiązanych danych z różnych tabel. Aby połączyć dane przechowywane w różnych tabelach, należy utworzyć relacje. Relacja jest logicznym połączeniem między dwiema tabelami, które określa wspólne pola obu tabel.

Klucze

Pola będące częścią relacji tabel są określane jako klucze. Klucz zwykle składa się z jednego pola, ale może składać się z wielu pól. Istnieją dwa rodzaje kluczy:

  • Klucz podstawowy    Tabela może mieć tylko jeden klucz podstawowy. Klucz podstawowy składa się z pewnej liczby pól, które pozwalają jednoznacznie zidentyfikować każdy rekord przechowywany w tabeli. Kluczem podstawowym zazwyczaj może być istniejący unikatowy numer identyfikacyjny, taki jak identyfikator, numer seryjny albo kod. Na przykład w tabeli Klienci każdy klient może mieć unikatowy identyfikator. Pole identyfikatora klienta jest kluczem podstawowym takiej tabeli. Gdy klucz podstawowy zawiera więcej niż jedno pole, jest zwykle złożony z istniejących pól, które łącznie zapewniają unikatowe wartości. Jako klucza podstawowego tabeli dotyczącej osób można na przykład użyć kombinacji nazwiska, imienia i daty urodzenia.

  • Klucz obcy    Tabela może również mieć jeden lub więcej kluczy obcych. Klucz obcy zawiera wartości odpowiadające wartościom w kluczu podstawowym innej tabeli. Przykładem może być tabela Zamówienia, w której dla każdego zamówienia istnieje numer identyfikacyjny klienta, odpowiadający rekordowi w tabeli Klienci. Pole identyfikatora klienta jest kluczem obcym tabeli Zamówienia.

Podstawą relacji między tabelami jest zgodność wartości w polach kluczy. Takie relacje służą do łączenia danych z powiązanych tabel. Załóżmy na przykład, że utworzono tabelę Klienci i tabelę Zamówienia. W tabeli Klienci poszczególne rekordy są identyfikowane przy użyciu pola klucza podstawowego o nazwie Identyfikator.

Aby skojarzyć każde zamówienie z klientem, do tabeli Zamówienia należy dodać pole klucza obcego odpowiadające polu Identyfikator tabeli Klienci, a następnie utworzyć relację między tymi dwoma kluczami. W przypadku dodawania rekordu do tabeli Zamówienia używana wartość identyfikatora klienta będzie pochodzić z tabeli Klienci. Gdy będzie konieczne wyświetlenie informacji o kliencie związanym z określonym zamówieniem, ta relacja umożliwi zidentyfikowanie, które dane z tabeli Klienci odpowiadają poszczególnym rekordom w tabeli Zamówienia.

An Access table relationship shown in the Relationships window
Relacja między tabelami widoczna w oknie Relacje.

1. Klucz podstawowy oznaczony ikoną klucza obok nazwy pola.

2. Klucz obcy — należy zwrócić uwagę na brak ikony klucza.

Zalety korzystania z relacji

Przechowywanie danych w osobnych, powiązanych tabelach ma następujące zalety:

  • Spójność    W związku z tym, że każdy element danych jest rejestrowany tylko raz, w jednej tabeli, zmniejsza się prawdopodobieństwo wystąpienia niejednoznaczności lub niespójności. Na przykład nazwa klienta jest przechowywana tylko raz, w tabeli dotyczącej klientów, a nie wielokrotnie (i potencjalnie niespójnie) w tabeli zawierającej dane dotyczące zamówień.

  • Wydajność    Rejestrowanie danych tylko w jednym miejscu zmniejsza użycie miejsca na dysku. Ponadto mniejsze tabele pozwalają udostępniać dane szybciej niż duże. Gdyby oddzielne tabele nie były stosowane w przypadku osobnych tematów, umożliwiłoby to wprowadzanie wartości null (brak danych) i nadmiarowych danych, co z kolei spowodowałoby utratę miejsca i pogorszenie wydajności.

  • Zrozumiałość    Projekt bazy danych jest łatwiejszy do zrozumienia, jeśli dane dla poszczególnych tematów są właściwie rozmieszczone w tabelach.

Porada: Tabele należy planować z myślą o relacjach. Aby utworzyć pole klucza obcego, można skorzystać z Kreatora odnośników, jeśli tabela zawierająca odpowiedni klucz podstawowy już istnieje. Kreator odnośników utworzy relacje automatycznie.

Początek strony

Specyfikacje tabeli

W Access 2010 tabeli zawiera następujące ograniczenie praktyczne:

Atrybut

Wartość maksymalna

Liczba znaków w nazwie tabeli

64

Liczba znaków w nazwie pola

64

Liczba pól w tabeli

255

Liczba otwartych tabel

2048; ten limit obejmuje tabele otwierane wewnętrznie przez program Access

Rozmiar tabeli

2 gigabajty minus miejsce potrzebne na obiekty systemowe

Liczba znaków w polu typu Tekst

255

Liczba znaków w polu typu Nota

65 535, gdy dane są wprowadzane za pośrednictwem interfejsu użytkownika;
2 gigabajty, gdy dane są wprowadzane programowo

Rozmiar pola typu Obiekt OLE

1 gigabajt

Liczba indeksów w tabeli

32

Liczba pól w indeksie

10

Liczba znaków w komunikacie sprawdzania poprawności

255

Liczba znaków w regule sprawdzania poprawności

2 048

Liczba znaków w opisie tabeli lub pola

255

Liczba znaków w rekordzie (oprócz pól typu Nota i Obiekt OLE), gdy właściwość pól Kompresja Unicode jest ustawiona na wartość Tak

4 000

Liczba znaków w ustawieniu właściwości pola

255

Początek strony

Co nowego

Różnice w porównaniu z programem Access 2007

Tworzenie tabeli w Access 2010 jest bardzo podobne proces tworzenia tabeli w programie Access 2007. Jednak w Access 2010 istnieje kilka nowych funkcji, które dotyczą tabel:

  • Makra danych    Obecnie makra można dołączać do zdarzeń w tabelach, co umożliwia wykonywanie akcji po zmodyfikowaniu, wstawieniu lub usunięciu rekordu. Te makra mogą być na przykład używane do sprawdzania poprawności danych lub wykonywania obliczeń.

  • Typ danych Obliczeniowy    Ten nowy typ danych umożliwia utworzenie pola na podstawie obliczeń uwzględniających inne pola w tej samej tabeli. Można na przykład utworzyć pole Suma wiersza, które będzie zawierać iloczyn wartości pola Ilość i pola Cena jednostkowa. W przypadku aktualizacji pola Ilość lub pola Cena jednostkowa pole Suma wiersza zostanie zaktualizowane automatycznie.

  • Łączność z usługami sieci Web    Oprócz tworzenia połączeń z zewnętrznymi źródłami danych, takimi jak skoroszyty programu Excel i listy programu SharePoint, można obecnie tworzyć połączenia z danymi w witrynach sieci Web, które udostępniają interfejs usługi sieci Web. Można na przykład utworzyć łącze z danymi w witrynie sieci Web sprzedawcy internetowego, a następnie utworzyć własną aplikację umożliwiającą wyświetlanie produktów lub wprowadzanie zamówień.

  • Tabeli i Szablony pól są zastępowane przez modele    Program Access 2007 wprowadzona Szablony tabel i Szablony pól. Szablony tabel są puste tabele, których można używać do tworzenia nowych tabel, dostępne są zgodne z wbudowanych list programu Windows SharePoint Services:

    • Kontakty

    • Zadania

    • Problemy

    • Wydarzenia

    • Majątek

      W Access 2010 można użyć modeli umożliwia dodawanie składników gotowy do bazy danych. Modele mogą zawierać tabele i można także dodać inne rodzaje obiektów bazy danych, takich jak kwerendy i formularze.

      Uwaga: Ten temat nie zawiera objaśnienia dotyczącego modeli. Więcej informacji można znaleźć w sekcji Zobacz też.

Różnice w porównaniu z programem Access 2003

  • Modele został zastąpiony Kreatorem tabel    Aby szybko utworzyć tabelę, odpowiadając na kilka pytań w wersjach programu Access wcześniejszych niż 2007 użyto Kreatora tabeli. W programie Access 2007 Kreatora tabel została zastąpiona Szablony tabel i pól. W Access 2010 modeli Zamień Szablony tabel i pól.

    Uwaga: Ten temat nie zawiera objaśnienia dotyczącego modeli. Więcej informacji można znaleźć w sekcji Zobacz też.

  • Tworzenie arkusza danych     Tabele i pola można obecnie tworzyć i modyfikować podczas pracy w widoku arkusza danych.

Początek strony

Tworzenie nowej tabeli

Nową tabelę można utworzyć, jeśli jest dostępne nowe źródło danych, które nie należy do żadnej z istniejących tabel.

Tabelę można utworzyć przez utworzenie nowej bazy danych, wstawienie tabeli do istniejącej bazy danych lub zaimportowanie albo połączenie tabeli z innego źródła danych — skoroszytu programu Microsoft Office Excel, dokumentu programu Microsoft Office Word, pliku tekstowego, usługi sieci Web lub innej bazy danych. Do utworzonej nowej, pustej bazy danych jest automatycznie wstawiana nowa, pusta tabela. Następnie można wprowadzić dane, aby rozpocząć definiowanie pól.

Co chcesz zrobić?

Tworzenie nowej tabeli w nowej bazie danych

Tworzenie nowej tabeli w istniejącej bazie danych

Tworzenie nowej tabeli w nowej bazie danych

  1. Na karcie Plik kliknij pozycję Nowy, a następnie kliknij pozycję Pusta baza danych.

  2. W polu Nazwa pliku wpisz nazwę pliku nowej bazy danych.

  3. Aby przejść do innej lokalizacji w celu zapisania bazy danych, kliknij ikonę folderu.

  4. Kliknij przycisk Utwórz.

    Program otworzy nową bazę danych z nową tabelą o nazwie Tabela1, która zostanie otwarta w widoku arkusza danych.

Tworzenie tabeli w istniejącej bazie danych

  1. Kliknij kartę Plik, wskaż pozycję Otwórz, a następnie wykonaj jedną z poniższych czynności:

    • Jeśli żądana baza danych znajduje się na liście w obszarze Ostatnio używane bazy danych, kliknij ją na tej liście.

      — lub —

    • Jeśli żądanej bazy danych nie ma w obszarze Ostatnio używane bazy danych, kliknij odpowiednią opcję w obszarze Otwórz dokument.

  2. W oknie dialogowym Otwieranie wybierz bazę danych, którą chcesz otworzyć, a następnie kliknij przycisk Otwórz.

  3. Na karcie Tworzenie w grupie Tabele kliknij pozycję Tabela.

    Do bazy danych zostanie wstawiona nowa tabela, która zostanie otwarta w widoku arkusza danych.

Początek strony

Importowanie lub łączenie w celu utworzenia tabeli

Tabelę można utworzyć przez zaimportowanie lub połączenie danych przechowywanych w innym miejscu. Można zaimportować lub połączyć dane znajdujące się między innymi w arkuszu programu Excel, na liście programu Windows SharePoint Services, w pliku XML, w innej bazie danych programu Access lub w folderze programu Microsoft Office Outlook.

Podczas importowania danych jest tworzona ich kopia w nowej tabeli w bieżącej bazie danych. Kolejne zmiany danych źródłowych nie będą miały wpływu na zaimportowane dane, a zmiany dotyczące zaimportowanych danych nie będą miały wpływu na dane źródłowe. Po nawiązaniu połączenia ze źródłem danych i zaimportowaniu danych można z nich korzystać, nie mając połączenia ze źródłem. Projekt zaimportowanej tabeli można zmienić.

Utworzenie łącza z danymi powoduje, że w bieżącej bazie danych jest tworzona tabela połączona, reprezentująca aktualizowane na bieżąco łącze z informacjami przechowywanymi w innym miejscu. Zmiana danych w tabeli połączonej powoduje ich zmianę w źródle. Każda zmiana danych w źródle jest widoczna w tabeli połączonej. W przypadku korzystania z tabeli połączonej użytkownik musi mieć możliwość nawiązania połączenia ze źródłem danych. Projektu tabeli połączonej nie można zmienić.

Uwaga: Przy użyciu tabeli połączonej nie można edytować danych w arkuszu programu Excel. Można natomiast zaimportować dane źródłowe do bazy danych programu Access, a następnie utworzyć łącze do niej z poziomu programu Excel. Aby uzyskać więcej informacji na temat tworzenia łączy do programu Access z poziomu programu Excel, przeszukaj Pomoc programu Excel lub skorzystaj z łączy w sekcji Zobacz też.

Tworzenie nowej tabeli przez zaimportowanie lub połączenie danych zewnętrznych

  1. Na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij jedno z dostępnych źródeł danych.

  2. Postępuj zgodnie z instrukcjami w oknach dialogowych wyświetlanych na poszczególnych etapach.

    Program Access utworzy nową tabelę i wyświetli ją w okienku nawigacji.

Porada: Za pomocą odpowiedniego polecenia na karcie Tworzenie można także zaimportować lub połączyć listę programu SharePoint.

Początek strony

Tworzenie tabeli przy użyciu witryny programu SharePoint

Można utworzyć tabelę w bazie danych, które importują dane z lub łącza do listy programu SharePoint. Można także tworzyć nowej listy programu SharePoint przy użyciu wstępnie zdefiniowanego szablonu. Wstępnie zdefiniowane szablony Access 2010 zawierać kontakty, zadania, problemy i wydarzenia.

  1. Na karcie Tworzenie w grupie Tabele kliknij pozycję Listy SharePoint.

  2. Wykonaj jedną z następujących czynności:

    • Tworzenie listy programu SharePoint na podstawie szablonu

      1. Kliknij pozycję Kontakty, Zadania, Problemy lub Wydarzenia.

      2. W oknie dialogowym Tworzenie nowej listy wpisz adres URL witryny programu SharePoint, w której chcesz utworzyć listę.

      3. Wprowadź nazwę nowej listy oraz jej opis w polach Określ nazwę nowej listy i Opis.

      4. Aby po utworzeniu połączonej tabeli otworzyć ją, zaznacz pole wyboru Otwórz listę po zakończeniu (domyślnie zaznaczone).

    • Tworzenie nowej listy niestandardowej

      1. Kliknij pozycję Niestandardowa.

      2. W oknie dialogowym Tworzenie nowej listy wpisz adres URL witryny programu SharePoint, w której chcesz utworzyć listę.

      3. Wprowadź nazwę nowej listy oraz jej opis w polach Określ nazwę nowej listy i Opis.

      4. Aby po utworzeniu połączonej tabeli otworzyć ją, zaznacz pole wyboru Otwórz listę po zakończeniu (domyślnie zaznaczone).

    • Importowanie danych z istniejącej listy

      1. Kliknij polecenie Istniejąca lista programu SharePoint.

      2. W oknie dialogowym Pobieranie danych zewnętrznych wpisz adres URL witryny programu SharePoint zawierającej dane, które chcesz zaimportować.

      3. Kliknij opcję Importuj dane źródłowe do nowej tabeli w bieżącej bazie danych, a następnie kliknij przycisk Dalej.

      4. Zaznacz pole wyboru obok każdej listy programu SharePoint, którą chcesz zaimportować.

    • Łączenie z istniejącą listą

      1. Kliknij polecenie Istniejąca lista programu SharePoint.

      2. W oknie dialogowym Pobieranie danych zewnętrznych — witryna programu SharePoint wpisz adres URL witryny programu SharePoint zawierającej listę, do której chcesz utworzyć łącze.

      3. Kliknij opcję Połącz ze źródłem danych, tworząc tabelę połączoną, a następnie kliknij przycisk Dalej.

      4. Zaznacz pole wyboru obok każdej listy programu SharePoint, do której chcesz utworzyć łącze.

Początek strony

Tworzenie tabeli przy użyciu usługi sieci Web

W bazie danych można utworzyć tabelę połączoną z danymi w witrynie sieci Web udostępniającej interfejs usługi sieci Web.

Uwaga: Tabele usług sieci Web są dostępne tylko do odczytu.

  1. Na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij pozycję Więcej, a następnie kliknij pozycjęUsługi danych.

  2. Jeśli połączenie, którego chcesz użyć, zostało już zainstalowane, przejdź do kroku 5. W przeciwnym razie przejdź do następnego kroku.

  3. Kliknij pozycję Zainstaluj nowe połączenie.

  4. Zaznacz plik połączenia, którego chcesz użyć, a następnie kliknij przycisk OK.

  5. W oknie dialogowym Tworzenie łącza do danych usługi sieci Web rozwiń połączenie, którego chcesz użyć.

  6. Zaznacz tabelę, do której chcesz utworzyć łącze.

    Program Access wyświetli pola po prawej stronie okna dialogowego.

  7. Opcjonalnie można wpisać nazwę połączonej tabeli w polu Określ nazwę łącza. Program Access użyje tej nazwy w okienku nawigacji.

  8. Kliknij przycisk OK.

    Program Access utworzy tabelę połączoną.

Początek strony

Ustawianie klucza podstawowego tabeli

Określenie klucza podstawowego tabeli pozwala uzyskać następujące korzyści:

  • Program Access automatycznie tworzy indeks dla klucza podstawowego, co może pomóc w zwiększeniu wydajności bazy danych.

  • Program Access sprawdza, czy każdy rekord ma wartość w polu klucza podstawowego.

  • Program Access sprawdza, czy każda wartość w polu klucza jest unikatowa. Unikatowość wartości jest bardzo ważna, ponieważ bez niej nie można jednoznacznie odróżnić danego rekordu od innych.

Gdy nowa tabela jest tworzona w widoku arkusza danych, program Access automatycznie tworzy klucz podstawowy i przypisuje mu nazwę pola Identyfikator oraz typ danych Autonumerowanie.

W widoku projektu można zmienić lub usunąć klucz podstawowy albo ustawić klucz podstawowy dla tabeli, która go nie ma.

Określanie pól używanych jako klucz podstawowy

Czasami użytkownik ma już dane, których chce używać jako klucza podstawowego. Mogą to być na przykład istniejące numery identyfikacyjne pracowników. Tworząc tabelę do śledzenia informacji o pracownikach, jako klucza podstawowego tabeli można użyć istniejących identyfikatorów pracowników. W niektórych przypadkach identyfikator pracownika jest unikatowy dopiero w połączeniu z identyfikatorem działu, co wymaga użycia obu pól jako klucza podstawowego. Pola używane jako klucz podstawowy powinny mieć następujące cechy:

  • Każdy rekord ma unikatową wartość dla pola lub kombinacji pól.

  • Pole lub kombinacja pól nigdy nie są puste ani nie mają wartości null — wartość zawsze istnieje.

  • Wartości nie są zmieniane.

Jeśli nie ma odpowiednich danych do użycia jako klucz podstawowy, można utworzyć nowe pole przeznaczone do tego celu. Podczas tworzenia nowego pola, które ma być używane jako klucz podstawowy, typ danych pola należy ustawić na Autonumerowanie, aby uzyskać pewność, że to pole będzie miało trzy wymienione wcześniej cechy.

Ustawianie lub zmienianie klucza podstawowego

  1. Zaznacz tabelę, której klucz podstawowy chcesz ustawić lub zmienić.

  2. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  3. W siatce projektu tabeli zaznacz pole lub pola, których chcesz użyć jako klucza podstawowego.

    Aby zaznaczyć jedno pole, kliknij selektor wiersza odpowiedniego pola.

    Aby zaznaczyć więcej niż jedno pole, przytrzymaj wciśnięty klawisz CTRL i kliknij kolejno selektory wiersza poszczególnych pól.

  4. Na karcie Projektowanie w grupie Narzędzia kliknij pozycję Klucz podstawowy.

    Grupa Narzędzia na karcie Projektowanie

    Wskaźnik klucza pojawi się po lewej stronie pola lub pól określonych jako klucz podstawowy.

Usuwanie klucza podstawowego

  1. Zaznacz tabelę, której klucz podstawowy chcesz usunąć.

  2. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  3. Kliknij selektor wiersza bieżącego klucza podstawowego. Jeśli klucz podstawowy obejmuje wiele pól, przytrzymaj naciśnięty klawisz CTRL, a następnie kliknij selektory wierszy poszczególnych pól.

  4. Na karcie Projektowanie w grupie Narzędzia kliknij przycisk Klucz podstawowy.

    Grupa Narzędzia na karcie Projektowanie

    Z pola lub pól określonych wcześniej jako klucz podstawowy zostanie usunięty wskaźnik klucza.

Uwaga: Jeśli nowa tabela jest zapisywana bez ustawienia dla niej klucza podstawowego, program Access wyświetla monit o utworzenie nowego pola dla klucza podstawowego. Jeśli użytkownik kliknie przycisk Tak, program Access utworzy pole identyfikatora mające typ danych Autonumerowanie, aby zapewnić unikatowe wartości każdego rekordu. Jeśli tabela zawiera już pole Autonumerowanie, program Access użyje go jako klucza podstawowego. Jeśli użytkownik kliknie przycisk Nie, program Access nie doda pola i nie ustawi klucza podstawowego.

Początek strony

Ustawianie właściwości tabeli

Właściwości można ustawić w taki sposób, aby były stosowane do całej tabeli lub do całych rekordów.

  1. Zaznacz tabelę, której właściwości chcesz ustawić.

  2. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  3. Na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij przycisk Arkusz właściwości.

    Grupa Pokazywanie/ukrywanie na karcie Projektowanie w programie Access

    Zostanie wyświetlony arkusz właściwości tabeli.

  4. W arkuszu właściwości kliknij kartę Ogólne.

  5. Kliknij pole po lewej stronie właściwości, którą chcesz ustawić, a następnie wprowadź ustawienie tej właściwości.

    Dostępne właściwości tabeli

    Właściwość tabeli

    Zastosowanie

    Wyświetl widoki w witrynie programu SharePoint

    Określenie, czy widoki utworzone na podstawie tabeli mogą być wyświetlane w witrynie programu SharePoint.

    Uwaga: Skutki użycia tego ustawienia zależą od ustawienia właściwości bazy danych Wyświetl wszystkie widoki w witrynie programu SharePoint.

    Więcej informacji można uzyskać w sekcji Zobacz też.

    Rozwinięty podarkusz danych

    Rozwijanie wszystkich podarkuszy danych po otwarciu tabeli.

    Wysokość podarkusza danych

    Wykonaj jedną z następujących czynności:

    • Jeśli chcesz, aby okno podarkusza danych było rozwijane w celu wyświetlenia wszystkich wierszy, pozostaw dla tej właściwości ustawienie 0 cm.

    • Jeśli chcesz sterować wysokością podarkusza danych, wprowadź żądaną wysokość w centymetrach.

    Orientacja

    Ustawienie orientacji widoku zgodnie ze sposobem czytania używanego języka — od lewej do prawej lub od prawej do lewej.

    Opis

    Podanie opisu tabeli. Ten opis będzie wyświetlany w etykietkach narzędzi danej tabeli.

    Widok domyślny

    Ustawienie domyślnego widoku używanego po otwarciu tabeli (widok Arkusz danych, Tabela przestawna lub Wykres przestawny).

    Reguła sprawdzania poprawności

    Wprowadzenie wyrażenia, które musi być spełnione przy dodawaniu lub zmienianiu rekordu.

    Tekst reguły sprawdzania poprawności

    Wprowadzenie tekstu komunikatu wyświetlanego w sytuacji, gdy rekord jest niezgodny z wyrażeniem we właściwości Reguła poprawności.

    Filtr

    Zdefiniowanie kryteriów służących do wyświetlania tylko dopasowanych wierszy w widoku arkusza danych.

    Uporządkuj według

    Określenie domyślnego porządku sortowania wierszy w widoku arkusza danych przez wybranie co najmniej jednego pola.

    Nazwa podarkusza danych

    Określenie, czy podarkusz danych powinien być wyświetlany w widoku arkusza danych, a jeśli tak, określenie, z której tabeli lub kwerendy mają pochodzić wiersze podarkusza.

    Podrzędne pola łączące

    Określenie listy pól w tabeli lub kwerendzie, które są używane w podarkuszu danych i są zgodne z właściwością Nadrzędne pola łączące określoną dla danej tabeli.

    Nadrzędne pola łączące

    Określenie listy pól w tabeli, które są zgodne z właściwością Podrzędne pola łączące określoną dla danej tabeli.

    Filtruj przy ładowaniu

    Automatyczne stosowanie kryteriów filtrowania określonych we właściwości Filtr po otwarciu tabeli w widoku arkusza danych (przez ustawienie tej właściwości na wartość Tak).

    Porządkuj przy ładowaniu

    Automatyczne stosowanie kryteriów sortowania określonych we właściwości Uporządkuj według po otwarciu tabeli w widoku arkusza danych (przez ustawienie tej właściwości na wartość Tak).

    Porada: Aby uzyskać więcej miejsca na wprowadzanie lub edytowanie ustawienia w polu właściwości, należy nacisnąć klawisze SHIFT+F2 w celu wyświetlenia okna Powiększenie. Jeśli we właściwości Reguła poprawności jest ustawiane wyrażenie i jest potrzebna pomoc przy jego konstruowaniu, należy kliknąć przycisk Przycisk Konstruktor obok pola właściwości RegułaPoprawności w celu wyświetlenia Konstruktora wyrażeń.

  6. Aby zapisać zmiany, naciśnij klawisze CTRL+S.

Początek strony

Dodawanie pola do tabeli

Każdy element danych, który ma być śledzony, jest przechowywany w polu. Na przykład w tabeli kontaktów można utworzyć pola Nazwisko, Imię, Numer telefonu i Adres. W tabeli produktów można utworzyć pola Nazwa produktu, Identyfikator produktu i Cena.

Przed utworzeniem pól warto rozdzielić dane na najmniejsze użyteczne elementy. O wiele łatwiej jest później połączyć te dane, niż je rozdzielać. Na przykład zamiast pola Imię i nazwisko warto rozważyć utworzenie osobnych pól dla nazwiska i dla imienia. Dzięki temu będzie można łatwo przeprowadzać wyszukiwanie lub sortowanie według pola Imię, według pola Nazwisko lub według obu tych pól jednocześnie. Jeśli w przypadku określonego elementu danych są planowane operacje raportowania, sortowania, wyszukiwania lub obliczania, należy umieścić ten element w osobnym polu. Aby uzyskać więcej informacji na temat projektowania bazy danych i tworzenia pól, skorzystaj z łączy w sekcji Zobacz też.

Po utworzeniu pola można również ustawić właściwości pola w celu sterowania jego wyglądem i zachowaniem.

Dodawanie pola przez wprowadzenie danych

Po utworzeniu nowej tabeli lub otwarciu istniejącej tabeli w widoku arkusza danych można dodać pole do tabeli, wprowadzając dane w kolumnie Dodaj nowe pole w arkuszu danych.

Datasheet in Access with Add New Field column

1. Dane należy wprowadzić w kolumnie Dodaj nowe pole.

  1. Utwórz lub otwórz tabelę w widoku arkusza danych.

    Aby uzyskać więcej informacji na temat tworzenia spisu zapoznaj się z sekcją Tworzenie nowej tabeli.

  2. W kolumnie Dodaj nowe pole wprowadź nazwę pola, które chcesz utworzyć.

    Użyj nazwy opisowej, aby można było to pole łatwiej zidentyfikować.

  3. Wprowadź dane w nowym polu.

Początek strony

Tworzenie pola obliczeniowego

Pole obliczeniowe jest tworzone w widoku projektu.

  1. Otwórz w widoku projektu tabelę, w której chcesz utworzyć pole obliczeniowe.

  2. W pierwszym pustym wierszu w siatce projektu tabeli wpisz nazwę pola obliczeniowego w obszarze Nazwa pola.

  3. W obszarze Typ danych wybierz pozycję Obliczeniowy.

    Zostanie otwarty Konstruktor wyrażeń.

  4. Wprowadź obliczeń, które chcesz wykonać w Konstruktorze wyrażeń. Na przykład, jeśli tabela ma pole1, Pole2, a chcesz utworzyć pole obliczeniowe (pole3) jest równa wartości pole1 podzielona przez liczbę pole2, należy wpisać [pole1]-[pole2] w Konstruktorze wyrażeń.

    Aby uzyskać więcej informacji na temat wyrażeń zobacz artykuł Wprowadzenie do wyrażeń.

  5. Po wprowadzeniu obliczenia kliknij przycisk OK.

    Porada: Warto przełączyć się do widoku arkusza danych w celu upewnienia się, że pole obliczeniowe działa w oczekiwany sposób.

Początek strony

Ustawianie właściwości pola

Po utworzeniu pola można ustawić właściwości pola w celu sterowania jego wyglądem i zachowaniem.

Ustawiając właściwości pola, można na przykład:

  • sterować wyglądem danych w polu,

  • zapobiec wprowadzaniu niepoprawnych danych w polu,

  • określić wartości domyślne pola,

  • przyspieszyć wyszukiwanie i sortowanie w polu.

Niektóre z dostępnych właściwości można ustawić podczas pracy w widoku arkusza danych. Aby jednak uzyskać dostęp do pełnej listy właściwości pola i móc je ustawiać, należy korzystać z widoku projektu.

Ustawianie właściwości pola w widoku arkusza danych

Podczas pracy w widoku arkusza danych można zmienić nazwę pola, typ danych pola, właściwość Format i kilka innych właściwości pola.

Otwieranie tabeli w widoku arkusza danych

  1. W okienku nawigacji kliknij prawym przyciskiem myszy tabelę, którą chcesz otworzyć.

  2. W menu skrótów kliknij polecenie Widok arkusza danych.

Zmienianie nazwy pola

Po dodaniu pola przez wprowadzenie danych w widoku arkusza danych program Access automatycznie przypisuje temu polu nazwę ogólną. Program Access przypisuje nazwę Pole1 pierwszemu nowemu polu, nazwę Pole2 — drugiemu nowemu polu i tak dalej. Domyślnie nazwa pola jest używana jako etykieta podczas wyświetlania pola, między innymi w nagłówku kolumny w arkuszu danych. Zmiana nazw pól na bardziej opisowe ułatwia korzystanie z pól podczas wyświetlania lub edytowania rekordów.

  1. Kliknij prawym przyciskiem myszy nagłówek pola, którego nazwę chcesz zmienić (na przykład Pole1).

  2. W menu skrótów kliknij polecenie Zmień nazwę kolumny.

  3. Wprowadź nową nazwę w nagłówku pola.

    Nazwy pól mogą zawierać maksymalnie 64 znaki (litery oraz liczby) z uwzględnieniem spacji.

Zmienianie typu danych pola

Po utworzeniu pola przez wprowadzenie danych w widoku arkusza danych program Access sprawdza te dane w celu określenia odpowiedniego typu danych dla pola. Jeśli na przykład zostanie wprowadzony ciąg 2006-01-01, program Access rozpozna te dane jako datę i ustawi dla pola typ danych Data/Godzina. Jeśli program Access nie może jednoznacznie określić typu danych, typ danych jest domyślnie ustawiany jako Tekst.

Typ danych pola określa, jakie inne właściwości pola można ustawiać. Na przykład właściwość Tylko dołącz można ustawić jedynie dla pól o typie danych Hiperłącze lub Nota.

Czasami jest konieczna ręczna zmiana typu danych pola. Załóżmy, że numery pokoi przypominają daty, na przykład 10-2001. Jeśli w nowym polu w widoku arkusza danych zostanie wprowadzony ciąg 10-2001, funkcja automatycznego wykrywania typu danych wybierze dla tego pola typ danych Data/Godzina. Ponieważ numery pokoi są etykietami, a nie datami, powinny mieć typ danych Tekst. Poniższa procedura umożliwia zmianę typu danych pola.

  1. Kliknij kartę Arkusz danych.

  2. Na liście Typ danych w grupie Typ i formatowanie danych wybierz odpowiedni typ danych.

    Obraz wstążki programu Access przedstawiający grupę Typ i formatowanie danych

    Dostępne typy danych

    Typ danych

    Przechowywane wartości

    Rozmiar

    Tekst

    Znaki alfanumeryczne.

    Służy do przechowywania tekstu lub liczb, które nie są wykorzystywane w obliczeniach (na przykład identyfikatora produktu). Przechowywanie wartości liczbowej w formacie tekstowym ułatwia jej logiczne sortowanie i filtrowanie, ale uniemożliwia jej łatwe używanie w obliczeniach.

    Maksymalnie 255 znaków.

    Nota

    Znaki alfanumeryczne (więcej niż 255 znaków) lub tekst sformatowany.

    Służy do przechowywania tekstu o długości większej niż 255 znaków lub tekstu sformatowanego. Dobrym przykładem użycia pola Nota jest wprowadzanie notatek, długich opisów czy akapitów sformatowanego tekstu (na przykład z zastosowaniem pogrubienia lub kursywy).

    Do 1 gigabajta znaków lub 2 gigabajty pamięci (2 bajty na znak), przy czym w formancie można wyświetlić 65 535 znaków.

    Liczba

    Wartości liczbowe (liczby całkowite lub ułamki).

    Służy do przechowywania liczb wykorzystywanych w obliczeniach, z wyjątkiem wartości pieniężnych (w przypadku wartości pieniężnych należy użyć typu danych Waluta).

    1, 2, 4 lub 8 bajtów; 16 bajtów w przypadku użycia jako identyfikatora replikacji.

    Data/Godzina

    Daty i godziny.

    Typ stosowany do przechowywania wartości daty/godziny. Każda przechowywana wartość zawiera zarówno składnik daty, jak i składnik godziny.

    8 bajtów.

    Waluta

    Wartości pieniężne.

    Typ stosowany do przechowywania wartości pieniężnych (waluty).

    8 bajtów.

    Autonumerowanie

    Unikatowa wartość liczbowa wstawiana automatycznie w programie Access w momencie dodania rekordu.

    Służy do generowania unikatowych wartości, których można użyć jako kluczy podstawowych. Wartości w polach Autonumerowanie mogą wzrastać kolejno lub o określoną wartość albo być przypisywane losowo.

    4 bajty lub 16 bajtów w przypadku identyfikatora replikacji.

    Tak/Nie

    Wartości logiczne (Tak/Nie).

    Możesz użyć jednego z następujących formatów: Tak/Nie, Prawda/Fałsz lub Włączone/Wyłączone.

    1 bit (8 bitów = 1 bajt).

    Obiekt OLE

    Obiekty OLE lub inne dane binarne.

    Służy do przechowywania obiektów OLE z innych programów dla systemu Microsoft Windows.

    Do 1 gigabajta.

    Załącznik

    Rysunki, obrazy, pliki binarne, pliki pakietu Office.

    Preferowany typ danych dla potrzeb przechowywania cyfrowych obrazów i plików binarnych dowolnego typu.

    2 gigabajty w przypadku załączników skompresowanych. Około 700 kilobajtów w przypadku załączników nieskompresowanych, w zależności od możliwego stopnia kompresji załącznika.

    Hiperłącze

    Hiperłącza.

    Typ stosowany do przechowywania hiperłączy w celu uzyskania dostępu jednym kliknięciem do stron sieci Web przy użyciu adresu URL (Uniform Resource Locator) lub do plików przy użyciu nazwy w formacie UNC (universal naming convention). Można też połączyć z obiektami programu Access przechowywanymi w bazie danych.

    Do 1 gigabajta znaków lub 2 gigabajty pamięci (2 bajty na znak), przy czym w formancie można wyświetlić do 65 535 znaków.

    Kreator odnośników

    Nie jest to faktyczny typ danych — powoduje uruchomienie Kreatora odnośników.

    Służy do uruchamiania Kreatora odnośników w celu utworzenia pola zawierającego pole kombi, używane do wyszukania wartości w innej tabeli, w zapytaniu lub na liście wartości.

    Zależnie od tabeli lub kwerendy: rozmiar kolumny związanej.

    Zależnie od wartości: rozmiar pola tekstowego używanego do przechowywania wartości.

    Uwaga: Maksymalny rozmiar pliku bazy danych programu Access to 2 gigabajty.

    Porady dotyczące typów danych

    • Aby zoptymalizować wydajność, należy użyć odpowiedni Rozmiar pola po utworzeniu pola tekst lub liczbę. Na przykład jeśli chcesz przechowywać kody pocztowe przewidywalne długość Określ tej długości jako rozmiar pola. Możesz określić rozmiar pola, ustawiając wartość w polu właściwości rozmiar pola. Aby uzyskać więcej informacji zobacz sekcję, ustawić inne właściwości pola.

    • W przypadku numerów telefonów, numerów katalogowych i innych liczb, które nie będą używane w obliczeniach matematycznych, należy wybrać typ danych Tekst, a nie Liczba. Wartość liczbowa przechowywana jako tekst może być sortowana i filtrowana w bardziej logiczny sposób.

Zmienianie formatu pola

Program Access nie tylko określa typ danych nowego pola, ale może również ustawić właściwość Format pola, zależnie od wprowadzonej wartości. Jeśli na przykład zostanie wprowadzony ciąg 10:50am, program Access ustawi typ danych na wartość Data/Godzina, a właściwość Format na wartość Godzina średnia. Aby ręcznie zmienić właściwość Format pola, należy wykonać następujące czynności:

  1. Na Wstążce kliknij kartę Arkusz danych.

  2. Na liście Format w grupie Typ i formatowanie danych wprowadź żądany format.

    Uwaga: W przypadku niektórych pól (na przykład pól typu Tekst) lista Format może być niedostępna. Zależy to od typu danych pola.

Ustawianie innych właściwości pola

  1. W widoku arkusza danych kliknij pole, dla którego chcesz ustawić właściwość.

  2. Na karcie Arkusz danych w grupie Typ i formatowanie danych wybierz żądane właściwości.

    Obraz wstążki programu Access przedstawiający grupę Typ i formatowanie danych

Początek strony

Ustawianie właściwości pola w widoku projektu

Podczas pracy z tabelą w widoku projektu można ustawić dowolną właściwość pola. W widoku projektu typ danych pola jest ustawiany w siatce projektu tabeli, a inne właściwości — w okienku Właściwości pola.

Otwieranie tabeli w widoku projektu

  1. W okienku nawigacji kliknij prawym przyciskiem myszy tabelę.

  2. W menu skrótów kliknij polecenie Widok projektu.

Zmienianie typu danych pola

  1. W siatce projektu tabeli zlokalizuj pole, dla którego chcesz ustawić typ danych.

  2. W kolumnie Typ danych wybierz z listy typ danych.

    Dostępne typy danych

    Typ danych

    Przechowywane wartości

    Rozmiar

    Tekst

    Znaki alfanumeryczne.

    Służy do przechowywania tekstu lub liczb, które nie są wykorzystywane w obliczeniach (na przykład identyfikatora produktu). Przechowywanie wartości liczbowej w formacie tekstowym ułatwia jej logiczne sortowanie i filtrowanie, ale uniemożliwia jej łatwe używanie w obliczeniach.

    Maksymalnie 255 znaków.

    Nota

    Znaki alfanumeryczne (więcej niż 255 znaków) lub tekst sformatowany.

    Służy do przechowywania tekstu o długości większej niż 255 znaków lub tekstu sformatowanego. Dobrym przykładem użycia pola Nota jest wprowadzanie notatek, długich opisów czy akapitów sformatowanego tekstu (na przykład z zastosowaniem pogrubienia lub kursywy).

    Do 1 gigabajta znaków lub 2 gigabajty pamięci (2 bajty na znak), przy czym w formancie można wyświetlić 65 535 znaków.

    Liczba

    Wartości liczbowe (liczby całkowite lub ułamki).

    Służy do przechowywania liczb wykorzystywanych w obliczeniach, z wyjątkiem wartości pieniężnych (w przypadku wartości pieniężnych należy użyć typu danych Waluta).

    1, 2, 4 lub 8 bajtów; 16 bajtów w przypadku użycia jako identyfikatora replikacji.

    Data/Godzina

    Daty i godziny.

    Typ stosowany do przechowywania wartości daty/godziny. Każda przechowywana wartość zawiera zarówno składnik daty, jak i składnik godziny.

    8 bajtów.

    Waluta

    Wartości pieniężne.

    Typ stosowany do przechowywania wartości pieniężnych (waluty).

    8 bajtów.

    Autonumerowanie

    Unikatowa wartość liczbowa wstawiana automatycznie w programie Access w momencie dodania rekordu.

    Służy do generowania unikatowych wartości, których można użyć jako kluczy podstawowych. Wartości w polach Autonumerowanie mogą wzrastać kolejno lub o określoną wartość albo być przypisywane losowo.

    4 bajty lub 16 bajtów w przypadku identyfikatora replikacji.

    Tak/Nie

    Wartości logiczne (Tak/Nie).

    Możesz użyć jednego z następujących formatów: Tak/Nie, Prawda/Fałsz lub Włączone/Wyłączone.

    1 bit (8 bitów = 1 bajt).

    Obiekt OLE

    Obiekty OLE lub inne dane binarne.

    Służy do przechowywania obiektów OLE z innych programów dla systemu Microsoft Windows.

    Do 1 gigabajta.

    Załącznik

    Rysunki, obrazy, pliki binarne, pliki pakietu Office.

    Preferowany typ danych dla potrzeb przechowywania cyfrowych obrazów i plików binarnych dowolnego typu.

    2 gigabajty w przypadku załączników skompresowanych. Około 700 kilobajtów w przypadku załączników nieskompresowanych, w zależności od możliwego stopnia kompresji załącznika.

    Hiperłącze

    Hiperłącza.

    Typ stosowany do przechowywania hiperłączy w celu uzyskania dostępu jednym kliknięciem do stron sieci Web przy użyciu adresu URL (Uniform Resource Locator) lub do plików przy użyciu nazwy w formacie UNC (universal naming convention). Można też połączyć z obiektami programu Access przechowywanymi w bazie danych.

    Do 1 gigabajta znaków lub 2 gigabajty pamięci (2 bajty na znak), przy czym w formancie można wyświetlić do 65 535 znaków.

    Kreator odnośników

    Nie jest to faktyczny typ danych — powoduje uruchomienie Kreatora odnośników.

    Służy do uruchamiania Kreatora odnośników w celu utworzenia pola zawierającego pole kombi, używane do wyszukania wartości w innej tabeli, w zapytaniu lub na liście wartości.

    Zależnie od tabeli lub kwerendy: rozmiar kolumny związanej.

    Zależnie od wartości: rozmiar pola tekstowego używanego do przechowywania wartości.

    Uwaga: Maksymalny rozmiar pliku bazy danych programu Access to 2 gigabajty.

    Porady dotyczące typów danych

    • W przypadku numerów telefonów, numerów katalogowych i innych liczb, które nie będą używane w obliczeniach matematycznych, należy wybrać typ danych Tekst, a nie Liczba. Wartość liczbowa przechowywana jako tekst może być bardziej logicznie sortowana i filtrowana, ale nie można jej łatwo używać w obliczeniach.

    • W przypadku typów danych Tekst i Liczba można dokładniej określić rozmiar pola lub inne cechy typu danych za pomocą wartości w polu właściwości Rozmiar pola.

Ustawianie innych właściwości pola

  1. W siatce projektu tabeli zaznacz pole, dla którego chcesz ustawić właściwości. Program Access wyświetli właściwości dla tego pola w okienku Właściwości pola.

    Typ danych pola określa, jakie właściwości można ustawiać.

  2. W okienku Właściwości pola wprowadź żądane ustawienia poszczególnych właściwości lub naciśnij klawisz F6, a następnie wybierz właściwość przy użyciu klawiszy strzałek.

    Jakie właściwości pól są dostępne?

    Uwaga: Nie wszystkie właściwości są dostępne dla każdego pola. Typ danych pola określa, jakie właściwości pola są dostępne.

    Właściwość pola

    Opis

    Rozmiar pola

    Ustawienie maksymalnego rozmiaru danych, które są przechowywane jako typ danych Tekst, Liczba lub Autonumerowanie.

    Porada: Aby osiągnąć najwyższą wydajność, zawsze należy określać najmniejszą wystarczającą wartość właściwości Rozmiar pola.

    Formatowanie

    Dostosowanie domyślnego wyglądu pola podczas wyświetlania lub drukowania.

    Miejsca dziesiętne

    Określenie liczby miejsc dziesiętnych używanych przy wyświetlaniu liczb.

    Nowe wartości

    Określenie, czy podczas dodawania nowego rekordu wartość pola Autonumerowanie jest zwiększana, czy ustawiana na wartość losową.

    Maska wprowadzania

    Wyświetlenie znaków ułatwiających wprowadzanie danych. Więcej informacji na temat tworzenia i używania maski wprowadzania można znaleźć w sekcji Zobacz też.

    Podpis

    Ustawienie tekstu wyświetlanego domyślnie w etykietach formularzy, raportów i kwerend.

    Wartość domyślna

    Automatyczne przypisanie wartości domyślnej do pola przy dodawaniu rekordów.

    Reguła sprawdzania poprawności

    Określenie wyrażenia, które musi być prawdziwe przy dodawaniu lub zmienianiu wartości w tym polu.

    Tekst reguły sprawdzania poprawności

    Wprowadzenie tekstu komunikatu wyświetlanego w sytuacji, gdy wartość jest niezgodna z wyrażeniem we właściwości Reguła sprawdzania poprawności.

    Wymagany

    Określenie, że wprowadzenie danych w tym polu jest wymagane.

    Zerowa długość dozwolona

    Umożliwienie wprowadzania ciągu o zerowej długości ("") w polu typu Tekst lub Nota (przez ustawienie tej właściwości na wartość Tak).

    Indeksowany

    Przyspieszenie dostępu do danych w tym polu przez utworzenie i użycie indeksu.

    Kompresja Unicode

    Kompresowanie małej ilości tekstu przechowywanego w polu (mniej niż 4096 znaków).

    Tryb IME

    Sterowanie konwersją znaków we wschodnioazjatyckiej wersji systemu Windows.

    Tryb zdania edytora IME

    Sterowanie konwersją zdań we wschodnioazjatyckiej wersji systemu Windows.

    Tagi akcji

    Dołącz tagu akcji do tego pola.

    Tylko dołącz

    Śledzenie historii wartości pola (przez ustawienie tej właściwości na wartość Tak).

    Format tekstu

    Wybranie wartości Tekst sformatowany umożliwia przechowywanie tekstu jako kodu HTML i stosowanie zaawansowanego formatowania. Wybranie wartości Zwykły tekst umożliwia przechowywanie tylko tekstu niesformatowanego.

    Wyrównanie tekstu

    Określenie domyślnego wyrównania tekstu w obrębie formantu.

  3. Aby zapewnić więcej miejsca na wprowadzanie lub edycję ustawienia w polu właściwości, naciśnij klawisze SHIFT+F2 w celu wyświetlenia okna Powiększenie.

    Porada: Jeśli wprowadzasz maskę wprowadzania lub wyrażenie reguły sprawdzania poprawności i potrzebujesz pomocy przy ich tworzeniu, kliknij przycisk Przycisk Konstruktor obok pola właściwości, aby wyświetlić odpowiedniego konstruktora.

  4. Aby zapisać zmiany, naciśnij klawisze CTRL+S.

Łącza do dodatkowych informacji na temat typów danych i właściwości pól można znaleźć w sekcji Zobacz też.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×