Wprowadzenie do kwerend

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Kwerenda ułatwia wyświetlanie, dodawanie, usuwanie i zmienianie danych w bazie danych programu Access. Inne powody do korzystania z kwerend:

  • Szybkie wyszukiwanie konkretnych danych z zastosowaniem filtrowania według określonych kryteriów (warunków)

  • Obliczanie i podsumowywanie danych

  • Automatyzowanie zadań związanych z zarządzaniem danymi, na przykład regularne przeglądanie najnowszych danych

Uwaga:  Aby wypróbować kwerendy z przykładów, należy skorzystać z bazy danych programu Access dla komputerów stacjonarnych.

Zapytania ułatwiają znajdowanie danych i pracę z danymi

Tworzenie zapytania wybierającego

Tworzenie zapytania parametrycznego

Tworzenie zapytania podsumowującego

Tworzenie zapytania krzyżowego

Tworzenie zapytania tworzącego tabelę

Tworzenie zapytania dołączającego

Tworzenie zapytania aktualizującego

Tworzenie zapytania usuwającego

Kwerendy ułatwiają znajdowanie danych i pracę z danymi

W dobrze zaprojektowanej bazie danych informacje, które mają zostać przedstawione w formularzu lub raporcie, zwykle znajdują się w kilku różnych tabelach. Kwerenda może odszukać informacje z różnych tabel i zebrać je, a następnie wyświetlić w formularzu lub raporcie. Kwerenda może mieć postać żądania wyników danych z bazy danych, wykonania działania na danych lub obie te postacie jednocześnie. Kwerenda pozwala uzyskać odpowiedź na proste zapytanie, przeprowadzać obliczenia, łączyć dane z różnych tabel oraz dodawać, zmieniać lub usuwać dane z bazy danych. Z uwagi na wszechstronność kwerend istnieje wiele ich typów, a użytkownik ma możliwość utworzenia kwerendy na podstawie zadania.

Główne typy kwerend

Zastosowanie

Wybierające

Pobieranie danych z tabeli lub wykonywanie obliczeń.

Funkcjonalne

Dodawanie, zmienianie i usuwanie danych. Do każdego zadania przypisany jest konkretny typ zapytania funkcjonalnego. Zapytania funkcjonalne nie są dostępne w aplikacjach sieci Web programu Access.

Tworzenie zapytania wybierającego

Jeśli chcesz przeglądanie danych pochodzących z tylko dla niektórych pól w tabeli, jednoczesne przeglądanie danych z wielu tabel lub być może po prostu wyświetlana danych na podstawie określonych kryteriów, typ kwerendy wybierającej będzie wyboru. Aby uzyskać więcej informacji zobacz Tworzenie prostej kwerendy wybierającej.

Przeglądanie danych pochodzących z wybranych pól

Na przykład jeśli baza danych zawiera tabelę pełną informacji na temat produktów i chce się wyświetlić ich listę wraz z cenami, oto sposób utworzenia kwerendy wybierającej, która zwracać będzie tylko nazwy produktów i powiązane ceny:

  1. Otwórz bazę danych i na karcie Tworzenie kliknij pozycję Projekt kwerendy.

  2. W oknie Pokazywanie tabeli na karcie Tabele kliknij dwukrotnie tabelę Produkty, a następnie zamknij okno dialogowe.

  3. Załóżmy, że w tabeli Produkty znajdują się pola Nazwa produktu i Cena. Kliknij dwukrotnie pozycje Nazwa produktu i Cena, aby dodać je do siatka projektu kwerendy.

  4. Na karcie Projektowanie kliknij przycisk Uruchom. Zapytanie zostanie uruchomione, a następnie zostanie wyświetlona lista produktów i ich cen.

Początek strony

Jednoczesne przeglądanie danych pochodzących z wielu powiązanych tabel

Na przykład można mieć bazę danych sklepu, który sprzedaje artykuły spożywcze, i chcieć przejrzeć zamówienia od klientów mieszkających w określonym mieście. Dane dotyczące zamówień i klientów mogą być przechowywane w dwóch tabelach, nazwanych odpowiednio Klienci i Zamówienia. Jeśli obie tabele będą zawierać pole Identyfikator klienta, które stanowi podstawę relacja jeden-do-wielu między tymi dwiema tabelami, kwerendę zwracającą zamówienia od klientów z określonego miasta, na przykład z Wyszkowa, można utworzyć, wykonując poniższą procedurę:

  1. Otwórz bazę danych i na karcie Tworzenie w grupie Kwerenda kliknij pozycję Projekt kwerendy.

  2. W oknie dialogowym Pokazywanie tabeli na karcie Tabele kliknij dwukrotnie tabele Klienci i Zamówienia.

  3. Zamknij okno dialogowe Pokazywanie tabeli. Zwróć uwagę na linię nazywaną sprzężeniem, która łączy pole Identyfikator w tabeli Klienci z polem Identyfikator klienta w tabeli Zamówienia. Ta linia pokazuje relację między obiema tabelami.

  4. W tabeli Klienci kliknij dwukrotnie pola Firma i Miasto, aby dodać je do siatki projektu kwerendy.

  5. W siatce projektu kwerendy, w kolumnie Miasto wyczyść pole wyboru w wierszu Pokaż.

  6. W wierszu Kryteria kolumny Miasto wpisz Wyszków.

    Wyczyszczenie pola wyboru Pokaż powoduje, że kwerenda nie wyświetla miasta w wynikach, a wpisanie nazwy miasta Wyszków w wierszu Kryteria pozwala określić, że chcesz zobaczyć tylko te rekordy, w których wartość pola Miasto to Wyszków. W tym przypadku kwerenda zwraca tylko klientów zlokalizowanych w Wyszkowie. Nie musisz wyświetlać pola, aby użyć go jako kryterium.

  7. W tabeli Zamówienia kliknij dwukrotnie pola Identyfikator zamówienia i Data zamówienia, aby dodać je do następnych dwóch kolumn siatki projektu kwerendy.

  8. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom. Kwerenda zostanie uruchomiona, a następnie wyświetli listę zamówień od klientów z Wyszkowa.

  9. Naciśnij klawisze CTRL+S, aby zapisać kwerendę.

Początek strony

Tworzenie kwerendy parametrycznej

Jeśli odmiany określonej kwerendy mają być uruchamiane często, warto rozważyć użycie kwerendy parametrycznej. Po uruchomieniu kwerenda parametryczna wyświetla monit o podanie wartości pól, a następnie tworzy kryteria kwerendy na podstawie podanych wartości.

Uwaga: W aplikacji sieci web programu Access nie można utworzyć kwerendę parametryczną.

Kontynuując poprzedni przykład, w którym zaprezentowano tworzenie kwerendy wybierającej zwracającej zamówienia od klientów zlokalizowanych w Wyszkowie, tę kwerendę można zmodyfikować, tak aby wyświetlała monit o podanie miasta po każdym uruchomieniu. W tym celu należy otworzyć bazę danych utworzoną w poprzednim przykładzie:

  1. W okienku nawigacji kliknij prawym przyciskiem myszy kwerendę o nazwie Zamówienia według miasta (utworzoną w poprzedniej sekcji), a następnie w menu skrótów kliknij polecenie Widok projektu.

  2. W siatce projektu zapytania w wierszu Kryteria kolumny Miasto usuń nazwę miasta Wyszków, a następnie wpisz ciąg [Dla jakiego miasta?].

    Ciąg [Dla jakiego miasta?] jest monitem o podanie parametru. Nawiasy kwadratowe wskazują, że chcesz, aby kwerenda wyświetlała monit o podanie parametru, a tekst (w tym przypadku Dla jakiego miasta?) jest pytaniem wyświetlanym w monicie.

    Uwaga: W tekście monitu o podanie parametru nie można użyć kropki (.) ani wykrzyknika (!).

  3. Zaznacz pole wyboru w wierszu Pokaż kolumny Miasto, aby w wynikach kwerendy było wyświetlane miasto.

  4. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom. Kwerenda wyświetli monit o wprowadzenie wartości dla kolumny Miasto.

  5. Wpisz nazwę miasta Gdańsk, a następnie naciśnij klawisz ENTER, aby wyświetlić zamówienia od klientów z Gdańska.

    Ale co zrobić, gdy nie zna się wartości, które można określić? Można w monicie użyć symboli wieloznacznych:

  6. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  7. W siatce projektu zapytania, w wierszu Kryteria kolumny Miasto wpisz ciąg Like [Dla jakiego miasta?]&"*".

    W tym monicie o podanie parametru słowo kluczowe Like, operator „handlowe i” (&) oraz gwiazdka (*) ujęta w cudzysłów umożliwiają użytkownikowi wpisanie kombinacji znaków, w tym symboli wieloznacznych, w celu zwrócenia przez kwerendę różnych wyników. Jeśli na przykład użytkownik wpisze symbol wieloznaczny *, kwerenda zwróci wszystkie miasta; jeśli użytkownik wpisze znak W, kwerenda zwróci wszystkie miasta, które zaczynają się od litery „W”; a jeśli użytkownik wpisze ciąg *s*, kwerenda zwróci wszystkie miasta, które zawierają literę „s”.

  8. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom, a następnie w monicie zapytania wpisz ciąg Gda i naciśnij klawisz ENTER.

    Kwerenda zostanie uruchomiona, a następnie wyświetli zamówienia od klientów z Gdańska.

Określanie typów danych parametrów

Określić można również, jaki typ danych powinien być akceptowany przez parametr. Typ danych można ustawić dla dowolnego parametru, ale szczególnie istotne jest ustawienie typu dla danych liczbowych, walutowych oraz daty/godziny. Określenie typu danych akceptowanego przez parametr umożliwia wyświetlanie pomocnego komunikatu o błędzie w przypadku, gdy użytkownik wprowadzi nieprawidłowy typ danych — na przykład tekst, gdy oczekiwanym typem danych jest waluta.

Jeśli parametr jest tak ustawiony, aby akceptował dane tekstowe, wszelkie wprowadzone dane są interpretowane jako tekst i nie jest wyświetlany żaden komunikat o błędzie.

Aby określić typ danych dla parametrów w kwerendzie, wykonaj poniższą procedurę:

  1. Po otwarciu kwerendy w widoku projektu na karcie Projektowanie, w grupie Pokazywanie/ukrywanie kliknij przycisk Parametry.

  2. W oknie dialogowym Parametry kwerendy, w kolumnie Parametr wpisz monit dla każdego parametru, dla którego chcesz określić typ danych. Upewnij się, że każdy parametr jest zgodny z monitem użytym w wierszu Kryteria siatki projektu kwerendy.

  3. W kolumnie Typ danych wybierz typ danych dla każdego parametru.

Aby uzyskać więcej informacji zobacz Używanie parametrów w celu wyświetlania monitu o wprowadzenie informacji podczas uruchamiania kwerendy.

Początek strony

Tworzenie kwerendy podsumowującej

Wiersz Suma w arkuszu danych jest bardzo przydatny, ale w przypadku bardziej złożonych pytań należy użyć kwerendy podsumowującej. Kwerenda podsumowująca to kwerenda wybierająca, która pozwala grupować i podsumowywać dane, na przykład gdy potrzebuje się wartości całkowitej sprzedaży dla każdego produktu. W przypadku kwerendy podsumowującej do pokazania wartości całkowitej sprzedaży dla każdego produktu można użyć funkcji Suma (funkcji agregującej).

Uwaga: Nie można użyć funkcji agregujących w aplikacji sieci web programu Access.

W celu zmodyfikowania kwerendy Sumy częściowe produktów utworzonej w poprzednim przykładzie w ten sposób, aby podsumowywała sumy częściowe produktów według produktu, wykonaj poniższą procedurę.

  1. Na karcie Narzędzia główne kliknij pozycję Widok > Widok projektu.

    Kwerenda Sumy częściowe produktów zostanie otwarta w widoku projektu.

  2. Na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij pozycję Sumy.

    W siatce projektu kwerendy zostanie wyświetlony wiersz Sumy.

Uwaga: Mimo podobnych nazw wiersz Sumy w siatce projektu i wiersz Suma w arkuszu danych to dwa różne wiersze:

  • Za pomocą wiersza Sumy w siatce projektu można grupować dane według wartości pól.

  • Wiersz Suma arkusza danych można dodać do wyników kwerendy podsumowującej.

  • Gdy jest używany wiersz Sumy w siatce projektu, należy wybrać funkcję agregującą dla każdego pola. Aby nie wykonywać obliczenia dla określonego pola, można pogrupować dane według tego pola.

  • W drugiej kolumnie siatki projektu, w wierszu Suma wybierz funkcję Suma z listy rozwijanej.

  • Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom. Kwerenda zostanie uruchomiona, a następnie wyświetli listę produktów z sumami częściowymi.

  • Naciśnij klawisze CTRL+S, aby zapisać kwerendę. Pozostaw ją otwartą.

Aby uzyskać więcej informacji zobacz Wyświetlanie sum kolumn w arkuszu danych za pomocą wiersza sumy.

Początek strony

Wykonywanie obliczeń na podstawie danych

Na ogół tabele nie są używane do przechowywania obliczonych wartości, takich jak sumy częściowe, nawet jeśli są one oparte o dane w tej samej bazie danych, ponieważ obliczone wartości mogą się dezaktualizować w przypadku zmiany danych, na których są oparte. Na przykład nie należy przechowywać wieku osoby w tabeli, ponieważ każdego roku konieczne byłoby aktualizowanie tej wartości; zamiast tego należy przechowywać datę urodzenia, a następnie użyć wyrażenia w kwerendzie do obliczenia wieku.

Można na przykład mieć bazę danych produktów do sprzedania z tabelą o nazwie Szczegóły zamówień, która zawiera informacje o produktach w polach takich jak cena jednostkowa i ilość. Sumę częściową można obliczyć, korzystając z kwerendy, która mnoży ilość produktu przez jego cenę jednostkową, a następnie odejmuje rabat całkowity od ceny całkowitej. Jeśli w poprzednim przykładzie została utworzona przykładowa baza danych, można ją otworzyć i wykonać następujące czynności:

  1. Na karcie Tworzenie kliknij pozycję Projekt kwerendy.

  2. W oknie dialogowym Pokazywanie tabeli na karcie Tabele kliknij dwukrotnie tabelę Szczegóły zamówienia.

  3. Zamknij okno dialogowe Pokazywanie tabeli.

  4. W tabeli Szczegóły zamówień kliknij dwukrotnie pole Identyfikator produktu, aby dodać je do pierwszej kolumny siatki projektu zapytania.

  5. W drugiej kolumnie siatki kliknij prawym przyciskiem myszy wiersz Pole, a następnie w menu skrótów kliknij polecenie Powiększenie.

  6. W oknie Powiększenie wpisz lub wklej następujący ciąg: Suma częściowa: ([Ilość]*[Cena jednostkowa])-([Ilość]*[Cena jednostkowa]*[Rabat])

  7. Kliknij przycisk OK.

  8. Na karcie Projektowanie kliknij przycisk Uruchom. Zapytanie zostanie uruchomione, a następnie zostanie wyświetlona lista produktów z sumami częściowymi według zamówień.

  9. Naciśnij klawisze CTRL+S, aby zapisać kwerendę, a następnie nadaj jej nazwę Sumy częściowe produktów.

Aby uzyskać więcej informacji zobacz Wyświetlanie sum kolumn w arkuszu danych za pomocą wiersza sumy.

Początek strony

Wyświetlanie danych podsumowanych lub zagregowanych

Korzystając z tabel do zapisywania transakcji lub regularnych danych liczbowych, warto mieć możliwość przeglądania danych zagregowanych, na przykład sum lub średnich. W programie Access do arkusz danych można dodać wiersz Suma. Wiersz Suma znajduje się na dole arkusza danych i służy do wyświetlania sumy bieżącej lub innej wartości zagregowanej.

  1. Uruchom kwerendę sumy częściowe produktów, utworzony wcześniej i pozostaw jej wyniki otwarte w widok arkusza danych.

  2. Na karcie Narzędzia główne kliknij pozycję sumy. Nowy wiersz pojawi się w dolnej części arkusza danych, z wyrazem sumy w pierwszej kolumnie.

  3. Kliknij komórkę o nazwie Suma znajdującą się w ostatnim wierszu arkusza danych.

  4. Kliknij strzałkę, aby wyświetlić dostępne funkcje agregujące. Ponieważ kolumna zawiera dane tekstowe, są dostępne tylko dwie opcje: Brak i Policz.

  5. Wybierz pozycję Policz. Zawartość komórki zmieni się z ciągu Suma na liczbę wartości w kolumnie.

  6. Kliknij sąsiednią komórkę (w drugiej kolumnie). W komórce pojawi się strzałka.

  7. Kliknij strzałkę, a następnie kliknij funkcję Suma. W polu zostanie wyświetlona suma wartości w kolumnie.

  8. Pozostaw kwerendę otwartą w widoku arkusza danych.

Początek strony

Tworzenie kwerendy krzyżowej

Teraz można założyć, że chce się przejrzeć sumy częściowe produktów, ale jednocześnie chce się agregować według miesiąca, aby w każdym wierszu były wyświetlane sumy częściowe produktu, a w każdej kolumnie były wyświetlane sumy częściowe produktów za miesiąc. Aby wyświetlić sumy częściowe produktu oraz sumy częściowe produktów za miesiąc, należy użyć zapytanie krzyżowe.

Uwaga: Kwerendy krzyżowej nie można wyświetlić w aplikacji sieci web programu Access.

Ponownie możesz zmodyfikować kwerendę Sumy częściowe produktów, aby zwracała wiersze sum częściowych produktów oraz kolumny miesięcznych sum częściowych.

  1. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  2. W grupie Konfiguracja kwerendy kliknij przycisk Pokaż tabelę.

  3. W oknie dialogowym Pokazywanie tabeli kliknij dwukrotnie pozycję Zamówienia, a następnie kliknij przycisk Zamknij.

  4. Na karcie Projektowanie w grupie Typ zapytania kliknij przycisk Krzyżowa. W siatce projektu jest ukryty wiersz Pokaż i jest wyświetlany wiersz Krzyżowe.

  5. W trzeciej kolumnie siatki projektu kliknij prawym przyciskiem myszy wiersz Pole, a następnie w menu skrótów kliknij polecenie Powiększenie. Zostanie otwarte okno Powiększenie.

  6. W oknie Powiększenie wpisz lub wklej następujący ciąg: Miesiąc: "Miesiąc" & DatePart("m", [Data zamówienia])

  7. Kliknij przycisk OK.

  8. W wierszu Krzyżowe wybierz z listy rozwijanej następujące wartości: Nagłówek wiersza dla pierwszej kolumny, Wartość dla drugiej kolumny i Nagłówek kolumny dla trzeciej kolumny.

  9. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom. Kwerenda zostanie uruchomiona, a następnie wyświetli sumy częściowe produktów zagregowane według miesiąca.

  10. Naciśnij klawisze CTRL+S, aby zapisać kwerendę.

    Aby uzyskać więcej informacji na temat kwerend krzyżowych zobacz Tworzenie podsumowania danych za pomocą kwerendy krzyżowej.

Początek strony

Tworzenie kwerendy tworzącej tabelę

Aby utworzyć nową tabelę z danych przechowywanych w innych tabelach, można użyć kwerendy tworzącej tabele.

Uwaga: Kwerenda tworząca tabelę nie jest dostępna w aplikacjach sieci web programu Access.

Wyobraź sobie na przykład, że chcesz wysłać dane zamówień z Kielc do partnera biznesowego z Kielc, który przygotowuje raporty w programie Access. Zamiast wysyłać wszystkie dane zamówień, chcesz ograniczyć wysyłane dane do danych dotyczących zamówień z Kielc.

Wykonując poniższą procedurę, można utworzyć kwerendę wybierającą, która zawiera dane zamówień z Kielc, a następnie za jej pomocą utworzyć nową tabelę,

  1. Otwórz przykładową bazę danych z poprzedniego przykładu.

    Do uruchomienia kwerendy tworzącej tabele może być konieczne włączenie zawartości tej bazy danych.

    Uwaga:  Jeśli pod Wstążką wyświetlony zostanie komunikat dotyczący włączenia bazy danych, kliknij opcję Włącz zawartość.Jeśli Twoja baza danych znajduje się już w zaufanej lokalizacji, pasek komunikatów nie zostanie wyświetlony.

  2. Na karcie Tworzenie w grupie Kwerendy kliknij przycisk Projekt kwerendy.

  3. W oknie dialogowym Pokazywanie tabeli kliknij dwukrotnie tabele Szczegóły zamówienia i Zamówienia, a następnie zamknij okno dialogowe Pokazywanie tabeli.

  4. W tabeli Zamówienia kliknij dwukrotnie pola Identyfikator klienta i Miasto odbiorcy, aby dodać je do siatki projektu.

  5. W tabeli Szczegóły zamówienia kliknij dwukrotnie pola Identyfikator zamówienia, Identyfikator produktu, Ilość, Cena jednostkowa i Rabat, aby dodać je do siatki projektu.

  6. W kolumnie Miasto odbiorcy siatki projektu wyczyść pole w wierszu Pokaż. W wierszu Kryteria wpisz nazwę miasta 'Kielce' (ujmij ją w pojedynczy cudzysłów). Sprawdź wyniki kwerendy, zanim za ich pomocą utworzysz tabelę.

  7. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

  8. Naciśnij klawisze CTRL+S, aby zapisać kwerendę.

  9. W polu Nazwa zapytania wpisz nazwę Zapytanie zamówień z Kielc, a następnie kliknij przycisk OK.

  10. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  11. Na karcie Projektowanie w grupie Typ zapytania kliknij pozycję Utwórz tabelę.

  12. W oknie dialogowym Tworzenie tabeli w polu Nazwa tabeli wpisz nazwę Zamówienia z Kielc, a następnie kliknij przycisk OK.

  13. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

  14. W oknie dialogowym potwierdzenia kliknij przycisk Tak. Nowa tabela zostanie wyświetlona w okienku nawigacji.

    Uwaga: Jeśli już istnieje tabela o takiej samej nazwie jak określona, program Access usunie ją przed uruchomieniem kwerendy.

Aby uzyskać więcej informacji o korzystaniu z tworzenie zapytań dotyczących tabel, zobacz Tworzenie tworzącej tabelę.

Początek strony

Tworzenie kwerendy dołączającej

Aby pobrać dane z jednej lub kilku tabel i dodać je do innej tabeli, możesz użyć kwerendy dołączającej.

Uwaga: Dołączanie kwerenda nie jest dostępna w aplikacjach sieci web programu Access.

Na przykład można przyjąć, że została utworzona tabela do udostępnienia współpracownikowi z Kielc, który pracuje też z klientami z Torunia. Przed udostępnieniem tabeli współpracownikowi trzeba do niej dodać wiersze z danymi dotyczącymi Torunia. Aby dodać dane dotyczące Torunia do tabeli Zamówienia z Kielc, wykonaj poniższą procedurę:

  1. Otwórz kwerendę o nazwie "Kwerenda zamówień z Kielc" utworzone wcześniej w widoku projektu.

  2. Na karcie Projektowanie w grupie Typ zapytania kliknij przycisk Dołącz. Zostanie otwarte okno dialogowe Dołączanie.

  3. W oknie dialogowym Dołączanie kliknij strzałkę w polu Nazwa tabeli, wybierz z listy rozwijanej nazwę Zamówienia z Kielc, a następnie kliknij przycisk OK.

  4. W siatce projektu w wierszu Kryteria kolumny Miasto odbiorcy usuń nazwę 'Kielce', a następnie wpisz nazwę 'Toruń'.

  5. W wierszu Dołączanie do wybierz odpowiednie pole dla każdej kolumny.

    W tym przykładzie wartości wiersza Dołączanie do powinny być zgodne z wartościami wiersza Pole, ale nie jest to wymagane do działania kwerend dołączających.

  6. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

Uwaga:  Uruchomienie kwerendy zwracającej dużą ilość danych może spowodować pojawienie się komunikatu o błędzie z informacją, że cofnięcie kwerendy nie będzie możliwe. Aby umożliwić przeprowadzenie kwerendy, należy spróbować zwiększyć ograniczenie segmentu pamięci do 3 MB.

Aby uzyskać więcej informacji dotyczących zapytań dołączających, zobacz Dodawanie rekordów do tabeli za pomocą zapytania dołączającego.

Początek strony

Tworzenie kwerendy aktualizującej

Aby zmienić dane w tabelach i wprowadzić kryteria określające, które wiersze powinny zostać zaktualizowane, możesz użyć kwerendy aktualizującej. Kwerenda aktualizująca daje możliwość przejrzenia zaktualizowanych danych przed wykonaniem aktualizacji.

Ważne: Kwerenda funkcjonalna nie można cofnąć. Należy rozważyć tworzenia kopii zapasowej wszystkich tabel, które zostanie zaktualizowany przy użyciu kwerendy aktualizującej. Kwerenda aktualizująca nie jest dostępna w aplikacjach sieci web programu Access.

W poprzednim przykładzie zostały dodane wiersze do tabeli Zamówienia z Kielc. W tabeli Zamówienia z Kielc w polu Identyfikator produktu jest widoczny liczbowy identyfikator produktu. Aby dane były bardziej przydatne w raportach, można zamienić identyfikatory produktów na nazwy produktów, korzystając z następującej procedury:

  1. Otwórz w widoku projektu tabelę Zamówienia z Kielc.

  2. W wierszu Identyfikator produktu zmień typ danych z Liczba na Tekst.

  3. Zapisz i zamknij tabelę Zamówienia z Kielc.

  4. Na karcie Tworzenie w grupie Kwerendy kliknij przycisk Projekt kwerendy.

  5. W oknie dialogowym Pokazywanie tabeli kliknij dwukrotnie tabele Zamówienia z Kielc i Produkty, a następnie zamknij okno dialogowe Pokazywanie tabeli. .

  6. Na karcie Projektowanie w grupie Typ kwerendy kliknij przycisk Aktualizuj.

  7. W siatce projektu znikną wiersze Sortuj i Pokaż oraz zostanie wyświetlony wiersz Aktualizacja do.

  8. W tabeli Zamówienia z Kielc kliknij dwukrotnie pole Identyfikator produktu, aby dodać je do siatki projektu.

  9. W siatce projektu w wierszu Aktualizacja do kolumny Identyfikator produktu wpisz lub wklej następujący ciąg: [Produkty].[Nazwa produktu]

    Porada: Za pomocą kwerendy aktualizującej możesz usunąć wartości pól, stosując w wierszu Aktualizacja do pusty ciąg ("") lub wartość NULL.

  10. W wierszu Kryteria wpisz lub wklej następujący ciąg: [Identyfikator produktu] Like ([Produkty].[Identyfikator])

  11. Wartości, które zostaną zmienione przez kwerendę aktualizującą, możesz przejrzeć, wyświetlając kwerendę w widoku arkusza danych.

  12. Na karcie Projektowanie kliknij pozycję Widok > Widok arkusza danych. Zapytanie zwróci listę identyfikatorów produktów, które zostaną zaktualizowane.

  13. Na karcie Projektowanie kliknij pozycję Uruchom.

    Po otwarciu tabeli zamówienia z Kielc, pojawi się, że wartości liczbowych w polu Identyfikator produktu zostały zastąpione nazwy produktów z tabeli Produkty.

Aby uzyskać więcej informacji na temat zapytań aktualizujących, zobacz Tworzenie i uruchamianie zapytania aktualizującego.

Początek strony

Tworzenie kwerendy usuwającej

Za pomocą kwerendy usuwającej możesz usuwać dane z tabel i wprowadzać kryteria określające, które wiersze powinny zostać usunięte. Kwerenda usuwająca zapewnia możliwość przejrzenia wierszy, które zostaną usunięte, przed wykonaniem operacji usunięcia.

Uwaga: Kwerenda usuwająca nie jest dostępna w aplikacjach sieci web programu Access.

Na przykład można przyjąć, że podczas przygotowywania do wysłania do współpracownika z Kielc tabeli Zamówienia z Kielc zaktualizowanej w poprzednim przykładzie zauważono, że niektóre wiersze zawierają pewną liczbę pustych pól. Przed wysłaniem tabeli te wiersze mają zostać usunięte. Wystarczyłoby otworzyć tabelę i usunąć wiersze ręcznie, ale może się okazać, że łatwiej będzie użyć kwerendy usuwającej, jeśli wierszy jest więcej i istnieją jasne kryteria określające, które wiersze należy usunąć.

Aby za pomocą kwerendy usunąć wiersze z tabeli Zamówienia z Kielc, które nie mają wartości dla pola Identyfikator zamówienia, wykonaj poniższą procedurę:

  1. Na karcie Tworzenie kliknij przycisk Projekt kwerendy.

  2. W oknie Pokazywanie tabeli kliknij dwukrotnie tabelę Zamówienia z Kielc, a następnie zamknij okno Pokazywanie tabeli.

  3. Na karcie Projektowanie w grupie Typ zapytania kliknij przycisk Usuń. W siatce projektu znikną wiersze Sortuj i Pokaż, a zostanie wyświetlony wiersz Usuń.

  4. W tabeli Zamówienia z Kielc kliknij dwukrotnie pole Zamówienie, aby dodać je do siatki.

  5. W siatce projektu w wierszu Kryteria kolumny Identyfikator zamówienia wpisz ciąg Is Null.

  6. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Uruchom.

Aby uzyskać więcej informacji na temat kwerendy usuwającej zobacz Tworzenie i uruchamianie kwerendy usuwającej.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×