Wdrażanie aplikacji programu Access

Access udostępnia platformę o bogatych funkcjach do tworzenia aplikacji baz danych. Aplikacja bazy danych to program komputerowy zapewniający zarówno sposób przechowywania danych i zarządzania nimi oraz interfejs użytkownika zgodny z logiką zadań biznesowych (logiką aplikacji). W tym artykule omówiono podstawowe Planowanie wdrażania, pakowanie i podpisywanie, wdrażanie aplikacji baz danych oraz środowisko uruchomieniowe Access.

Co chcesz zrobić?

Zaplanować wdrożenie

Wdrożyć aplikację programu Access

Opis i pobieranie programu Access Runtime

Tworzenie pakietu instalacyjnego

Zaplanować wdrożenie

Zanim zaczniesz zadaj sobie następujące pytania dotyczące sposobu wdrażania aplikacji.

Czy należy rozdzielić dane i logikę?

Możesz utworzyć aplikację Access, która łączy zarządzanie danymi i logikę aplikacji w jednym pliku. Jest to domyślna struktura aplikacji w Access. Łączenie zarządzania danymi i logiki aplikacji w jednym pliku zapewnia najprostszą metodę wdrażania, ale ta metoda działa najlepiej tylko wtedy, gdy kilka osób korzysta z aplikacji w tym samym czasie, co wiąże się z pewnym ryzykiem. Na przykład użytkownik może spowodować utratę danych przez nieumyślnie usunięcie lub uszkodzenie pliku aplikacji. W większości przypadków należy rozdzielić zarządzanie danymi i logikę aplikacji. Ułatwia to poprawę wydajności i niezawodności.

Jednym ze sposobów separacji danych i logiki jest użycie polecenia Baza danych programu Access (na karcie Narzędzia bazy danych w grupie Przenoszenie danych). To polecenie dzieli aplikację bazy danych na dwa pliki programu Access: jednej dla logiki (frontonu) i jednej dla danych (back-end). Na przykład baza danych o nazwie websolution. accdb jest dzielona na dwa pliki o nazwie MySolution_fe. accdb i MySolution_be. accdb. Wewnętrzną bazę danych można umieścić w lokalizacji udostępnionej, na przykład w folderze sieciowym. Po rozpowszechnieniu pliku frontonu jest to jedna kopia dla każdego użytkownika na komputerze. Możesz nawet rozpowszechnić różne pliki frontonu z innymi użytkownikami. Aby uzyskać więcej informacji, zobacz dzielenie bazy danych programu Access.

Innym sposobem separacji zarządzania danymi i logiki aplikacji jest użycie programu serwera bazy danych (takiego jak Microsoft SQL Server) do zarządzania danymi, a programu Access do logiki aplikacji. Aby uzyskać więcej informacji, zobacz Migrowanie bazy danych programu Access do programu SQL Server.

Dodatkowe przyczyny oddzielenia danych i logiki są następujące:

  • Integralność i zabezpieczenie danych     Jeśli połączysz dane i logikę w jednym pliku, dane są narażone na te same zagrożenia, co logika aplikacji. Aplikacja Access, która korzysta z osobnych plików logicznych i danych, może pomóc w ochronie integralności danych i zabezpieczeń, wykorzystując funkcje zabezpieczeń NTFS w folderach sieciowych.

    Access użytkownicy muszą mieć uprawnienia do odczytu, zapisu, tworzenia i usuwania w folderze, w którym znajduje się plik frontonu. Można jednak przypisywać różne uprawnienia do samego pliku frontonu. Na przykład możesz chcieć przypisać użytkownikom uprawnienia tylko do odczytu i uprawnienia do odczytu i zapisu innym użytkownikom.

    Twoja aplikacja może wymagać dodatkowych opcji zabezpieczeń, takich jak możliwość kontrolowania, którzy użytkownicy mają dostęp do konkretnych danych. W takim przypadku możesz używać programu SQL Server lub programu SharePoint do przechowywania danych aplikacji i zarządzania nimi, a także w celu zapewnienia logiki aplikacji za pomocą programu Access.

  • Skalowalność    Plik Access może mieć maksymalny rozmiar 2 gigabajtów (GB). Chociaż 2 GB to znaczna ilość danych tekstowych, może być ona niewystarczająca w niektórych aplikacjach, szczególnie w aplikacjach zapisujących załączniki w rekordach bazy danych. Jeśli rozdzielisz dane i logikę, Twoja aplikacja może zmieścić więcej danych. Jeśli oczekujesz, że użytkownicy będą przechowywać duże ilości danych, warto rozważyć zastosowanie kilku plików danych Access.

    Aby uzyskać inne informacje o skalowalności, zapoznaj się ze specyfikacjami programu Access. Aby dowiedzieć się więcej na temat specyfikacji Access, zobacz artykuł Specyfikacja programu Access.

  • Wydajność sieci    Jeśli wielu użytkowników będzie jednocześnie używać aplikacji w sieci, najprawdopodobniej wystąpi uszkodzenie danych, gdy dane i logika są połączone w jeden plik. Ponadto, jeśli połączysz dane i logikę w jednym pliku programu Access, nie możesz zoptymalizować ruchu sieciowego generowanego przez program Access. Jeśli wielu użytkowników będzie jednocześnie używać Twojej aplikacji w sieci, należy rozdzielić dane i wartość logiczną, stosując przynajmniej dwa pliki programu Access albo stosując produkt serwera bazy danych dla danych a programu Access do logiki aplikacji.

Do czego będzie podobne środowisko sieciowe?

Wybranie prawidłowego rozwiązania bazy danych programu Access dla środowiska sieciowego jest krokiem krytycznym w celu jego prawidłowego przeprowadzenia. Skorzystaj z poniższych wskazówek, aby ułatwić sobie wybór potrzeb.

Sieć domowa

Jeśli baza danych programu Access jest udostępniana tylko niektórym użytkownikom, możesz użyć pojedynczej bazy danych, która jest otwierana i używana w sieci domowej. Aby uzyskać więcej informacji, zobacz udostępnianie plików w sieci w systemie Windows 10.

Lokalna sieć komputerowa (LAN)

Sieć LAN to sieć wewnętrzna, która zwykle zapewnia doskonałą wydajność, ale jest ograniczona do małego obszaru geograficznego, takiego jak jedno pomieszczenie, budynek lub Grupa budynków. Jeśli masz więcej niż kilku użytkowników współużytkujących bazę danych w sieci LAN, najlepiej jest podzielić bazę danych, przechowywać wewnętrzną bazę danych w folderze sieciowym, a następnie wdrożyć kopię zewnętrznej bazy danych dla każdego użytkownika.

Sieć rozległa (WAN)

Istnieje wiele możliwych konfiguracji sieci WAN, które obejmują szeroki obszar geograficzny. Możesz korzystać z wielu biur w całym mieście połączonym z siecią publiczną, linią dzierżawioną, a nawet satelitami. Często jest używana wirtualna sieć prywatna (VPN) umożliwiająca bezpieczne uzyskiwanie dostępu zdalnego z domu lub w podróży. Prostą metodą zrozumienia sieci WAN jest to, że zawsze, gdy znajdujesz się poza siecią lokalną, ale jest z nią połączony, korzystasz z sieci WAN.

Ostrzeżenie    Unikanie używania podzielonej bazy danych programu Access w sieci WAN, ponieważ wydajność może być uszkodzona i bazy danych mogą ulec uszkodzeniu.

Istnieją trzy obsługiwane sposoby korzystania z programu Access w sieci WAN:

  • Baza danych programu Access z tabelami połączonymi na listy programu SharePoint.

  • Fronton bazy danych programu Access z wewnętrzną bazą danych programu SQL Server lub usługą Azure SQL.

  • Usługi pulpitu zdalnego (RDS) (znane wcześniej jako serwer terminali), które tworzą wirtualne środowisko pulpitu systemu Windows na komputerze klienckim użytkownika. W przypadku usług RDS występują następujące zalety:

    • Nie jest wymagana instalacja programu Access lub bazy danych programu Access, ponieważ użytkownicy uruchomią klienta pulpitu zdalnego, który jest dostępny na wielu urządzeniach.

    • Transfer danych jest zminimalizowany między klientem a serwerem, ponieważ jest to zubożony klient, który skutecznie przesyła strumieniowo tylko interfejs użytkownika.

    • Użytkownicy mogą nadal kopiować i wklejać dane oraz drukować raporty lokalnie z komputera klienckiego.

    • W programie RemoteApp można uruchomić tylko jeden program, taki jak aplikacja Turnkey dla dostawców lub firmy Frontline Systems pracowników.

    Aby uzyskać więcej informacji, zobacz usługi pulpitu zdalnego— Zapraszamy!

Czy użytkownicy będą mieli Access?

Jeśli wszyscy Twoi użytkownicy zainstalują Access na swoich komputerach, będą mogli otworzyć i używać aplikacji, jak dowolnego pliku bazy danych Access.

Jeśli na komputerach niektórych lub wszystkich użytkowników nie ma zainstalowanych Access, możesz również wdrożyć oprogramowanie Access Runtime dla tych użytkowników podczas wdrażania aplikacji. Aby uzyskać więcej informacji, zobacz Opis i pobieranie programu Access Runtime.

Początek strony

Wdrażanie aplikacji Access

Aby wdrożyć aplikację Access, należy wykonać następujące zadania.

Przygotowywanie bazy danych jako rozwiązania aplikacji

Aby zablokować rozwiązanie, sterować nawigacją i uruchamianiem oraz ustawić inne ważne opcje, wykonaj następujące czynności:

Zadanie

Więcej informacji

Decydowanie, jak użytkownicy nawigują po interfejsie użytkownika: używanie formularza domyślnego, Tworzenie panelu przełączania, używanie formularza nawigacji lub korzystanie z hiperłączy i przycisków poleceń.

Ustawianie formularza domyślnego wyświetlanego po otwarciu bazy danych programu Access

Tworzenie formularza nawigacji

Dostosowywanie okienka nawigacji

Pokazywanie lub ukrywanie kart obiektów

Szablony polecanego dostępu

Co się stało z panelami przełączania?

Decydowanie, czy chcesz dostosować wstążkę pakietu Office i menu poleceń

Tworzenie niestandardowej wstążki w programie Access

Tworzenie menu niestandardowych i menu skrótów za pomocą makr

Używanie niestandardowych pasków narzędzi i ustawień uruchamiania w starszych wersjach programu Access

Stosowanie spójnego motywu i tła pakietu Office

Dodawanie tła pakietu Office

Zmienianie motywu pakietu Office

Sterowanie uruchamianiem bazy danych

Dodawanie niestandardowego tytułu lub niestandardowej ikony do bazy danych

Pomijanie opcji uruchamiania podczas otwierania bazy danych

Tworzenie makra uruchamianego podczas otwierania bazy danych

Przełączniki wiersza polecenia dla produktów pakietu Microsoft Office

Ustawianie ważnych właściwości i opcji

Ustawianie właściwości uruchamiania i opcji whttps://docs.microsoft.com/en-us/office/vba/access/concepts/settings/set-startup-properties-and-options-in-codekodu

Wyświetlanie lub zmienianie właściwości pliku pakietu Office

Modyfikowanie ustawień regionalnych

Zmienianie ustawień regionalnych systemu Windows w celu zmodyfikowania wyglądu części typów danych

Porada    Aby uzyskać dokładne ustawienia, przejdź do okna dialogowego Opcje programu Access ( Opcjepliku >), a następnie kliknij pozycję Pomoc dla każdej karty. Mogą być dostępne dodatkowe opcje, które należy kontrolować w celu rozwiązania aplikacji.

Przed wdrożeniem

Przed wdrożeniem zewnętrznej bazy danych warto zapoznać się z najważniejszymi wskazówkami:

Określanie używanego formatu pliku

Istnieją cztery formaty pliku Access, których możesz użyć podczas wdrażania aplikacji:

  • accdb    Jest to domyślny format pliku dla Access. Gdy wdrożysz aplikację w tym formacie, użytkownicy mają większość opcji do dostosowywania i nawigowania w aplikacji w dowolny wybrany przez nich sposób. Jeśli chcesz mieć pewność, że użytkownicy nie zmienią projektu Twojej aplikacji, należy użyć formatu pliku accde. Ponadto użytkownik nie może łatwo ustalić, czy plik accdb został zmieniony po opakowaniu go — aby było to oczywiste, użyj formatu pliku accdc.

  • accdc    Ten format jest również znany jako plik wdrożenia programu Access. Plik wdrożenia programu Access zawiera plik aplikacji i skojarzony z tym plikiem podpis cyfrowy. Ten format pliku gwarantuje użytkownikom, że nikt nie zmienił pliku aplikacji po jego opakowaniu. Ten format możesz zastosować do formatu domyślnego pliku Access (accdb) lub do skompilowanego pliku binarnego Access (accde). Aby uzyskać więcej informacji, zobacz Pokazywanie zaufania przez dodanie podpisu cyfrowego.

    W pliku wdrożenia programu Access można umieścić tylko jeden plik aplikacji. Jeśli Twoja aplikacja ma oddzielne pliki danych i logiki, możesz je opakować oddzielnie.

  • accde    Ten format jest również znany jako skompilowany plik binarny. W Access skompilowany plik binarny jest plikiem aplikacji bazy danych, który został zapisany z całym skompilowanym kodem języka VBA. Żaden kod źródłowy języka VBA nie pozostaje w skompilowanym pliku binarnym programu Access. Plik ACCDE zapobiega zmianom w projekcie i kodzie, zmniejsza rozmiar bazy danych i zwiększa wydajność. Aby uzyskać więcej informacji, zobacz Ukrywanie kodu VBA u użytkowników.

    Środowisko uruchomieniowe Access może służyć do otwierania skompilowanego pliku binarnego Access. Jeśli program obsługi nie rozpoznaje rozszerzenia nazwy pliku ACCDE, Otwórz plik binarny, tworząc skrót wskazujący środowisko uruchomieniowe i dołącz ścieżkę do skompilowanego pliku binarnego, który ma być otwierany przez skrót.

    Ważne   Użytkownicy nie mogą otworzyć skompilowanego pliku binarnego przy użyciu wcześniejszej wersji programu Access niż wersja, w której została skompilowana, jeśli wcześniejsza wersja nie obsługuje funkcji dodanej w nowszej wersji. Aby rozwiązać ten problem, skompiluj plik binarny w wersji programu Access zainstalowanej przez użytkowników.

  • accdr    Ten format umożliwia wdrożenie aplikacji, która będzie otwierana w trybie środowiska uruchomieniowego. Wdrażanie aplikacji środowiska uruchomieniowego może pomóc kontrolować sposób jego używania, chociaż nie jest to środek zabezpieczania aplikacji. Aby uzyskać więcej informacji o trybie środowiska uruchomieniowego, zobacz sekcję Poznawanie środowiska uruchomieniowego programu Access.

Instalowanie i uaktualnianie bazy danych frontonu programu Access

Po przyjęciu projektu podzielonej bazy danych musisz rozpowszechnić zewnętrzną bazę danych z każdym użytkownikiem. Aby elementy były płynnie sprawnie stosowane, należy uwzględnić następujące najważniejsze wskazówki:

  • Upewnij się, że każdy użytkownik ma odpowiednią wersję programu Access i że baza danych frontonu zostanie otwarta w odpowiedniej wersji. Program Access oferuje również 32-bitowe i 64 bitowe wersje. Uruchamianie niepoprawnej "bitów" może wpływać na wywołania API systemu Windows, odwołania do bibliotek DLL oraz kontrolki ActiveX. Aby uzyskać więcej informacji, zobacz Wybieranie między 64-bitową lub 32-bitową wersją pakietu Office.

  • Utwórz pakiet instalacyjny dla innych plików, które mogą być wymagane, w tym sterowniki baz danych, pliki wsadowe do instalacji i konfiguracji oraz pliki powiązane z aplikacją. Aby uzyskać więcej informacji, zobacz Tworzenie pakietu instalacyjnego.

  • Podaj skrót klawiaturowy systemu Windows, aby użytkownik mógł szybko uruchomić rozwiązanie programu Access. Dołączanie do skrótu do lokalizacji folderu, opisowej nazwy skrótu, opisu i ikony. Aby uzyskać więcej informacji, zobacz Tworzenie skrótu na pulpicie dla programu lub pliku pakietu Office.

    Porada    Poinstruuj użytkowników, jak przypinać aplikacje do menu Start.

  • Umożliwia określenie efektywnego sposobu ponownego wdrażania i zamieniania zewnętrznej bazy danych, gdy są wymagane aktualizacje, oraz przechowywania wersji plików, aby śledzić zmiany. Możesz na przykład dodać kod języka VBA, aby sprawdzić nowe wersje i uaktualnić automatycznie, nawet zanim użytkownicy uruchomili aplikację.

  • Podczas tworzenia połączenia ODBC przy użyciu pliku DSN zawierającego parametry połączenia ten plik DSN musi być również zainstalowany na każdym komputerze klienta. Innym rozwiązaniem jest utworzenie połączenia "ze DSN-less" w kodzie VBA, aby wyeliminować konieczność użycia pliku DSN. Aby uzyskać więcej informacji, zobacz Korzystanie z połączeń ze DSN-minus.

Początek strony

Opis i pobieranie programu Access Runtime

Aby wdrożyć aplikacje Access, które mogą być uruchamiane bez instalacji Access na komputerze użytkownika, możesz je dystrybuować wraz z programem Access Runtime, który jest dostępny bezpłatnie w centrum pobierania Microsoft. Po otwarciu bazy danych Access za pomocą środowiska uruchomieniowego Access baza danych jest otwierana w trybie środowiska uruchomieniowego.

Tryb środowiska uruchomieniowego to tryb pracy Access, w którym pewne funkcje Access nie są domyślnie dostępne. Jednak niektóre z tych niedostępnych funkcji można udostępnić w trybie środowiska uruchomieniowego.

Jakie funkcje nie są dostępne w trybie środowiska uruchomieniowego?

Poniższe funkcje Access nie są dostępne w trybie środowiska uruchomieniowego:

  • Klucze specjalne    Klawisze, takie jak Ctrl + Break, Ctrl + G, oraz klawisz Shift, aby ominąć opcje uruchamiania w bazie danych.

  • Okienko nawigacji    Okienko nawigacji nie jest dostępne w trybie środowiska uruchomieniowego. Dzięki temu użytkownicy nie mogą uzyskiwać dostępu do dowolnych obiektów w Twojej aplikacji bazy danych. Tylko te obiekty, które udostępniasz użytkownikom, na przykład przez udostępnienie formularza nawigacji, mogą być otwierane podczas korzystania z trybu wykonywania. Nie można udostępnić okienka nawigacji w trybie środowiska uruchomieniowego.

  • Wstążka    Domyślnie wstążka nie jest dostępna w trybie środowiska uruchomieniowego. Zapobiega to tworzeniu lub modyfikowaniu przez użytkowników obiektów bazy danych i wykonywaniu innych potencjalnie niebezpiecznych akcji, takich jak łączenie się z nowymi źródłami danych lub eksportowanie danych w sposób, który nie został przewidziany. Nie możesz udostępnić domyślnych kart wstążki w trybie środowiska uruchomieniowego. Możesz jednak utworzyć Wstążkę niestandardową, a następnie skojarzyć tę Wstążkę z formularzem lub raportem. Aby uzyskać więcej informacji, zobacz Tworzenie Wstążki niestandardowej w programie Access.

  • Widok projektu i widoku układu    W trybie środowiska uruchomieniowego widok projektu i widok układu nie są dostępne dla dowolnego obiektu bazy danych. Dzięki temu użytkownicy nie mogą modyfikować projektu obiektów w aplikacji bazy danych. Widoku projektu lub układu nie można włączyć w trybie środowiska uruchomieniowego.

  • Pomoc    Zintegrowana pomoc nie jest domyślnie dostępna w trybie środowiska uruchomieniowego. Ponieważ kontrolujesz, jakie funkcje są dostępne w aplikacji w trybie środowiska uruchomieniowego, niektóre zintegrowane elementy standardowej pomocy Access mogą być nieodpowiednie dla osób używających aplikacji i potencjalnie mogą je mylić lub frustrować. Możesz utworzyć własny niestandardowy plik pomocy, aby uzupełnić aplikację trybu wykonywania.

Jak symulować tryb wykonywania?

W trybie środowiska uruchomieniowego możesz uruchomić dowolną bazę danych Access na komputerze, który ma zainstalowaną pełną wersję Access. Aby uruchomić bazę danych Access w trybie środowiska uruchomieniowego, wykonaj jedną z następujących czynności:

  • Zmień rozszerzenie nazwy pliku bazy danych z accdb na accdr.

  • Utwórz skrót do bazy danych za pomocą przełącznika wiersza polecenia /Runtime .

    1. Na pulpicie systemu Windows kliknij prawym przyciskiem myszy i wybierz polecenie nowy > skrót.

    2. Wprowadź lokalizację MSAccess. exe, lokalizację bazy danych oraz kwalifikator polecenia /Runtime . Na przykład:

      "C:\Program Files\Microsoft Office\MSACCESS.EXE" "C:\MyDB.accdb" /runtime

    Aby uzyskać więcej informacji, zobacz Tworzenie skrótu na pulpicie dla programu lub pliku pakietu Office.

Czy tryb środowiska uruchomieniowego powoduje, że moja baza danych jest bezpieczniejsza?

Chociaż tryb środowiska uruchomieniowego ogranicza dostępność do funkcji nawigacji i projektowania, nie należy używać trybu środowiska uruchomieniowego jako podstawowego środka ochrony aplikacji bazy danych. Na komputerze mającym zainstalowaną pełną wersję Access użytkownik może mieć możliwość otwarcia aplikacji bazy danych w środowisku uruchomieniowym jak zwykłej aplikacji bazy danych (czyli z dostępem do wszystkich funkcji), a następnie zmiany projektu lub wykonania innych niepożądanych akcji.

Nawet jeśli wdrożysz aplikację bazy danych tylko na komputerach, które nie mają zainstalowanej pełnej wersji Access, użytkownik nadal może przesłać aplikację na komputer, który ma zainstalowaną pełną wersję Access, a następnie otworzyć aplikację bazy danych w środowisku uruchomieniowym jako zwykłą aplikację bazy danych.

Początek strony

Pobieranie środowiska uruchomieniowego Access

Aby pobrać środowisko uruchomieniowe Access z Centrum pobierania Microsoft, kliknij link odpowiedni dla Twojej wersji:

Zakup nie jest konieczny do pobrania, używania lub redystrybucji środowiska uruchomieniowego Access i nie ma ograniczenia liczby użytkowników, do których możesz dystrybuować środowisko uruchomieniowe.

Początek strony

Tworzenie pakietu instalacyjnego

Istnieje kilka metod, które można wykonać w zależności od wersji programu Access.

Korzystanie z ogólnego pakietu instalacyjnego (Access 2013 lub nowszego)

w przypadku programu Access w wersji 2013 lub nowszej możesz użyć Instalatora Windows lub wyszukać program innej firmy, który tworzy pakiety instalacyjne.

Pakowanie i podpisywanie bazy danych Access (Access 2007 i 2010)

W programie Access 2007 lub 2010 łatwiejsze i szybsze rejestrowanie i rozpowszechnianie bazy danych. Po utworzeniu pliku accdb lub accde można go spakować, opatrzyć podpisem cyfrowym, a następnie rozpowszechnić w celu udostępnienia innym użytkownikom. Funkcja Spakuj i podpisz umieszcza bazę danych w pliku wdrażania programu Access (accdc), podpisuje plik, a następnie umieszcza pakiet z podpisanym kodem w wybranej lokalizacji na komputerze użytkownika. Użytkownicy mogą następnie wyodrębniać bazę danych z pakietu i pracować bezpośrednio w bazie danych (nie w pliku pakietu). Aby uzyskać więcej informacji, zobacz Omówienie Kreatora rozwiązań pakietu.

Uwaga: Funkcja opisana w tej sekcji pakuje plik Access i dodaje do pakietu podpis cyfrowy, który pomaga wskazać użytkownikom, że plik jest godny zaufania.

Podczas kontynuowania tworzenia i podpisywania pakietu pamiętaj o następujących kwestiach:

  • Pakowanie bazy danych i podpisywanie pakietu to sposoby przekazywania informacji o zaufaniu. Gdy Ty lub Twoi użytkownicy otrzymają pakiet, podpis potwierdza, że baza danych nie została naruszona. Jeśli ufasz autorowi, możesz włączyć zawartość.

  • Funkcja Spakuj i podpisz ma zastosowanie tylko do baz danych zapisanych w formacie pliku accdb.

  • Do pakietu można dodać tylko jeden plik bazy danych.

  • Podczas pakowania i tworzenia bazy danych wszystkie obiekty w bazie danych mają podpisany kod, a nie tylko makra lub moduły kodu. Proces pakowania i podpisywania również kompresuje plik pakietu, pomagając skrócić czasy pobierania.

  • Po wyodrębnieniu bazy danych z pakietu nie ma już połączenia między podpisanym pakietem i wyodrębnioną bazą danych.

  • Jeśli podpiszesz pakiet bazy danych za pomocą certyfikatu z podpisem własnym, a następnie podczas otwierania tego pakietu klikniesz pozycję Zawsze ufaj zawartości od tego wydawcy, to pakiety podpisane za pomocą certyfikatów z podpisami własnymi zawsze będą zaufane.

  • Jeśli wyodrębnisz bazę danych do zaufanej lokalizacji, jej zawartość będzie automatycznie włączana przy każdym otwarciu. Jeśli wybierzesz lokalizację, która nie jest zaufana, pewna część zawartości bazy danych może zostać domyślnie wyłączona.

W poniższych sekcjach wyjaśniono, jak utworzyć podpisany plik pakietu oraz jak korzystać z bazy danych w podpisanym pliku pakietu. Aby wykonać te kroki, musisz mieć dostępny co najmniej jeden certyfikat zabezpieczeń. Jeśli na komputerze nie zainstalowano certyfikatu, możesz utworzyć go za pomocą narzędzia SelfCert lub uzyskać świadectwo komercyjne. Aby uzyskać informacje na temat certyfikatów zabezpieczeń, zobacz Wyświetlanie zaufania przez dodanie podpisu cyfrowego.

Tworzenie podpisanego pakietu

  1. Otwórz bazę danych, którą chcesz spakować i podpisać.

  2. Kliknij kartę Plik, a następnie kliknij pozycję Zapisz jako.

  3. W obszarze Typy plików bazy danych kliknij pozycję Spakuj i podpisz, a następnie kliknij pozycję Zapisz jako.

  4. W oknie dialogowym Wybierz certyfikat wybierz certyfikat cyfrowy, a następnie kliknij przycisk OK.

    Zostanie wyświetlone okno dialogowe Tworzenie podpisanego pakietu programu Microsoft Office Access.

  5. Na liście Zapisz w wybierz lokalizację, w której chcesz umieścić podpisany pakiet bazy danych.

  6. W polu Nazwa pliku wprowadź nazwę dla podpisanego pakietu, a następnie kliknij pozycję Utwórz.

    Program Access utworzy plik accdc i umieści go w wybranej lokalizacji.

Wyodrębnianie i używanie podpisanego pakietu

  1. Kliknij pozycję Plik > Otwórz.

  2. W oknie dialogowym Otwieranie wybierz pozycję Podpisane pakiety programu Access pakietu Microsoft Office (*.accdc) jako typ pliku.

  3. Na liście Szukaj w znajdź folder zawierający Twój plik accdc, zaznacz ten plik, a następnie kliknij przycisk Otwórz.

  4. Wykonaj jedną z następujących czynności:

    • Jeśli certyfikat cyfrowy, który został zastosowany do pakietu wdrożenia, został uznany za zaufany, zostanie wyświetlone okno dialogowe Wyodrębnianie bazy danych do. Przejdź do kroku 5.

    • Jeśli jeszcze nie ufasz certyfikatowi cyfrowemu, zostanie wyświetlona wskazówka.

      Wskazówka

      Jeśli baza danych jest zaufana, kliknij pozycję Otwórz. Jeśli wszystkie certyfikaty od tego dostawcy są zaufane, kliknij pozycję Zawsze ufaj zawartości od tego wydawcy. Zostanie wyświetlone okno dialogowe Wyodrębnianie bazy danych do.

  5. Opcjonalnie na liście Zapisz w wybierz lokalizację, w której chcesz umieścić wyodrębnioną bazę danych, a następnie w polu Nazwa pliku wprowadź inną nazwę dla wyodrębnionej bazy danych.

W przypadku wątpliwości dotyczących wiarygodności certyfikatu zapoznaj się z artykułem Jak stwierdzić, czy podpis cyfrowy jest wiarygodny, w którym podano ogólne informacje o sprawdzaniu dat i innych pozycji w certyfikacie, ułatwiających potwierdzenie jego ważności.

Początek strony

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×