Włączanie lub wyłączanie podpisów cyfrowych

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Podczas projektowania szablonu formularza można określić, czy użytkownicy będą mogli używać podpisów cyfrowych podczas wypełniania formularzy opartych na szablonie formularza. Za pomocą podpisu cyfrowego dla wielu tych samych powodów, że mogą podpisywać dokumentu. Podpis cyfrowy jest używany do informacji cyfrowych uwierzytelnianie — takie jak szablonów formularzy, formularze, wiadomości e-mail i dokumentów — za pomocą komputera kryptograficzny. Po podpisaniu formularza nie można zmienić cały formularz lub części formularza, który został podpisany nie unieważnieniu podpis.

Uwaga: Szablon formularza utworzonym na podstawie schematu XML, można włączyć podpisy cyfrowe dla szablonu formularza, tylko wtedy, gdy węzeł, który znajduje się w podpis cyfrowy XML World Wide Web Consortium (W3C) przestrzeń nazw schematu XML.

W tym artykule

Informacje dotyczące zgodności

Włączanie podpisów cyfrowych, tak aby użytkownicy mogli logować całego formularza

Włączanie podpisów cyfrowych, tak aby użytkownicy mogli logować części formularza

Wyłączanie podpisów cyfrowych

Informacje dotyczące zgodności

Po utworzeniu szablonu formularza można włączyć podpisów cyfrowych, dzięki czemu użytkownicy mogą dodawać je do całego formularza lub do określonej części formularza. W Microsoft Office InfoPath 2007 możesz również projektowanie szablonu formularza zgodnego z przeglądarkami. Szablon formularza zgodny z przeglądarką jest zaprojektowanej w programie InfoPath, korzystając z trybu zgodności określonego szablonu formularza. Szablon formularza zgodny z przeglądarką mogą być obsługiwanych w przeglądarce po opublikowaniu na serwerze z usług InfoPath Forms Services. W szablonach formularzy obsługiwanych w przeglądarce można włączyć tylko podpisów cyfrowych, które mają zostać dodane do określonej części formularze wypełniania przez użytkowników. Po włączeniu podpisów cyfrowych dla części formularza podpisy dotyczą tylko dane w określonej części formularza.

Początek strony

Włączanie podpisów cyfrowych, tak aby użytkownicy mogli logować całego formularza

  1. W menu Narzędzia kliknij polecenie Opcje formularza.

  2. W kategorii kliknij polecenie Podpisy cyfrowe, a następnie kliknij Włącz podpisy cyfrowe dla całego formularza.

    Uwaga: W przypadku projektowania szablonu formularza zgodnego z przeglądarkami, opcja Włącz podpisy cyfrowe dla całego formularza jest niedostępna, ponieważ szablonów formularzy zgodnych z przeglądarką tylko obsługi podpisów cyfrowych wybranych części szablonu formularza. Jeśli zmienisz opcje zgodności dla szablonu formularza po włączeniu podpisów cyfrowych, należy uruchomić moduł sprawdzania projektu, aby sprawdzić, czy podpis cyfrowy opcje są poprawnie skonfigurowane. Więcej informacji na temat sprawdzania projektu można znaleźć w sekcji Zobacz też.

  3. Jeśli szablon formularza na podstawie bazy danych, usługi sieci Web lub schemat XML zawierający obszar nazw podpisu cyfrowego, kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku , aby określić grupę w źródle danych, przechowywania podpis. Grupa musi być częścią obszar nazw podpisu cyfrowego.

    Uwaga: Projektowanie szablonu formularza, który nie jest oparty na bazie danych, usługi sieci Web lub schematu XML zawiera przestrzeń nazw cyfrowy, ta opcja jest niedostępna. W tym przypadku przejdź do kroku 5.

  4. W oknie dialogowym Wybieranie pola lub grupy kliknij pole lub grupę, dla której chcesz włączyć podpisy cyfrowe, a następnie kliknij przycisk OK.

  5. Jeśli użytkownik ma mieć możliwość podpisywać formularz przed przesłaniem, zaznacz pole wyboru Monituj użytkownika do podpisania formularza, jeśli jest przesyłany bez podpisu.

    Uwaga: Jeśli nie włączono już przesyłania formularza dla szablonu formularza, możesz to zrobić po zaznaczeniu tego pola wyboru.

Początek strony

Włączanie podpisów cyfrowych, tak aby użytkownicy mogli logować części formularza

  1. W menu Narzędzia kliknij polecenie Opcje formularza.

  2. W kategorii kliknij polecenie Podpisy cyfrowe, a następnie kliknij Włącz podpisy cyfrowe dla określonych danych w formularzu.

  3. Kliknij przycisk Dodaj.

  4. W oknie dialogowym Z danych do podpisania wpisz nazwę dla części szablonu formularza, dla której chcesz włączyć podpisy cyfrowe.

    Porada: Nazwy, których nie może zawierać spacji.

  5. Kliknij pozycję Wybierz wyrażenie XPath Obraz przycisku obok pola pola i grupy do podpisania.

  6. W oknie dialogowym Wybieranie pola lub grupy kliknij pole lub grupę, dla której chcesz włączyć podpisy cyfrowe, a następnie kliknij przycisk OK.

  7. W obszarze Opcje podpisu w oknie dialogowym Z danych do podpisania wykonaj jedną z następujących czynności:

    • Aby zezwolić na tylko jeden podpis w tej części szablonu formularza, kliknij przycisk Zezwalaj tylko jeden podpis.

    • Aby zezwolić na wiele podpisów, które są niezależne od siebie, a które można dodać lub usunąć bez wpływu na inne podpisy, kliknij pozycję wszystkie podpisy są niezależne (znak Współtworzenie).

    • Aby zezwolić na wiele podpisów, których podpisywania starszych podpisów, kliknij każdy podpis podpisuje poprzedzający podpis (kontrasygnuje).

  8. W oknie dialogowym Potwierdzenie podpisu wpisz tekst, który ma być wyświetlany, gdy użytkownik podczas logowania tej części formularza, a następnie kliknij przycisk OK.

  9. W szablonie formularza skojarzyć części szablonu formularza, dla której zostały włączone podpisy cyfrowe z sekcją.

    Jak to zrobić?

    1. Umieść kursor w miejscu, w którym chcesz wstawić sekcję.

    2. Jeśli okienko zadań Źródło danych nie jest widoczny, kliknij pozycję Źródła danych, w menu Widok.

    3. W okienku zadań Źródło danych wykonaj jedną z następujących czynności:

      • Aby dodać formant związany z polem, kliknij prawym przyciskiem myszy pole, a następnie kliknij kontrolkę, którą chcesz powiązać do tego pola.

      • Aby dodać sekcję, która jest powiązana z grupą, kliknij prawym przyciskiem myszy grupę, a następnie kliknij sekcja z formantami.

        Uwaga: Jeśli pola lub grupy, którą określono powtarza, musisz zaznaczyć grupę niepowtarzające, która zawiera pola lub grupy.

  10. W szablonie formularza kliknij dwukrotnie etykietę sekcji poniżej sekcji, która zawiera inne sekcje lub kontrolek, które zostały wstawione.

  11. Kliknij kartę Podpisy cyfrowe.

  12. Zaznacz pole wyboru Zezwalaj użytkownikom na cyfrowe podpisywanie tej sekcji.

  13. W oknie dialogowym Podpisz następujące dane w formularzu, gdy ta sekcja jest zalogowany kliknij nazwę sekcji, który został utworzony w kroku 4 podpis cyfrowy.

  14. Aby wyświetlić podpisów w sekcji, gdy są one dodawane, zaznacz pole wyboru Pokaż podpisy w sekcji.

  15. Aby wyświetlić formanty w sekcji jako tylko do odczytu po są podpisane, zaznacz pole wyboru po podpisaniu zmień tryb formantów tylko do odczytu.

Początek strony

Wyłączanie podpisów cyfrowych

  1. W menu Narzędzia kliknij polecenie Opcje formularza.

  2. W kategorii kliknij polecenie Podpisy cyfrowe, a następnie wykonaj jedną z następujących czynności:

    • Aby wyłączyć podpisy cyfrowe w całym szablonie formularza, kliknij pozycję nie włączaj podpisów cyfrowych.

    • Aby wyłączyć podpisy cyfrowe dla określonej części szablonu formularza, kliknij pozycję Włącz podpisy cyfrowe dla określonych danych w formularzu, kliknij część tego szablonu formularza na liście danych w formularzu, które można podpisać, który chcesz wyłączyć cyfrowe podpisy, a następnie kliknij przycisk Usuń.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×