Udostępnianie danych tabeli zewnętrznej w usługach programu Excel za pomocą tabeli przestawnej

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Uwaga: Ten artykuł spełnił swoje zadanie i wkrótce zostanie wycofany. Aby zapobiec błędom „Nie można odnaleźć strony”, usuniemy znane nam linki. Jeśli zostały utworzone linki do tej strony, należy je usunąć — dbajmy wspólnie o łączność w sieci Web.

Jeśli chcesz pracować z danymi tabeli oparte na połączenia danych zewnętrznych w Usługi programu Excel, nie można używać zakresu danych zewnętrznych (nazywane również tabela kwerendy). Musisz utworzyć tabelę przestawną, która spłaszcza wielowymiarowych, hierarchicznych danych do tabeli lub dwóch wymiarów. Oto jak to zrobić.

Porównanie danych wielowymiarowych i dwuwymiarowych

1. Konwertuj wielowymiarowych tabeli przestawnej...

2... .Aby dwuwymiarowych tabeli przestawnej...

3. …w celu wyświetlenia uproszczonych danych tabeli w usługach programu Excel.

Co chcesz zrobić?

Dowiedz się, jak w usługach programu Excel obsługiwane są połączenia z zewnętrznymi źródłami danych

Poznaj różnice między raportami tabeli przestawnej połączonymi z danymi zewnętrznymi i zakresami danych zewnętrznych

Tworzenie dwuwymiarowego raportu tabeli przestawnej w formie tabelarycznej

Tworzenie raportu tabeli przestawnej i łączenie go z zewnętrznym źródłem danych

Dodawanie, układanie i rozmieszczanie pól w obszarze Etykiety wierszy

Zmienianie opcji tabeli przestawnej i ustawień pól

Tworzenie dwuwymiarowego układu raportu tabeli przestawnej

Dostosowywanie projektu raportu tabeli przestawnej

Publikowanie skoroszytu w usługach programu Excel

Dowiedz się jak w usługach programu Excel obsługiwane są połączenia z zewnętrznymi źródłami danych

Tabele przestawne są przeznaczone do agregacji wiele danych liczbowych do sum i sum oraz pracować z danych wielowymiarowych, które są zorganizowane w hierarchii. Z drugiej strony zakresy danych zewnętrznych są dwuwymiarowych tabel strukturze wierszy i kolumn, wyświetlane nonaggregated rekordy danych źródłowych.

Nawiązywanie połączenia z danymi zewnętrznymi za pomocą Kreatora połączenia danych lub programu Microsoft Query możesz zazwyczaj utworzyć zakresu danych zewnętrznych. Jedynym wyjątkiem jest po utworzeniu tabeli przestawnej, który jest połączony z danymi zewnętrznymi. Tabela przestawna nie tworzy zakresu danych zewnętrznych. Ta różnica w ten sposób utworzenia połączenia jest ważne, aby dowiedzieć się, kiedy publikowanie skoroszytu w usługach programu Excel, ponieważ usług programu Excel tylko obsługuje połączenia danych zewnętrznych według tabel przestawnych, a nie obsługuje zakresy danych zewnętrznych.

Początek strony

Więcej informacji na temat różnic w tabelach przestawnych, które są połączone z danymi zewnętrznymi i zakresy danych zewnętrznych

Podczas pracy z tabeli przestawnej, który jest połączony z danymi zewnętrznymi, weź pod uwagę różnice między zachowanie tabeli przestawnej i zakresu danych zewnętrznych, który należy pamiętać, łącznie z następujących czynności:

Grupy i podgrupy danych tabeli przestawnej w kolejności od lewej do prawej

Zazwyczaj zgrupowanych danych jest oparty na sortowanie danych według jednej lub więcej kolumn. Na przykład jeśli chcesz uzyskać listę wszystkich pracowników pogrupowane według ich działy, można wykonywać podstawowego sort z danych według działów i sortowania dodatkowego przez pracowników. Można także zagnieździć grup, takich jak linii produktów, kategorii i produktu, lub geograficznych, Kraj/Region, stan/prowincja i Miasto. Domyślnie tabele przestawne są automatycznie sortowane do grup i podgrup w kolejności od lewej do prawej, aby ułatwić wyświetlanie powiązanych danych do wyświetlania informacji nagłówka i podsumowania i aby rozwinąć lub zwinąć powiązanych elementów.

Dane pogrupowane według Linii produktówi subgrouped w każdym Wierszu produktu według kategorii

Linia produktów

Kategoria

Produkt

Silniki

Samolot

Mocowane na skrzydłach

Mocowane na ogonie

Dopalacz

Samochód

269 KM

454 KM

Układy wydechowe

Osobowy

Wysokotemperaturowy

Standardowy

Terenowy

Mały

Umieszczając kolumnę unikatowych wartości w obszarze Etykiety wierszy po prawej stronie, można automatycznie zmniejszyć wielowymiarowość danych.

Tych samych danych Linii produktów spłaszczoną przez dodanie kolumny Identyfikator Num

Nr ew.

Linia produktów

Kategoria

Produkt

WM-345

Silniki

Samolot

Mocowane na skrzydłach

TM-231

Silniki

Samolot

Mocowane na ogonie

BSTR-567

Silniki

Samolot

Dopalacz

6C-734

Silniki

Samochód

269 KM

8C-121

Silniki

Samochód

454 KM

MF-202

Układy wydechowe

Osobowy

Wysokotemperaturowy

MF-321

Układy wydechowe

Osobowy

Standardowy

MF-211

Układy wydechowe

Terenowy

Mały

Jeśli nie chcesz wyświetlić kolumnę, po dodaniu kolumny do tabeli przestawnej, można ukryć kolumny. (Zaznacz kolumnę, a następnie na karcie Narzędzia główne w grupie komórki kliknij strzałkę obok pola Format, wskaż pozycję Ukryj i Odkryj, a następnie kliknij Ukryj kolumny.)

Ważne: Jeśli tabela przestawna wykryje dwa lub więcej wierszy zduplikowanych danych ze źródła danych, Tabela przestawna z wyświetlonymi tylko jeden wiersz. Jeśli chcesz, aby wszystkie wiersze, nawet zduplikowane wiersze, wyświetlane w tabeli przestawnej, należy dodać kolumnę zawierającą unikatowe wartości do tabeli, kwerendy lub widoku, który możesz zaimportować ze źródła danych. Jeśli źródło danych nie zawiera kolumny unikatowe, to można dodać w źródle danych. Na przykład można dodać kolumny, która ma AutoNum typ danych do tabeli programu Microsoft Office Access lub kolumnę zawierającą tożsamości typ danych do tabeli programu Microsoft SQL Server lub kolumny obliczeniowej, która zawiera unikatowy numer dla każdego rekordu do zapytania bazy danych lub Wyświetl w.

Edytowanie danych w komórkach i dodawanie kolumn obliczeniowych

Przed opublikowanie skoroszytu w usługach programu Excel można edytować jego dane przy użyciu zakresu danych zewnętrznych. Dane w raporcie tabeli przestawnej są zawsze tylko do odczytu.

Dwukrotne kliknięcie komórki w zakresie danych zewnętrznych powoduje przejście do trybu edycji i umożliwia zmianę wartości, a nawet wprowadzenie formuły. Należy jednak zauważyć, że zmianom nie ulegają oryginalne wartości w źródle danych i podczas następnego odświeżenia danych nowe wartości mogą zostać zastąpione zależnie od ustawienia właściwości Jeśli liczba wierszy w zakresie danych zmieni się podczas odświeżania zakresu danych zewnętrznych.

Dwukrotne kliknięcie komórki etykiet wierszy w tabeli przestawnej komórkę rozwija lub zwija elementy tej etykiety wierszy. Spłaszczenie tabeli przestawnej do tabeli dwuwymiarowych spłaszczanie ma sprawia, wszystkie wartości wiersza w grupę, do lewej strony komórki zniknąć lub pojawia się ponownie.

Można dodawać kolumny obliczeniowe dowolne miejsce w tabeli programu Microsoft Office Excel, która jest oparty na zakres danych zewnętrznych lub możesz wstawić kolumny i Wypełnij w dół formuł w zakresu danych zewnętrznych. Nie można wstawiać kolumn obliczeniowych w tabeli przestawnej (choć można wstawić pola obliczeniowe). Możesz dodać kolumnę, która wypełnia w dół danych lub formuł w celu natychmiastowego lewej lub prawej strony tabeli przestawnej i w formule wypełnione w dół, można użyć odwołania do komórek w tabeli przestawnej.

Tworzenie wykresów

Jeśli chcesz utworzyć wykres na podstawie danych w tabeli przestawnej, możesz utworzyć wykres przestawny, która działa podobnie jak standardowe wykresy, ale istnieją pewne niektóre różnice, łącznie z następujących czynności:

Interakcji     Ze standardowymi wykresami utworzyć jeden wykres dla każdego widoku danych, które mają być wyświetlane, ale nie są interakcyjne widoki. Wykresy przestawne możesz utworzyć pojedynczy wykres i interakcyjne przeglądanie danych na różne sposoby, zmieniając układ raportu lub wyświetlania szczegółów. W usługach programu Excel zarówno wykres standardowy i wykresu przestawnego można aktualizować według interakcji użytkownika w skoroszycie, ale obu wykresów są wyświetlane jako statyczne obrazy.

Typy wykresów     Domyślny typ wykresu na wykres standardowy jest wykres kolumnowy grupowany, który porównuje wartości w poszczególnych kategoriach. Domyślny typ wykresu na wykresie przestawnym jest skumulowany wykres kolumnowy, który porównuje udziału każdej wartości w sumie dla różnych kategorii. Możesz zmienić wykresu przestawnego na wykres dowolnego typu z wyjątkiem wykresu xy (punktowego), giełdowego i bąbelkowego.

Elementy wykresu     Wykresy przestawne zawierają te same elementy co standardowy wykresy, ale zawierają również pola i elementy, które można dodać do, obrócony lub usuwać w celu wyświetlenia różnych widoków danych. Kategorie, serii i danych na wykresach standardowe są pól kategorii, serii, a wartość pola w wykresów przestawnych. Wykresy przestawne również mogą zawierać filtry raportu. Każde z tych pól zawiera elementy, które w standardowymi wykresami są wyświetlane jako etykiety kategorii lub serii nazwy w legendy.

Formatowanie     Większość formatowania, takich jak elementy, układ i styl, są zachowywane podczas możesz odświeżanie wykresu przestawnego. Jednak linie trendu, etykiety danych, słupki błędów i inne zmiany w serii danych nie są zachowywane. Standardowymi wykresami nie utracić formatowanie zastosowane.

Przenoszenie lub zmienianie rozmiaru elementów     W wykresu przestawnego nie można przenieść lub zmienić rozmiar obszar kreślenia, legendy, tytułów wykresu lub tytuły osi, mimo że można wybrać jedną z kilku wstępnie ustawionych pozycji legendy i możesz zmienić rozmiar czcionki tytułów. Na wykresie standardowej można przenieść i zmienianie rozmiaru wszystkich tych elementów.

Po utworzeniu wykresu przestawnego, jeśli wolisz, możesz przekonwertować go na wykres standardowy. Aby uzyskać więcej informacji zobacz artykuł Tworzenie tabeli przestawnej z danymi arkusza anaylzelub Tworzenie wykresu przestawnego.

Porównanie właściwości zakresu danych zewnętrznych z opcjami tabeli przestawnej

Zakresy danych zewnętrznych i tabele przestawne mają właściwości, których można używać do sterowania formatowanie danych i układ i działanie odświeżania danych.

I zakresów danych zewnętrznych i tabele przestawne umożliwiają dopasowywanie szerokości kolumny, zachowane kolumna sortowania, filtrowania, formatowania komórek i układu danych w przypadku odświeżania danych zewnętrznych.

Zakresu danych zewnętrznych możesz również dostępna opcja łącznie z numerami wierszy jako pierwszą kolumnę danych. W tabeli przestawnej jest opcja Brak podobne. Zapoznaj się z sekcją grupy i podgrupy danych tabeli przestawnej w kolejności od lewej do prawej, aby uzyskać omówienie dodanie unikatowych kolumny w źródle danych.

Podczas odświeżania zakresu danych zewnętrznych można decydować o tym, co się stanie z istniejącymi danymi, jeśli liczba wierszy w zakresie danych ulegnie zmianie, ustawiając jedną z poniższych opcji:

  • Wstaw komórki dla nowych danych, usuń nieużywane komórki (ustawienie domyślne)

  • Wstaw całe wiersze dla nowy danych i usuń nieużywane komórki

  • Zastąp istniejące komórki nowymi danymi, wyczyść nieużywane komórki

Po odświeżeniu tabeli przestawnej, po prostu przełącza nowe dane. Jednak możesz się monitu i monit z pytaniem, czy zastąpić istniejące komórki poniżej bieżącego raportu.

Filtrowanie danych

Filtrowanie danych w danych zewnętrznych zakresu lub tabeli przestawnej są bardzo podobne, ale istnieją pewne różnice między innymi następujące:

  • Zakresy danych zewnętrznych za pomocą Filtru tekstu, Filtry liczb i polecenia Filtr daty, dlatego tabel przestawnych za pomocą polecenia Filtr etykiet, Filtr wartości i Filtr daty.

  • Menu filtru zakresu danych zewnętrznych zawsze usuwa elementy, które nie są już prawidłowe, i menu filtru nigdy nie zawiera nowych elementów przy użyciu zastosowanego filtru po zakończeniu operacji odświeżania, ale tabela przestawna zawiera opcje służące do sterowania to zachowanie. Aby uzyskać więcej informacji zobacz sekcję Opcje tabeli przestawnej Zmień i ustawienia pola.

  • Tabela przestawna zawiera raportu funkcji filtrowania (opcja nie jest dostępna do zakresu danych zewnętrznych) umożliwiający pracować z podzbiorem danych w tabeli przestawnej.

Sortowanie danych

W zakresu danych zewnętrznych można wykonywać wielokolumnowy sortowanie według maksymalnie 64 kolumny, możesz wybrać dowolnej kolumny jako podstawowego sortowania i możesz wybrać innych kolumn jako sortuje pomocniczą. Jednak procesy sortowanie danych w tabeli przestawnej i sortowania zakresu danych zewnętrznych są różne. W przeciwieństwie do zakresu danych zewnętrznych w tabeli przestawnej można wykonać tylko podstawowy sortowania na lewej kolumny. Wszystkie pozostałe kolumny wykonanie pomocniczej sortowania według kolumny bezpośrednio po lewej. Krótko mówiąc możesz można wykonać tylko głównego i pomocniczego sortowanie w kolejności od lewej do prawej.

Ponadto wstawienie kolumny z unikatowymi wartościami jako pierwszej od lewej powoduje, że sortować można wyłącznie według tej kolumny, ponieważ każdy wiersz staje się grupą główną. W zależności od potrzeb użytkowników dane można posortować wstępnie w programie Excel, a następnie po opublikowaniu skoroszytu w usługach programu Excel wyłączyć sortowanie przez wyczyszczenie pola wyboru Sortowanie w okienku narzędzi składnika Web Part programu Microsoft Office Excel Web Access.

Używanie hiperłączy

W odróżnieniu od zakresów danych zewnętrznych, aktywne hiperłącza nie są obsługiwane w komórkach tabel przestawnych. Hiperłącze jest traktowane jako tekst i nie można za jego pomocą przejść do strony sieci Web albo dokumentu w programie Excel lub w usługach programu Excel.

Początek strony

Tworzenie tabeli przestawnej dwuwymiarowych, tabelarycznego

Istnieje wiele czynności, które są wymagane do Spłaszcz wielowymiarowych danych w tabeli przestawnej dwuwymiarowych, tabelarycznego. Aby uzyskać najlepsze wyniki wykonaj poniższe procedury w sekwencji.

Początek strony

Tworzenie tabeli przestawnej i połączyć go z zewnętrznego źródła danych

  1. Zaznacz pustą komórkę.

  2. Na karcie Wstawianie w grupie Tabele kliknij przycisk Tabela przestawna, a następnie kliknij polecenie Tabela przestawna.

    Obraz Wstążki programu Excel

    Zostanie wyświetlone okno dialogowe Tworzenie tabeli przestawnej.

  3. Kliknij pozycję Użyj zewnętrznego źródła danych.

  4. Kliknij przycisk Wybierz połączenie.

    Na Zostanie wyświetlone okno dialogowe Istniejące połączenia.

  5. Na liście Pokaż u góry okna dialogowego wybierz kategorię połączeń, z której chcesz wybrać połączenie, lub zaznacz opcję Wszystkie istniejące połączenia (jest to domyślne ustawienie).

  6. Wybierz połączenie z listy Wybierz połączenie, a następnie kliknij przycisk Otwórz.

  7. Wprowadź lokalizację. Wykonaj jedną z następujących czynności:

    • Aby umieścić tabelę przestawną w nowym arkuszu, zaczynając od komórki A1, kliknij przycisk Nowy arkusz.

    • Aby umieścić tabelę przestawną w istniejącym arkuszu, wybierz pozycję Istniejący arkusz, a następnie wpisz pierwszą komórkę zakresu komórek, w którym chcesz umieścić tabelę przestawną.

      Alternatywnie kliknij przycisk Zwiń okno dialogowe Obraz przycisku tymczasowo ukryć okno dialogowe, zaznaczyć początkową komórkę w arkuszu, a następnie kliknij przycisk Rozwiń okno dialogowe Obraz przycisku .

  8. Kliknij przycisk OK.

Pustą tabelę przestawną, z listy pól tabeli przestawnej wyświetlane, zostaną dodane do lokalizacji, w której zostały wprowadzone.

Początek strony

Dodawanie, układanie i rozmieszczanie pól w obszarze Etykiety wierszy

Lista pól tabeli przestawnej służy do dodawania, układania i rozmieszczania pól, a także pozwala upewnić się, że wszystkie pola zostały dodane do obszaru Etykiety wierszy.

  1. Kliknij tabelę przestawną.

  2. Wykonaj co najmniej jedną z następujących czynności:

    • Aby dodać pola do raportu, należy wykonać jedną lub więcej z poniższych czynności:

      • Zaznacz pole wyboru obok każdej nazwy pola w sekcji pól na liście pól. Każde pole zostanie umieszczone w obszarze domyślnym sekcji układu, ale rozmieszczenie pól można zmienić.

        Domyślnie pola nienumeryczne są dodawane do obszaru Etykiety wierszy, pola numeryczne są dodawane do obszaru Wartości, a pola daty/godziny — do obszaru Etykiety kolumn.

      • Aby przenieść pole do obszaru Etykiety wierszy, kliknij prawym przyciskiem myszy nazwę pola, a następnie wybierz w menu skrótów polecenie Dodaj do etykiet wierszy.

        Porada: Można też kliknąć i przytrzymać nazwę pola, a następnie przeciągnąć pole z sekcji pól do obszaru w sekcji układu.

    • Aby ponownie rozmieścić pola, kliknij nazwę pola w jednym z obszarów, a następnie wybierz jedno z następujących poleceń:

Przenieś w górę    

Powoduje przeniesienie pola o jedną pozycję w górę w obrębie obszaru.

Przenieś w dół    

Powoduje przeniesienie pola o jedną pozycję w dół w obrębie obszaru.

Przenieś na początek    

Powoduje przeniesienie pola na początek obszaru.

Przenieś na koniec   

Powoduje przeniesienie pola na koniec obszaru.

Przenieś do etykiet wierszy    

Powoduje przeniesienie pola do obszaru etykiet wierszy.

  • Aby usunąć pole, kliknij pole Nazwa w jednym z obszarów układ, a następnie kliknij pozycję Usuń pole lub wyczyść pole wyboru obok nazw poszczególnych pól, który chcesz usunąć, w sekcji pól.

    Porada: Można też kliknąć i przytrzymać nazwę pola w sekcji układu, a następnie przeciągnąć ją poza okno Lista pól tabeli przestawnej.

    Uwaga: Wyczyszczenie pola wyboru w sekcji pól powoduje usunięcie z raportu wszystkich wystąpień pola.

Początek strony

Zmienianie opcji tabeli przestawnej i ustawień pól

W celu zapewnienia tabeli przestawnej działa podobnie jak do zakresu danych zewnętrznych, wykonaj następujące czynności:

Zmienianie opcji tabeli przestawnej   

  1. Kliknij tabelę przestawną.

  2. Na karcie Opcje w grupie Tabela przestawna kliknij przycisk Opcje.

    Zostanie wyświetlone okno dialogowe Opcje tabeli przestawnej.

  3. Aby szerokość kolumn była automatycznie dostosowywana po przeprowadzeniu operacji odświeżania, kliknij kartę Układ i format, a następnie w sekcji Wyświetl zaznacz pole wyboru Automatycznie dopasuj szerokość kolumn podczas aktualizacji.

  4. W celu zachowania formatowania podczas każdego odświeżania danych kliknij kartę Układ i format, a następnie w sekcji Wyświetl zaznacz pole wyboru Zachowaj formatowanie komórek podczas aktualizacji.

  5. Jeśli chcesz mieć pewność, że menu Filtr będzie usuwało elementy, które straciły swoją ważność, po przeprowadzeniu operacji odświeżania, kliknij kartę Dane i w polu Liczba elementów do zachowania w każdym polu wybierz opcję Brak.

Zmienianie ustawień pola   

  1. Kliknij tabelę przestawną.

  2. Do uwzględnienia nowych elementów w tabeli przestawnej przy użyciu zastosowanego filtru dla każdego pola, kliknij prawym przyciskiem myszy komórkę, w menu skrótów kliknij polecenie Ustawienia pola, kliknij kartę sumy częściowe i filtry, a następnie w sekcji Filtry, wybierz pozycję Dołącz nowe elementy do filtru ręcznego pole wyboru.

Początek strony

Układ tabeli przestawnej jako tabelę dwuwymiarowych

Aby zmienić układ tabeli przestawnej jako dwuwymiarowych tabeli, wykonaj następujące czynności:

  1. Kliknij tabelę przestawną.

  2. Na karcie Projektowanie w grupie Układ kliknij przycisk Sumy częściowe, a następnie kliknij opcję Nie pokazuj sum częściowych.

  3. Na karcie Projektowanie w grupie Układ kliknij przycisk Sumy końcowe, a następnie kliknij opcję Wyłącz dla wierszy i kolumn.

  4. Na karcie Projektowanie w grupie Układ kliknij przycisk Układ raportu, a następnie kliknij opcję Pokaż w formie tabelarycznej.

  5. Na karcie Opcje w grupie Pokazywanie/ukrywanie kliknij przycisk Nagłówki pól.

Początek strony

Dostosowywanie projektu tabeli przestawnej

Wbudowane style tabeli przestawnej i opcje stylu są przeznaczone dla danych wielowymiarowych nie dwuwymiarowych tabelę. Gdy Spłaszcz raport do tabeli dwuwymiarowych tych stylów Nie wyświetlaj obramowania komórek, a Wiersze naprzemienne i Kolumny naprzemienne pola wyboru w grupie Opcje stylu tabeli przestawnej, na karcie Projektowanie nie wpływają na formatowanie komórek. Jednak styl tabeli przestawnej można dostosować tak, aby każdej komórki ma obramowania komórek i tabeli przestawnej korzysta z formatowania warunkowego do wyświetlenia naprzemienne wiersze lub kolumny.

Dostosowywanie stylu tabeli przestawnej   

  1. Kliknij tabelę przestawną.

  2. Na karcie Projektowanie w grupie Style tabeli przestawnej zaznacz odpowiedni styl, a następnie wykonaj poniższe czynności:

    1. Kliknij prawym przyciskiem myszy widoczny styl, przewiń okno galerii lub kliknij przycisk Więcej u dołu paska przewijania, aby zobaczyć wszystkie dostępne style.

    2. Kliknij polecenie Duplikuj.

      Zostanie otwarte okno dialogowe Modyfikowanie szybkiego stylu tabeli przestawnej.

    3. Opcjonalnie wprowadź nową nazwę w polu Nazwa.

    4. W polu Element tabeli wybierz opcję Cała tabela, a następnie kliknij przycisk Formatuj.

      Zostanie wyświetlone okno dialogowe Formatowanie komórek.

    5. Kliknij kartę Obramowanie, a następnie określ obramowanie komórek.

    6. Opcjonalnie po kliknięciu kart Wypełnienie i Czcionka możesz wprowadzić inne zmiany.

    7. Kliknij dwa razy przycisk OK.

    8. Kliknij przycisk Więcej u dołu paska przewijania, a następnie w kategorii Niestandardowe kliknij właśnie utworzony styl tabeli przestawnej.

Wyświetlanie naprzemiennych wierszy i kolumn przy użyciu formatowania warunkowego   

  1. Zaznacz wszystkie kolumny w tabeli przestawnej.

  2. Na karcie Narzędzia główne w grupie Style kliknij strzałkę obok przycisku Formatowanie warunkowe, a następnie kliknij polecenie Zarządzaj regułami.

    Obraz Wstążki programu Excel

    Zostanie wyświetlone okno dialogowe Menedżer reguł formatowania warunkowego.

  3. Aby dodać format warunkowy, kliknij przycisk Nowa reguła.

    Zostanie wyświetlone okno dialogowe Nowa reguła formatowania.

  4. W obszarze Wybierz typ reguły kliknij opcję Użyj formuły do określenia komórek, które należy sformatować.

    1. W obszarze Edytuj opis reguły, w polu Formatuj wartości, dla których następująca formuła jest prawdziwa wprowadź formułę.

    2. Wykonaj jedną z następujących czynności: 

      • Aby wyświetlić wiersze naprzemiennie, wprowadź następującą formułę:

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A))

  • Aby wyświetlić kolumny naprzemiennie, wprowadź następującą formułę:

=AND(MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  • Aby wyświetlić wiersze i kolumny naprzemiennie, wprowadź następującą formułę:

=AND(MOD(ROW(),2)=1,ROW()<=COUNTA(A:A),MOD(COLUMN(),2)=1,COLUMN()<=COUNTA(1:1))

  1. Kliknij przycisk Formatuj, aby wyświetlić okno dialogowe Formatowanie komórek.

  2. Wybierz format liczby, czcionki, obramowania lub wypełnienia, jaki ma zostać zastosowany, gdy wartość komórki będzie spełniać określony warunek, a następnie kliknij przycisk OK.

    Można wybrać więcej niż jeden format. Wybrane formaty są wyświetlane w polu Podgląd.

Początek strony

Publikowanie skoroszytu w usługach programu Excel

  1. Kliknij przycisk Microsoft Office Obraz przycisku pakietu Office , kliknij strzałkę obok przycisku Publikuj, a następnie kliknij polecenie Usługi programu Excel w grupie Rozpowszechnij dokument do innych osób.

  2. W polu Nazwa pliku wprowadź ścieżkę do serwera, akceptując przy tym sugerowaną nazwę skoroszytu lub wprowadzając nową.

    Na komputerze z uruchomionym systemem Windows Vista    

    • Na pasku adresu wybierz lokalizację sieciową, która jest dostępna dla odpowiednich użytkowników, a następnie kliknij przycisk Zapisz.

      Na komputerze z uruchomionym systemem Microsoft Windows XP    

    • W polu Zapisz w wybierz lokalizację sieciową, która jest dostępna dla odpowiednich użytkowników, a następnie kliknij przycisk Zapisz.

      Na przykład wpisz http://witryny/serwera/nazwy pliku

      Uwaga: Program Excel może opublikować na serwerze skoroszyt tylko w następujących formatach programu Microsoft Office Excel 2007: format plików oparty na języku XML (xlsx) lub binarny format plików programu Office Excel 2007 (xlsb).

  3. Kliknij przycisk OK.

  4. Aby sprawdzić, czy widoczne obszary skoroszytu są poprawnie wyświetlane w przeglądarce, zaznacz pole wyboru Otwórz ten skoroszyt w mojej przeglądarce po zapisaniu pliku.

  5. Kliknij przycisk Zapisz.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×