Używanie funkcji i funkcji zagnieżdżonych w formułach programu Excel

Funkcje to wstępnie zdefiniowane formuły wykonujące obliczenia z wykorzystaniem określonych wartości, zwanych argumentami, w określonej kolejności, czyli strukturze. Funkcje mogą służyć do wykonywania prostych lub złożonych obliczeń. Wszystkie funkcje programu Excel można znaleźć na karcie Formuły na Wstążce:

Karta Formuły na wstążce w programie Excel
  • Składnia funkcji programu Excel

    Poniższy przykład, w którym użyto funkcji ZAOKR do zaokrąglenia liczby w komórce A10, ilustruje składnię funkcji.

    Struktura funkcji

    1. Struktura. Struktura funkcji zaczyna się od znaku równości (=), po którym następuje nazwa funkcji, nawias otwierający, argumenty funkcji oddzielone średnikami i nawias zamykający.

    2. Nazwa funkcji. Aby wyświetlić listę dostępnych funkcji, kliknij komórkę i naciśnij klawisze SHIFT+F3, co spowoduje otwarcie okna dialogowego Wstawianie funkcji.

    Formuły programu Excel — okno dialogowe Wstawianie funkcji

    3. Argumenty. Mogą to być liczby, tekst, wartości logiczne, takie jak PRAWDA lub FAŁSZ, tablice, wartości błędów (takie jak #N/D!) lub odwołania do komórek. Zdefiniowany argument musi gwarantować uzyskanie prawidłowej wartości. Argumentami mogą także być stałe, formuły lub inne funkcje.

    4. Etykietka argumentu. Etykietka ze składnią i argumentami pojawia się podczas wprowadzania funkcji. Pojawia się na przykład po wpisaniu tekstu =ZAOKR(. Etykietki są wyświetlane tylko w przypadku funkcji wbudowanych.

    Uwaga: Nie trzeba wpisywać funkcji wersalikami, na przykład =ZAOKR, ponieważ program Excel automatycznie zmieni litery nazwy funkcji na wielkie po naciśnięciu klawisza Enter. Jeśli błędnie wpiszesz nazwę funkcji, na przykład =SUME(A1:A10) zamiast =SUMA(A1:A10), program Excel zwróci błąd #NAZWA?.

  • Wprowadzanie funkcji programu Excel

    Podczas tworzenia formuły zawierającej funkcję można użyć okna dialogowego Wstawianie funkcji, które ułatwia wprowadzanie funkcji arkusza. Po wybraniu funkcji w oknie dialogowym Wstawianie funkcji program Excel uruchomi kreatora funkcji, który wyświetla nazwę funkcji i każdy z jej argumentów, opis funkcji i argumentów, bieżący wynik funkcji i bieżący wynik całej formuły.

    Kreator funkcji programu Excel

    Funkcja Autouzupełnianie formuł upraszcza tworzenie i edytowanie formuł, a także pozwala ograniczyć do minimum występujące przy tym błędy pisowni i składni. Po wpisaniu znaku równości (=) i pierwszych liter funkcji program Excel wyświetli dynamiczną listę rozwijaną zawierającą prawidłowe funkcje, argumenty i nazwy odpowiadające wpisanym literom. Możesz wtedy wybrać funkcję z listy rozwijanej, a program Excel ją wprowadzi.

    Autouzupełnianie formuł w programie Excel

  • Zagnieżdżanie funkcji programu Excel

    W niektórych przypadkach może zajść potrzeba użycia funkcji jako jednego z argumentów innej funkcji. Na przykład następująca formuła korzysta z zagnieżdżonej funkcji ŚREDNIA i porównuje wynik z wartością 50.

    Funkcje zagnieżdżone

    1. Funkcje ŚREDNIA i SUMA są zagnieżdżone w funkcji JEŻELI.

    Prawidłowość zwracanych wartości    Jeśli jako argument zostaje użyta funkcja zagnieżdżona, musi ona zwracać wartość tego samego typu co typ używany przez ten argument. Jeśli na przykład argument zwraca wartość PRAWDA lub FAŁSZ, to zagnieżdżona funkcja musi zwrócić wartość PRAWDA lub FAŁSZ. Jeśli tak się nie dzieje, program Excel wyświetla wartość błędu #ARG!.

    Ograniczenia poziomu zagnieżdżania    Formuła może zawierać najwyżej siedem poziomów funkcji zagnieżdżonych. Gdy jedna funkcja (nazwijmy ją Funkcja B) jest używana jako argument w innej funkcji (Funkcji A), Funkcja B działa jako funkcja drugiego poziomu. Na przykład funkcja ŚREDNIA i funkcja SUMA są funkcjami drugiego poziomu, jeśli są używane jako argumenty funkcji JEŻELI. Funkcja zagnieżdżona w funkcji ŚREDNIA jest wtedy funkcją trzeciego poziomu i tak dalej.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×