Tworzenie tabeli i dodawanie pól

Tworzenie tabeli i dodawanie pól

Po utworzeniu bazy danych programu Access dane są przechowywane w tabelach — tematycznych listach zawierających wiersze i kolumny. Możesz na przykład utworzyć tabelę Kontakty, aby zapisać listę nazwisk, adresów i numerów telefonów, lub tabelę Produkty w celu przechowywania informacji o produktach. W tym artykule wyjaśniono, jak utworzyć tabelę, dodać pola do tabeli i ustawić klucz podstawowy tabeli. Wyjaśniono również sposób określania właściwości tabeli i pól.

Przed utworzeniem tabel i dodawaniem pól upewnij się, że rozumiesz podstawowe pojęcia. Aby uzyskać więcej informacji, zobacz Wprowadzenie do tabel.

W tym artykule

Tworzenie tabeli
Tworzenie w nowej bazie danych
Tworzenie w istniejącej bazie danych
Importowanie lub łączenie
— — Używanie danych zewnętrznych
— — Używanie witryny programu SharePoint
— — Używanie usługi internetowej
Ustawianie właściwości tabeli
Zapisywanie tabeli

Ustawianie klucza podstawowego
Określanie używanych pól
Ustawianie lub zmienianie klucza podstawowego
Usuwanie klucza podstawowego

Przenoszenie pola

Dodawanie pól
Dodawanie przez wprowadzenie danych
Dodawanie za pomocą szablonu pola
Ustawianie właściwości pola
Ustawianie w widoku arkusza danych
— — Zmienianie nazwy pola
— — Zmienianie typu danych
— — Zmienianie formatu
— — Ustawianie innych właściwości
Ustawianie właściwości w widoku projektu
— — Zmienianie typu danych
— — Ustawianie innych właściwości

Tworzenie tabeli

Prosta baza danych, zawierająca na przykład listę kontaktów, może zawierać tylko jedną tabelę. Jednak wiele baz danych zawiera większą liczbę tabel. Podczas tworzenia nowej bazy danych na komputerze jest tworzony nowy plik, działający jako kontener dla wszystkich obiektów w bazie danych, w tym także dla tabel.

Możesz utworzyć tabelę, tworząc nową bazę danych, wstawiając tabelę do istniejącej bazy danych, a także importując tabelę albo tworząc link do tabeli z innego źródła danych — skoroszytu programu Microsoft Excel, dokumentu programu Microsoft Word, pliku tekstowego, czy też innej bazy danych. Do utworzonej nowej, pustej bazy danych jest automatycznie wstawiana nowa, pusta tabela. Następnie można wprowadzić dane, aby rozpocząć definiowanie pól.

Początek strony

Tworzenie nowej tabeli w nowej bazie danych

  1. Kliknij pozycję Plik > Nowy, a następnie wybierz pozycję Pusta baza danych dla komputerów stacjonarnych.

  2. W polu Nazwa pliku wpisz nazwę pliku nowej bazy danych.

  3. Aby przejść do innej lokalizacji i zapisać bazę danych, kliknij ikonę folderu.

  4. Kliknij przycisk Utwórz.

    Zostanie otwarta nowa baza danych, w której zostanie utworzona nowa tabela o nazwie Tabela1, wyświetlona w widoku arkusza danych.

Początek strony

Tworzenie tabeli w istniejącej bazie danych

  1. Kliknij pozycję Plik > Otwórz, a następnie kliknij bazę danych, o ile znajduje się na liście Ostatnio używane. W innym przypadku możesz użyć jednej z opcji przeglądania, aby zlokalizować odpowiednią bazę danych.

  2. W oknie dialogowym Otwieranie zaznacz bazę danych, którą chcesz otworzyć, a następnie kliknij przycisk Otwórz.

  3. Na karcie Tworzenie w grupie Tabele kliknij pozycję Tabela.

    Nowa tabela zostanie wstawiona w bazie danych i otwarta w widoku arkusza danych.

Początek strony

Importowanie lub łączenie w celu utworzenia tabeli

Tabelę można utworzyć przez zaimportowanie danych przechowywanych w innym miejscu lub utworzenie do nich linku. Dotyczy to danych znajdujących się między innymi w arkuszu programu Excel, na liście programu SharePoint, w pliku XML, w innej bazie danych programu Access lub w folderze programu Microsoft Outlook.

Podczas importowania danych jest tworzona ich kopia w nowej tabeli w bieżącej bazie danych. Kolejne zmiany danych źródłowych nie będą miały wpływu na zaimportowane dane, a zmiany dotyczące zaimportowanych danych nie będą miały wpływu na dane źródłowe. Po nawiązaniu połączenia ze źródłem danych i zaimportowaniu danych można z nich korzystać, nie mając połączenia ze źródłem. Projekt zaimportowanej tabeli można zmienić.

Utworzenie łącza z danymi powoduje, że w bieżącej bazie danych jest tworzona tabela połączona, reprezentująca aktualizowane na bieżąco łącze z informacjami przechowywanymi w innym miejscu. Zmiana danych w tabeli połączonej powoduje ich zmianę w źródle. Każda zmiana danych w źródle jest widoczna w tabeli połączonej. W przypadku korzystania z tabeli połączonej użytkownik musi mieć możliwość nawiązania połączenia ze źródłem danych. Projektu tabeli połączonej nie można zmienić.

Uwaga: Przy użyciu tabeli połączonej nie można edytować danych w arkuszu programu Excel. Można natomiast zaimportować dane źródłowe do bazy danych programu Access, a następnie utworzyć łącze do niej z poziomu programu Excel.

Początek strony

Tworzenie nowej tabeli przez zaimportowanie lub połączenie danych zewnętrznych

  1. Kliknij pozycję Plik > Otwórz.

  2. W oknie dialogowym Otwieranie wybierz i otwórz bazę danych, w której chcesz utworzyć nową tabelę.

  3. Na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij jedno z dostępnych źródeł danych. 

    Obraz wstążki programu Access

  4. Postępuj zgodnie z instrukcjami w oknach dialogowych wyświetlanych na poszczególnych etapach.

    Program Access utworzy nową tabelę i wyświetli ją w okienku nawigacji.

Początek strony

Tworzenie tabeli przy użyciu witryny programu SharePoint

W bazie danych można utworzyć tabelę w celu zaimportowania danych z listy programu SharePoint lub utworzenia linku do takiej listy. Można również utworzyć nową listę programu SharePoint, korzystając ze wstępnie zdefiniowanego szablonu. W programie Access są dostępne takie wstępnie zdefiniowane szablony, jak Kontakty, Zadania, Problemy i Zdarzenia.

  1. Kliknij pozycję Plik > Otwórz.

  2. W oknie dialogowym Otwieranie zaznacz bazę danych, w której chcesz utworzyć nową tabelę, a następnie kliknij przycisk Otwórz.

  3. Na karcie Tworzenie w grupie Tabele kliknij pozycję Listy SharePoint.

  4. Wykonaj jedną z następujących czynności:

    Tworzenie listy programu SharePoint na podstawie szablonu

    1. Kliknij pozycję Kontakty, Zadania, Problemy lub Wydarzenia.

    2. W oknie dialogowym Tworzenie nowej listy wpisz adres URL witryny programu SharePoint, w której chcesz utworzyć listę.

    3. Wprowadź nazwę nowej listy oraz jej opis w polach Określ nazwę nowej listy i Opis.

    4. Aby po utworzeniu połączonej tabeli otworzyć ją, zaznacz pole wyboru Otwórz listę po zakończeniu (domyślnie zaznaczone).

    Tworzenie listy niestandardowej

    1. Kliknij pozycję Niestandardowa.

    2. W oknie dialogowym Tworzenie nowej listy wpisz adres URL witryny programu SharePoint, w której chcesz utworzyć listę.

    3. Wprowadź nazwę nowej listy oraz jej opis w polach Określ nazwę nowej listy i Opis.

    4. Aby po utworzeniu połączonej tabeli otworzyć ją, zaznacz pole wyboru Otwórz listę po zakończeniu (domyślnie zaznaczone).

    Importowanie danych z istniejącej listy

    1. Kliknij pozycję Istniejąca lista programu SharePoint.

    2. W oknie dialogowym Pobieranie danych zewnętrznych wpisz adres URL witryny programu SharePoint zawierającej dane, które chcesz zaimportować.

    3. Kliknij pozycję Importuj dane źródłowe do nowej tabeli w bieżącej bazie danych, a następnie kliknij przycisk Dalej.

    4. Zaznacz pole wyboru obok każdej listy programu SharePoint, którą chcesz zaimportować.

    Łączenie z listą

    1. Kliknij pozycję Istniejąca lista programu SharePoint.

    2. W oknie dialogowym Pobieranie danych zewnętrznych — witryna programu SharePoint wpisz adres URL witryny programu SharePoint zawierającej listę, do której chcesz utworzyć łącze.

    3. Kliknij pozycję Połącz ze źródłem danych, tworząc tabelę połączoną, a następnie kliknij przycisk Dalej.

    4. Zaznacz pole wyboru obok każdej listy programu SharePoint, do której chcesz utworzyć łącze.

Początek strony

Tworzenie tabeli przy użyciu usługi sieci Web

W bazie danych można utworzyć tabelę połączoną z danymi w witrynie sieci Web udostępniającej interfejs usługi sieci Web. Tabele usług sieci Web są dostępne tylko do odczytu.

  1. Na karcie Dane zewnętrzne w grupie Importowanie i łączenie kliknij pozycję Więcej, a następnie kliknij pozycjęUsługi danych.

  2. Jeśli połączenie, którego chcesz użyć, zostało już zainstalowane, przejdź do kroku 5. W przeciwnym razie przejdź do następnego kroku.

  3. Kliknij pozycję Zainstaluj nowe połączenie.

  4. Zaznacz plik połączenia, którego chcesz użyć, a następnie kliknij przycisk OK.

  5. W oknie dialogowym Tworzenie łącza do danych usługi sieci Web rozwiń połączenie, którego chcesz użyć.

  6. Zaznacz tabelę, do której chcesz utworzyć łącze. Program Access wyświetli pola po prawej stronie okna dialogowego.

  7. Opcjonalnie można wpisać nazwę połączonej tabeli w polu Określ nazwę łącza. Program Access użyje tej nazwy w okienku nawigacji.

  8. Kliknij przycisk OK. Program Access utworzy tabelę połączoną.

Początek strony

Ustawianie właściwości tabeli

Oprócz właściwości pól możesz ustawić także właściwości stosowane do całej tabeli lub do całych rekordów.

  1. Zaznacz tabelę, której właściwości chcesz ustawić.

  2. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  3. Na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij przycisk Arkusz właściwości.

    Grupa Pokazywanie/ukrywanie na karcie Projektowanie w programie Access

    Zostanie wyświetlony arkusz właściwości tabeli.

  4. W arkuszu właściwości kliknij kartę Ogólne.

  5. Kliknij pole po lewej stronie właściwości, którą chcesz ustawić, a następnie wprowadź ustawienie tej właściwości.

    Pamiętaj o konieczności naciśnięcia klawiszy CTRL+S, aby zapisać zmiany.

    Właściwość tabeli

    Zastosowanie

    Wyświetl widoki w witrynie programu SharePoint

    Określenie, czy widoki utworzone na podstawie tabeli mogą być wyświetlane w witrynie programu SharePoint.

    Uwaga: Skutki użycia tego ustawienia zależą od ustawienia właściwości bazy danych Wyświetl wszystkie widoki w witrynie programu SharePoint.

    Rozwinięty podarkusz danych

    Rozwijanie wszystkich podarkuszy danych po otwarciu tabeli.

    Wysokość podarkusza danych

    Wykonaj jedną z następujących czynności:

    • Jeśli chcesz, aby okno podarkusza danych było rozwijane w celu wyświetlenia wszystkich wierszy, pozostaw dla tej właściwości ustawienie 0 cm.

    • Jeśli chcesz sterować wysokością podarkusza danych, wprowadź żądaną wysokość w centymetrach.

    Orientacja

    Ustawienie orientacji widoku zgodnie ze sposobem czytania używanego języka — od lewej do prawej lub od prawej do lewej.

    Opis

    Podanie opisu tabeli. Ten opis będzie wyświetlany w etykietkach narzędzi danej tabeli.

    Widok domyślny

    Ustawienie domyślnego widoku używanego po otwarciu tabeli (widok Arkusz danych, Tabela przestawna lub Wykres przestawny). Opcje tabeli przestawnej i wykresu przestawnego zostały usunięte z programu Access począwszy od wersji 2013 tego programu.

    Reguła poprawności

    Wprowadzenie wyrażenia, które musi być spełnione przy dodawaniu lub zmienianiu rekordu.

    Tekst reguły sprawdzania poprawności

    Wprowadzenie tekstu komunikatu wyświetlanego w sytuacji, gdy rekord jest niezgodny z wyrażeniem we właściwości Reguła poprawności.

    Filtr

    Zdefiniowanie kryteriów służących do wyświetlania tylko dopasowanych wierszy w widoku arkusza danych.

    Uporządkuj według

    Określenie domyślnego porządku sortowania wierszy w widoku arkusza danych przez wybranie co najmniej jednego pola.

    Nazwa podarkusza danych

    Określenie, czy podarkusz danych powinien być wyświetlany w widoku arkusza danych, a jeśli tak, określenie, z której tabeli lub kwerendy mają pochodzić wiersze podarkusza.

    Podrzędne pola łączące

    Określenie listy pól w tabeli lub kwerendzie, które są używane w podarkuszu danych i są zgodne z właściwością Nadrzędne pola łączące określoną dla danej tabeli.

    Nadrzędne pola łączące

    Określenie listy pól w tabeli, które są zgodne z właściwością Podrzędne pola łączące określoną dla danej tabeli.

    Filtruj przy ładowaniu

    Automatyczne stosowanie kryteriów filtrowania określonych we właściwości Filtr po otwarciu tabeli w widoku arkusza danych (przez ustawienie tej właściwości na wartość Tak).

    Porządkuj przy ładowaniu

    Automatyczne stosowanie kryteriów sortowania określonych we właściwości Uporządkuj według po otwarciu tabeli w widoku arkusza danych (przez ustawienie tej właściwości na wartość Tak).

    Porada    Aby uzyskać więcej miejsca na wprowadzanie lub edytowanie ustawienia w polu właściwości, należy nacisnąć klawisze SHIFT+F2 w celu wyświetlenia okna Powiększenie. Jeśli we właściwości Reguła poprawności jest ustawiane wyrażenie i jest potrzebna pomoc przy jego konstruowaniu, należy kliknąć przycisk Przycisk Konstruktor obok pola właściwości RegułaPoprawności w celu wyświetlenia Konstruktora wyrażeń.

Początek strony

Zapisywanie tabeli

Po utworzeniu lub zmodyfikowaniu tabeli należy zapisać jej projekt. Podczas zapisywania tabeli po raz pierwszy nadaj jej nazwę opisującą zawarte w niej dane. Możesz użyć maksymalnie 64 znaków alfanumerycznych ze spacjami. Możesz na przykład nazwać tabelę Klienci, Katalog części lub Produkty.

Program Access zapewnia dużą elastyczność, jeśli chodzi o nazewnictwo tabel, jednak istnieją pewne ograniczenia, o których należy pamiętać. Maksymalna długość nazwy tabeli to 64 znaki. Może ona zawierać dowolne połączenie liter, liczb, spacji i znaków specjalnych za wyjątkiem kropki (.), wykrzyknika (!), nawiasów kwadratowych ([]), spacji początkowej, początkowego znaku równości (=) i znaków niedrukowanych, takich jak powrót karetki. Nazwa nie może też zawierać żadnego z następujących znaków:` / \ : ; * ? " ' < > | # <TAB> { } % ~ &.

Porada: Warto wybrać konwencję nazewnictwa obiektów w bazie danych i konsekwentnie ją stosować.

  1. Wybierz pozycję Plik > Zapisz lub naciśnij klawisze CTRL+S.

  2. Jeśli zapisujesz tabelę po raz pierwszy, wpisz nazwę tabeli, a następnie kliknij przycisk OK.

Początek strony

Ustawianie klucza podstawowego

O ile nie ma konkretnych przesłanek, aby tego nie robić, należy określić klucz podstawowy tabeli. W programie Access klucz podstawowy jest automatycznie indeksowany, co może poprawić wydajność bazy danych. Program Access sprawdza również, czy każdy rekord zawiera wartość w polu klucza podstawowego i czy ta wartość jest unikatowa. Wartości te muszą być unikatowe, ponieważ w przeciwnym razie nie będzie możliwe prawidłowe rozróżnienie poszczególnych wierszy.

Podczas tworzenia nowej tabeli w widoku arkusza danych w programie Access jest automatycznie tworzony klucz podstawowy z przypisaną nazwą pola Identyfikator i typem danych Autonumerowanie.

W widoku projektu możesz zmienić lub usunąć klucz podstawowy, a także ustawić klucz podstawowy tabeli, która jeszcze go nie ma.

Początek strony

Określanie pól używanych jako kluczy podstawowych

W niektórych przypadkach dane, których chcesz użyć jako klucza podstawowego, są już dostępne. Na przykład możesz mieć już numery identyfikacyjne swoich pracowników. Tworząc tabelę do przechowywania informacji o pracownikach, możesz wybrać istniejące identyfikatory użytkowników jako klucz podstawowy tabeli. Być może jednak identyfikator pracownika jest unikatowy wyłącznie w kombinacji z identyfikatorem działu, w związku z czym klucz podstawowy musi zawierać oba te pola. Potencjalny klucz podstawowy powinien spełniać następujące warunki:

  • Każdy rekord zawiera unikatową wartość w tym polu lub w tej kombinacji pól.

  • Dane pole lub dana kombinacja pól zawsze zawiera wartości — nie występują pola puste ani wartości null.

  • Wartości nie zmieniają się.

Jeśli nie zostały jeszcze wprowadzone dane odpowiednie do użycia jako klucz podstawowy, możesz utworzyć w tym celu nowe pole. Tworząc nowe pole, które będzie używane jako klucz podstawowy, ustaw typ danych Autonumerowanie, aby mieć pewność, że pole to będzie spełniało trzy warunki wymienione powyżej.

Początek strony

Ustawianie lub zmienianie klucza podstawowego

  1. Zaznacz tabelę, w której chcesz ustawić lub zmienić klucz podstawowy.

  2. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  3. W siatce projektu tabeli zaznacz pole lub pola, których chcesz użyć jako klucza podstawowego.

    Aby zaznaczyć jedno pole, kliknij selektor wiersza odpowiedniego pola.

    Aby zaznaczyć więcej niż jedno pole, naciśnij i przytrzymaj klawisz CTRL, a następnie kliknij selektory wiersza poszczególnych pól.

  4. Na karcie Projektowanie w grupie Narzędzia kliknij przycisk Klucz podstawowy.

    Grupa Narzędzia na karcie Projektowanie

    Po lewej stronie pól określanych jako klucz podstawowy jest wyświetlany znacznik klucza.

Początek strony

Usuwanie klucza podstawowego

  1. Zaznacz tabelę, której klucz podstawowy chcesz usunąć.

  2. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok projektu.

  3. Kliknij selektor wiersza bieżącego klucza podstawowego. Jeśli klucz podstawowy obejmuje wiele pól, przytrzymaj naciśnięty klawisz CTRL, a następnie kliknij selektory wierszy poszczególnych pól.

  4. Na karcie Projektowanie w grupie Narzędzia kliknij przycisk Klucz podstawowy.

    Grupa Narzędzia na karcie Projektowanie

    Wskaźnik klucza zostanie usunięty z pól, które zostały wcześniej określone jako klucz podstawowy.

Podczas zapisywania nowej tabeli bez uprzedniego ustawienia klucza podstawowego w programie Access zostanie wyświetlony monit o utworzenie nowego pola klucza podstawowego. Jeśli klikniesz przycisk Tak, w programie Access zostanie utworzone pole Identyfikator z typem danych Autonumerowanie w celu zapewnienia unikatowej wartości w każdym rekordzie. Jeśli tabela zawiera już pole z typem danych Autonumerowanie, to pole zostanie użyte jako klucz podstawowy. Jeśli klikniesz przycisk Nie, w programie Access nie zostanie utworzone nowe pole i klucz podstawowy nie zostanie ustawiony.

Początek strony

Dodawanie pól

Jeśli zachodzi potrzeba przechowywania nowych danych związanych z zagadnieniem, dla którego już istnieje tabela w programie Access, warto rozważyć dodanie pola do tabeli. Przypuśćmy na przykład, że istnieje tabela, w której jest przechowywane imię, nazwisko, adres e-mail, numer telefonu i adres wysyłkowy każdego klienta. Aby rozpocząć śledzenie preferowanych metod komunikacji poszczególnych klientów, można dodać pole, w którym te dane będą przechowywane.

Każdy element danych, który ma być śledzony, jest przechowywany w polu. Na przykład w tabeli kontaktów można utworzyć pola Nazwisko, Imię, Numer telefonu i Adres. W tabeli produktów można utworzyć pola Nazwa produktu, Identyfikator produktu i Cena.

Każde pole ma określone cechy podstawowe, takie jak nazwa unikatowo identyfikująca pole w tabeli, typ danych definiujący specyfikę danych, operacje, które można wykonywać na danych, oraz ilość miejsca do magazynowania, jaką należy przeznaczyć na każdą wartość.

Przed utworzeniem pól warto rozdzielić dane na najmniejsze użyteczne elementy. O wiele łatwiej jest później połączyć te dane, niż je rozdzielać. Na przykład zamiast pola Imię i nazwisko warto rozważyć utworzenie osobnych pól dla nazwiska i dla imienia. Dzięki temu będzie można łatwo przeprowadzać wyszukiwanie lub sortowanie według pola Imię, według pola Nazwisko lub według obu tych pól jednocześnie. Jeśli w przypadku określonego elementu danych są planowane operacje raportowania, sortowania, wyszukiwania lub obliczania, należy umieścić ten element w osobnym polu.

Po utworzeniu pola można również ustawić właściwości pola w celu sterowania jego wyglądem i zachowaniem. Na przykład właściwość Format definiuje sposób wyświetlania danych w arkuszu danych lub w formularzu zawierającym określone pole.

Początek strony

Dodawanie pola przez wprowadzenie danych

Po utworzeniu nowej tabeli lub otwarciu istniejącej tabeli w widoku arkusza danych można dodać pole do tabeli, wprowadzając dane w kolumnie Dodaj nowe pole w arkuszu danych (1). Program Access automatycznie przypisuje typ danych do pola na podstawie wprowadzonych wartości. Jeśli z wprowadzonych danych nie wynika żaden inny typ danych, program Access ustawia typ danych Tekst, ale możesz zmienić typ danych.

Arkusz danych w programie Access z kolumną Dodaj nowe pole

Aby wprowadzić dane w kolumnie Dodaj nowe pole:

  1. Utwórz lub otwórz tabelę w widoku arkusza danych, klikając prawym przyciskiem myszy odpowiednią tabelę w okienku nawigacji, a następnie klikając w menu skrótów pozycję Widok arkusza danych.

  2. W kolumnie Dodaj nowe pole wprowadź nazwę pola, które chcesz utworzyć.

    Użyj nazwy opisowej, aby można było łatwiej zidentyfikować to pole.

  3. Wprowadź dane w nowym polu.

Początek strony

Dodawanie pola za pomocą szablonu pola

Czasem łatwiej jest wybrać pole odpowiednie do potrzeb z listy wstępnie zdefiniowanych pól, niż tworzyć je ręcznie. Możesz użyć listy Więcej pól, aby wybrać z listy szablonów pól. Szablon pola to wstępnie zdefiniowany zbiór cech i właściwości opisujących pole. Definicja szablonu pola obejmuje jego nazwę, typ danych, ustawienie właściwości Format i inne właściwości pola.

  1. Na karcie Narzędzia główne w grupie Widoki kliknij pozycję Widok, a następnie kliknij pozycję Widok arkusza danych.

  2. Na karcie Pola w grupie Dodawanie i usuwanie kliknij pozycję Więcej pól.

    Zrzut ekranu grupy Dodawanie i usuwanie na karcie wstążki Pola.

  3. Z listy Więcej pól wybierz pole, aby wstawić nową kolumnę. Program Access umieści pole z prawej strony kolumny, w której jest obecnie umieszczony kursor. Jeśli wybierzesz jedną z opcji pola pod nagłówkiem Szybki start, na przykład Adres, program Access utworzy w tabeli kilka pól zawierających różne składniki adresu.

Początek strony

Ustawianie właściwości pola

Po utworzeniu pola można ustawić właściwości pola w celu sterowania jego wyglądem i zachowaniem.

Ustawiając właściwości pola, można na przykład:

  • sterować wyglądem danych w polu,

  • zapobiec wprowadzaniu niepoprawnych danych w polu,

  • określić wartości domyślne pola,

  • przyspieszyć wyszukiwanie i sortowanie w polu.

Niektóre z dostępnych właściwości można ustawić podczas pracy w widoku arkusza danych. Aby jednak uzyskać dostęp do pełnej listy właściwości pola i móc je ustawiać, należy korzystać z widoku projektu.

Od typu danych pola zależy, jakie właściwości można ustawiać.

Początek strony

Ustawianie właściwości pola w widoku arkusza danych

Podczas pracy w widoku arkusza danych można zmienić nazwę pola, typ danych pola, właściwość Format i kilka innych właściwości pola.

  1. W okienku nawigacji kliknij prawym przyciskiem myszy tabelę, którą chcesz otworzyć.

  2. W menu skrótów kliknij polecenie Widok arkusza danych.

Początek strony

Zmienianie nazwy pola

Po dodaniu pola przez wprowadzenie danych w widoku arkusza danych program Access automatycznie przypisuje temu polu nazwę ogólną. Program Access przypisuje nazwę Pole1 pierwszemu nowemu polu, nazwę Pole2 — drugiemu nowemu polu i tak dalej. Domyślnie nazwa pola jest używana jako etykieta podczas wyświetlania pola, między innymi w nagłówku kolumny w arkuszu danych. Zmiana nazw pól na bardziej opisowe ułatwia korzystanie z nich podczas wyświetlania lub edytowania rekordów.

  1. Kliknij prawym przyciskiem myszy nagłówek pola, którego nazwę chcesz zmienić (na przykład Pole1).

  2. W menu skrótów kliknij polecenie Zmień nazwę pola.

  3. Wprowadź nową nazwę w nagłówku pola.

    Nazwy pól mogą zawierać maksymalnie 64 znaki (litery oraz liczby) z uwzględnieniem spacji.

Początek strony

Zmienianie typu danych pola

Po utworzeniu pola przez wprowadzenie danych w widoku arkusza danych program Access sprawdza te dane w celu określenia odpowiedniego typu danych dla pola. Jeśli na przykład zostanie wprowadzony ciąg 2017-01-01, program Access rozpozna te dane jako datę i ustawi dla pola typ danych Data/Godzina. Jeśli program Access nie może jednoznacznie określić typu danych, domyślnie ustawiany jest typ danych Tekst (Krótki tekst w przypadku programu Access 2016).

Typ danych pola określa, jakie inne właściwości pola można ustawiać. Na przykład właściwość Tylko dołącz można ustawić jedynie dla pól o typie danych Hiperłącze lub Nota (Długi tekst w przypadku programu Access 2016).

Czasami jest konieczna ręczna zmiana typu danych pola. Załóżmy, że numery pokoi przypominają daty, na przykład 10-2017. Jeśli w nowym polu w widoku arkusza danych zostanie wprowadzony ciąg 10-2017, funkcja automatycznego wykrywania typu danych wybierze dla tego pola typ danych Data/Godzina. Ponieważ numery pokoi są etykietami, a nie datami, powinny mieć typ danych Tekst. Poniższa procedura umożliwia zmianę typu danych pola.

  1. Na wstążce kliknij kartę Pola.

  2. Na liście Typ danych w grupie Formatowanie wybierz odpowiedni typ danych.

    Obraz wstążki programu Access przedstawiający grupę Typ i formatowanie danych

    Jakie typy danych są dostępne?

    Zobacz Typy danych w bazach danych programu Access dla komputerów stacjonarnych, aby uzyskać pełną listę dostępnych typów danych w bazach danych programu Access.

    Porady dotyczące typów danych

    • Maksymalny rozmiar pliku bazy danych programu Access to 2 gigabajty.

    • W celu optymalizacji wydajności należy podczas tworzenia pola typu Tekst lub Liczba korzystać z najbardziej odpowiedniego ustawienia właściwości Rozmiar pola. Na przykład jeśli chcesz przechowywać kody pocztowe o przewidywalnej długości, wskaż tę długość jako rozmiar pola. Rozmiar pola możesz określić, wprowadzając wartość w polu właściwości Rozmiar pola. Aby uzyskać więcej informacji, zobacz sekcję Ustawianie innych właściwości pola.

    • W przypadku numerów telefonów, numerów części i innych wartości liczbowych, które nie będą używane w obliczeniach matematycznych, należy wybrać typ danych Tekst, a nie Liczba. Przechowywanie wartości liczbowej w formacie tekstowym ułatwia jej logiczne sortowanie i filtrowanie.

Początek strony

Zmienianie formatu pola

Program Access nie tylko określa typ danych nowego pola, ale może również ustawić właściwość Format pola, zależnie od wprowadzonej wartości. Jeśli na przykład zostanie wprowadzony ciąg 10:50am, program Access ustawi typ danych na wartość Data/Godzina, a właściwość Format na wartość Godzina średnia. Aby ręcznie zmienić właściwość Format pola, należy wykonać następujące czynności:

  1. Na Wstążce kliknij kartę Pola

  2. Na liście Format w grupie Formatowanie wprowadź odpowiedni format. 

    Uwaga: W przypadku niektórych pól (na przykład pól typu Tekst) lista Format może być niedostępna. Zależy to od typu danych pola.

Początek strony

Ustawianie innych właściwości pola

  1. W widoku arkusza danych kliknij pole, dla którego chcesz ustawić właściwość.

  2. Na karcie Pola w grupach Właściwości, Formatowanie lub Sprawdzanie poprawności pola wybierz żądane właściwości.

Początek strony

Ustawianie właściwości pola w widoku projektu

Możesz ustawić dowolną właściwość pola podczas pracy z tabelą w widoku projektu. W widoku projektu możesz ustawić typ danych pola w siatce projektu tabeli, a pozostałe właściwości w okienku Właściwości pola.

  1. W okienku nawigacji kliknij tabelę prawym przyciskiem myszy.

  2. W menu skrótów kliknij polecenie Widok projektu.

Początek strony

Zmienianie typu danych pola

Po utworzeniu pola można zmieniać jego różne właściwości.

Ostrzeżenie: Ponadto można zmieniać te szczegóły dotyczące pola, które nie zostały utworzone. Jeśli jednak pole już zawiera dane, niektóre akcje będą niedostępne lub mogą spowodować utratę danych.

  1. W siatce projektu tabeli znajdź pole, dla którego chcesz ustawić typ danych.

  2. W kolumnie Typ danych wybierz z listy odpowiedni typ danych.

    Jakie typy danych są dostępne?

    Zobacz Typy danych w bazach danych programu Access dla komputerów stacjonarnych, aby uzyskać pełną listę dostępnych typów danych w bazach danych programu Access.

    Porady dotyczące typów danych

    • Maksymalny rozmiar pliku bazy danych programu Access to 2 gigabajty.

    • W przypadku numerów telefonów, numerów części i innych wartości liczbowych, które nie będą używane w obliczeniach matematycznych, należy wybrać typ danych Tekst, a nie Liczba. Przechowywanie wartości liczbowej w formacie tekstowym ułatwia jej logiczne sortowanie i filtrowanie, ale uniemożliwia jej łatwe używanie w obliczeniach.

    • W przypadku typów danych Tekst i Liczba możesz dokładniej określić rozmiar pola lub typ danych, wprowadzając wartość w polu właściwości Rozmiar pola.

Początek strony

Ustawianie innych właściwości pola

Uwaga: Niektóre formaty nie są dostępne dla wszystkich typów danych. Najpierw ustaw typ danych, a potem, w razie potrzeby, ustaw format.

  1. W siatce projektu tabeli zaznacz pole, którego właściwości chcesz ustawić. Właściwości tego pola zostaną wyświetlone w programie Access w okienku Właściwości pola.

    Typ danych pola określa właściwości, które można ustawić.

  2. W okienku Właściwości pola wprowadź odpowiednie ustawienia poszczególnych właściwości lub naciśnij klawisz F6 i użyj klawiszy strzałek, aby wybrać właściwość.

    Jakie właściwości pól są dostępne?

    Zobacz Wprowadzenie do typów danych i właściwości pól, aby uzyskać pełną listę właściwości pola dostępnych dla każdego typu danych w bazach danych programu Access.

    Uwaga: Nie wszystkie właściwości są dostępne dla każdego pola. Typ danych pola wpływa na dostępność jego właściwości.

  3. Aby uzyskać większą ilość miejsca do wprowadzania lub edytowania ustawień właściwości w polu właściwości, naciśnij klawisze SHIFT+F2 w celu wyświetlenia pola Powiększenie.

    Porada: Jeśli wprowadzasz maskę wprowadzania lub wyrażenie reguły sprawdzania poprawności i potrzebujesz pomocy przy ich tworzeniu, kliknij przycisk Przycisk Konstruktor obok pola właściwości, aby wyświetlić odpowiedniego konstruktora.

  4. Aby zapisać zmiany, naciśnij klawisze CTRL+S.

Początek strony

Przenoszenie pola

Aby przenieść pole, przeciągnij je w odpowiednie miejsce. W celu zaznaczenia wielu sąsiadujących pól do przeniesienia kliknij pierwsze pole, przytrzymaj naciśnięty klawisz SHIFT i kliknij ostatnie pole. Tak zaznaczoną grupę pól można następnie przeciągnąć w nowe miejsce.

Przeciągnięcie pola powoduje zmianę jego położenia w arkuszu danych, ale nie zmienia kolejności pól w projekcie tabeli. W przypadku uzyskiwania programowego dostępu do pól stosowana jest kolejność oryginalna. Na przykład po przeciągnięciu pola do nowego położenia w arkuszu danych, a następnie utworzeniu formularza na podstawie tabeli za pomocą przycisku Formularz, to pole znajdzie się w swoim pierwotnym położeniu.

Początek strony

Zobacz też

Dodawanie pola obliczeniowego do tabeli

Dodawanie pola do formularza lub raportu

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×