Tworzenie kodów SPP

Subskrypcja usługi Office 365, Project Professional 2019, Project Professional 2016, Office 2013, Office 2010

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

W pigułce kody struktury podziału prac (SPP) są konspekt numerami, które można stosować do zadań i edytować w celu dostosowania się do konkretnych potrzeb firmy. Program Project automatycznie udostępnia podstawowe numery konspektu dla każdego zadania, ale w dowolnym momencie możesz zastosować do projektu własny niestandardowy schemat konspektu.

Co chcesz zrobić?

Tworzenie niestandardowych kodów SPP

Ponowne numerowanie kodów SPP

Używanie podstawowych numerów konspektu

Tworzenie niestandardowych kodów SPP

  1. Kliknij pozycję Widok, a następnie wybierz widok arkusza, taki jak arkusz zadań lub Arkusz zasobów.

  2. Kliknij pozycję projekt. W grupie Właściwości kliknij pozycję spp , a następnie kliknij pozycję Definiuj kod.

    Obraz opcji Definiuj kod przycisku SPP

  3. W polu prefiks kodu projektu można utworzyć odpowiedni kod w programie Project. Możesz używać cyfr, wielkich i małych liter oraz symboli.

Obraz okna dialogowego Definicja kodu SPP

  1. Aby ustawić kod dla zadań pierwszego poziomu, w pierwszym wierszu w kolumnie sekwencja wybierz typ znaku z listy rozwijanej. Można wybierać liczby, wielkie lub małe litery albo kombinację cyfr, liter i innych symboli.

  2. W kolumnie Długość Ustaw liczbę znaków dla każdego poziomu ciągu kodu. Kliknij pozycję dowolny , aby zezwolić na liczbę znaków na tym poziomie.

  3. W kolumnie separator wybierz znak, aby oddzielić kod jednego poziomu od kodu dla następnego poziomu.

    Domyślnym separatorem jest kropka. Możesz wybrać inne osoby lub w ogóle nie wybierać znaku separatora.

    Uwaga: Znaku separatora nie można również użyć jako części kodu.

  4. Ustaw ciąg kodu dla każdego poziomu zadań z wcięciami w konspekcie.

    Aby określić poszczególne kody dla każdego poziomu, kliknij Następny wiersz i wypełnij kolumny sekwencja, Długośći separator .

  5. Jeśli nie chcesz, aby program Project automatycznie przypisywał kod SPP za każdym razem, gdy wprowadzisz nowe zadanie, wyczyść pole wyboru Generuj kod SPP dla nowego zadania .

  6. Aby zezwolić na używanie tego samego kodu SPP dla wielu zadań, wyczyść pole wyboru Weryfikuj unikatowość nowych kodów SPP .

Ponowne numerowanie kodów SPP

Po przeniesieniu lub usunięciu zadań w programie Project nie są automatycznie ponownie numerowane kody SPP na wypadek, gdyby były używane w dokumentach lub innych systemach, które nie są połączone z plikiem projektu. Oznacza to, że kody dla pozostałych zadań będą prawdopodobnie nieprawidłowe. Poniżej opisano, jak ponownie przenumerować kody SPP dla wszystkich zadań lub zaznaczonych zadań:

  1. Kliknij pozycję Widok, a następnie wybierz widok arkusza (na przykład arkusz zadań) zawierający zadania, których numerację chcesz zmienić.

  2. Wybierz zadania, których numerację chcesz zmienić. Pierwsze wybrane zadanie nie zostanie przenumerowane.

    Aby ponownie ponumerować kody SPP dla wszystkich zadań, nie zaznaczaj żadnych zadań.

  3. Kliknij pozycję projekt. W grupie Właściwości kliknij pozycję spp , a następnie kliknij pozycję Przenumeruj ponownie.

    Obraz karty Projekt, przycisku SPP, polecenia Ponumeruj ponownie w menu rozwijanym.

  4. Kliknij pozycję zaznaczone zadania, Aby ponownie ponumerować kody wybranych zadań.

    Kliknij pozycję cały projekt , aby ponownie ponumerować kody wszystkich zadań w projekcie.

    Obraz okna dialogowego Ponowne numerowanie kodów SPP

Używanie podstawowych numerów konspektu

Jeśli nie potrzebujesz szczegółowej struktury udostępnianej przez kody SPP, możesz użyć podstawowego konspektu.

Program Project automatycznie tworzy numer w konspekcie dla każdego zadania, na podstawie miejsca, w którym zadanie jest wyświetlane w strukturze listy zadań. Na przykład pierwsze zadanie na liście zadań jest numerowane 1. Jeśli to zadanie ma trzy podzadania, podzadania są numerowane 1,1, 1,2 i 1,3.

Numery w konspekcie zawierają tylko cyfry i nie można ich edytować. Zmieniają się automatycznie podczas przenoszenia zadania w górę lub w dół na liście zadań oraz podczas zwiększania lub zmniejszania wcięcia zadań.

Aby wyświetlić numery konspektu, Dodaj pole numer w konspekcie do widoku tabela lub arkusz. Możesz również dodać numery konspektu bezpośrednio do nazw zadań:

  1. Przejdź do widoku Wykres Gantta lub zadanie.

  2. Kliknij pozycję Format, a następnie w grupie Pokazywanie/ukrywanie zaznacz pole wyboru numer konspektu.

Początek strony

Ta sekcja dotyczy tylko programu Microsoft Project 2007.

Co chcesz zrobić?

Informacje na temat kodów SPP

Definiowanie niestandardowych kodów SPP

Ponowne numerowanie kodów SPP

Informacje na temat kodów SPP

W programie Microsoft Office Project występują dwa typy kodów SPP: numery konspektów i niestandardowe kody spp. Aby dowiedzieć się więcej, zaPoznaj się z poniższymi sekcjami.

Numery konspektu

Numery w konspekcie są najprostszym typem kodowania spp. Program Microsoft Office Project automatycznie oblicza numer w konspekcie każdego zadania, opierając się na strukturze konspektu na liście zadań. Na przykład pierwsze zadanie na liście zadań jest numerowane 1. Jeśli to zadanie ma trzy podzadania, podzadania są numerowane 1,1, 1,2 i 1,3.

Numery w konspekcie zawierają tylko cyfry (bez liter) i nie można ich edytować. Są one jednak zmieniane automatycznie podczas przenoszenia zadania w górę lub w dół na liście zadań oraz podczas zwiększania lub zmniejszania wcięcia zadań. Jeśli na przykład podzadanie ma numer konspektu 3.5.4, a Jeśli przeniesiesz go w górę o jedno wiersza, numer konspektu zostanie automatycznie zaktualizowany na wartość 3.5.3. W przypadku zmniejszenia wcięcia tego samego podzadania numer konspektu zostanie automatycznie zaktualizowany do 3,6.

Porada: Aby wyświetlić numery w konspekcie, można dodać pole numer w konspekcie do widoku tabela lub arkusz, a także wybrać opcję wyświetlania numerów konspektu obok nazw zadań. Aby wyświetlić numery konspektu obok nazw zadań, w menu Narzędzia kliknij polecenie Opcje, a następnie kliknij kartę Widok . W obszarze Opcje konspektuzaznacz pole wyboru Pokaż numer konspektu .

Niestandardowe kody SPP

Jeśli projekt będzie korzystać z szczegółowych kodów SPP składających się z określonych długości, sekwencji lub zestawów liczb i liter, można zdefiniować jeden niestandardowy _Z0Z_ spp dla projektu. (Żaden projekt nie może mieć więcej niż jednej niestandardowej maski kodu). Niestandardowy kod SPP jest rejestrowany w polu spp .

Podobnie jak w przypadku numerów w konspekcie, każdy poziom niestandardowego kodu SPP przedstawia poziom konspektu na liście zadań. W przypadku każdego poziomu kodu można użyć unikatowego formatu, a każdy poziom jest wyświetlany w kodzie w zależności od hierarchii zadań, zadań sumarycznych i podzadań.

Jeśli na przykład planujesz projekty stopniowane, które są dostosowane do dyrektyw organizacyjnych w nadchodzącym roku obrachunkowym, możesz utworzyć niestandardową maskę kodu SPP, która reprezentuje każde zadanie za pomocą odpowiedniej dyrektywy, kwartału i projektu. Korzystając z tego kodu, możesz mieć zadanie z niestandardowym kodem spp CustSat. Q3. CSTools. 11, co oznacza, że jest to zadanie 11 w projekcie uaktualnienia narzędzi obsługi klienta, który rozpoczyna się w trzecim kwartale, co stanowi wsparcie dla firmy klienta. Dyrektywa dotycząca planowanego roku obrachunkowego.

Definiowanie niestandardowych kodów SPP

  1. W menu Widok kliknij Widok arkusza, na przykład widok arkusza zadań.

    Aby użyć widoku, który nie jest wyświetlany w menu Widok , kliknij pozycję więcej widoków, kliknij Widok, którego chcesz użyć na liście widoki , a następnie kliknij przycisk Zastosuj.

  2. W menu projekt wskaż polecenie spp, a następnie kliknij polecenie Definiuj kod.

  3. Aby odróżnić zadania w tym projekcie od zadań w innych projektach, wpisz odpowiedni prefiks kodu projektu w polu prefiks kodu projektu .

    Ten prefiks ułatwia identyfikowanie projektu na najwyższym poziomie kodu SPP. Prefiks może być przydatny do identyfikowania podprojektów w projekcie głównym lub podczas tworzenia współzależności między projektami.

    W polu prefiks kodu projektu można wprowadzić dowolną kombinację cyfr, wielkich i małych liter oraz symboli.

  4. Aby określić ciąg kodu dla zadań pierwszego poziomu, w pierwszym wierszu w kolumnie sekwencja kliknij typ znaku, którego chcesz użyć dla tego poziomu:

    • Kliknij pozycję liczby (uporządkowane) , aby wyświetlić na tym poziomie liczbowy kod SPP (na przykład 1, 2 i 3 dla pierwszych trzech zadań sumarycznych w projekcie).

    • Kliknij pozycję wielkie litery (uporządkowane) , aby wyświetlić alfabetyczne kody SPP alfabetyczne (na przykład litery A, B i C dla pierwszych trzech zadań sumarycznych w projekcie).

    • Kliknij pozycję małe litery (uporządkowane) , aby wyświetlić kody SPP małymi literami (na przykład litery a, b i c dla pierwszych trzech zadań sumarycznych w projekcie).

    • Kliknij pozycję znaki (nieuporządkowane) , aby wyświetlić dowolną kombinację liczb i wielkich i małych liter (na przykład Arch1, Const1 i Insp1 dla pierwszych trzech zadań sumarycznych w projekcie).

      Wybranie tej opcji zapewnia większą elastyczność wprowadzania niestandardowych kodów SPP. Program Project wyświetli gwiazdkę (*) w polu SPP do momentu wpisania lub wprowadzenia ciągu znaków dla tego poziomu kodu SPP.

  5. W kolumnie Długość wpisz lub wybierz liczbę znaków dla każdego poziomu ciągu kodu. Można wprowadzić dokładną liczbę znaków lub wybrać dowolną liczbę znaków dla tego poziomu kodu.

    Można na przykład wpisać 3 , aby wprowadzić trzy znaki obowiązkowej liczby znaków wprowadzanych na jednym poziomie kodu SPP. Łączna długość kodu SPP może wynosić od 1 do 255 znaków.

  6. W kolumnie separator wpisz lub wybierz znak, aby oddzielić ciąg kodu dla jednego poziomu z ciągu kodu dla następnego poziomu.

    Domyślnie znakiem separatora jest kropka. Możesz użyć innego znaku separatora na każdym poziomie kodu.

    Możesz również zrezygnować z używania dowolnego znaku separatora między poziomami kodu. W polu separator Usuń znak separatora.

  7. Umożliwia określenie jednego ciągu kodu dla każdego poziomu wcięcia zadań w konspekcie.

    Aby określić poszczególne ciągi kodu dla każdego poziomu, kliknij Następny wiersz i wypełnij kolumny sekwencja, Długośći separator .

  8. Jeśli nie chcesz, aby program Project automatycznie przypisywał kod SPP za każdym razem, gdy wprowadzisz nowe zadanie, wyczyść pole wyboru Generuj kod SPP dla nowego zadania .

  9. Aby zezwolić na używanie tego samego kodu SPP dla wielu zadań, wyczyść pole wyboru Weryfikuj unikatowość nowych kodów SPP .

    Uwagi: 

    • Znaku, którego użyto jako separatora, nie można również użyć jako części kodu. Jeśli na przykład jako separatora użyto łącznika, nie można użyć łącznika w kodzie używanym do reprezentowania zadania.

    • Dla każdego projektu nie można zdefiniować więcej niż jednego zestawu kodów SPP. Jeśli jest konieczne wyświetlenie dodatkowej struktury organizacyjnej zadań, można użyć pól niestandardowych w celu utworzenia lub zastosowania oddzielnego zestawu kodów.

    • Aby wyświetlić kody SPP, należy dodać pole spp do widoku.

    • Aby zmienić kod SPP dla zadanie sumaryczne i wszystkich jego podzadań, należy zmienić istniejący kod lub zestaw gwiazdek w kodzie spp zadania sumarycznego na inny zestaw znaków.

      Na przykład kod SPP dla konkretnego podzadania to PH3. Prj5. Arch. Task3. "Task3" reprezentuje podzadanie "opracowanie planu", a "Arch" oznacza zadanie sumaryczne "rozwiązanie w ramach architekta". Nazwa zadania sumarycznego jest zamieniana na "rozwiązanie projektowe" i trzeba zaktualizować kod zadania sumarycznego i wszystkie podzadania. Można zmodyfikować kod SPP, aby zadanie sumaryczne było reprezentowane przez "des", a kod SPP dla podzadania "opracowanie planu" zostanie automatycznie zaktualizowany do PH3. Prj5. des. Task3.

Ponowne numerowanie kodów SPP

Po przeniesieniu lub usunięciu zadań ich niestandardowe kody SPP mogą nie być już wprowadzane w odpowiedniej kolejności. Program Project nie automatycznie ponumeruje kodów SPP, ponieważ mogą one być używane w dokumentach lub systemach, które nie są połączone z plikiem projektu. Można zmienić numerację kodów SPP wszystkich zadań lub zaznaczonych zadań:

  1. W menu Widok kliknij Widok arkusza zawierający zadania, które chcesz ponumerować, na przykład arkusz zadań.

    Aby użyć widoku, który nie jest wyświetlany w menu Widok , kliknij pozycję więcej widoków, kliknij Widok, którego chcesz użyć na liście widoki , a następnie kliknij przycisk Zastosuj.

  2. Zaznacz zadania, których numerację chcesz zmienić. (Pierwsze zadanie w wyborze zadań nie jest przenumerowane. Jest on wykorzystywany jako punkt odniesienia do przeprowadzenia ponownej numeracji innych zadań.

    Aby ponownie ponumerować kody SPP dla wszystkich zadań, nie zaznaczaj żadnych zadań.

  3. W menu projekt wskaż polecenie spp, a następnie kliknij polecenie Zmień numerację.

  4. Aby skorygować kolejność kodu SPP tylko wybranych zadań sąsiadujących, kliknij pozycję zaznaczone zadania.

    Aby skorygować kolejność kodu SPP wszystkich zadań w projekcie, kliknij pozycję cały projekt.

    Uwagi: 

    • Jeśli projekt zawiera podprojekty, można ponumerować niektóre lub wszystkie zadania w każdym podprojekcie, wyświetlając wszystkie podzadania. Kliknij pozycję Pokaż Obraz przycisku , a następnie kliknij pozycję wszystkie podzadania. (Program Project nie może ponownie przenumerować zadań z podprojektów, które nie są wyświetlane).

    • Zmiana numeracji podprojektów wstawionych do projektu głównego powoduje również zmianę kodu odpowiadającego poszczególnym podprojektom na poziomie projektu.

    • Aby wyświetlić kody SPP, można dodać kolumnę spp do widoku arkusza.

    • Aby zmienić kody SPP po ich obliczeniu w programie Project, w menu projekt wskaż polecenie spp, a następnie kliknij polecenie Definiuj kod. W kolumnie sekwencje Zmień typ znaku dowolnego poziomu maski kodu. Po zaktualizowaniu kodu na poziomie zadania sumarycznego wszystkie podzadania tego zadania sumarycznego są automatycznie aktualizowane.

  • Jeśli masz trudności z zmianą kodów SPP, może to wynikać z jednej z następujących przyczyn:

    • Próbujesz zmienić kod SPP z maską kodu po obliczeniu kodu     Jeśli została utworzona maska kodu SPP, a kody SPP zostały już obliczone dla zadań, można zmienić kod SPP tylko przez ponowne zdefiniowanie poziomów maski kodu. Po przedefiniowaniu poziomów maski kodu możesz zmienić dowolny poziom maski kodu z uporządkowanych numerów, uporządkowane wielkie litery, uporządkowane małe litery lub nieuporządkowane znaki na inny typ.

    • Próbujesz zmienić kody SPP na niższym poziomie na liście zadań     Nie można zmienić znaków w kodzie spp podzadania, tylko w przypadku zadania sumarycznego, w którym zdefiniowano ten poziom kodu SPP.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×