Tworzenie i uruchamianie zapytania usuwającego

Tworzenie i uruchamianie zapytania usuwającego

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Jeśli chcesz szybko usunąć wiele danych lub usuwanie zestawu danych na bieżąco pulpitu bazy danych programu Access, usuń lub kwerenda aktualizująca może być przydatne kwerendy pozwalają określić kryteria, aby szybko znaleźć i usunąć dane. Korzystanie z kwerendy można także timesaver ponieważ można ponownie użyć zapisanej kwerendy.

Uwaga: Przed usunięciem danych lub uruchamianie kwerendy usuwającej, upewnij się, że masz kopię zapasową bazy danych programu Access pulpitu.

W przypadku usuwania tylko kilku rekordów korzystanie z kwerendy nie jest konieczne. Wystarczy otworzyć tabelę w widoku arkusza danych, zaznaczyć pola (kolumny) lub rekordy (wiersze) przeznaczone do usunięcia i nacisnąć klawisz DELETE.

Ważne: Informacje w tym artykule są przeznaczone do użytku z bazach danych dla komputerów stacjonarnych. Nie można użyć Usuń lub zaktualizuj kwerend w aplikacjach sieci web programu Access.

W tym artykule

Wybieranie typu kwerendy

Korzystanie z kwerendy usuwającej

Korzystanie z kwerendy aktualizującej

Dodatkowe informacje

Porady dotyczące rozwiązywania problemów

Wybieranie typu kwerendy

Do usunięcia danych z bazy danych można użyć kwerendy aktualizującej lub kwerendy usuwającej. Kwerendę należy wybrać na podstawie informacji z poniższej tabeli:

Typ kwerendy

Okoliczności użycia

Wyniki

Korzystanie z kwerendy usuwającej

W celu usunięcia całych rekordów (wierszy) z tabeli lub jednocześnie z dwóch powiązanych tabel.

Uwaga: Jeśli rekordy znajdują się po stronie "jeden" relacji jeden do wielu, może być konieczne zmienianie relacji przed uruchomieniem kwerendy usuwającej. Zobacz sekcję o usuwaniu danych z powiązanych tabel.

Kwerendy usuwające usuwają wszystkie dane w każdym polu, łącznie z wartością klucza, która jest unikatowym identyfikatorem rekordu.

Korzystanie z kwerendy aktualizującej

W celu usunięcia wartości poszczególnych pól z tabeli.

Kwerenda aktualizująca ułatwia usuwanie wartości, aktualizując istniejące wartości przez zastąpienie ich wartością null (czyli brak danych) lub ciągiem o zerowej długości (para cudzysłowów podwójnych nieoddzielonych spacją).

Początek strony

Co należy sprawdzić przed użyciem kwerendy w celu usunięcia danych

  • Upewnij się, że plik nie jest plikiem tylko do odczytu:

    1. Kliknij prawym przyciskiem myszy przycisk Start i kliknij pozycję Otwórz Eksploratora Windows.

    2. Kliknij prawym przyciskiem myszy plik bazy danych i kliknij pozycję Właściwości.

    3. Sprawdź, czy atrybut Tylko do odczytu jest zaznaczony.

  • Sprawdź, czy masz uprawnienia do usuwania rekordów z bazy danych. Jeśli masz wątpliwości, skontaktuj się z administratorem systemu lub projektantem bazy danych.

  • Upewnij się, że są włączone zawartość bazy danych. Domyślnie program Access blokuje wszystkie zapytania funkcjonalne (zapytania delete, aktualizacji i tworząca tabelę), o ile nie zostanie najpierw ustawiona jako zaufana bazy danych. Aby dowiedzieć się, jak zaufanie bazy danych zobacz sekcję Tryb wyłączony zatrzymywanie blokowania kwerendy przez.

  • Poproś innych użytkowników bazy danych o zamknięcie wszystkich tabel, formularzy, kwerend i raportów korzystających z danych, które chcesz usunąć. Pomoże to uniknąć naruszeń blokady.

  • Przed edytowaniem lub usunięciem rekordów, wykonanie kopii zapasowej bazy danych jest dobrym pomysłem, w przypadku, gdy chcesz wycofać zmiany.

Porada: Jeśli wielu użytkowników połączenia z bazą danych, może być konieczne Zamknij bazę danych i ponownym otwarciu go w trybie wyłączności.

Aby otworzyć bazę danych w trybie wyłączności:

  1. Kliknij kartę Plik > Otwórz.

  2. Przejdź do bazy danych i zaznacz ją wskazaniem, kliknij strzałkę obok przycisku Otwórz i kliknij polecenie Otwórz z wyłącznością.

    Otwieranie pliku w trybie wyłączności

Tworzenie kopii zapasowej bazy danych

  1. Kliknij kartę Plik i wskaż polecenie Zapisz jako.

  2. Kliknij polecenie Zapisz bazę danych jako, kliknij pozycję Wykonaj kopię zapasową bazy danych. Program Access zamknie oryginalny plik, utworzy kopię zapasową, a następnie ponownie otworzy oryginalny plik.

  3. Kliknij polecenie Zapisz jako, określ nazwę i lokalizację kopii zapasowej, a następnie kliknij przycisk Zapisz.

Uwaga:  W przypadku korzystania z bazy danych tylko do odczytu utworzonej we wcześniejszej wersji programu Access może zostać wyświetlony komunikat z informacją, że wykonanie kopii zapasowej bazy danych jest niemożliwe.

Aby przywrócić dane z kopii zapasowej, zamknij oryginalny plik i zmień jego nazwę, dzięki czemu będzie można użyć nazwy oryginalnej wersji dla kopii zapasowej. Przypisz nazwę oryginalnej wersji do kopii zapasowej, a następnie otwórz kopię zapasową w programie Access.

Korzystanie z kwerendy usuwającej

Aby utworzyć kwerendę usuwającą, kliknij Tworzenie kart w grupie kwerendy kliknij Projekt kwerendy. W okno dialogowe Pokazywanie tabeli kliknij dwukrotnie każdą tabelę, z której chcesz usunąć rekordy, a następnie kliknij pozycję Zamknij.

Tabela jest widoczna jako okno w górnej części siatki projektu kwerendy. Na liście pól należy kliknąć dwukrotnie gwiazdkę (*), aby dodać wszystkie pola tabeli do siatki projektu.

Korzystanie z określonych kryteriów kwerendy usuwającej

Ważne: Należy podać kryteria, aby zostały zwrócone tylko rekordy przeznaczone do usunięcia. W przeciwnym razie kwerenda usuwająca usunie wszystkie rekordy w tabeli.

Kliknij dwukrotnie pole, które chcesz określić jako kryteria do usunięcia, wprowadź jedną kryteriów w wiersza kryteriów kwerendy projektanta, a następnie wyczyść pole wyboru Pokaż dla każdego pola kryterium.

Przykład zastosowania tej opcji: załóżmy, że użytkownik chce usunąć wszystkie oczekujące zamówienia określonego klienta. Aby znaleźć tylko te rekordy, należy dodać pola ID klienta i Data zamówienia do siatki projektu kwerendy, a następnie wprowadzić numer identyfikacyjny klienta oraz dzień, w którym zamówienia klienta utraciły ważność.

  1. Na karcie Projekt kliknij pozycję Widok > Widok arkusza danych.

  2. Upewnij się, że kwerenda zwraca rekordy przeznaczone do usunięcia, a następnie naciśnij klawisze CTRL+S, aby zapisać kwerendę.

  3. Aby uruchomić kwerendę, kliknij ją dwukrotnie w okienku nawigacji.

Początek strony

Korzystanie z kwerendy aktualizującej

Uwaga: Nie można użyć opcji kwerendy aktualizującej aplikacji sieci web programu Access.

W tej sekcji omówiono sposób użycia kwerendy aktualizującej w celu usunięcia pojedynczych pól z tabel. Należy pamiętać, że uruchomienie kwerendy aktualizującej w celu usunięcia danych zmieni istniejące wartości na wartości NULL lub na ciągi znaków o zerowej długości (dwa znaki podwójnego cudzysłowu bez spacji między nimi) zależnie od określonych kryteriów.

  1. Kliknij kartę Tworzenie i w grupie kwerendy kliknij przycisk Projekt kwerendy.

  2. Zaznacz tabelę, która zawiera dane, który chcesz usunąć (jeśli dotyczy tabeli, zaznacz tabelę po stronie "jeden" relacji), kliknij przycisk Dodaj, a następnie kliknij przycisk Zamknij.

    Tabela jest widoczna jako okno w górnej części siatki projektu kwerendy. W oknie będą wyszczególnione wszystkie pola zaznaczonej tabeli.

  3. Kliknij dwukrotnie gwiazdkę (*), aby dodać wszystkie pola tabeli do siatki projektu. Dodanie wszystkich pól tabeli pozwala na usuwanie całych rekordów (wierszy) z tabeli za pomocą kwerendy usuwającej.

    Opcjonalnie można wprowadzić kryteria dla jednej lub większej liczbie pól w wierszu kryteria projektanta, a następnie wyczyść pole wyboru Pokaż dla każdego pola kryterium. Aby uzyskać więcej informacji na temat korzystania z kryteriów zobacz tabelę Przykładowe kryteria kwerend wybierających .

    Uwaga: Należy podać kryteria, aby zostały zwrócone jedynie rekordy przeznaczone do usunięcia. W przeciwnym przypadku kwerenda aktualizująca ustawi wartość NULL dla każdego rekordu w każdym z pól w kwerendzie.

  4. Na karcie Projektowanie w grupie Wyniki kliknij przycisk Widok, a następnie kliknij pozycję Widok arkusza danych.

  5. Upewnij się, że kwerenda zwraca rekordy, które ma zostać wstawiona wartość NULL lub ciąg o zerowej długości (dwa znaki podwójnego cudzysłowu bez spacji między nimi ("").

  6. W razie potrzeby powtórz kroki od 3 do 5 i zmienianie pola lub kryterium, aż kwerenda zwraca tylko dane, które chcesz usunąć, a następnie naciśnij klawisze CTRL + S, aby zapisać kwerendę.

  7. Aby uruchomić kwerendę, kliknij ją dwukrotnie w okienku nawigacji.

Początek strony

Informacje dodatkowe

Usuwanie danych z powiązanych tabel

Jeśli chcesz usunąć dane z wielu powiązanych tabel, należy włączyć opcje Więzów integralności i Kaskadowo usuń rekordy pokrewne dla każdej relacji. Dzięki temu zapytania usunąć dane z tabeli po stronie "jeden" i "wiele" relacji. Przygotowywanie usunięcie powiązanych danych wymaga weryfikacji z następujących czynności:

  • Określ, które rekordy znajdują się po stronie „jeden” relacji, a które znajdują się po stronie „wiele”.

  • Aby usunąć rekordy znajdujące się po stronie „jeden” relacji oraz rekordy pokrewne znajdujące się po stronie „wiele”, należy włączyć zestaw reguł o nazwie Więzy integralności oraz opcję usuwania kaskadowego. W tej sekcji wyjaśniono opcję Więzy integralności oraz sposób wykonania obu zadań.

  • Aby usunąć rekordy znajdujące się tylko po stronie „jeden” relacji, najpierw usuń tę relację, a następnie usuń dane.

Aby usunąć dane znajdujące się tylko po stronie „wiele” relacji, można utworzyć i uruchomić kwerendę usuwającą bez konieczności zmieniania relacji.

Aby dowiedzieć się, które rekordy znajdują się po stronie "jeden" i "wiele" relacji, na karcie Narzędzia bazy danych w grupie Relacje kliknij przycisk Relacje. Na karcie relacji jest wyświetlana tabel w bazie danych i relacje. Każda relacja jest przedstawiona jako linia łącząca tabele między polami.

Na poniższej ilustracji pokazano typowej relacji. Większość, jeśli nie wszystkie relacji w bazie danych ma stronie "jeden" i "wiele" relacji. Diagram relacji oznacza po stronie "jeden" z liczb jeden (1 ), a po stronie "wiele" symbolem nieskończoności (∞;).

Relacja między dwiema tabelami

Usunięcie rekordów ze strony „jeden” relacji skutkuje usunięciem wszystkich rekordów pokrewnych ze strony „wiele” relacji. Ale w przypadku usunięcia rekordów ze strony „wiele” relacji rekordy po stronie „jeden” tej relacji zazwyczaj nie są usuwane.

W programie Access jest automatycznie wymuszany zestaw reguł zwany więzami integralności. Te reguły zapewniają, że klucze obce w bazie danych zawierają poprawne wartości. Klucz obcy jest kolumną, której wartości odpowiadają wartościom kolumny klucza podstawowego w innej tabeli.

Edytowanie relacji

Te kroki należy wykonać tylko wtedy, gdy trzeba usunąć dane po stronie „jeden” oraz po stronie „wiele” relacji.

  1. Na karcie Narzędzia bazy danych w grupie Relacje kliknij pozycję Relacje.

  2. Kliknij prawym przyciskiem myszy relację (linię) łączącą tabele, których dotyczy operacja usuwania, a następnie w menu skrótów kliknij polecenie Edytuj relację.

  3. W oknie dialogowym Edytowanie relacji upewnij się, że jest zaznaczone pole wyboru Wymuszaj więzy integralności.

  4. Zaznacz pole wyboru Kaskadowo usuń rekordy pokrewne.

    Uwaga: Do czasu ponownego wyłączenia tej właściwości usunięcie rekordu po stronie „jeden” relacji będzie powodowało usunięcie rekordów pokrewnych po stronie „wiele” relacji.

  5. Kliknij przycisk OK, Zamknij okienko Relacje, a następnie przejdź do następnego zestawu kroków.

Usuwanie relacji

  1. Jeśli nie zrobiono tego wcześniej, otwórz okienko Relacje.

  2. Na karcie Narzędzia bazy danych w grupie Relacje kliknij pozycję Relacje.

    Zanotuj pola uwzględnione w relacji, aby można było przywrócić relację po usunięciu danych.

  3. Kliknij prawym przyciskiem myszy relację (linię) łączącą tabele, których dotyczy operacja usuwania, a następnie kliknij pozycję Usuń w menu skrótów.

Uwaga: Aby przywrócić relacji, wykonaj powyższe kroki i otwórz okienko Relacje przeciągnij klucz podstawowy z tabeli "jeden" i upuść go w polu klucza obcego tabeli po stronie "wiele". Zostanie wyświetlone okno dialogowe Edytowanie relacji. Jeśli stare relacji wymuszane więzy integralności, wybierz pozycję Wymuszaj więzy integralności i kliknij przycisk Utwórz. W przeciwnym razie po prostu kliknij przycisk Utwórz.

Początek strony

Przykładowe kryteria kwerend wybierających

W poniższej tabeli wyszczególniono przykładowe kryteria, których można użyć w kwerendach wybierających, aby zagwarantować, że będą usuwane tylko dane przeznaczone do usunięcia. W niektórych przykładach są używane symbole wieloznaczne.

Kryteria

Wynik

> 234

Zwraca wszystkie liczby większe niż 234. Aby znaleźć wszystkie liczby mniejsze niż 234, należy użyć wyrażenia < 234.

>= "Misztal"

Zwraca wszystkie rekordy od nazwiska Misztal do końca alfabetu.

Between #2010-02-02# And #2010-12-01#

Zwraca daty od 2-lut-2010 do 1-gru-2010 (ANSI-89). Jeśli w bazie danych są używane symbole wieloznaczne ANSI-92, należy użyć cudzysłowów pojedynczych (') zamiast znaków numeru (#). Przykład: Between '2010-02-02' And '2010-12-01'.

Not "Niemcy"

Znajduje wszystkie rekordy, w których dokładna zawartość pola nie jest równa „Niemcy”. Kryterium zwróci rekordy zawierające dodatkowe znaki oprócz wyrazu „Niemcy”, na przykład „Niemcy (euro)” lub „Europa (Niemcy)”.

Not "T*"

Znajduje wszystkie rekordy oprócz rekordów zaczynających się od litery T. Jeśli w bazie danych jest używany zestaw symboli wieloznacznych ANSI-92, należy użyć znaku procentu (%) zamiast gwiazdki (*).

Not "*t"

Znajduje wszystkie rekordy, które nie kończą się literą t. Jeśli w bazie danych jest używany zestaw symboli wieloznacznych ANSI-92, należy użyć znaku procentu (%) zamiast gwiazdki (*).

In(Kanada,USA)

Znajduje na liście wszystkie rekordy zawierające wyrazy Kanada lub USA.

Like "[A-D]*"

W polu typu Tekst znajduje wszystkie rekordy rozpoczynające się literami od A do D. Jeśli w bazie danych jest używany zestaw symboli wieloznacznych ANSI-92, należy użyć znaku procentu (%) zamiast gwiazdki (*).

Like "*ar*"

Znajduje wszystkie rekordy zawierające sekwencję liter „ar”. Jeśli w bazie danych jest używany zestaw symboli wieloznacznych ANSI-92, należy użyć znaku procentu (%) zamiast gwiazdki (*).

Like "Maison Dewe?"

Znajduje wszystkie rekordy, które zaczynają się od wyrazu „Maison” i zawierają drugi pięcioliterowy ciąg znaków, w którym pierwsze 4 litery to „Dewe”, a ostatnia litera jest nieznana. Jeśli w bazie danych jest używany zestaw symboli wieloznacznych ANSI-92, należy użyć znaku podkreślenia (_) zamiast znaku zapytania (?).

#2010-02-02#

Znajduje wszystkie rekordy dla 2 lutego 2010. Jeśli w bazie danych są używane symbole wieloznaczne ANSI-92, należy ująć datę w cudzysłowy pojedyncze zamiast w znaki numeru ('2010-02-02').

< Date() - 30

Zwraca wszystkie daty starsze niż 30 dni za pomocą funkcji Date.

Date()

Zwraca wszystkie rekordy zawierające dzisiejszą datę za pomocą funkcji Date.

Between Date() And DateAdd("M";3;Date())

Zwraca wszystkie rekordy między datą dzisiejszą a datą o trzy miesiące późniejszą za pomocą funkcji Date i DateAdd.

Is Null

Zwraca wszystkie rekordy zawierające wartość null (pustą lub niezdefiniowaną).

Is Not Null

Zwraca wszystkie rekordy zawierające dowolną wartość (która nie jest wartością null).

""

Zwraca wszystkie rekordy zawierające ciąg znaków o zerowej długości. Ciąg znaków o zerowej długości jest używany, gdy trzeba dodać wartości do wymaganego pola, ale rzeczywista wartość nie jest jeszcze znana. Na przykład w polu może być wymagany numer faksu, ale niektórzy klienci nie mają faksu. W takim przypadku zamiast numeru należy wprowadzić dwa znaki cudzysłowu podwójnego bez spacji między nimi ("").

Początek strony

Porady dotyczące rozwiązywania problemów

Dlaczego jest wyświetlany ten komunikat o błędzie i jak można poprawić ten błąd?

Jeśli utworzono kwerendę usuwającą przy użyciu wielu tabel, a właściwość kwerendy Rekordy unikatowe ustawiono na wartość Nie, po uruchomieniu kwerendy w programie Access zostanie wyświetlony komunikat o błędzie: Nie można usunąć danych z podanych tabel.

Aby usunąć ten problem, należy ustawić właściwość Rekordy unikatowe kwerendy na Tak.

  1. Otwórz kwerendę usuwającą w widoku projektowania.

  2. Jeśli arkusz właściwości kwerendy jest zamknięty, naciśnij klawisz F4, aby go otworzyć.

  3. Kliknij projektanta zapytań, aby wyświetlić właściwości zapytania (a nie właściwości pola).

  4. W arkuszu właściwości zapytania odszukaj właściwość Unikatowe rekordy i ustaw ją na Tak.

Zatrzymywanie blokowania kwerendy przez tryb wyłączony

Domyślnie po otwarciu pulpitu bazy danych, która nie została wybrana za zaufany lub nie znajduje się w zaufanej lokalizacji, program Access blokuje uruchamianie wszystkich kwerend funkcjonalnych.

Jeśli użytkownik próbuje uruchomić zapytanie funkcjonalne i wydaje się, że nic się nie dzieje, należy sprawdzić, czy na pasku stanu programu Access jest wyświetlany następujący komunikat:

Akcja lub zdarzenie zostało zablokowane przez tryb wyłączony.

W przypadku wyświetlenia tego komunikatu, wykonaj następujące czynności, aby włączyć zablokowaną zawartość:

  • Na pasku komunikatów Ostrzeżenie o zabezpieczeniach kliknij przycisk Włącz zawartość, i ponownie uruchom zapytanie.

Aby uzyskać więcej informacji na temat trybu wyłączonego i zabezpieczeń programu Access zobacz artykuł zachowanie zaufanych i niezaufanych w obiektów bazy danych.

początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×