Tworzenie histogramu w programie Excel

Tworzenie histogramu w programie Excel

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Histogram jest wykresem kolumnowym przedstawiającym dane dotyczące częstotliwości.

Uwaga: W tym temacie tylko zawiera informacje o tworzeniu histogram. Aby uzyskać informacje na wykres Pareto (posortowany histogram) zobacz Tworzenie wykresu Pareto.

  1. Zaznacz dane.

    (Jest to typowy przykład danych histogramu).

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Kliknij pozycję Wstawianie > Wstaw wykres statystyczny > Histogram.

    Polecenie Histogram dostępne przy użyciu przycisku Wstaw wykres statystyczny

    Histogram można również utworzyć przy użyciu karty Wszystkie wykresy w obszarze Polecane wykresy.

Porady: 

  • Dostosowywanie wyglądu wykresu przy użyciu karty Projektowanie i Formatowanie.

  • Jeśli nie widzisz karty te, kliknij dowolne miejsce na histogramie w celu dodania opcji Narzędzia wykresów na Wstążce.

Karty Projektowanie i Formatowanie dla obszaru Narzędzia wykresów

  1. Kliknij prawym przyciskiem myszy oś poziomą wykresu, kliknij pozycję Formatuj oś, a następnie kliknij pozycję Opcje osi.

    Polecenie Formatuj oś w menu skrótów
  2. Określanie opcji, które chcesz ustawić w okienku zadań Formatowanie osi, skorzystaj z informacji w poniższej tabeli.

    Opcja

    Opis

    Według kategorii

    Wybierz tę opcję, gdy tekstowych zamiast numerycznym kategorii (oś pozioma). Histogram grupy kategorii, a następnie sumować wartości osi wartości.

    Porada: Aby zliczyć liczbę wystąpień ciągów tekstowych, dodaj kolumnę i wypełnij ją wartością „1”, a następnie wykreśl histogram i ustaw przedziały Według kategorii.

    Automatyczne

    To ustawienie domyślne histogramów. Szerokość pojemnika jest obliczane za pomocą Reguła odniesienia normalnego Scotta.

    Szerokość Kosza

    Wprowadź dodatnią dziesiętną liczbę punktów danych w każdym zakresie.

    Liczba przedziałów

    Wprowadź liczbę przedziałów histogramu (w tym przedziałów przepełnienia i niedopełnienia).

    Przedział przepełnienia

    Zaznacz to pole wyboru, aby utworzyć pojemnika dla wszystkich wartości powyżej wartości w polu po prawej. Aby zmienić wartość, wprowadź inną liczbę dziesiętną w polu.

    Przedział niedopełnienia

    Zaznacz to pole wyboru, aby utworzyć pojemnika dla wszystkich wartości poniżej lub równa wartości w polu po prawej. Aby zmienić wartość, wprowadź inną liczbę dziesiętną w polu.

    Okienko zadań Formatowanie osi

Porada: Aby uzyskać więcej informacji na temat wykresu histogramu, i jak go ułatwia wizualizowanie danych statystycznych, zobacz ten wpis w blogu histogram, Pareto, i wykresu Skrzynka i wąsy przez zespół programu Excel. Możesz również skorzystać dodatkowe informacje o innych nowych typów wykresów opisanych w tym blogu opublikować.

Opcja automatycznie (reguła odniesienia normalnego Scotta)   

Formuła dla opcji Automatyczna

Zgodnie z regułą odniesienia normalnego Scotta minimalizowane jest obciążenie w wariancji histogramu w porównaniu z zestawem danych przy założeniu normalnego rozkładu danych.

Opcja pojemnika przepełnienia   

Formuła dla opcji Przedział przepełnienia

Opcja pojemnika niedopełnienia   

Formuła dla opcji Przedział niedopełnienia
  1. Upewnij się, że załadowaniu dodatku Analysis ToolPak. Aby uzyskać więcej informacji zobacz Ładowanie dodatku Analysis ToolPak w programie Excel.

  2. W arkuszu wpisz dane wejściowe w jednej kolumnie, dodając ewentualnie etykietę w pierwszej komórce.

    Pamiętaj o użyciu ilościowych danych numerycznych, takich jak ilości elementów lub wyniki testów. Narzędzie Histogram nie obsługuje jakościowych danych numerycznych, takich jak numery identyfikacyjne wprowadzone jako tekst.

  3. W następnej kolumnie wpisz wartości graniczne w kolejności rosnącej, dodając ewentualnie etykietę w pierwszej komórce.

    Warto użyć własnych wartości granicznych, ponieważ mogą się okazać przydatniejsze do analizy. Jeśli nie wprowadzisz wartości granicznych, narzędzie Histogram utworzy równomiernie rozłożone interwały graniczne, używając jako punktów początkowych i końcowych wartości minimalnych i maksymalnych w zakresie wejściowym.

  4. Kliknij pozycję Dane > Analiza danych.

    Przycisk Analiza danych w grupie Analiza danych

  5. Kliknij pozycję Histogram > OK.

    Okno dialogowe Analiza danych

  6. W obszarze Wejście zrób tak:

    1. W polu Zakres wejściowy wprowadź odwołanie do komórki dotyczącej zakresu danych zawierającego liczby wejściowe.

    2. W polu Zakres graniczny wprowadź odwołanie do komórki dotyczące zakresu zawierającego wartości graniczne.

      Jeśli w arkuszu były używane etykiety kolumn, możesz je uwzględnić w odwołaniach do komórek.

      Porada: Zamiast ręcznego wprowadzania odwołań możesz kliknąć przycisk Obraz przycisku , aby tymczasowo zwinąć okno dialogowe i wybrać zakresy w arkuszu. Ponowne kliknięcie przycisku spowoduje rozwinięcie okna dialogowego.

  7. Jeśli etykiety kolumn zostały uwzględnione w odwołaniach do komórek, zaznacz pole wyboru Etykiety.

  8. W obszarze Opcje danych wyjściowych wybierz lokalizację danych wyjściowych.

    Możesz umieścić histogram w tym samym arkuszu, w nowym arkuszu bieżącego skoroszytu lub w nowym skoroszycie.

  9. Zaznacz co najmniej jedno z następujących pól wyboru:

    Pareto (posortowany histogram) Powoduje wyświetlenie danych uporządkowanych według malejącej częstotliwości występowania.

    Łączny udział procentowy     Powoduje wyświetlenie łącznych udziałów procentowych i dodanie wiersza łącznego udziału procentowego do wykresu histogramu.

    Wykres wyjściowy     Powoduje wyświetlenie osadzonego wykresu histogramu.

  10. Kliknij przycisk OK.

    Można dostosować do histogram, można zmienić tekst etykiet i kliknij w dowolnym miejscu na wykresie histogramu, aby za pomocą przycisków Elementy wykresu, Style wykresu i Filtr wykresu na prawo od wykresu.

  1. Zaznacz dane.

    (Jest to typowy przykład danych histogramu).

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Kliknij pozycję Wstawianie > Wykres.

    Przycisk Wykres w grupie Ilustracje na karcie Wstawianie w programie Word
  3. W oknie dialogowym Wstawianie wykresu w obszarze Wszystkie wykresy kliknij pozycję Histogram, a następnie kliknij przycisk OK.

Porady: 

  • Dostosowywanie wyglądu wykresu przy użyciu karty Projektowanie i Formatowanie na Wstążce.

  • Jeśli nie widzisz karty te, kliknij dowolne miejsce na histogramie w celu dodania opcji Narzędzia wykresów na Wstążce.

Karty Projektowanie i Formatowanie dla obszaru Narzędzia wykresów

  1. Kliknij prawym przyciskiem myszy oś poziomą wykresu, kliknij pozycję Formatuj oś, a następnie kliknij pozycję Opcje osi.

    Polecenie Formatuj oś w menu skrótów
  2. Określanie opcji, które chcesz ustawić w okienku zadań Formatowanie osi, skorzystaj z informacji w poniższej tabeli.

    Opcja

    Opis

    Według kategorii

    Wybierz tę opcję, gdy tekstowych zamiast numerycznym kategorii (oś pozioma). Histogram grupy kategorii, a następnie sumować wartości osi wartości.

    Porada: Aby zliczyć liczbę wystąpień ciągów tekstowych, dodaj kolumnę i wypełnij ją wartością „1”, a następnie wykreśl histogram i ustaw przedziały Według kategorii.

    Automatyczne

    To ustawienie domyślne histogramów.

    Szerokość Kosza

    Wprowadź dodatnią dziesiętną liczbę punktów danych w każdym zakresie.

    Liczba przedziałów

    Wprowadź liczbę przedziałów histogramu (w tym przedziałów przepełnienia i niedopełnienia).

    Przedział przepełnienia

    Zaznacz to pole wyboru, aby utworzyć pojemnika dla wszystkich wartości powyżej wartości w polu po prawej. Aby zmienić wartość, wprowadź inną liczbę dziesiętną w polu.

    Przedział niedopełnienia

    Zaznacz to pole wyboru, aby utworzyć pojemnika dla wszystkich wartości poniżej lub równa wartości w polu po prawej. Aby zmienić wartość, wprowadź inną liczbę dziesiętną w polu.

    Okienko zadań Formatowanie osi

Porada: Aby uzyskać więcej informacji na temat wykresu histogramu, i jak go ułatwia wizualizowanie danych statystycznych, zobacz ten wpis w blogu histogram, Pareto, i wykresu Skrzynka i wąsy przez zespół programu Excel. Możesz również skorzystać dodatkowe informacje o innych nowych typów wykresów opisanych w tym blogu opublikować.

Wykonaj poniższe czynności, aby utworzyć histogram w programie Excel dla komputerów Mac:

  1. Zaznacz dane.

    (Jest to typowy przykład danych histogramu).

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Na wstążce kliknij kartę Wstawianie, a następnie kliknij Ikona statystyczne wykresu (ikonastatystyczne ), a następnie w obszarze Histogram wybierz Histogram.

Porady: 

  • Dostosowywanie wyglądu wykresu przy użyciu karty Projektowanie wykresu i Formatowanie.

  • Jeśli nie widzisz karty Projektowanie wykresu i Formatowanie, kliknij dowolne miejsce na histogramie, aby dodać je do wstążki.

Aby utworzyć histogram w programie Excel 2011 dla komputerów Mac, musisz pobrać dodatek innych firm. Zobacz: nie mogę znaleźć pakietu Analysis Toolpak w programie Excel 2011 dla komputerów Mac , aby uzyskać więcej informacji.

W Excel Online histogram (wykresem kolumnowym przedstawiającym dane dotyczące częstotliwości) można wyświetlić, ale nie można go utworzyć, ponieważ wymaga dodatku Analysis ToolPak, Excel dodatek nie jest obsługiwane w Excel Online.

Jeśli masz aplikację klasyczną Excel, można za pomocą przycisku Edytuj w programie Excel Otwórz Excel na komputerze i Utwórz histogram.

Przycisk edytowania w programie Excel

  1. Naciśnij, aby zaznaczyć dane.

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Jeśli jesteś w telefonie, naciśnij ikonę Edytuj Ikona Edytuj Aby wyświetlić Wstążkę. a następnie naciśnij kartę Narzędzia główne.

  3. Wybierz polecenie Wstaw > Wykresy > Histogram.

    W razie potrzeby możesz dostosować elementów wykresu.

    Uwaga: Ta funkcja jest dostępna tylko dla posiadaczy subskrypcji usługi Office 365. Jeśli jesteś subskrybentem usługi Office 365, upewnij się, że masz najnowszą wersję pakietu Office.

    Wypróbuj usługę Office 365 lub najnowszą wersję programu Excel

  1. Naciśnij, aby zaznaczyć dane.

    Dane użyte do utworzenia przykładowego histogramu powyżej
  2. Jeśli jesteś w telefonie, naciśnij ikonę Edytuj Ikona Edytuj Aby wyświetlić Wstążkę, a następnie wybierz dla użytkowników domowych.

  3. Wybierz polecenie Wstaw > Wykresy > Histogram.

Aby utworzyć histogram w Excel, udostępnienia dwóch typów danych — dane, które chcesz analizować, a wartości graniczne reprezentujące interwałów, które chcesz zmierzyć częstotliwości. Zorganizuj dane z dwóch kolumn w arkuszu. Te kolumny musi zawierać następujące dane:

  • Wprowadzania danych    To dane, które chcesz analizować za pomocą narzędzia Histogram.

  • Graniczne    Te liczby przedstawić interwałów, które mają Histogram narzędzi służących do pomiaru danych wejściowych, analizy danych.

Korzystając z narzędzia Histogram, Excel zlicza punktów danych w Koszu poszczególnych danych. Punkt danych znajduje się w Koszu określonego, jeśli liczba jest większa niż dolna granica i równa lub mniejsza niż większa powiązana pojemnika danych. Jeśli pominie się argument zakres graniczny, Excel tworzy się równomiernie rozłożonych przedziałów między wartości minimalne i maksymalne danych wejściowych.

Wyniki analizy histogram jest wyświetlany w nowym arkuszu (lub w nowym skoroszycie) i jest wyświetlana tabela histogramu i wykresem kolumnowym odzwierciedlającym dane w tabeli histogramu.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×