Tworzenie diagramu składników UML

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Możesz utworzyć diagram składników UML pokazanie składniki, porty, interfejsów i relacje między nimi. Najpierw otwórz szablon Składnik UML i wybierz jedną z opcji cztery szablonu. Następnie wzornika Składnik UML pojawi się wraz z kształtów, które są zgodne z 2,5 UML standardowy.

Wzornik Składnik UML i przykład kształty na stronie

Uwaga: Wzornik Składnik UML jest dostępna tylko w przypadku subskrybentów programu Visio Online Plan 2 . Jeśli masz subskrypcję, Upewnij się, że masz najnowszą wersję programu Visio.

  1. Uruchom program Visio. Lub jeśli masz już otwarciu pliku, kliknij pozycję plik > Nowy.

  2. Przejdź do kategorii > oprogramowania i baz danych > Składnik UML.

  3. Wybierz pusty szablon lub lub diagramy startowe trzy z nich. Po wybraniu szablonu, który ma, kliknij przycisk Utwórz.

  4. Powinien zostać wyświetlony okna Kształty obok diagramu. Jeśli nie widzisz, przejdź do pozycji Widok > Okienka zadań i upewnij się, że jest zaznaczony kształt. Jeśli nadal nie widać, kliknij przycisk Rozwiń okno kształty Okno Kształty przycisk Rozwiń po lewej stronie.

  5. Na karcie Widok upewnij się, że jest zaznaczone pole wyboru obok Punkty połączeń. Spowoduje to połączenie, którego punkty są wyświetlane po uruchomieniu łączenie kształtów.

  6. Teraz przeciągnij kształty, które chcesz uwzględnić na diagramie z okna Kształty na stronę. Aby zmienić tekst etykiet, kliknij dwukrotnie etykiet.

Kiedy należy używać

Kształty składnika dla każdej jednostki funkcjonalności systemu lub w aplikacji.

Kształt składnik "Store"

Pokazywanie lub ukrywanie stereotypu

Kliknij prawym przyciskiem myszy kształt, który chcesz pokazać lub ukryć etykiety stereotyp.

Kliknij prawym przyciskiem myszy, polecenie Pokaż stereotyp, << składnik >> Tekst etykiety

Podsystemów

Kształt składnik jako podsystemu, która zawiera inne składniki. Po prostu zmiany rozmiaru, aby był większy i upuść inne składniki znajdujący się na nim. Gdy zostanie wyświetlony zielone wyróżnienie, zwolnij przycisk myszy. Od tej chwili większy kształt będzie działać jako kontenera, a mniejszym kształtem zostaną przeniesione z nim.

Porada: Jeśli składnik znika po przeciągnięciu go na wierzchu innego składnika, następnie przenieś go na wierzch, naciskając klawisze CTRL + SHIFT + F.

Przechowywanie podsystemu ze składnikiem kolejności przeciągany znajdujący się na nim

Kiedy należy używać

  1. Kształt Interfejsu podany jest chcesz określić realizacji interfejs klasy.

  2. Za pomocą Interfejsu wymagane chcesz określić zależność klasy-interfejsu.

Połączenie dwóch interfejsów, 1: kształt podany interfejs kończące się literami okrąg, 2: kształt wymagany interfejs kończące się literami socket

Krok 1

Przeciągnij kształt Podany interfejs do strony, a wyrównać ramka portu z punktu połączenia. Pamiętaj, że jest podłączone po wyświetleniu zielone wyróżnienie wokół punktu połączenia.

Opisane kształt interfejs przyklejony do kształtu składnik

Krok 2

Przeciągnij kształt Interfejsu wymagane do strony, a wyrównać ramka portu z punktu połączenia, a także. Pamiętaj, że jest podłączone po wyświetleniu zielone wyróżnienie wokół punktu połączenia.

Wymagane kształt interfejs przyklejony do kształtu składnik

Krok 3

Aby połączyć oba dostarczonych i wymagane interfejs razem, najpierw zaznacz kształt wymagane interfejsu. Następnie znajdź żółty uchwyt.

Żółty uchwyt dla kształtu interfejs wymagane

Krok 4

Przeciągnij żółty uchwyt, aby połączyć się z interfejsu opisane.

Wymagane kształt interfejs połączony z udostępnionej interfejsu

Wyprostować łączniki

Jeśli łącznik trwa zbyt wiele zmieni się, kliknij go prawym przyciskiem myszy, a następnie kliknij r Może połączyć się proste.

Pokazywanie liczebność

W razie potrzeby kliknij łącznik prawym przyciskiem myszy i wybierz pozycję Pokaż liczebność. Po wykonaniu tych są wyświetlane czterema polami tekstowymi, miejsce, w którym można dodać szczegóły. Jeśli nie potrzebujesz wszystkie pola tekstowe, należy usunąć te, których nie potrzebujesz.

Zmiana typu łącznika

Możesz zmienić typ łącznika. Możesz na przykład zmienić z skojarzenia do skojarzenia przekierowanie. Kliknij prawym przyciskiem myszy łącznik, a następnie kliknij polecenie Ustaw typ łącznika.

Nawiązywanie połączenia dynamiczne zamiast punktu połączenia

Jeśli przewidujesz wiele przenoszenie kształtów, należy rozważyć, czy połączenie dynamiczne zamiast punkt połączenia.

Przenoszenie lub obracanie tekstu na łączników

Prawdopodobnie musisz obracanie i przenoszenie tekstu na swojej linie łączników. Oto jak to zrobić:

  1. Kliknij pusty obszar strony, aby usunąć zaznaczenie nic może być zaznaczony.

  2. Na karcie Narzędzia główne w grupie Narzędzia kliknij Narzędzie blok tekstu Przycisk bloku tekstu

  3. Kliknij łącznik, który zawiera tekst, którą chcesz obrócić lub przenieść.

  4. Przeciągnij blok tekstu, aby go przenieść, lub obracanie go przy użyciu Uchwyt obrotu Uchwyt obrotu podczas przeciągania

  5. Gdy skończysz, kliknij przycisk Wskaźnik — narzędzie Przycisk wskaźnika

    Po przełączeniu się do przycisk Wskaźnik — narzędzie Przycisk wskaźnika tekst pozwala na tej samej pozycji względem kształtu. Jeśli przeciągnij wskaźnik nad tekstem za pomocą Narzędzia wskaźnik Przycisk wskaźnika kształt będzie również przenieść. Aby przenieść tekst niezależnie od kształtu, wróć do Narzędzia blok tekstu Przycisk bloku tekstu .

Zobacz też

Diagramy UML w programie Visio

Tworzenie diagramu UML komunikacji

Tworzenie diagramu wdrożenia UML

Tworzenie diagramu sekwencji UML

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×