Tworzenie diagramu przestawnego programu Visio 2007 na podstawie danych arkusza programu Excel 2007

Ważne: Ten artykuł został przetłumaczony maszynowo, zobacz zastrzeżenie. Angielskojęzyczną wersję tego artykułu można znaleźć tutaj .

Okładka książki Advanced Microsoft Office Documents 2007 Edition Inside Out

Wewnątrz Pomniejsz dokumenty zaawansowane Microsoft® Office 2007 Edition
Przez Stephanie Krieger

Stephanie Krieger jest, specjalista MVP w dziedzinie programu Microsoft Office System, a także autor książki Advanced Microsoft Office Documents 2007 Edition Inside Out i Projektant dokumentu programu Microsoft Office. Jako konsultant profesjonalny dokument Anna ma pomógł wiele firm globalnej opracowywać rozwiązania w przedsiębiorstwie pakietu Microsoft Office i nauczanych wiele pracownikom tworzenie profesjonalnych dokumentów przy opis jak w programach pakietu Office "Pomyśl." Stephanie regularnie zapisuje dla kilku stron sieci Web firmy Microsoft i często zapewnia emisjami Microsoft Office.

Aby dowiedzieć się więcej na temat innych książek w programie Microsoft Office 2007, odwiedź witrynę Microsoft Press.

W tym artykule

Generowanie diagramu przestawnego

Formatowanie i zarządzanie diagramu przestawnego

Jak można edytować etykietka ekranowa zastosowanego kształtu na diagramie przestawnym

Jest to jeden z pierwszych dziesięciu Moje ulubione funkcje w wersji pakietu Office 2007. Diagram przestawny to po prostu co go brzmi jak — diagram, której będą wyświetlane tylko dane, takie jak tabeli przestawnej lub wykresu przestawnego. Diagram przestawny to hierarchicznej diagram (podobnie jak w strukturze schematu organizacyjnego) pozostanie połączony z danymi, tak, aby mogą przeglądać dane graficzne w możliwie jak najwięcej różnych konfiguracji, jak pozwala na danych.

Generowanie diagramu przestawnego

Aby utworzyć na diagramie przestawnym, Rozpocznij instalację danych w programie Excel dla tabeli przestawnej (dane w kolumnach z jednym wierszem nagłówków) i wartości we wszystkich komórkach, a następnie wykonaj jedną z następujących czynności.

  • Jeśli dane programu Excel jest sformatowana jako tabelę, na karcie Narzędzia tabel, projektowanie kliknij pozycję Opcje eksportu, a następnie kliknij pozycję Eksportuj tabelę do diagramu przestawnego programu Visio.

  • Czy dane programu Excel jest sformatowana jako tabelę lub zakres, można także tworzyć diagramu przestawnego z programu Visio. W tym celu w menu plik wskaż polecenie Nowy, wskaż polecenie biznesowe, a następnie kliknij diagramu przestawnego. Wykonaj kreatora, aby wybrać plik programu Excel, a w razie potrzeby wybierz określone arkusza lub zakresu, w tym pliku. Po prostu zachować klikając Dalej do momentu wyświetlenia opcji zakończenia. Kliknij przycisk Zakończ, aby utworzyć tabelę.

    Podczas tworzenia diagramu przestawnego przy użyciu tego kreatora źródła danych można pochodzą skoroszytu programu Excel, bazy danych programu Access, listy programu Windows SharePoint Services, bazy danych programu SQL Server lub innego OLEBD (obiekt połączony baza danych osadzony) lub ODBC (Open Database Connectivity) źródło danych zgodne.

    Ważne: Jeśli plik programu Excel zawiera wszystkie wykresy na własne arkusze, użyj metody opisane poniżej, aby wygenerować diagramu przestawnego na karcie Narzędzia tabel, projektowanie w programie Excel. Lub otwieranie pliku programu Excel przed uruchomieniem kreatora diagramu przestawnego programu Visio. Kreator nie może uzyskać dostęp do plików programu Excel, które zawierają wykresów, arkusze, chyba że plik jest aktualnie otwierane.

Przy użyciu jednej z powyższych metod stronie diagramu przestawnego jest generowany z pojedynczego kształtu, aby wyznaczyć najwyższego poziomu diagramu i identyfikowanie danych źródłowych, ostatniej aktualizacji i wszystkie filtry, w miejscu kształtu, jak pokazano na poniższej ilustracji.

Kształty na stronie diagramu przestawnego w programie Visio 2007

Należy zauważyć, że wszystkie dostępne pola dla diagramu przestawnego znajdują się w okienku diagramu przestawnego podzielone na kategorie (odpowiednik pola wierszy i kolumn w tabeli przestawnej) i sum (odpowiednik wartości pól w tabeli przestawnej).

Początek strony

Formatowanie i zarządzanie diagramu przestawnego

Wystarczy kliknąć, aby zastosować kategorię w okienku diagramu przestawnego do strony i Visio wygeneruje dotyczy kształtów. Ponadto w okienku wybierz sum, które mają być wyświetlane przy każdym kształcie. W poniższym przykładzie przedstawiono szkolenie koszt osoby według obszaru działania firmy.

Diagram przestawny przedstawiający koszty szkolenia podzielone według obszaru działania firmy

Poniżej przedstawiono kilka porad dotyczących klawiszy ułatwia tworzenie diagramu przestawnego potrzebujesz.

  • Suma w poprzednim przykładzie diagramu przestawnego jest wyświetlany jako koszt osoby, ponieważ jest to nazwa nagłówka odpowiedniej kolumny w danych programu Excel. Ale, ponieważ w tym przypadku były wyświetlane rzeczywiście koszt całkowity szkolenia dla działu, można zmienić nazwę pola. Aby zmienić nazwę dowolnej kategorii lub pole sumy, jak będzie wyglądać na diagramie, kliknij strzałkę, która jest wyświetlana po wskaż pole w okienku diagramu przestawnego, a następnie kliknij pozycję Konfiguruj kolumnę. Edytowanie nazwy, stosownie do potrzeb, a następnie kliknij przycisk OK. Nazwa pola automatycznie zmieni się w całej tabeli.

  • Aby przerwać się jeszcze bardziej kategorie, wybierz kształty kategorii, do których chcesz rozbicie, a następnie kliknij odpowiednią kategorię, dla której chcesz wyświetlić szczegóły. Na przykład aby wyświetlić koszt osoby w działu rozwoju firmy, zaznacz kształt Rozwoju firmy, który zawiera sumę, a następnie kliknij nazwę w okienku diagramu przestawnego. Wynik wygląda.

    Diagram przestawny przedstawiający koszty szkolenia podzielone według pracowników działu rozwoju firmy

    Ponieważ można pokazać szczegóły dla poszczególnych kształtów, jeśli chcesz dodać nowy Podkategoria dla wszystkich należy wybrać wszystkie kształty w kategorii. Należy wybrać część kształtu, który zawiera sumy i nie nagłówek kształtu. Aby szybko zaznaczyć wszystkie kształty w kategorii, wskaż nazwę kategorii w okienku diagramu przestawnego, kliknij wyświetloną strzałkę listy rozwijanej, a następnie kliknij przycisk Zaznacz wszystko.

  • Można formatować i zmienianie rozmiaru kształtów, tak jak robisz kształtów diagramu w programie Visio. Aby zmienić rozmiar kilku kształtów jednocześnie, zaznacz wszystkie kształty, aby zmienić rozmiar, a następnie przeciągnij z uchwyty wokół zaznaczenia, aby zmienić rozmiar ich jako grupy.

  • Aby zmienić format liczbowy sumy, w menu diagramu przestawnego kliknij Edytowanie grafiki związanej z danymi. Lub, w okienku diagramu przestawnego kliknij przycisk Inne akcje i kliknij pozycję Edytuj grafikę związaną z danymi. Następnie wykonaj następujące czynności:

    1. Zaznacz grafikę związaną z danymi zawierającą nazwę pola, dla którego chcesz zmienić format, a następnie kliknij pozycję Edytuj element.

    2. W polu Format wartości, kliknij wielokropek, aby otworzyć okno dialogowe Format danych, w którym można określić liczbę formatowanie, możesz potrzebujesz.

  • Kształty na diagramie przestawnym, które zawierają sumy dla każdego kształtu w kategorii są nazywane węzłów diagramu przestawnego. Możesz zastosować bardziej interesujące kształtów do węzłów diagramu przestawnego przy użyciu opcji Zastosuj kształt w menu diagramu przestawnego lub okienka. Po prostu wybierz opcję węzłów diagramu przestawnego, do którego chcesz zastosować kształtu, a następnie w oknie dialogowym Stosowanie kształtów, kliknij kształt, a następnie kliknij przycisk OK. Kształty z wzorników działy i Obiekty przepływu pracy są dostępne automatycznie to okno dialogowe.

    Aby udostępnić innych kształtów diagramu przestawnego w menu plik wskaż polecenie Kształty, a następnie wybierz pozycję wzorniki, które mają. Po otwarciu nowego wzornika staje się dostępna z listy rozwijanej wzornik w oknie dialogowym Stosowanie kształtu

  • Aby uzyskać dostęp do opcji filtru dla dowolnego pola na diagramie, kliknij strzałkę, która jest wyświetlana po wskaż pola w okienku diagramu przestawnego, a następnie kliknij pozycję Konfiguruj kolumnę.

  • Z menu diagramu przestawnego można zarządzać układu diagramu, sortowanie zaznaczonych kształtów na diagramie, Scalanie zaznaczonych kształtów w jeden kształt (może to być doskonały sposób, aby oszczędzać miejsce, gdy chcesz wstawić podział się kilka kategorii na diagramie pojedynczego) i ustawić wiele opcji służących do diagramu przestawnego.

    Zmienianie nazwy tabeli za pomocą okna dialogowego Opcje diagramu przestawnego dostępne menu diagramu przestawnego, wybierz pozycję, aby pokazać lub ukryć elementy diagramu i poprawianie źródła danych, jak pokazano na ilustracji, znajdujący się.

    Okno dialogowe Opcje diagramu przestawnego w programie Visio 2007

Początek strony

Jak można edytować etykietka ekranowa zastosowanego kształtu na diagramie przestawnym

Kształt zostanie zastosowany do węzła diagramu przestawnego, zgodnie z opisem na powyższej liście, można zmienić na etykietce ekranowej wyświetlanej po wskazaniu kształt. Jednak jeśli zaznacz kształt, a następnie kliknij przycisk Dołącz oczekiwano znaleźć odpowiednią opcję Edytuj etykietkę ekranową kształtu, może być zobaczysz opcji Etykietkę ekranową kształtu zamiast tego. Opcja ostatnie wskazuje, że dla zaznaczenia istnieje obecnie nie etykietka ekranowa.

Przyczynę nie widzisz opcji edycji jest zaznaczenie faktycznie na grupy kształtów. Kształt stosowane jest automatycznie zgrupowane z węzeł diagramu przestawnego. Po raz drugi (to jest mniejsza niż dwukrotne) do wybierz tylko — edytowanie istniejących etykietka ekranowa zastosowanego kształtu, kliknij jeden raz na kształcie zastosowanego (po wybraniu tej opcji grupy), a następnie kliknij przycisk zastosowanego kształt należący do grupy. Gdy kształt jest zaznaczony, pojawi się znakiem x w środku każdego z uchwytami kształtu. Po właśnie kształt jest zaznaczony, kliknij menu Wstaw, a opcja Edytuj etykietkę ekranową kształtu będzie dostępna.

Dzięki pomocy technicznej odtwarzania Jagadeesh Parameswaran, intrepid członek zespołu test programu Visio 2007, w tym i kilka innych porady dotyczące sygnalizować.

Początek strony

Uwaga: Zrzeczenie dotyczące tłumaczenia maszynowego: Ten artykuł został przetłumaczony przez system komputerowy bez interwencji człowieka. Firma Microsoft udostępnia te tłumaczenia maszynowe, aby ułatwić użytkownikom, którzy nie znają języka angielskiego, korzystanie z zawartości dotyczącej produktów, usług i technologii firmy Microsoft. Ponieważ ten artykuł został przetłumaczony maszynowo, może zawierać błędy w słownictwie, składniowe lub gramatyczne.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×