Przejdź do głównej zawartości

SUMA.JEŻELI, funkcja

Funkcja SUMA.JEŻELI służy do sumowania wartości z zakresu spełniającego określone kryteria. Załóżmy na przykład, że mają zostać zsumowane liczby z danej kolumny, które są większe od 5. W tym celu można zastosować następującą formułę: =SUMA.JEŻELI(B2:B25,">5")

Docieranie do odbiorców za pomocą ogłoszeń

Ten klip wideo jest częścią kursu szkoleniowego zatytułowanego Dodawanie liczb w programie Excel.

Porady: 

  • Kryteria można też zastosować do jednego zakresu i zsumować odpowiednie wartości należące do innego zakresu. Na przykład formuła =SUMA.JEŻELI(B2:B5;"Jan";C2:C5) zsumuje wartości z zakresu C2:C5, dla których zawartość odpowiadających im komórek z zakresu B2:B5 jest równa „Jan”.

  • Aby uzyskać informacje o sumowaniu zawartości komórek na podstawie wielu kryteriów, zobacz SUMA.WARUNKÓW, funkcja.

Ważne: Funkcja suma. Jeżeli zwraca niepoprawne wyniki, gdy jest używana w celu dopasowania ciągów zawierających więcej niż 255 znaków lub ciągu #VALUE!.

Składnia

SUMA.JEŻELI(zakres;kryteria;[suma_zakres])

W składni funkcji SUMA.JEŻELI występują następujące argumenty:

  • zakres   Argument wymagany. Jest to zakres komórek, do których zostaną zastosowane kryteria. Komórki w każdym zakresie muszą być liczbami lub nazwami, tablicami albo odwołaniami zawierającymi liczby. Wartości puste i wartości tekstowe są ignorowane. Wybrany zakres może zawierać daty w standardowym formacie programu Excel (przykłady poniżej).

  • kryteria   Argument wymagany. Są to kryteria w postaci liczby, wyrażenia, odwołania do komórki, tekstu lub funkcji określającej, które komórki będą dodawane. Symbole wieloznaczne można dołączać — znakiem zapytania (?) w celu dopasowania dowolnego pojedynczego znaku, gwiazdka (*) w celu dopasowania dowolnej sekwencji znaków. Aby znaleźć znak zapytania lub gwiazdkę, przed szukanym znakiem należy wpisać tyldę (~).

    Na przykład kryteria można wyrazić jako 32, ">32", B5, "3?", "Apple *", "* ~?" lub TODAY ().

    Ważne: Wszelkie kryteria tekstowe oraz zawierające symbole matematyczne lub logiczne należy ująć w podwójny cudzysłów ("). Kryteria liczbowe nie wymagają cudzysłowów.

  • suma_zakres   Argument opcjonalny. Są to rzeczywiste komórki, które podlegają sumowaniu w przypadku, gdy należy zsumować komórki inne niż określone w argumencie zakres. Jeśli argument suma_zakres zostanie pominięty, program Excel zsumuje komórki wyznaczone przez argument zakres (te same, do których mają zastosowanie kryteria).

    Sum_range powinien mieć ten sam rozmiar i kształt co zakres. Jeśli tak nie jest, może wystąpić wydajność, a formuła spowoduje zsumowanie zakresu komórek, który rozpoczyna się od pierwszej komórki w sum_range , ale ma te same wymiary co zakres. Na przykład:

    zakres

    suma_zakres

    Rzeczywiste sumowane komórki

    A1:A5

    B1:B5

    B1:B5

    A1:A5

    B1: K5

    B1:B5

Przykłady

Przykład 1

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

Wartość nieruchomości

Prowizja

Dane

100 000 zł

7 000 zł

250 000 zł

200 000 zł

14 000 zł

300 000 zł

21 000 zł

400 000 zł

28 000 zł

Formuła

Opis

Wynik

=SUMA.JEŻELI(A2:A5;">160000";B2:B5)

Suma prowizji dla wartości nieruchomości powyżej 160 000 zł.

63 000 zł

=SUMA.JEŻELI(A2:A5;">160000")

Suma wartości nieruchomości powyżej 160 000 zł.

900 000 zł

=SUMA.JEŻELI(A2:A5;300000;B2:B5)

Suma prowizji dla wartości nieruchomości równych 300 000 zł.

21 000 zł

=SUMA.JEŻELI(A2:A5;">" &C2;B2:B5)

Suma prowizji dla wartości nieruchomości powyżej kwoty zawartej w komórce C2.

49 000 zł

Przykład 2

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

Kategoria

Żywność

Sprzedaż

Warzywa

Pomidory

2 300 zł

Warzywa

Brokuły

5 500 zł

Owoce

Pomarańcze

800 zł

Masło

400 zł

Warzywa

Marchew

4 200 zł

Owoce

Jabłka

1 200 zł

Formuła

Opis

Wynik

=SUMA.JEŻELI(A2:A7;"Owoce";C2:C7)

Łączna wartość sprzedaży produktów żywnościowych w kategorii „Owoce”.

2 000 zł

=SUMA.JEŻELI(A2:A7;"Warzywa";C2:C7)

Łączna wartość sprzedaży produktów żywnościowych w kategorii „Warzywa”.

12 000 zł

=SUMA.JEŻELI(B2:B7;"*y";C2:C7)

Łączna wartość sprzedaży produktów żywnościowych, których nazwy kończą się literą „y” (pomidory i brokuły).

4 300

=SUMA.JEŻELI(A2:A7;"";C2:C7)

Łączna wartość sprzedaży produktów żywnościowych niezakwalifikowanych do żadnej kategorii.

400 zł

Początek strony

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Funkcja SUMA.WARUNKÓW sumuje wszystkie argumenty, które spełniają wiele kryteriów

Funkcja SUMA.KWADRATÓW sumuje wartości po wykonaniu operacji matematycznej podniesienia każdej z nich do kwadratu

Funkcja LICZ.JEŻELI dodaje tylko wartości spełniające pojedyncze kryterium

Funkcja LICZ.WARUNKI zlicza tylko wartości, które spełniają wiele kryteriów

Funkcja WARUNKI (usługa Office 365, program Excel 2016 lub nowszy)

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Funkcje matematyczne i trygonometryczne

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×