Sposoby udostępniania bazy danych programu Access dla komputerów stacjonarnych

Sposoby udostępniania bazy danych programu Access dla komputerów stacjonarnych

Bazę danych programu Access możesz udostępniać na kilka sposobów, w zależności od potrzeb i dostępności zasobów. W tym artykule omówiono dostępne opcje i ich zalety oraz wskazano zasoby umożliwiające uzyskanie dodatkowych informacji na temat wybranej przez Ciebie metody.

Aby można było wprowadzać zmiany w projekcie bazy danych, na komputerze musi być zainstalowany program Access.

W tym artykule

Udostępnianie danych przy użyciu folderów sieciowych

Udostępnianie podzielonej bazy danych

Udostępnianie bazy danych w witrynie programu SharePoint

Udostępnianie bazy danych za pomocą łączenia z listami programu SharePoint

Udostępnianie bazy danych przy użyciu serwera

Zagadnienia, które należy uwzględnić, wybierając metodę

Udostępnianie danych przy użyciu folderów sieciowych

Jest to najprostsza opcja, która ma najmniejsze wymagania, ale oferuje najbardziej ograniczoną funkcjonalność. W tej metodzie plik bazy danych jest przechowywany na udostępnionym dysku sieciowym i używany przez wszystkie osoby jednocześnie. Jeśli wielu użytkowników zmienia dane w tym samym czasie, niektóre ograniczenia tej metody obejmują niezawodność i dostępność, ponieważ wszystkie obiekty bazy danych są udostępnione. Ta technika może również zmniejszać wydajność ze względu na to, że wszystkie obiekty bazy danych są wysyłane przez sieć.

Ta opcja może być odpowiednia, jeśli tylko kilka osób będzie używać bazy danych jednocześnie i użytkownicy nie muszą zmieniać projektu bazy danych.

Uwaga: Ta metoda jest mniej bezpieczna niż inne metody udostępniania bazy danych, ponieważ każdy użytkownik ma pełną kopię pliku bazy danych. Zwiększa to ryzyko nieautoryzowanego dostępu.

Aby udostępnić bazę danych przy użyciu folderu sieciowego:

  1. Jeśli nie istnieje jeszcze folder sieciowy, skonfiguruj go.

    Aby uzyskać pomoc dotyczącą tej czynności, zobacz Pomoc systemu operacyjnego na komputerze, na którym będzie udostępniana baza danych. Jeśli folder udostępniony znajduje się na serwerze sieciowym, może być potrzebna pomoc administratora sieci.

  2. Upewnij się, że program Access jest skonfigurowany tak, aby był otwierany w trybie udostępniania na komputerach wszystkich użytkowników. Jest to ustawienie domyślne, ale należy je mimo wszystko sprawdzić — jeśli użytkownik otworzy bazę danych w trybie wyłączności, zakłóci dostępność danych. Wykonaj następujące czynności na wszystkich komputerach:

    1. Uruchom program Access i w menu Plik kliknij polecenie Opcje. Uwaga: jeśli korzystasz z programu Access 2007, kliknij przycisk pakietu Microsoft Office, a następnie kliknij polecenie Opcje programu Access.

    2. W oknie dialogowym Opcje programu Access kliknij pozycję Ustawienia klienta. Uwaga: jeśli korzystasz z programu Access 2007, kliknij pozycję Zaawansowane.

    3. W sekcji Zaawansowane w obszarze Domyślny tryb otwierania wybierz opcję Udostępniony, kliknij przycisk OK, a następnie zamknij program Access.

  3. Skopiuj plik bazy danych do folderu udostępnionego. Po skopiowaniu pliku ustaw jego atrybuty tak, aby umożliwić odczytywanie i zapisywanie. Użytkownicy korzystający z bazy danych muszą mieć prawa odczytu i zapisu.

  4. Utwórz skrót do pliku bazy danych na komputerze każdego z użytkowników. W oknie dialogowym Właściwości skrótu wprowadź ścieżkę do pliku bazy danych we właściwości Element docelowy, używając adresu UNC, a nie litery zamapowanego dysku. Na przykład użyj ścieżki \\nazwa_komputera\udostępniona.accdb zamiast F:\przykładowa.accdb.

    Uwaga: Użytkownicy mogą sami wykonać ten krok.

Początek strony

Udostępnianie podzielonej bazy danych

Ta opcja jest przydatna w przypadku braku witryny programu SharePoint i serwera bazy danych. Udostępnionych podzielonych baz danych można używać za pośrednictwem sieci lub witryny programu SharePoint. Podczas dzielenia baza danych jest umieszczana w dwóch plikach — wewnętrznej bazie danych zawierającej tabele danych oraz zewnętrznej bazie danych zawierającej wszystkie inne obiekty bazy danych, takie jak kwerendy, formularze i raporty. Każdy użytkownik pracuje z danymi za pomocą lokalnej kopii zewnętrznej bazy danych.

Zalety dzielenia bazy danych

  • Zwiększona wydajność   Przez sieć udostępniane są tylko dane — bez tabel, zapytań, formularzy, raportów, makr i modułów.

  • Większa dostępność    Transakcje bazy danych, takie jak edytowanie rekordów, są wykonywane szybciej.

  • Ulepszone zabezpieczenia    Użytkownicy uzyskują dostęp do wewnętrznej bazy danych za pomocą tabel połączonych, dzięki czemu ryzyko uzyskania nieautoryzowanego dostępu do danych przez intruzów za pośrednictwem zewnętrznej bazy danych jest mniejsze.

  • Większa niezawodność    Jeśli użytkownik napotka problem i baza danych zostanie nieoczekiwanie zamknięta, uszkodzenie pliku bazy danych będzie zwykle ograniczone do kopii zewnętrznej bazy danych, która została otworzona przez użytkownika.

  • Elastyczne środowisko projektowania    Każdy użytkownik może niezależnie projektować zapytania, formularze, raporty i inne obiekty bazy danych, nie zakłócając pracy innym użytkownikom. Ponadto można opracować i rozpowszechnić nową wersję zewnętrznej bazy danych bez zakłócania dostępu do danych przechowywanych w wewnętrznej bazie danych.

Jeśli ta opcja Ci odpowiada, przejdź do instrukcji w temacie Dzielenie bazy danych programu Access.

Początek strony

Udostępnianie bazy danych w witrynie programu SharePoint

Ważne    Firma Microsoft nie zaleca już tworzenia aplikacji sieci Web programu Access ani używania ich w programie SharePoint. Jako alternatywę rozważ tworzenie rozwiązań biznesowych bez użycia kodu dla sieci Web i urządzeń przenośnych za pomocą usługi Microsoft PowerApps.

W przypadku używania serwera z programem SharePoint, a zwłaszcza serwera z usługami programu Access, można korzystać z kilku przydatnych opcji. Dostępnych jest kilka metod integracji z programem SharePoint, które ułatwiają korzystanie z bazy danych. Gdy publikujesz internetową bazę danych, usługi programu Access tworzą witrynę programu SharePoint zawierającą tę bazę danych. Wszystkie obiekty i dane bazy danych zostają przeniesione na listy programu SharePoint w tej witrynie.

W przypadku publikowania bazy danych jest ona przenoszona do sieci Web. Można utworzyć formularze i raporty sieci Web działające w oknie przeglądarki, a ponadto tworzyć standardowe obiekty programu Access (czasami zwane obiektami klienta w celu odróżnienia ich od obiektów sieci Web). Aby używać obiektów klienta programu Access, trzeba mieć ten program zainstalowany na komputerze, jednak wszystkie obiekty bazy danych w programie SharePoint są udostępniane.

Uwaga: Użytkownicy, którzy mają zainstalowany program Access, mogą korzystać z obiektów klienta z bazy danych sieci Web. W przeciwnym razie można używać tylko obiektów bazy danych sieci Web.

Usługi programu Access stanowią platformę tworzenia baz danych, których można używać w sieci Web. Za pomocą programu Access 2010 i programu SharePoint można zaprojektować i opublikować bazę danych sieci Web, z której użytkownicy będą korzystać w przeglądarce sieci Web.

Uwaga:  Do opublikowania bazy danych w witrynie programu SharePoint są potrzebne uprawnienia projektanta do danej witryny.

Formularze, raporty i makra interfejsu użytkownika są uruchamiane w przeglądarce.

W przypadku używania internetowej bazy danych dane są przechowywane na listach programu SharePoint: wszystkie tabele stają się listami programu SharePoint, a rekordy — elementami list, dzięki czemu można używać uprawnień programu SharePoint w celu kontrolowania dostępu do internetowej bazy danych.

Kwerendy i makra danych są uruchamiane na serwerze: całe przetwarzanie języka SQL odbywa się na serwerze, co pomaga zwiększyć wydajność sieci dzięki ograniczeniu ruchu w zestawach wyników.

Zapisywanie bazy danych w bibliotece dokumentów 

Bazę danych można zapisać w dowolnej bibliotece dokumentów programu SharePoint. Ta metoda jest podobna do zapisywania bazy danych w folderze sieciowym i zapewnia wygodny sposób zarządzania dostępem do bazy danych. Tworzenie łączy do list programu SharePoint umożliwia udostępnianie danych, ale nie obiektów bazy danych. Każdy użytkownik korzysta z własnej kopii bazy danych.

Jeśli na przykład witryna programu SharePoint zawiera listy do śledzenia problemów związanych z obsługą klientów i przechowywania informacji o pracownikach, można utworzyć bazę danych programu Access, która będzie aplikacją zewnętrzną dla tych list. Korzystając z zapytań programu Access, można analizować problemy, a dzięki raportom programu Access można formatować i publikować pisemne raporty ze spotkań dotyczących stanu zespołu. Osobom, które mają na swoich komputerach zainstalowany program Access, można udostępnić zapytania i raporty tego programu w menu Widok dla listy programu SharePoint. Osoby wyświetlające listę w witrynie programu SharePoint będą mogły lokalizować i otwierać zapytania, raporty oraz inne obiekty programu Access przez kliknięcie menu Widok. Osoby, które nie mają programu Access, także będą mogły używać danych zawartych na listach, korzystając z widoków programu SharePoint.

  1. Otwórz bazę danych, którą chcesz udostępnić.

  2. Na karcie Plik kliknij pozycję Zapisz jako.

  3. Kliknij pozycję Zapisz bazę danych jako w sekcji Zaawansowane, wybierz pozycję SharePoint, a następnie kliknij przycisk Zapisz jako.

    Uwagi: 

    • Jeśli korzystasz z programu Access 2007, kliknij przycisk pakietu Microsoft Office, a następnie kliknij pozycję Publikuj > Serwer zarządzania dokumentami.

    • Jeśli korzystasz z programu Access 2010, kliknij pozycję Plik > Zapisz i publikuj > Zapisz bazę danych jako > SharePoint.

  4. W oknie dialogowym Zapisz w programie SharePoint przejdź do biblioteki dokumentów, której chcesz użyć.

  5. Sprawdź nazwę i typ pliku bazy danych, w razie potrzeby wprowadź zmiany, a następnie kliknij przycisk Zapisz.

Aby uzyskać więcej informacji, zobacz Publikowanie w usługach programu Access i Importowanie danych z listy programu SharePoint lub łączenie z nią danych.

Początek strony

Udostępnianie bazy danych za pomocą łączenia z listami programu SharePoint

Ta metoda daje te same korzyści, co używanie podzielonej bazy danych, i użytkownicy mogą modyfikować własną kopię bazy danych, ponieważ dane są udostępniane za pośrednictwem witryny programu SharePoint. Nie daje to korzyści podobnych do publikowania bazy danych w witrynie programu SharePoint, ale umożliwia przechowywanie danych w centralnej lokalizacji. Dzięki umieszczeniu danych na listach programu SharePoint można oddzielnie udostępniać dane w sieci przy użyciu funkcji tego programu.

Ta metoda wymaga wykonania trzech podstawowych czynności:

  1. Przeniesienie danych na listy programu SharePoint.

  2. Utworzenie łączy do tych list.

  3. Rozpowszechnienie pliku bazy danych.

Pierwsze dwie czynności można wykonać za pomocą Kreatora przenoszenia do witryny programu SharePoint. Ostatnią czynność można wykonać w dowolny dostępny sposób.

Korzystanie z Kreatora eksportowania tabel do programu SharePoint

  1. Na karcie Narzędzia bazy danych w grupie Przenoszenie danych kliknij pozycję SharePoint.

    Uwagi: 

    • Ta opcja jest dostępna tylko w przypadku baz danych zapisanych w formacie pliku accdb.

    • Jeśli korzystasz z programu Access 2007, na karcie Dane zewnętrzne w grupie Listy programu SharePoint kliknij pozycję Przenieś do programu SharePoint.

  2. Postępuj zgodnie z instrukcjami Kreatora eksportowania tabel do programu SharePoint, określając między innymi lokalizację witryny programu SharePoint. Aby anulować ten proces, kliknij przycisk Anuluj.

  3. Na ostatniej stronie kreatora zaznacz pole wyboru Pokaż szczegóły, aby wyświetlić więcej szczegółów dotyczących migracji.

    Na tej stronie kreatora opisano, które tabele zostały połączone z listami, i podano informacje o lokalizacji kopii zapasowej oraz adresie URL bazy danych. Ponadto ta strona zawiera ostrzeżenie, jeśli wystąpiły błędy migracji, oraz lokalizację tabeli dziennika zawierającej więcej szczegółowych informacji o problemach.

  4. Po ukończeniu akcji kreatora kliknij przycisk Zakończ.

    Jeśli w kreatorze zostanie wyświetlone ostrzeżenie, należy przejrzeć tabelę dziennika i podjąć konieczne działania. Na przykład niektóre pola mogą nie zostać przeniesione lub mogą zostać przekonwertowane na inny typ danych, zgodny z listą programu SharePoint.

Uwaga: Aby wyświetlić listy w witrynie programu SharePoint, kliknij przycisk Listy na pasku Szybkie uruchamianie lub kliknij pozycję Wyświetl całą zawartość witryny. Może być konieczne odświeżenie strony w przeglądarce sieci Web. Aby listy były wyświetlane na pasku Szybkie uruchamianie w witrynie programu SharePoint lub aby zmienić inne ustawienia, na przykład włączyć śledzenie wersji, można zmodyfikować ustawienia list w witrynie programu SharePoint. Aby uzyskać więcej informacji, zobacz Pomoc w witrynie programu SharePoint.

Początek strony

Udostępnianie bazy danych przy użyciu serwera

Bazę danych można udostępnić, używając programu Access razem z serwerem bazy danych, takim jak SQL Server. Zastosowanie tej metody niesie ze sobą szereg korzyści, ale wymaga dodatkowego oprogramowania — serwera bazy danych.

Ta metoda przypomina dzielenie bazy danych, ponieważ tabele są przechowywane w sieci, a każdy użytkownik ma lokalną kopię pliku bazy danych programu Access, zawierającą łącza do tabel oraz kwerendy, formularze, raporty i inne obiekty bazy danych. Tej opcji należy używać, jeśli jest dostępny serwer bazy danych i wszyscy użytkownicy mają zainstalowany program Access. Korzyści tej metody udostępniania zależą od używanego oprogramowania serwera bazy danych, lecz na ogół obejmują konta użytkowników, selektywny dostęp do danych, wysoką dostępność danych i rozbudowane, zintegrowane narzędzia do zarządzania danymi. Ponadto większość oprogramowania serwerów baz danych umożliwia łatwą współpracę z wcześniejszymi wersjami programu Access, dzięki czemu nie wszyscy użytkownicy muszą korzystać z tej samej wersji programu. Udostępniane są wyłącznie tabele.

Zalety udostępniania bazy danych za pośrednictwem serwera bazy danych

  • Wysoka wydajność i skalowalność    Zazwyczaj serwer bazy danych oferuje wyższą wydajność niż sam plik bazy danych programu Access. Wiele serwerów baz danych obsługuje bardzo duże bazy danych — o rozmiarach kilku terabajtów, co około 500-krotnie przewyższa obecne ograniczenie rozmiaru pliku bazy danych programu Access (2 GB). Serwery baz danych działają bardzo wydajnie dzięki równoległemu przetwarzaniu zapytań (z użyciem wielu wątków natywnych w pojedynczym procesie do obsługi żądań użytkowników) i minimalizacji wymagań dodatkowej pamięci wynikających ze zwiększania liczby użytkowników.

  • Zwiększona dostępność    Większość serwerów baz danych umożliwia wykonywanie kopii zapasowych baz danych, które są w użyciu. Dzięki temu użytkownicy nie muszą zamykać bazy danych, aby umożliwić wykonanie kopii zapasowej danych. Zazwyczaj serwery baz danych w bardzo wydajny sposób obsługują jednoczesne edytowanie i blokowanie rekordów.

  • Udoskonalone zabezpieczenia    Żadnej bazy danych nie można całkowicie zabezpieczyć. Serwery baz danych oferują jednak zabezpieczenia o wysokim poziomie niezawodności, chroniące dane przed nieautoryzowanym użyciem. Większość serwerów baz danych udostępnia zabezpieczenia oparte na kontach, które pozwalają określać widoczność tabel dla poszczególnych użytkowników. Zabezpieczenia tego typu zapobiegają nieautoryzowanemu użyciu danych w przypadku uzyskania przez osobę atakującą zewnętrznej aplikacji programu Access.

  • Automatyczne odzyskiwanie danych    Niektóre serwery baz danych dysponują automatycznymi mechanizmami odzyskiwania baz danych w przypadku awarii systemu (na przykład awarii systemu operacyjnego lub zaniku zasilania). Takie funkcje przywracają ostatni spójny stan bazy danych w kilka minut, bez angażowania administratora bazy danych.

  • Przetwarzanie oparte na serwerze    Używanie programu Access w konfiguracji klient-serwer umożliwia ograniczenie ruchu sieciowego dzięki przetwarzaniu zapytań bazy danych na serwerze przed wysłaniem wyników do klienta. Przetwarzanie danych na serwerze jest wydajniejsze, szczególnie w przypadku pracy z dużymi zestawami danych.

Podstawowe czynności używania programu Access z serwerem bazy danych

  1. Dokładne czynności, jakie należy wykonać w celu użycia programu Access z serwerem bazy danych, zależą od używanego serwera bazy danych. Ogólne czynności pozostają jednak bez zmian:

  2. Przeniesienie danych z tabel bazy danych programu Access do tabel na serwerze bazy danych.

  3. Utworzenie w pliku programu Access połączeń z tabelami umieszczonymi na serwerze bazy danych.

  4. Utworzenie odpowiednich kont użytkowników na serwerze bazy danych.

  5. Rozpowszechnienie pliku bazy danych programu Access.

  6. Instalacja wymaganych sterowników bazy danych na komputerach użytkowników.

  7. Aby uzyskać dokładne informacje dotyczące używania programu Access z programem SQL Server, zobacz Przenoszenie danych z programu Access do bazy danych programu SQL Server przy użyciu Kreatora rozbudowy.

Zobacz też Łączenie z bazą danych programu SQL Server lub importowanie z niej.

Początek strony

Zagadnienia, które należy uwzględnić, wybierając metodę

Wymagania dotyczące metody

Dzielona baza danych

Folder sieciowy

Witryna programu SharePoint

Serwer bazy danych

Czy wymaga oprogramowania serwera bazy danych?

N

N

N

T

Czy wymaga programu SharePoint

N

N

T

N

Czy wymaga uruchomienia usług programu Access w programie SharePoint Server?

N

N

W zależności od rozwiązania:

Funkcje tworzenia łączy do list i zapisywania w bibliotece dokumentów nie wymagają usług programu Access

Funkcje publikowania jako internetowej bazy danych lub jako aplikacji internetowej wymagają usług programu Access

N

Dostępność danych

Dobra

Odpowiednia w przypadku małych grup i niezbyt częstego edytowania danych

Najlepsza. Dopuszcza rozwiązania offline.

Najlepsza

Zabezpieczenia

Zależnie od podjętych dodatkowych działań

Najmniej bezpieczna metoda

Najlepsze

Najlepsze

Elastyczność

Dobra. Można łatwo opracowywać nowe funkcje bazy danych bez zakłócania pracy. Użytkownicy mogą modyfikować projekt we własnej kopii.

Obniżona. Modyfikacje można wprowadzać w kopii offline bazy danych, która jest następnie zamieniana. Użytkownicy nie mogą osobno zmieniać projektu bazy danych.

Dobra. Na potrzeby kontroli dostępu i zmian w projekcie używane są uprawnienia programu SharePoint. Niektóre obiekty bazy danych, takie jak formularze, mogą być używane w przeglądarce.

Dobra. Można łatwo opracowywać nowe funkcje bazy danych bez zakłócania pracy. Użytkownicy mogą modyfikować projekt obiektów we własnej kopii.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×