Samouczek: tworzenie raportu programu Power View za pomocą danych z usługi Azure Marketplace

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Podczas pracy z tym samouczkiem programu Power View będziesz pobierać bezpłatne dane z usługi Microsoft Azure Marketplace, dodawać kolejne dane oraz tworzyć relacje między tabelami. Utworzysz serię wizualizacji w programie Power View, dzięki czemu dowiesz się, jakie wizualizacje są odpowiednie dla poszczególnych rodzajów danych, a więc kiedy warto używać mapy oraz wykresu słupkowego i liniowego, jak sortować i filtrować dane w wizualizacjach, a także jak działa przechodzenie do szczegółów. Ponadto utworzysz proste pola obliczeniowe w dodatku Power Pivot, dzięki czemu program Power View będzie mógł lepiej pobierać dane w skoroszycie. Do tego potrzebne są dane.

Arkusz programu Power View korzystający z danych usługi Windows Azure Marketplace z mapą oraz wykresem słupkowym i liniowym

Tworzenie arkusza programu Power View z mapą lotnisk w Stanach Zjednoczonych, wykresem słupkowym przedstawiającym średnie opóźnienia linii lotniczych oraz wykresem liniowym przedstawiającym opóźnienia według miesiąca.

W tym artykule

Pobieranie danych z usługi Microsoft Azure Marketplace

Tworzenie arkusza programu Power View z wykresem grupowanym

Zmienianie kolejności sortowania

Zmienianie agregacji z sumy na średnią

Pobieranie danych linii lotniczych

Tworzenie relacji między tabelami w programie Power View

Filtrowanie wykresu

Zmienianie układu wykresu

Tworzenie innego wykresu

Zmienianie kolejności sortowania wykresu

Pobieranie danych kodów lotnisk

Tworzenie relacji między tabelą Airports i innymi tabelami

Tworzenie mapy

Filtrowanie mapy

Krzyżowe filtrowanie wizualizacji

Dodawanie wizualizacji czasu

Tworzenie tabeli Nazwa miesiąca

Dodawanie tabeli do modelu

Tworzenie pola obliczeniowego MonthName Year

Używanie nowego pola obliczeniowego MonthName Year w programie Power View

Sortowanie pola według innego pola

Tworzenie wykresu liniowego według miesięcy

Dodawanie funkcji rozwijania szczegółów do wykresu liniowego

Urozmaicanie danych opóźnień linii lotniczych

Motywy i formatowanie

Informacje pokrewne

Pobieranie danych z usługi Microsoft Azure Marketplace

  1. W programie Excel na karcie Power Pivot kliknij pozycję Model danych > Zarządzaj.

Karta Power Pivot nie jest widoczna? Uruchom dodatek Power Pivot w programie Microsoft Excel 2013 dodatku.

  1. Kliknij pozycję Pobierz dane zewnętrzne > Z usługi danych > Z usługi Microsoft Azure Marketplace.

  2. W Kreatorze importu tabeli w obszarze Typ wybierz opcję Dane, a w obszarze Cena wybierz opcję Bezpłatne.

  3. Wyszukaj frazę „air carriers” (linie lotnicze).

  4. Obok pozycji US Air Carrier Delays (Opóźnienia linii lotniczych w USA) kliknij przycisk Subskrybuj.

  5. Zaloguj się za pomocą konta Microsoft. Jeśli nie masz takiego konta, wykonaj odpowiednie kroki, aby je utworzyć.

W tym oknie są wyświetlane przykładowe dane.

  1. Przewiń do końca przykładowych danych i kliknij przycisk Wybierz zapytanie.

  2. Możesz wpisać przyjazną nazwę połączenia, a następnie kliknij przycisk Dalej.

  3. Kliknij pozycję Wyświetl podgląd i przefiltruj.

  4. W tym oknie można wybrać kolumny do zaimportowania, usuwając zaznaczenia z pól wyboru. Potrzebne są wszystkie kolumny, więc kliknij przycisk OK, a następnie kliknij przycisk Zakończ.

Proces pobierania może zająć trochę czasu. Ten zestaw danych zawiera ponad 2,4 mln wierszy.

  1. Kliknij przycisk OK.

Masz tylko utworzony Model danych w programie Excel.

Tworzenie arkusza programu Power View z wykresem grupowanym

  1. W programie Excel na karcie Wstawianie kliknij przycisk Raport programu Power View.

Na liście pól znajduje się tabela On_Time_Performance (Terminowość).

  1. Kliknij strzałkę obok tabeli On_Time_Performance (Terminowość).

W tej tabeli znajdują się pola (kolumny).

  1. Zaznacz pole Carrier (Przewoźnik).

Spowoduje to wyświetlenie listy skrótów nazw przewoźników.

  1. Zaznacz pole ArrDelayMinutes (Opóźnienie przylotu w minutach).

Uzyskasz zagregowaną liczbę na przewoźnika.

  1. W polu Wartości kliknij strzałkę obok pola ArrDelayMinutes (Opóźnienie przylotu w minutach).

Uzyskasz sumę minut opóźnienia na przewoźnika.

  1. Na karcie Projekt kliknij strzałkę pod pozycją Wykres słupkowy i kliknij pozycję Słupkowy grupowany.

  2. Zwiększ wysokość wykresu: przeciągnij uchwyt na dolnej krawędzi, gdy kursor przybierze kształt wskazującej dłoni. Kursor w kształcie wskazującej dłoni w programie Power View

  3. Na liście pól przeciągnij pole DepDelayMinutes (Opóźnienie wylotu w minutach) do pola Wartości, tak aby znalazło się pod polem ArrDelayMinutes (Opóźnienie przylotu w minutach).

Teraz widać, że część przewoźników ma lepsze wyniki w zakresie przylotów o czasie, a część ma lepsze wyniki w zakresie wylotów o czasie.

Zmienianie kolejności sortowania

  1. Umieść kursor na wykresie, aby wyświetlić pozycję sortuj według w lewym górnym rogu. Kliknij pozycję Carrier (Przewoźnik).

Dane są teraz sortowane wg pola ArrDelayMinutes (Opóźnienie przylotu w minutach).

  1. Ponownie w lewym górnym rogu kliknij pozycję ros. Teraz dane są sortowane malejąco.

Wyraźnie widać, że największa liczba jest przypisana do przewoźnika WN.

Zmienianie agregacji z sumy na średnią

Możliwe jednak, że sumowanie opóźnień nie jest dobrym pomysłem — linia lotnicza organizująca więcej lotów może częściej przylatywać o czasie, ale mimo to suma jej opóźnień będzie duża.

  1. W polu Wartości kliknij strzałkę obok pola ArrDelayMinutes (Opóźnienie przylotu w minutach) i zmień agregację z Suma na Średnia.

  2. Wykonaj tę samą czynność w odniesieniu do pola DepDelayMinutes (Opóźnienie wylotu w minutach).

  3. Ustaw kolejność sortowania według pola ArrDelayMinutes (Opóźnienie przylotu w minutach).

Ta zmiana spowodowała zupełną zmianę wyników — przewoźnik WN nie znajduje się w gronie firm o dużych średnich opóźnieniach. Widać za to, że najgorszą średnią ma przewoźnik XE.

Dowiedz się więcej o zmienianiu sum na średnie lub inne agregacje w programie Power View.

Pobieranie danych linii lotniczych

Powstał kolejny problem: kto zna skróty nazw przewoźników? Jaka linia lotnicza ma oznaczenie XE? Na szczęście wszystko można znaleźć w sieci web.

  1. Przejdź do witryny z listą kodów linii lotniczych dwuliterowych: http://www.airfarewatchdog.com/pages/3799702/airline-letter-codes/.

  2. Zaznacz dwie kolumny danych i skopiuj je.

  3. W skoroszycie programu Excel kliknij pusty arkusz i wpisz w komórce A1 nazwę AirlineCode (Kod linii lotniczej), a w komórce B1 nazwę AirlineName (Nazwa linii lotniczej).

  4. Kliknij w komórce A2 i wklej dane.

  5. Formatowanie danych jako tabeli (Ctrl + T) i nadaj mu nazwę Airlines.

  6. Zmień także nazwę karty Airlines (Linie lotnicze).

Tworzenie relacji między tabelami w programie Power View

  1. Wróć do arkusza programu Power View w skoroszycie programu Excel.

  2. Widać, że tabela Airlines (Linie lotnicze) znajduje się już na liście pól.

Jeśli jej nie widzisz, kliknij pozycję Wszystkie na liście pól.

  1. Upewnij się, że jest wybrany wykres słupkowy i usuń pozycję Carrier (Przewoźnik) z pola .

Spowoduje to wyświetlenie ogólnej średniej opóźnień przylotów i wylotów dla wszystkich przewoźników.

  1. Rozwiń tabelę Airlines (Linie lotnicze) i zaznacz pole AirlineName (Nazwa linii lotniczej).

Teraz na wykresie znajdują się nazwy linii lotniczych. Ale jest też problem: wszystkie wartości są takie same. Program Power View wyświetla na liście pól następujący komunikat: Mogą być wymagane relacje między tabelami.

  1. Kliknij przycisk Utwórz.

  2. W tabeli kliknij pozycję on_time_performance (terminowość).

  3. W polu Kolumna (obiekt obcy) kliknij pozycję Carrier (Przewoźnik).

  4. W Polu powiązana tabela kliknij linii lotniczych.

  5. W Polu powiązana kolumna (podstawowa) kliknij pozycję. AirlineCode.

To spowoduje utworzenie relacji między dwiema tabelami pól AirlineCode i przewoźników.

  1. Kliknij przycisk OK.

  2. Ponownie posortuj tabelę, tak aby pole ArrDelayMinutes (Opóźnienie przylotu w minutach) było posortowane w kolejności malejącej.

Zobacz: liczby w tabeli nie są już wszędzie takie same, a zamiast kodów przewoźników są wyświetlane nazwy linii lotniczych. Widać więc, że XE to kod linii lotniczej ExpressJet.

Filtrowanie wykresu

Widzisz wartość (puste) na liście linii lotniczych? Temu zaradzić, filtrując dane.

  1. Po zaznaczeniu wykresu słupkowego Airlines (Linie lotnicze) w obszarze filtrów kliknij pozycję Wykres.

    Porada: Obszar filtrów nie jest widoczny? Na karcie Power View kliknij pozycję Widok > Obszar filtrów.

    W obszarze filtrów są już widoczne pola z wykresu. Filtry widoczne w obszarze filtrów wykresu będą filtrować tylko ten wykres, a nie inne wizualizacje w arkuszu.

  2. Kliknij pozycję AirlineName (Nazwa linii lotniczych), zaznacz pole (Wszystko), a następnie anuluj zaznaczenie pola (Puste).
    Pole o wartości (Puste) zniknie z wykresu.

Zmienianie układu wykresu

  1. Upewnij się, że jest zaznaczony wykres kolumnowy.

  2. Na karcie Układ kliknij pozycję Legenda > Pokaż legendę u góry.

Ten układ umożliwia lepsze wykorzystanie miejsca.

  1. Po zaznaczeniu wykresu kliknij uchwyt zmiany rozmiaru po prawej stronie i zwęź wykres.

  2. Dzięki temu powstało miejsce na inną wizualizację.

Tworzenie innego wykresu

  1. Kliknij pusty arkusz, aby rozpocząć tworzenie innej wizualizacji.

Porada: Oto klucz: dopóki jest zaznaczona wizualizacja, wybieranie pól powoduje dodawanie ich do tej wizualizacji, a nie rozpoczęcie tworzenia nowej.

  1. Na liście pól w tabeli On_Time_Performance (Terminowość) zaznacz pole Origin (Lotnisko początkowe).

Pole Origin (Lotnisko początkowe) to kolejna lista kodów. Tym razem są to kody lotnisk.

  1. W tabeli On_Time_Performance (Terminowość) zaznacz pole DepDelayMinutes (Opóźnienie wylotu w minutach).

  2. W polu Pola kliknij strzałkę obok pola DepDelayMinutes (Opóźnienie wylotu w minutach) i kliknij pozycję Średnia.

Widoczna liczba ma wiele miejsc dziesiętnych.

  1. Kliknij kolumnę Średnia z DepDelayMinutes i na karcie Projekt kliknij przycisk Zmniejsz liczbę miejsc dziesiętnych.

Teraz ta liczba ma dwa miejsca dziesiętne.

  1. Na karcie Projekt kliknij strzałkę pod pozycją Wykres słupkowy i kliknij pozycję Skumulowany słupkowy.

  2. Przeciągnij górny i dolny uchwyt zmiany rozmiaru, aby wyświetlić jak najwięcej słupków.

Zmienianie kolejności sortowania wykresu

  1. Umieść kursor na wykresie, aby wyświetlić pozycję sortuj według w lewym górnym rogu. Kliknij pozycję Origin (Lotnisko docelowe).

Dane są teraz sortowane wg pola DepDelayMinutes (Opóźnienie wylotu w minutach).

  1. Ponownie w lewym górnym rogu kliknij pozycję ros. Teraz dane są sortowane malejąco.

Wyraźnie widać, że najgorsze wyniki w zakresie terminowych przylotów ma lotnisko JLN. Gdzie ono jest? I znowu mamy interesujące dane, ale nie możemy z nich sensownie korzystać, ponieważ nie znamy większości kodów lotnisk.

Pobieranie danych kodów lotnisk

  1. Przejdź do http://www.airportcodes.us/us-airports.htm.

  2. W tej witrynie sieci web zaznacz i skopiuj cztery kolumny danych — Code (Kod), Name (Nazwa), City (Miasto) i State (Stan) — bez nagłówka tabeli US Airports, Sorted by Airport Code (Lotniska w USA, sortowane wg kodów lotnisk).

  3. W programie Excel kliknij przycisk plus (+), aby dodać pusty arkusz.

  4. Kliknij w komórce A1 i wklej dane.

  5. Zmień nazwy kolumn:

    • Code (Kod) = AirportCode (Kod lotniska)

    • Name (Nazwa) = AirportName (Nazwa lotniska)

    • City (Miasto) = AirportCity (Miasto lotniska)

    • State (Stan) = AirportState (Stan lotniska)

  6. Formatowanie danych jako tabeli (Ctrl + T) i nadaj mu nazwę lotnisk.

  7. Zmień także nazwę karty Airports (Lotniska).

Tworzenie relacji między tabelą Airports (Lotniska) i innymi tabelami

  1. Wróć do arkusza programu Power View w skoroszycie programu Excel.

  2. Tabela Airports (Lotniska) znajduje się już na liście pól.

    Jeśli jej nie widzisz, kliknij pozycję Wszystkie na liście pól.

  3. Upewnij się, że jest zaznaczony wykres kolumnowy i usuń pozycję Origin (Lotnisko początkowe) z pola .

  4. Spowoduje to wyświetlenie ogólnej średniej opóźnień wylotów dla wszystkich lotnisk.

  5. Rozwiń tabelę Airports (Lotniska) i zaznacz pole AirportName (Nazwa lotniska).

    Teraz na wykresie znajdują się nazwy linii lotniczych. Ale znowu wszystkie wartości są takie same i na liście pól jest wyświetlany komunikat „Mogą być wymagane relacje między tabelami”.

    Spróbuj utworzyć relacje w inny sposób.

  6. Na karcie Power Pivot kliknij pozycję Model danych > Zarządzaj.

  7. W oknie dodatku Power Pivot kliknij kartę Narzędzia główne > Widok diagramu.

    W modelu są wyświetlane trzy tabele. Widoczna jest linia między tabelami On_Time_Performance (Terminowość) i Airlines (Linie lotnicze), ale nie ma linii prowadzącej do tabeli Airports (Lotniska).

  8. Znajdź pole Origin (Lotnisko początkowe) w tabeli On_Time_Performance (Terminowość) i przeciągnij z niej kursor do pola AirportCode (Kod lotniska) w tabeli Airports (Lotniska).

  9. Wróć do arkusza programu Power View w programie Excel.

  10. Kliknij przycisk OK w komunikacie dotyczącym zmienionego modelu danych.

    Liczby w tabeli nie są już wszędzie takie same, a zamiast kodów przewoźników są wyświetlane nazwy lotnisk.

  11. Posortuj wykres w kolejności malejącej według wartości Średnia z DepDelayMinutes.

JLN to kod lotniska Joplin Regional Airport.

Dowiedz się więcej o tworzeniu relacji między tabelami.

Tworzenie mapy

Te dane nie będzie bardziej interesujące, jeśli firma Microsoft znajdował się na mapie? Teraz gdy mamy już nazwy miasta i stanu w tabeli Airports, możemy mapowania danych. Najpierw Przejdźmy wykresu linii lotniczych, więc możemy mieć więcej miejsca.

  1. Przeciągnij uchwyty przenoszenia wykresu Airlines (Linie lotnicze), tak aby umieścić go wzdłuż lewej krawędzi wykresu, a następnie przeciągnij uchwyty zmiany rozmiaru, tak aby wykres był wysoki i wąski.

  2. Zaznacz wykres Airports (Lotniska) i na karcie Projekt kliknij pozycję Mapa.

Podczas tworzenia mapy w programie Power View po raz pierwszy jest wyświetlane ostrzeżenie dotyczące prywatności z informacją o konieczności geokodowania danych przez wysłanie ich do usługi Bing za pośrednictwem bezpiecznego połączenia sieci Web.

  1. Kliknij przycisk OK.

  2. Program Power View mógł umieścić pole AirportName (Nazwa lotniska) w polu Kolor. Jeśli tak się stało, przeciągnij je do pola Lokalizacje.

  3. Przeciągnij uchwyty zmiany rozmiaru, tak aby mapa zajmowała całą pozostałą szerokość arkusza.

Na mapie znajduje się zbyt wiele kropek. Dlatego należy skoncentrować się na lotniskach, na których występują największe opóźnienia. Widzisz kropkę na północ od Australii? To Guam.

Filtrowanie mapy

  1. Po zaznaczeniu mapy kliknij w obszarze filtrów pozycję Mapa.

  2. Kliknij pozycję Średnia z DepDelayMinutes.

Zobaczysz pasek przewijania o wartościach od 0 do 25,37 minut.

  1. Przeciągnij lewą stronę paska przewijania, tak aby były wyświetlane tylko opóźnienia większe niż 10 minut.

Porada:  Aby uzyskać dokładniejsze wyniki, można to także zrobić w zaawansowanym trybie filtru. Kliknij ikonę z prawej strony nazwy filtru (Średnia z DepDelayMinutes) i w polu Pokaż elementy, dla których wartość > jest większa lub równa wpisz wartość 10.

  1. Teraz odfiltruj lotnisko w Guam. W obszarze filtrów kliknij pozycję AirportName (Nazwa lotniska). Zaznacz pole wyboru Wszystko, w polu wyszukiwania wpisz „Guam”, a następnie kliknij ikonę lupy obok pola wyszukiwania.

Lotnisko Guam International Airport jest jedynym wynikiem.

  1. Wyczyść pole wyboru obok pozycji Guam.

  2. Kliknij znak plus w prawym górnym rogu mapy, aby ją powiększyć, i za pomocą kursora zmień jej pozycję, tak aby była widoczna tylko kontynentalna część USA oraz Alaska.

  3. Umieść kursor na dużej kropce odpowiadającej lotnisku Bering Sea: Adak Airport. Ma ono prawie 24 minuty opóźnienia.

Krzyżowe filtrowanie wizualizacji

Czas zrobić coś ciekawszego: utworzysz interakcję między wizualizacjami.

  1. Kliknij dymek lotniska Adak Airport.

  2. Zwróć uwagę na to, co się stało z wykresem słupkowym Airlines (Lotniska). Wygląda na to, że Alaska to jedyne linie lotnicze z lotami na lotnisko Adak Airport. Nadal są widoczne wszystkie pozostałe linie lotnicze i łączna średnia linii lotniczych Alaska. Jeśli średnia pojedynczej wartości jest większa niż łączna średnia, program Power View zmniejszy szerokość słupka łącznej średniej, aby ta wartość była nadal widoczna.

  3. Powiększ mapę i zmień jej pozycję, tak aby była widoczna tylko kontynentalna część USA.

  4. Na wykresie słupkowym kliknij pozycję ExpressJet.

Jest to w większości wschodnia i środkowa część Stanów Zjednoczonych.

  1. Kliknij słupek Frontier (Zachodnia część Stanów Zjednoczonych).

To tylko trzy lotniska: San Francisco, Palm Springs i Greater Rockford. Lotnisko w San Francisco może być największym lotniskiem na tej mapie.

  1. Na mapie kliknij dymek San Francisco.

Niemal każde linie lotnicze oferujące wyloty z San Francisco ma gorszą średnią niż inne lotnisk.

Dowiedz się więcej o Filtrowanie i wyróżnianie w programie Power View.

Dodawanie wizualizacji czasu

Sprawdźmy dane linii lotniczych z innych miesięcy. Możemy się domyślać, które miesiące były najgorsze. Sprawdźmy, czy to prawda. Tabela On_Time_Performance (Terminowość) zawiera różne pola dat, w tym pole FlightDate (Data lotu) w formacie D/M/YYYY HH:MM:SS — na przykład 1/1/2012 12:00:00.

Jest też dostępne pole Month (Miesiąc). Zawiera ono tylko wartości liczbowe bez nazw miesięcy, ale zacznijmy od niego.

  1. Utwórz nowy arkusz programu Power View: w programie Excel kliknij pozycję Wstawianie > Raport dodatku Power View.

  2. Na liście pól rozwiń tabelę On_Time_Performance (Terminowość) i zaznacz pole wyboru Month (Miesiąc).

Jest to pole liczbowe, oznaczone symbolem sigma (Σ), dlatego program Power View doda wartości.

  1. W polu Pola kliknij strzałkę obok pozycji Month (Miesiąc) i kliknij pozycję Nie sumuj.

Program Power View utworzy tabelę z miesiącami. 1, 2, 10, 11 i 12. Jest tylko jeden problem: nie są one wyświetlane w odpowiedniej kolejności.

  1. Po zaznaczeniu tabeli Month (Miesiąc) na arkuszu w tabeli On_Time_Performance (Terminowość) przeciągnij pole Year (Rok) powyżej pola Month (Miesiąc) w polu Pola.

  2. W polu Pola kliknij strzałkę obok pozycji Year (Rok) i kliknij pozycję Nie sumuj.

  3. Miesiące o numerach 10, 11 i 12 są wyświetlane przed miesiącami o numerach 1 i 2, ponieważ są to miesiące z 2011 r.

Tworzenie tabeli Month Name (Nazwa miesiąca)

  1. W nowym arkuszu programu Excel utwórz tabelę, począwszy od komórki A1:

MonthNumber

MonthName

1

Styczeń

2

Luty

  1. Zaznacz komórki od A2 do B3, a następnie przeciągnij uchwyt wypełniania w prawym dolnym rogu komórki B3 [ZA010278334] do komórki B13.

Uchwyt wypełniania

Spowoduje to wypełnienie wierszy od 4 do 13 pozostałymi numerami i nazwami miesięcy.

  1. Zaznacz wiersze od 1 do 13 oraz kolumny A i B, a następnie utwórz tabelę (Ctrl+T).

  2. Upewnij się, że wybrano pozycję Moja tabela zawiera nagłówki.

  3. Na karcie Projektowanie w programie Excel > Nazwa tabeli wpisz MonthNames.

  4. Zmień nazwę arkusza na Month Names (Nazwy miesięcy).

Dodawanie tabeli do modelu

  1. Po zaznaczeniu tabeli w programie Excel na karcie Power Pivot kliknij pozycję Dodaj do modelu danych.

    Spowoduje to otwarcie okna dodatku Power Pivot z arkuszem MonthNames (Nazwy miesięcy).

  2. W oknie dodatku Power Pivot na karcie Narzędzia główne kliknij pozycję Widok > Widok diagramu.

  3. Utwórz relację między tabelami, przeciągając wskaźnik myszy z pola Month (Miesiąc) w tabeli On_Time_Performance (Terminowość) do pola MonthNumber (Numer miesiąc) w tabeli MonthNames (Nazwy miesięcy).

Tworzenie pola obliczeniowego MonthName Year (Nazwa miesiąca, rok)

  1. W dodatku Power Pivot na karcie Narzędzia główne kliknij pozycję Widok > Widok danych.

  2. Przejdź do tabeli On_Time_Performance (Terminowość) i kliknij kolumnę Dodaj kolumnę.

    Utworzysz podstawową kolumnę obliczeniową.

  3. Wpisz:

    = POWIĄZANYCH

  4. Kliknij arkusz MonthNames (Nazwy miesięcy) i kliknij kolumnę MonthName (Nazwa miesiąca).

    Spowoduje to wyświetlenie pola MonthName z tabeli MonthNames i dodaje (MonthNames [MonthName] do formuły w tabeli on_time_performance (terminowość).

  5. Wpisz:

    ) & " " &

    Upewnij się, że wpisano cudzysłowy proste, a nie drukarskie.

  6. Kliknij kolumnę Year (Rok) w tabeli On_Time_Performance (Terminowość).

    Spowoduje to dodanie ciągu [Year] do formuły. Cała formuła będzie wyglądać następująco:

    =RELATED(MonthNames[MonthName]) & " " & [Year]

  7. Naciśnij klawisz Enter.

    Dodatek Power Pivot wstawi w polu nazwę miesiąca z tabeli MonthNames (Nazwy miesięcy), odstęp i numer roku z tabeli On_Time_Performance (Terminowość), na przykład Październik 2011.

  8. Zaznacz kolumnę, kliknij prawym przyciskiem myszy i zmień nazwę na MonthName Year (Nazwa miesiąca, rok).

Używanie nowego pola obliczeniowego MonthName Year (Nazwa miesiąca, rok) w programie Power View

  1. Wróć do arkusza programu Power View w programie Excel.

  2. Przeciągnij nowe pole MonthName Year (Nazwa miesiąca, rok) do arkusza.

Coś się nie zgadza. Miesiące są wyświetlane w kolejności alfabetycznej, a nie chronologicznej.

Sortowanie pola według innego pola

  1. Powróć do okna dodatku Power Pivot.

  2. Przejdź do tabeli On_Time_Performance (Terminowość) i kliknij kolumnę Dodaj kolumnę, aby utworzyć kolejną podstawową kolumnę obliczeniową.

  3. Wpisz:

    = YEAR([

    Spowoduje to wyświetlenie listy kolumn w tabeli.

  4. Kliknij kolumnę flightdate (datalotu) , a następnie naciśnij klawisz Tab.

  5. Wpisz:

    ) & FORMAT(MONTH([

  6. Ponownie kliknij kolumnę FlightDate (Data lotu) na liście kolumn w tabeli i naciśnij klawisz Tab.

  7. Wpisz:

    ), “00”

    Cała formuła będzie wyglądać następująco:

    =YEAR([FlightDate]) & FORMAT(MONTH([FlightDate]),”00″)

  8. Naciśnij klawisz Enter.

    Dodatek Power Pivot utworzy kolumnę z numerem roku z pola FlightDate (Data lotu) i numerem miesiąca z tego samego pola. Wartość 00 oznacza, że numer miesiąca jest wyświetlany przy użyciu dwóch cyfr. Na przykład 201201 to styczeń 2012 r.

  9. Zaznacz kolumnę, kliknij prawym przyciskiem myszy i zmień jej nazwę na MonthNumber Year.

  10. Zaznacz kolumnę MonthName Year (Nazwa miesiąca, rok), a następnie w dodatku Power Pivot na karcie Narzędzia główne wybierz pozycję Sortuj wg kolumny.

    MonthName Year znajduje się w polu Kolumna sortowania.

  11. W polu Według kolumny kliknij pozycję MonthNumber Year > OK.

Tworzenie wykresu liniowego według miesięcy

  1. Wróć do programu Excel, a następnie w arkuszu programu Power View kliknij przycisk OK w oknie komunikatu z informacją o zmianie modelu danych.

    Model rzeczywiście został zmieniony: miesiące są teraz wyświetlane w kolejności chronologicznej — od października 2011 do lutego 2012. Znacznie lepiej.

  2. Po zaznaczeniu tabeli MonthName Year (Nazwa miesiąca, rok) na liście pól w tabeli On_Time_Performance (Terminowość) zaznacz pole DepDelayMinutes (Opóźnienie wylotu w minutach).

    Pole zostanie dodane jako suma.

  3. W polu pola kliknij pozycję DepDelayMinutes > Średnia.

  4. Wybierz pozycję Projektowanie > Inne wykresy > Liniowy.

    Tak jak przewidywaliśmy — grudzień i styczeń były najgorszymi miesiącami.

  5. Teraz dodaj drugi wiersz: po zaznaczeniu tabeli MonthName Year (Nazwa miesiąca, rok) na liście pól w tabeli On_Time_Performance (Terminowość) przeciągnij pole ArrDelayMinutes (Opóźnienie przylotu w minutach) do pola Wartości.

    To pole również zostanie dodane jako suma.

  6. W polu pola kliknij pozycję największe > Średnia.

Największe opóźnienia wylotów występowały w grudniu, ale największe opóźnienia przylotów występowały w styczniu.

Sprawdźmy, które dni miesiąca miały najgorsze wyniki.

Dodawanie funkcji przechodzenia do szczegółów na wykresie liniowym

  1. Zaznaczony, z listy pól wykresu liniowego > On_Time_Performance tabeli, przeciągnij Dnia miesiąca do pola poniżej MonthName Year.

Wygląd wykresu liniowego nie zmieni się.

  1. Kliknij dwukrotnie punkt dotyczący grudnia 2011.

Zostaną wyświetlone opóźnienia z każdego dnia grudnia 2011. Widzisz dwie najwyższe wartości DepDelayMinutes (Opóźnienie wylotu w minutach)?

  1. Umieść wskaźnik myszy na tych najwyższych wartościach DepDelayMinutes (Opóźnienie wylotu w minutach): 22 i 27 grudnia, bezpośrednio przed Bożym Narodzeniem i po nim.

A co z listopadem?

  1. Kliknij strzałkę Uogólnij w prawym górnym rogu, aby wrócić do wykresu posortowanego według miesięcy.

Strzałka Uogólnij w wizualizacjach wykresu programu Power View

  1. Kliknij dwukrotnie listopad 2011.

Tak jak przewidywaliśmy — 29 listopada był najgorszym dniem dla przylotów i wylotów.

Dowiedz się więcej na temat dodawania funkcji rozwijania szczegółów do wykresu programu Power View lub macierzy.

Urozmaicanie danych opóźnień linii lotniczych

W ramach tego samouczka wykonano następujące czynności:

  • Pobrano dane ze źródeł w sieci Web.

  • Utworzono relacje.

  • Utworzono różne wykresy i mapę.

  • Wykonano filtrowanie i filtrowanie krzyżowe danych.

  • Utworzono pola obliczeniowe w dodatku Power Pivot.

  • Użyto danych czasu w dodatku Power Pivot i programie Power View.

  • Dodano funkcję przechodzenia do szczegółów na wykresie.

Możesz kontynuować pracę z tymi danymi. Na przykład możesz skopiować wykres liniowy MonthName Year (Nazwa miesiąca, rok) z tego arkusza programu Power View i wkleić go do arkusza z mapą. Klikając lotniska na mapie, można porównać dane z różnych miesięcy.

Motywy i formatowanie

Spróbuj odtworzyć za pomocą motywów na karcie Power View. Arkusz programu Power View na obrazie na początku jest używana kompozycja złożone z Pełnym Light2 w tle. Zobacz, co możesz opracowywane! Dowiedz się więcej o formatowaniu raportów programu Power View.

Informacje pokrewne

Wykresy i inne wizualizacje w programie Power View.

Filtrowanie, wyróżnianie i fragmentatory w programie Power View

Mapy w programie Power View

Co nowego w programie Power View w programie Excel 2013 i SharePoint Server

Power View: eksplorowanie, wizualizowanie i prezentowanie danych

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×