Rozpoczynanie pracy: tworzenie systemu notatek ze spotkań przy użyciu programów InfoPath i SharePoint

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Zmodyfikowaniu pomocniczych do szablonu formularza próbki z Microsoft Office InfoPath 2007 i tworzenie biblioteki dokumentów w witrynie Windows SharePoint Services 3.0, można zaimplementować systemu, który umożliwia sporządzanie notatek w spójny sposób, wysyłanie notatek do każdego uczestnika spotkania i przechowywanie tych notatek w bibliotece dokumentów programu SharePoint Services. W tym artykule pokazano, jak utworzyć ten komputer.

W tym artykule

Omówienie

Przed rozpoczęciem

Tworzenie nowego spotkania systemu notatek

Aktualizacja szablonu formularza

Omówienie

Dołączonych do programu InfoPath jest przykładowy szablon formularza, którego została zaprojektowana w celu zbierania typowych dane spotkania, takie jak plany, uczestnicy, elementy dyskusji i czynności do wykonania. Przykładowy szablon formularza są skonfigurowane tak, tak aby można było wysyłać kopię formularza, który jest oparty na szablonie za pośrednictwem poczty e-mail do wszystkich uczestników spotkania.

Przykładowy szablon formularza jest skonfigurowany do pomocy zabezpieczenie notatki zbieranie danych, które zwykle został zapisany w spotkaniu. Formanty są rozmieszczone w logiczne sekcje ułatwiające zabezpieczenie notatki zbieranie właściwych danych, a także zwolnić go ze zbierania danych, które mogą być generowane automatycznie. Układ formantów także spójne ramy, zamiast zabezpieczenie notatki konieczności Pamiętaj, jakiego rodzaju dane na potrzeby zbierania on po prostu wypełnia pustych komórek w trakcie spotkania.

Mimo że można modyfikować szablonu formularza do zbierania dodatkowych danych, zaleca się używanie istniejącego szablonu formularza, jak to jeden modyfikacji, która umożliwia zapisywanie wypełnione formularze w bibliotece dokumentów programu SharePoint. Można przetestować skuteczność systemu i za pomocą materiału podczas próby modyfikowania szablonu formularza do potrzeb Twojej grupy.

Za pomocą tego szablonu formularza próbki w systemie publikując pierwszym przykładowy szablon formularza w bibliotece dokumentów w witrynie programu SharePoint. Użytkownik utworzy nową bibliotekę dokumentów w ramach procesu publikowania. Po opublikowaniu szablonu formularza i tworzenie nowej biblioteki dokumentów, następnie zmodyfikuj szablon formularza, który zapisuje wypełniony formularz nowej biblioteki dokumentów i wysyła kopię formularza do uczestników spotkania.

Aby użyć tego systemu, zabezpieczenie notatki przechodzi do biblioteki dokumentów i tworzy nowy formularz oparty na tym szablonie formularza. Podczas spotkania, zabezpieczenie notatki wypełnia dane w odpowiednie formanty w formularzu. Na koniec spotkania zabezpieczenie notatki przesłaniu formularza do biblioteki dokumentów i do każdego uczestnika spotkania jest wysyłana kopia formularza. Te osoby, które nie uczestniczyć w spotkaniu można przeczytać informacje, przechodząc do biblioteki dokumentów i otwieranie formularza w programie InfoPath.

Przykładowy szablon formularza zawiera następujące sekcje:

Szablon formularza planu spotkania z czterema sekcjami

1. sekcja tytuł zawiera kontrolki dla nazwy, przeznaczenie, lokalizację, a spotkanie daty i godziny. Kontrola daty automatycznie wyświetlana jest data utworzenia formularza. Domyślnie Czas zakończenia w polu tekstowym automatycznie wyświetla godzinę czyli godzinę później niż godziny wprowadzone w polu tekstowym Czas rozpoczęcia.

2. uczestników powtarzających się, że sekcja zawiera kontrolki dla nazwy i adresy e-mail wszystkich uczestników spotkania. Jeśli zabezpieczenie notatki prześle wypełniony formularz, każdego uczestnika wymienionych w tej sekcji, otrzymuje kopię wypełniony formularz.

3. element dyskusji sekcji powtarzającej się zawiera kontrolki dla każdej osoby prowadzącej (uczestnika, który prowadzi dyskusji) i notatki dotyczące poszczególnych dyskusji. Formant pola listy rozwijanej prezentera zawiera nazwy z sekcji uczestników.

4. czynność do wykonania sekcji powtarzającej się zawiera kontrolki nazwisko, przydział i ukończenia daty dla każdego elementu akcji. Formant pola listy rozwijanej przydziału zawiera nazwy z sekcji uczestników.

Jeśli jesteś nowym użytkownikiem programu InfoPath, następujące artykuły pomoże Ci zrozumienie ważnych pojęć i lepiej zdefiniowane warunki, które można napotkać podczas wykonania każdego zadania, w tym artykule. W przypadku, gdy chcesz uzyskać więcej informacji, jak wykonać zadanie również znajdziesz te łącza w odpowiednich sekcjach w tym artykule.

Początek strony

Zanim rozpoczniesz

Będzie potrzebny Uniform Resource Locator (URL) i, co najmniej uprawnienia do zbioru witryn, witryny programu SharePoint, który będzie używany dla systemu projektowanie. Jeśli tworzysz biblioteki dokumentów w zbiorze witryn, dysponuje się odpowiednimi uprawnieniami. Osoby, które muszą być widoczne notatki ze spotkań będą potrzebne uprawnienia do odczytu w zbiorze witryn. Jeśli potrzebne są uprawnienia do tworzenia biblioteki dokumentów lub ustawianie uprawnień do odczytu do zbioru witryn dla użytkowników formularza, skontaktuj się z administratorem zbioru witryn.

Konieczne będzie również co najmniej jeden adres e-mail do której możesz wysłać kopię wypełniony formularz, a klient poczty e-mail, takich jak Microsoft Office Outlook 2007, skonfigurowanym do odbierania wiadomości tak, aby przetestować szablonu formularza.

W tym artykule założono, że używasz domyślnej konfiguracji programu SharePoint Services.

Początek strony

Tworzenie nowego spotkania systemu notatek

Aby utworzyć ten system, będzie wykonaj następujące czynności:

  1. Otwieranie i zapisywanie szablonu formularza próbki.

  2. Publikowanie szablonu formularza próbki, aby utworzyć nową bibliotekę dokumentów dla notatek ze spotkania.

  3. Modyfikowanie szablonu formularza próbki, aby zapisać wypełnione formularze Nowa biblioteka dokumentów, a następnie wysłać kopię do każdego uczestnika.

  4. Publikowanie szablonu formularza zmienione.

  5. Testowanie zmodyfikowany szablon formularza i Nowa biblioteka dokumentów przez tworzenie i przesyłanie formularzy test, które są oparte na tym szablonie formularza.

Otwieranie i zapisywanie szablonu formularza

  1. W menu plik kliknij pozycję Projektowanie szablonu formularza.

  2. W obszarze, Otwórz szablon formularza kliknij przycisk Dostosuj próbki.

  3. W obszarze Dostosowywanie przykładu kliknij dwukrotnie Przykładowy spotkania.

  4. W menu Plik kliknij polecenie Zapisz.

  5. Jeśli programu InfoPath zostanie wyświetlony komunikat o publikowanie szablonu formularza, kliknij przycisk OK.

  6. W oknie dialogowym Zapisz jako Określ lokalizację, w której chcesz zapisać szablon formularza.

  7. W polu Nazwa pliku wpisz nazwę dla szablonu formularza.

  8. Na liście Zapisz jako typ kliknij Szablon formularza programu InfoPath, a następnie kliknij przycisk Zapisz.

Publikowanie szablonu formularza

W ramach procesu publikowania użytkownik utworzy nową bibliotekę dokumentów.

Aby dowiedzieć się więcej na temat publikowania szablonu formularza, zobacz artykuł Wprowadzenie do publikowania szablonu formularza.

  1. W menu plik kliknij pozycję Publikuj.

  2. Na pierwszej stronie Kreatora publikowania kliknij pozycję do programu SharePoint server z lub bez usług InfoPath Forms Services, a następnie kliknij przycisk Dalej.

  3. Na następnej stronie kreatora w polu Wprowadź lokalizację witryny programu SharePoint lub usług InfoPath Forms Services wpisz adres URL zbioru witryn w witrynie programu SharePoint, a następnie kliknij przycisk Dalej. Na przykład aby użyć zbioru witryn przy użyciu adresu URL http://www.adventureworks.com/EmployeesOnly, możesz wpisz http://www.adventureworks.com/EmployeesOnly w polu.

  4. Na następnej stronie kliknij Bibliotekę dokumentów, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kliknij pozycję Utwórz nową bibliotekę dokumentów, a następnie kliknij przycisk Dalej.

  6. Na następnej stronie wpisz nazwę i opis nowej biblioteki dokumentów, a następnie kliknij przycisk Dalej.

  7. Zaakceptuj sugerowaną kolumny i kliknij przycisk Dalej.

  8. Na ostatniej stronie kreatora sprawdź poprawność informacji wyświetlanych, a następnie kliknij pozycję Publikuj.

  9. Kliknij przycisk Zamknij.

    Otrzymasz potwierdzenie na ostatniej stronie kreatora po pomyślnym opublikowaniu szablonu formularza.

Zanotuj adres URL nowej biblioteki dokumentów; konieczne będzie w dalszej części tego artykułu. Adres URL nowej biblioteki dokumentów będzie adres URL zbioru witryn, następuje po ukośnika (/), oraz nazwę biblioteki dokumentów. Na przykład jeśli została utworzona nowa Biblioteka dokumentów w zbiorze witryn przy użyciu adresu URL http://www.adventureworks.com/EmployeeOnlyo nazwie MeetingNotes, adres URL nowej biblioteki dokumentów będzie http://www.adventureworks.com/EmployeeOnly/MeetingNotes.

Modyfikowanie szablonu formularza

W tej sekcji przedstawiono sposób wykonywania następujących czynności:

  • Dodaj nowe połączenie danych przesyłania który zapisuje wypełniony formularz do nowej biblioteki dokumentów.

    Aby dowiedzieć się więcej na temat przesyłania połączenia danych, zobacz Wprowadzenie do połączeń danych.

  • Zmień odpowiednie opcje połączenia danych, tak aby zapisuje wypełnionego formularza do biblioteki dokumentów i wysyła kopię wypełnionego formularza do każdego uczestnika spotkania.

  • Szablon formularza tak skonfigurować program zostanie zamknięty formularza po przesłaniu.

Aby dowiedzieć się więcej na temat przesyłania formularza, który jest oparty na szablonie formularza, zobacz artykuł Wprowadzenie do przesyłania danych formularza.

Dodawaj nowe połączenie danych przesyłania

W tej sekcji spowoduje utworzenie nowego przesyłanie połączenia danych z nowej biblioteki dokumentów i skonfigurować połączenie danych, aby zapisać formularz pod inną nazwą. Nazwa formularza będzie kombinacją tytuł spotkania oraz Data utworzenia formularza.

Rozpoczynanie tworzenia połączenia danych
  1. W menu Narzędzia kliknij polecenie Połączenia danych.

  2. W oknie dialogowym Połączenia danych kliknij przycisk Dodaj.

  3. W Kreatorze połączenia danych kliknij przycisk Utwórz nowe połączenie, kliknij Przesyłanie danych, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kreatora kliknij w bibliotece dokumentów w witrynie programu SharePoint, a następnie kliknij przycisk Dalej. Wybieranie miejsca docelowego przesyłanych danych w Kreatorze połączenia danych

  5. Na następnej stronie kreatora w polu biblioteki dokumentów wpisz adres URL biblioteki dokumentów, utworzoną w poprzedniej sekcji. Na przykład aby użyć biblioteki dokumentów z adresu URL http://www.adventureworks.com/EmployeesOnly/MeetingNotes, pisania http://www.adventureworks.com/EmployeesOnly/MeetingNotes w polu biblioteki dokumentów.

    Następnej sekcji przeprowadzi Cię przez proces definiowania nazwa formularza unikatowe, która wymaga, aby pozostać na tej stronie kreatora. Nie klikaj jeszcze Dalej.

Definiowanie nazwy unikatowe formularza

Szablon formularza zapisuje formularz w bibliotece dokumentów przy użyciu domyślnej nazwy. Jeśli używasz domyślną nazwę nowej biblioteki dokumentów będzie przechowywana tylko jeden wypełniony formularz. W tej sekcji skonfigurujesz połączenie danych, aby zapisać formularzy opartych na tym szablonie formularza z nazwą składa się z tytuł spotkania i datę spotkania. W tym celu utworzyć formułę, która korzysta z funkcji XPath .

Aby dowiedzieć się więcej na temat formuł i funkcji, zobacz Dodawanie formuły do formantu.

  1. Kliknij przycisk Wstaw formułę Obraz przycisku .

  2. W oknie dialogowym Wstawianie formuły kliknij przycisk Wstaw funkcję.

  3. Na liście Kategorie okna dialogowego Wstawianie funkcji kliknij pozycję tekst.

  4. Na liście funkcji kliknij "concat", a następnie kliknij przycisk OK.

  5. W polu Formuła kliknij dwukrotnie pierwsze wystąpienie kliknij dwukrotnie, aby wstawić pole.

    Dwukrotne kliknięcie w celu wstawienia pierwszego pola, które ma zostać użyte jako część nazwy formularza

  6. W oknie dialogowym Wybieranie pola lub grupy Otwórz spotkanie, kliknij pozycję meetingTitle, a następnie kliknij przycisk OK.

    Wybieranie pola meetingTitle w oknie dialogowym Wybieranie pola lub grupy

  7. W polu Formuła kliknij drugiego wystąpienia kliknij dwukrotnie, aby wstawić pole, aby go zaznaczyć (nie klikaj jej dwukrotnie).

    Dwukrotne kliknięcie w celu wstawienia znaku łącznika jako części nazwy formularza

  8. Wpisz podwójny cudzysłów (""), a po nim znak łącznika (-), a następnie innego podwójny cudzysłów.

    Wstawianie znaku łącznika jako części nazwy formularza

  9. Kliknij dwukrotnie trzecie wystąpienie liczby kliknij dwukrotnie, aby wstawić pole.

    Dwukrotne kliknięcie w celu wstawienia kolejnego pola, które ma zostać użyte jako część nazwy formularza

  10. W oknie dialogowym Wybieranie pola lub grupy Otwórz spotkanie, kliknij meetingDate, a następnie kliknij przycisk OK.

    Wybieranie pola meetingDate w oknie dialogowym Wybieranie pola lub grupy

    W oknie dialogowym Wstawianie formuły powinna wyglądać następująco:

    Ukończona formuła konstruująca nazwę formularza w oknie dialogowym Wstawianie formuły

  11. Aby Sprawdź formułę pod kątem poprawnej składni, w oknie dialogowym Wstawianie formuły, kliknij przycisk Sprawdź formułę.

  12. Jeśli formuła nie zawiera wszystkie błędy, kliknij przycisk OK, aby zamknąć okno dialogowe.

Kończenie konfigurowania połączenia danych
  1. W kreatorze kliknij przycisk Dalej.

  2. Na następnej stronie kreatora w polu Wprowadź nazwę dla tego połączenia danych wpisz opisową nazwę dla tego przedstawia połączenia danych.

  3. Sprawdź, że informacje są prawidłowe, w sekcji Podsumowanie, a następnie kliknij przycisk Zakończ.

  4. Kliknij przycisk Zamknij.

  5. W menu Plik kliknij polecenie Zapisz.

Zmienianie opcji Prześlij korzystać z obu przesyłania połączenia danych

  1. W menu Narzędzia kliknij polecenie Opcje przesyłania.

  2. W oknie dialogowym Opcje przesyłania zaznacz pole wyboru Zezwalaj użytkownikom na przesyłanie tego formularza.

  3. Kliknij Wykonywanie akcji niestandardowych przy użyciu reguł, a następnie kliknij pozycję reguły.

  4. W oknie dialogowym Reguły przesyłania formularzy kliknij przycisk Dodaj.

  5. Kliknij pozycję Dodaj akcję.

  6. W polu akcji kliknij przycisk Prześlij przy użyciu połączenia danych.

  7. Na liście połączenia danych kliknij pozycję połączenia danych w bibliotece dokumentów, która została utworzona w poprzedniej sekcji, a następnie kliknij przycisk OK.

  8. Kliknij pozycję Dodaj akcję.

  9. W polu akcji kliknij przycisk Prześlij przy użyciu połączenia danych.

  10. Na liście połączenia danych kliknij przycisk Prześlij główne, a następnie kliknij przycisk OK.

    Aby wysłać kopię formularza do każdego uczestnika użyje połączenia danych Przesyłanie główne.

  11. W oknie dialogowym reguły w polu Nazwa wpisz Reguły przesyłania do identyfikacji reguły, która została właśnie utworzona.

  12. Kliknij dwa razy przycisk OK.

Konfigurowanie szablonu formularza, aby zamknąć formularz po przesłaniu.

  1. W oknie dialogowym Opcje przesyłania kliknij przycisk Zaawansowane.

  2. Na liście po przesyłanie kliknij pozycję Zamknij formularz.

  3. Kliknij przycisk OK.

  4. W menu Plik kliknij polecenie Zapisz.

Publikowanie szablonu formularza

Po zmodyfikowaniu szablonu formularza, musisz opublikować go do biblioteki dokumentów do wdrożenia zmiany.

  1. W menu plik kliknij pozycję Publikuj.

  2. Na pierwszej stronie Kreatora publikowania kliknij pozycję do programu SharePoint server z lub bez usług InfoPath Forms Services, a następnie kliknij przycisk Dalej.

  3. Na następnej stronie kreatora w polu Wprowadź lokalizację witryny programu SharePoint lub usług InfoPath Forms Services wpisz lokalizację biblioteki dokumentów w zbiorze witryn w witrynie programu SharePoint, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kliknij Bibliotekę dokumentów, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kliknij przycisk Aktualizuj szablonu formularza w istniejącej biblioteki dokumentów.

  6. Na liście Biblioteka dokumentów, aby zaktualizować kliknij bibliotekę dokumentów, a następnie kliknij przycisk Dalej.

  7. Kliknij przycisk Dalej.

  8. Na następnej stronie Zweryfikuj poprawność informacji wyświetlanych, a następnie kliknij pozycję Publikuj.

    Otrzymasz potwierdzenie na ostatniej stronie kreatora po pomyślnym opublikowaniu szablonu formularza.

Testowanie szablonu formularza i witryny

  1. Na ostatniej stronie Kreatora publikowania kliknij przycisk Otwórz tę bibliotekę dokumentów, a następnie kliknij przycisk Zamknij.

  2. W bibliotece dokumentów kliknij przycisk Nowy.

  3. Wypełnij formularz tak, jakby były sporządzanie notatek na spotkaniu. Po wprowadzeniu czas w kontrolce pola tekstowego czas rozpoczęcia, naciśnij klawisz TAB, aby przejść do następnej kontrolki. Program InfoPath automatycznie wstawia w polu tekstowym czas zakończenia.

  4. Wprowadź adres e-mail uczestnika spotkania w polu Adres E-mail sekcji uczestnika. Aby dodać dodatkowych uczestników i ich adresy e-mail, kliknij pozycję Dodaj uczestnika.

  5. Na pasku narzędzi programu InfoPath kliknij przycisk Prześlij.

  6. W oknie dialogowym Sprawdź, czy są wyświetlane adresy e-mail poprawne.

  7. Kliknij przycisk Wyślij, a następnie kliknij przycisk OK, aby zamknąć okno dialogowe.

Notatki ze spotkania możesz powinien być wyświetlany w bibliotece dokumentów i należy również trafią do skrzynki odbiorczej poczty e-mail jako nową wiadomość e-mail.

Po przetestowaniu systemu przez tworzenie i przesyłanie kilka formularzy opartych na tym szablonie formularza, można uruchomić w systemie do przechowywania i rozpowszechnianie notatek ze spotkania.

Początek strony

Aktualizacja szablonu formularza

Po innym osobom zostały wypróbowane nowego systemu przez tworzenie i zapisywanie notatek ze spotkania, możesz zechcieć zmienić projekt szablonu formularza w odpowiedzi na swoje opinie. Aby wprowadzić zmiany w szablonie formularza, należy wykonać następujące czynności:

  1. Otwieranie szablonu formularza z biblioteki dokumentów, zmodyfikuj szablon formularza, stosownie do potrzeb, a następnie zapisz zmiany.

  2. Zatwierdzić wprowadzone zmiany przez opublikowanie szablonu formularza w bibliotece dokumentów.

Otwieranie szablonu formularza z biblioteki dokumentów

  1. Otwórz bibliotekę dokumentów.

  2. Kliknij pozycję Ustawienia, a następnie kliknij pozycję Ustawienia Biblioteki formularzy.

  3. W obszarze Ustawienia ogólne kliknij pozycję Ustawienia Zaawansowane.

  4. W polu Adres URL szablonu w sekcji Szablon dokumentu kliknij przycisk Edytuj szablon.

  5. Jeśli programu InfoPath zostanie wyświetlony komunikat o publikowanie szablonu formularza, kliknij przycisk Tak.

Po zmodyfikowaniu szablonu formularza, Zapisz szablon formularza przed opublikowaniem.

Publikowanie szablonu formularza

Po wprowadzeniu zmiany, musisz opublikować zmodyfikowany szablon formularza do biblioteki dokumentów.

  1. W menu plik kliknij pozycję Publikuj.

  2. Na pierwszej stronie Kreatora publikowania kliknij pozycję do programu SharePoint server z lub bez usług InfoPath Forms Services, a następnie kliknij przycisk Dalej.

  3. Na następnej stronie kreatora w polu Wprowadź lokalizację witryny programu SharePoint lub usług InfoPath Forms Services wpisz lokalizację biblioteki dokumentów w zbiorze witryn w witrynie programu SharePoint, a następnie kliknij przycisk Dalej.

  4. Na następnej stronie kliknij Bibliotekę dokumentów, a następnie kliknij przycisk Dalej.

  5. Na następnej stronie kliknij przycisk Aktualizuj szablonu formularza w istniejącej biblioteki dokumentów.

  6. Na liście Biblioteka dokumentów, aby zaktualizować kliknij bibliotekę dokumentów, a następnie kliknij przycisk Dalej.

  7. Kliknij przycisk Dalej.

  8. Na następnej stronie Zweryfikuj poprawność informacji wyświetlanych, a następnie kliknij pozycję Publikuj.

  9. Kliknij przycisk Zamknij.

    Otrzymasz potwierdzenie na ostatniej stronie kreatora, gdy został pomyślnie opublikowany szablon formularza.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×