Rejestrowanie makra

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Jeśli jakieś zadanie jest często wykonywane w programie Microsoft Office Project, można je zautomatyzować za pomocą makra. Makro jest serią poleceń i funkcji przechowywanych w moduł i może być uruchamiane zawsze, gdy trzeba wykonać dane zadanie.

  1. Na karcie Widok kliknij polecenie makra, a następnie kliknij przycisk Zarejestruj makro.

    (W programie Project 2007, w menu Narzędzia wskaż polecenie makro, a następnie kliknij Zarejestruj nowe makro ).

  2. W polu Nazwa makra wpisz nazwę makro.

    Pierwszy znak nazwy makra musi być literą. Pozostałe znaki mogą być literami, cyframi lub znakami podkreślenia. Spacje nie są dozwolone w nazwie makra, ale wyrazy można rozdzielać za pomocą znaku podkreślenia.

  3. Aby umożliwić uruchamianie makra przez naciśnięcie klawisz skrótu, wpisz literę lub kombinację klawiszy w polu Klawisz skrótu.

    Można użyć klawiszy CTRL+ litera (w przypadku małych liter) lub CTRL+SHIFT+ litera (w przypadku wielkich liter), gdzie litera jest dowolnym klawiszem literowym na klawiaturze, ale nie jest cyfrą ani znakiem specjalnym. Nie można wykorzystać kombinacji klawiszy, która jest już używana w programie Microsoft Office Project.

  4. Na liście Przechowuj makro w kliknij lokalizację, w której chcesz przechowywać makro.

    • Aby makro było dostępne przy każdym użyciu programu Project, kliknij opcję Plik globalny.

    • Aby udostępnić makro tylko w bieżącym projekcie, kliknij opcję Ten projekt.

  5. Aby dołączyć opis makra, wpisz go w polu Opis.

  6. Jeżeli w trakcie rejestracji makra zaznaczono komórki, te same kolumny (pola) zostaną zaznaczone przez makro przy każdym jego uruchomieniu, bez względu na to, która komórka została zaznaczona jako pierwsza, ponieważ rejestrowane są odwołania bezwzględne do kolumn. Jeżeli makro w momencie uruchomienia powinno zaznaczać kolumny bez względu na położenie aktywnej komórki, kliknij opcję Względne w obszarze Odwołania kolumn.

    W momencie uruchomienia makra zostaną zaznaczone wiersze bez względu na położenie aktywnej komórki, ponieważ rejestrowane są odwołania względne do wierszy. Jeżeli za każdym razem ten sam wiersz powinien być zaznaczany przez makro, bez względu na to, która komórka została zaznaczona jako pierwsza, kliknij opcję Bezwzględne (Identyfikator) w obszarze Odwołania wierszy.

    Uwaga: Ustawienia te będą używane przez program Project podczas rejestrowania makr do czasu ich zmiany lub do chwili zamknięcia programu Project.

  7. Kliknij przycisk OK, a następnie wykonaj czynności, które chcesz zarejestrować.

  8. Po wykonaniu wszystkich czynności, które chcesz zarejestrować, na karcie Widok kliknij przycisk makra, a następnie kliknij przycisk Zatrzymaj rejestrowanie.

    (W programie Project 2007, w menu Narzędzia wskaż polecenie makro, a następnie kliknij Zatrzymaj rejestrator ).

Uwaga dotycząca zabezpieczeń: Ponieważ makra mogą zawierać wirusy, podczas ich uruchamiania należy zachować ostrożność. Należy przedsięwziąć następujące środki bezpieczeństwa: uruchamiać na komputerze aktualne oprogramowanie antywirusowe; ustawić poziom zabezpieczeń makr na wysoki; wyczyścić pole wyboru Ufaj wszystkim zainstalowanym dodatkom i szablonom; używać podpisów cyfrowych; korzystać z listy zaufanych wydawców.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×