Publikowanie bazy danych w witrynie programu SharePoint

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Gdy publikujesz bazę danych Microsoft Office Access 2007 w witrynie usługi Windows SharePoint Services 3.0, inni członkowie organizacji mogą pracować z bazą danych.

W tym artykule

Omówienie

Publikowanie bazy danych w witrynie programu SharePoint

Ponowne publikowanie bazy danych w witrynie programu SharePoint

Omówienie

Gdy publikujesz bazę danych w witrynie programu SharePoint, możesz udostępnić te dane innym osobom korzystającym z witryny programu SharePoint, gdy nadal używasz programu Access jako frontonu formularzy, raportów i zapytań w bazie danych.

Istnieją dwa sposoby współpracy z publikowaną bazą danych. Jeśli jesteś projektantem bazy danych, możesz tworzyć zapytania, formularze i raporty korzystające z danych z witryny programu SharePoint. Jeśli jesteś użytkownikiem bazy danych, możesz za pomocą programu Access wprowadzać, wyświetlać i analizować dane z witryny programu SharePoint.

Możesz opublikować utworzoną już bazę danych lub utworzyć bazę danych z jednej lub kilku tabel, które są połączone z listami lub bibliotekami programu SharePoint. Gdy dane z listy lub biblioteki programu SharePoint są połączone z tabelą programu Access, można tworzyć widoki dla tych list lub bibliotek opartych na formularzach, kwerendach i raportach w programie Access. Umożliwia to utworzenie aplikacji programu Access śledzącej dane w witrynie programu SharePoint.

Jeśli na przykład witryna programu SharePoint zawiera listy do śledzenia problemów związanych z obsługą klientów i przechowywania informacji o pracownikach, można utworzyć bazę danych programu Access, która będzie aplikacją zewnętrzną dla tych list. Korzystając z zapytań programu Access, można analizować problemy, a dzięki raportom programu Access można formatować i publikować pisemne raporty ze spotkań dotyczących stanu zespołu. Jeśli użytkownicy mają dostęp na swoich komputerach, są one dostępne w menu Widok Menu Widok dla listy programu SharePoint. Osoby wyświetlające listę w witrynie programu SharePoint będą mogły lokalizować i otwierać zapytania, raporty oraz inne obiekty programu Access przez kliknięcie menu Widok.

Gdy publikujesz bazę danych w witrynie programu SharePoint po raz pierwszy, program Access udostępnia listę serwerów sieci Web, które ułatwiają przejście do lokalizacji, w której chcesz publikować, na przykład w bibliotece dokumentów. Po opublikowaniu bazy danych program Access zapamiętuje lokalizację, tak aby nie trzeba było ponownie lokalizować serwera po opublikowaniu zmian.

Publikowanie bazy danych w witrynie programu SharePoint jest dostępne tylko w przypadku plików bazy danych zapisanych w formacie Office Access 2007.

Praca z danymi w witrynie programu SharePoint

Jeśli chcesz utworzyć bazę danych opartą na liście programu SharePoint, możesz zacząć od listy programu SharePoint. Możesz kliknąć pozycję Otwórz w programie Microsoft Access w menu Akcje Obraz menu dla listy programu SharePoint, a następnie wybrać łącze do danych w witrynie programu SharePoint. Następnie możesz tworzyć formularze, raporty i kwerendy dla danych oraz inne listy dodawane do bazy danych.

Po opublikowaniu bazy danych w bibliotece w witrynie programu SharePoint obiekty utworzone w programie Access będą dostępne dla innych do użycia w menu Widok listy programu SharePoint. Po otwarciu widoków obiekty programu Access są dostępne jako tylko do odczytu. Aby zaktualizować widoki, możesz zaktualizować odpowiednie obiekty, edytując opublikowaną bazę danych.

Gdy ludzie współpracują z opublikowaną bazą danych, są monitowani o zapisanie kopii lokalnej. Zmiany są przechowywane lokalnie do momentu opublikowania zmian. Zwykle przyspiesza to wydajność i ułatwia odzyskiwanie danych, gdy wystąpi błąd sieciowy. Po wprowadzeniu jakichkolwiek zmian w danych lub obiektach należy ponownie opublikować bazę danych, zanim zmiany staną się dostępne dla innych osób.

Program Access zawiera kilka przycisków, które umożliwiają łatwe korzystanie z danych z list programu SharePoint, na przykład tworzenie alertów i modyfikowanie kolumn list. W przypadku edytowania tabel połączonych z listami programu SharePoint w opublikowanej bazie danych za pomocą programu Access przyciski są dostępne w grupie Lista programu SharePoint na karcie Arkusz danych .

Gdy publikujesz bazę danych w witrynie programu SharePoint, baza danych staje się dostępna dla osób z uprawnieniami do współpracy z tą witryną. Jeśli użytkownicy mają uprawnienie do zmieniania list w lokalizacji, w której opublikowano bazę danych, taką jak biblioteka dokumentów, mogą aktualizować bazę danych. Jeśli użytkownicy mają uprawnienia do współtworzenia list w witrynie programu SharePoint, mogą dodawać dane do bazy danych. Jeśli użytkownicy mają uprawnienia do wyświetlania list, mogą wyświetlać dane w bazie danych.

Ponowne publikowanie bazy danych

Gdy publikujesz bazę danych w witrynie programu SharePoint, a następnie wprowadzasz zmiany w danych, ponownie Opublikuj bazę danych, aby zostały zapisane ostatnie zmiany. Po ponownym opublikowaniu baza danych jest wyświetlana jako dostępna baza danych przy następnym otwarciu programu Access.

Początek strony

Publikowanie bazy danych w witrynie programu SharePoint

Podczas publikowania bazy danych możesz zacząć od istniejącej bazy danych lub utworzyć bazę danych przy użyciu list w witrynie programu SharePoint.

  1. Kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , wskaż polecenie Publikuj , a następnie kliknij pozycję serwer zarządzania dokumentami.

  2. Wpisz adres URL witryny programu SharePoint, w której chcesz opublikować bazę danych.

    Jeśli podczas ostatniego otwierania programu Access była używana ta sama lokalizacja, baza danych zostanie wyświetlona w oknie dialogowym Publikowanie na serwerze sieci Web .

    Uwaga: Ta opcja jest dostępna tylko wtedy, gdy baza danych jest zapisana w formacie Office Access 2007.

  3. Wybierz bibliotekę, na przykład bibliotekę dokumentów, w której chcesz opublikować bazę danych, a następnie kliknij przycisk Otwórz.

  4. W polu Nazwa wpisz nazwę pliku bazy danych.

  5. Kliknij pozycję Opublikuj.

Uwaga: Po otwarciu bazy danych w witrynie programu SharePoint zostanie wyświetlony monit o zapisanie kopii lokalnej.

Początek strony

Ponowne publikowanie bazy danych w witrynie programu SharePoint

Po wprowadzeniu zmian w danych lub projekcie bazy danych należy ponownie opublikować ją w witrynie programu SharePoint. W przypadku ponownego publikowania bazy danych program Access zapamiętuje lokalizację, więc nie trzeba jej ponownie przechodzić.

Po otwarciu bazy danych do edycji, która została opublikowana w bibliotece programu SharePoint, w górnej części bazy danych zostanie wyświetlony pasek komunikatów z przyciskiem Publikuj w witrynie programu SharePoint . Jeśli pasek komunikatów jest niedostępny z jakiegoś powodu — na przykład po zamknięciu paska komunikatów podczas pracy — możesz użyć poleceń publikowania dostępnych na przycisku pakietu Microsoft Office.

  1. Na pasku komunikatów kliknij przycisk Publikuj w witrynie programu SharePoint .

    Uwaga: Jeśli nie widzisz paska komunikatów z przyciskiem Publikuj w witrynie programu SharePoint , kliknij przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , wskaż polecenie Publikuj , a następnie kliknij pozycję serwer zarządzania dokumentami.

  2. W oknie dialogowym Publikowanie na serwerze sieci Web upewnij się, że pokazana biblioteka jest lokalizacją, w której chcesz ponownie opublikować dane.

  3. Kliknij pozycję Opublikuj.

  4. Po wyświetleniu monitu o zastąpienie kopii bazy danych w witrynie kliknij przycisk tak.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×