Przygotowanie źródła danych programu Excel dla korespondencji seryjnej programu Word

Utworzono listę kontaktów i innych danych, których chcesz użyć w korespondencji seryjnej programu Word. Jeśli źródłem danych jest istniejący arkusz kalkulacyjny programu Excel, wystarczy przygotować dane do korespondencji seryjnej. Jeśli jednak źródłem danych jest plik z wartościami rozdzielanymi znakami tabulatora (txt) lub przecinkami (csv), należy najpierw zaimportować dane do programu Excel, a następnie przygotować je do korespondencji seryjnej.

Krok 1. Konfigurowanie źródła danych w programie Excel

Jeśli korzystasz już z arkusza kalkulacyjnego programu Excel jako źródła danych dla korespondencji seryjnej w programie Word, pomiń ten krok. Jeśli źródłem danych jest plik txt lub csv, skonfiguruj dane w programie Excel przy użyciu Kreatora importu tekstu.

Po pomyślnym zaimportowaniu pliku txt lub csv przejdź do kroku 2.

  1. Otwórz program Excel.

  2. Przejdź do pozycji Dane > Z tekstu/pliku CSV.

    Zaznaczanie tekstu/pliku CSV na karcie dane

  3. Wybierz odpowiedni plik txt lub csv, a następnie wybierz pozycję Importuj.

  4. W oknie podglądu wybierz pozycję Przekształć dane.

  5. Wybierz kod pocztowy lub inną kolumnę do sformatowania.

  6. Przejdź do pozycji Przekształcenie > Typ danych: i wybierz pozycję Tekst.

    Okno dodatku Power Query z zaznaczonym tekstem

  7. Wybierz pozycję Zastąp bieżący.

  8. W razie potrzeby powtórz kroki od 5 do 7.

  9. Wybierz pozycję Zamknij i załaduj.

  10. Przejdź do pozycji Plik > Zapisz jako i zapisz pod inną nazwą.

  1. Otwórz program Excel.

  2. Excel 2016    Przejdź do pozycji Dane > Pobieranie danych zewnętrznych > Z tekstu.

    Opcja Z tekstu jest wyróżniona na karcie Dane.

  3. Wybierz odpowiedni plik txt lub csv, a następnie wybierz pozycję Importuj.

  4. W Kreatorze importu tekstu w okienku Typ danych źródłowych wybierz opcję Rozdzielany.

    Pobieranie danych zewnętrznych z tekstu w programie Excel, Kreator importu tekstu, krok 1 z 3

  5. Zaznacz pole wyboru Moje dane mają nagłówki znajdujące się nad okienkiem Podgląd, jeśli plik zawiera nagłówki, a następnie wybierz pozycję Dalej.

  6. W obszarze Ograniczniki zaznacz pole wyboru, które jest zgodne z ogranicznikiem (na przykład Tabulator lub Przecinek) używanym w danych, a następnie wybierz pozycję Dalej.

    Opcje pozycji Ograniczniki są wyróżnione w Kreatorze importu tekstu.

  7. W obszarze Podgląd danych wybierz kolumnę zawierającą kody pocztowe, a następnie w obszarze Format danych w kolumnie wybierz pozycję Tekst.

    Opcja Tekst w obszarze Format danych kolumny jest wyróżniona w Kreatorze importu tekstu.

    Uwaga: Po każdorazowym zastosowaniu formatu danych (Ogólny, Tekst lub Data) do kolumny nazwa formatu pojawi się w nagłówku tabeli dla tej kolumny.

  8. W razie potrzeby powtórz krok 7, wybierając kolumnę, którą chcesz zmodyfikować, oraz format danych, który chcesz zastosować.

  9. Wybierz pozycję Zakończ.

  10. W oknie dialogowym Importowanie danych zaakceptuj domyślne ustawienie opcji Istniejący arkusz oraz adres komórki, a następnie wybierz pozycję OK.

    W oknie dialogowym Importowanie danych wybierz opcję umieszczenia danych w istniejącym arkuszu, która jest ustawieniem domyślnym, lub w nowym arkuszu

    Przestroga: Adres komórki w oknie dialogowym Importowanie danych zawiera obecnie wybraną komórkę. Dane są importowane, począwszy od adresu nazwanej komórki.

  11. Zapisz arkusz kalkulacyjny z nową nazwą pliku.

Krok 2. Przygotowywanie źródła danych

Upewnij się, że w źródle danych programu Excel, które będzie służyć jako lista adresowa w korespondencji seryjnej programu Word, kolumny danych liczbowych są poprawnie sformatowane. Sformatuj kolumny zawierające liczby, aby pasowały do określonej kategorii, na przykład waluta.

Jeśli jako kategorię wybierzesz wartość procentową, pamiętaj, że format procentowy pomnoży wartość komórki przez 100. Sformatuj kolumnę wartości procentowych jako tekst, jeśli chcesz uniknąć mnożenia wartości.

Kody pocztowe muszą zostać sformatowane jako tekst, aby zabezpieczyć dane podczas tworzenia korespondencji seryjnej. Jeśli nie wykonano tego podczas importowania, sformatuj je teraz. Zera wiodące w kodach (na przykład 00399) są pomijane podczas tworzenia korespondencji seryjnej, jeśli nie są sformatowane jako tekst.

  1. Wybierz kolumnę zawierającą kody pocztowe lub inne dane do sformatowania.

  2. Przejdź do pozycji Narzędzia główne, a następnie w grupie Liczba zaznacz strzałkę w dół obok pola Format liczby, a następnie wybierz odpowiednią opcję z listy (na przykład tekst).

    W programie Excel na karcie Narzędzia główne w grupie Liczba w polu Ogólne kliknij strzałkę w dół, aby wybrać odpowiedni format liczb.

Upewnij się, że przed lub za polem korespondencji seryjnej został dodany odpowiedni symbol. Jeśli pominiesz symbole, waluta i wartości procentowe w Twojej wiadomości będą wyglądały jak na poniższym przykładzie.

Dokument korespondencji seryjnej zawiera tekst w formacie „wkład wynosi 50,00 zł” i „oferujemy 20% rabatu”.

Jeśli użyjesz symboli, użyte liczby będą bardziej sensowne.

Dokument korespondencji seryjnej zawiera tekst w formacie „wkład wynosi 50,00 zł” i „oferujemy 20% rabatu”.

W dokumencie korespondencji seryjnej możesz dodać symbole przed lub za polem korespondencji seryjnej, jak pokazano poniżej:

Przykładowy dokument korespondencji seryjnej, w którym po polu Darowizna jest dodawany symbol waluty, a po polu Procent występuje symbol procentu.

Zobacz też

Najważniejszym krokiem w procesie tworzenia korespondencji seryjnej w programie Word jest konfigurowanie i przygotowywanie źródła danych. Możesz użyć istniejącego źródła danych programu Excel lub utworzyć nowe, importując plik wartości rozdzielanych tabulatorami (txt) lub przecinkami (csv). Po skonfigurowaniu i przygotowaniu źródła danych możesz utworzyć korespondencję seryjną, używając dynamiczna wymiana danych (DDE, Dynamic Data Exchange) z Kreatorem korespondencji seryjnej krok po kroku lub metody ręcznego tworzenia korespondencji seryjnej.

Jeśli nie korzystasz z istniejącego źródła danych programu Excel do korespondencji seryjnej, możesz użyć listy kontaktów lub książki adresowej w pliku txt lub csv. Kreator importu tekstu przeprowadzi Cię przez kolejne etapy pobierania danych znajdujących się w pliku txt lub csv do programu Excel.

  1. Otwórz program Excel.

  2. Na karcie Dane wybierz pozycję Z tekstu/pliku csv.

  3. Wybierz odpowiedni plik txt lub csv, a następnie wybierz pozycję Importuj.

  4. W Kreatorze importu tekstu w okienku Typ danych źródłowych wybierz opcję Rozdzielany.

    Pobieranie danych zewnętrznych z tekstu w programie Excel, Kreator importu tekstu, krok 1 z 3

  5. Jeśli importowany plik zawiera nagłówki, zaznacz pole wyboru Moje dane mają nagłówki znajdujące się nad okienkiem Podgląd, a następnie wybierz pozycję Dalej.

  6. W obszarze Ograniczniki zaznacz pole wyboru, które jest zgodne z ogranicznikiem (na przykład Tabulator lub Przecinek) używanym w Twoich danych, a następnie wybierz pozycję Dalej.

    Opcje pozycji Ograniczniki są wyróżnione w Kreatorze importu tekstu.

    Porada: W okienku Podgląd danych można zobaczyć, jak będą wyglądały wyniki w formacie tabeli.

  7. W obszarze Podgląd danych wybierz kolumnę zawierającą kody pocztowe, a następnie w obszarze Format danych w kolumnie wybierz pozycję Tekst.

    Opcja Tekst w obszarze Format danych kolumny jest wyróżniona w Kreatorze importu tekstu.

    Uwagi: 

    • Dostępne formaty to Ogólne, Tekst i Data. Po każdorazowym zastosowaniu formatu danych do kolumny nazwa formatu pojawia się w nagłówku tabeli dla tej kolumny.

    • Jeśli na przykład w kolumnie znajdują się dane liczbowe, takie jak wartości procentowe lub walutowe, można je sformatować dopiero po zaimportowaniu pliku. Aby uzyskać więcej informacji, zobacz podsekcję „Formatowanie danych liczbowych w programie Excel” poniżej.

  8. W razie potrzeby powtórz krok 7, wybierając kolumnę, którą chcesz zmodyfikować, oraz format danych, który chcesz zastosować.

  9. Wybierz pozycję Zakończ.

  10. W oknie dialogowym Importowanie danych zaakceptuj domyślne ustawienie opcji Istniejący arkusz oraz adres komórki, a następnie wybierz pozycję OK.

    W oknie dialogowym Importowanie danych wybierz opcję umieszczenia danych w istniejącym arkuszu, która jest ustawieniem domyślnym, lub w nowym arkuszu

    Przestroga: Adres komórki w oknie dialogowym Importowanie danych zawiera obecnie wybraną komórkę. Dane są importowane, począwszy od adresu nazwanej komórki.

  11. Po zakończeniu zapisz swoje źródło danych pod nową nazwą pliku.

Formatowanie danych liczbowych w programie Excel

Sformatuj wszystkie dane liczbowe, takie jak wartości procentowe lub walutowe, w każdym nowym lub istniejącym źródle danych w programie Excel, którego zamierzasz używać w korespondencji seryjnej w programie Word. Aby zachować dane numeryczne sformatowane jako wartość procentowa lub walutowa podczas tworzenia korespondencji seryjnej, wykonaj instrukcje zawarte w sekcji „Krok 2. Używanie dynamicznej wymiany danych (DDE, Dynamic Data Exchange) w ramach korespondencji seryjnej”.

Upewnij się, że w źródle danych programu Excel, które będzie służyć jako lista adresowa w korespondencji seryjnej programu Word, kolumny danych liczbowych są poprawnie sformatowane. Sformatuj kolumny zawierające liczby, aby pasowały do określonej kategorii, na przykład waluta.

  1. Otwórz swoje źródło danych programu Excel.

  2. Wybierz kolumnę, którą chcesz sformatować.

  3. Na karcie Narzędzia główne w grupie Liczba kliknij strzałkę w dół przy okienku Format liczb (Ogólne), a następnie wybierz odpowiednią opcję z listy.

    W programie Excel na karcie Narzędzia główne w grupie Liczba w polu Ogólne kliknij strzałkę w dół, aby wybrać odpowiedni format liczb.

  4. W razie potrzeby powtórz kroki 2 i 3.

  5. Gdy skończysz, wybierz pozycję Zapisz.

W przypadku źródła danych programu Excel zawierającego sformatowane liczby, takie jak wartości procentowe i walutowe, niektóre dane liczbowe mogą nie zachować swojego formatowania podczas tworzenia korespondencji seryjnej. Uzyskasz żądane wyniki korespondencji seryjnej i możesz zachować format danych numerycznych w programie Excel za pomocą DDE.

Format danych programu Excel w porównaniu z polem roboczym korespondencji seryjnej przy użyciu dynamicznej wymiany danych lub nie

Uwaga: Jeśli zdecydujesz się nie korzystać z DDE, postępuj zgodnie z instrukcjami w artykule Używanie korespondencji seryjnej do wysyłania zbiorczych wiadomości e-mail.

  1. Otwórz program Word, wybierz pozycję Plik > Opcje > Zaawansowane.

  2. W obszarze Ogólne zaznacz pole wyboru Potwierdź konwersję formatu podczas otwierania pliku.

    Opcja Potwierdź konwersję formatu podczas otwierania pliku

  3. Wybierz pozycję OK.

  4. Na karcie Korespondencja wybierz pozycję Rozpoczynanie korespondencji seryjnej > Kreator korespondencji seryjnej krok po kroku.

    W programie Word na karcie Korespondencja wybierz pozycję Rozpocznij korespondencję seryjną, a następnie wybierz pozycję Kreator korespondencji seryjnej krok po kroku.

  5. W okienku Korespondencja seryjna w obszarze Wybierz adresatów wybierz pozycję Użyj istniejącej listy.

    W programie Word po wybraniu Kreatora tworzenia korespondencji seryjnej krok po kroku w grupie korespondencji seryjnej zostanie otwarte okienko zadań Korespondencja seryjna

  6. W obszarze Użyj istniejącej listy wybierz pozycję Przeglądaj, a następnie otwórz sformatowany arkusz kalkulacyjny.

  7. W oknie dialogowym Potwierdzanie źródła danych wybierz pole wyboru Pokaż wszystko, a następnie wybierz pozycję Arkusze programu MS Excel przez DDE (*.xls) > OK.

    Okno dialogowe Potwierdzanie źródła danych

  8. W oknie dialogowym Microsoft Excel wybierz pozycję Cały arkusz kalkulacyjny > OK.

    Okno dialogowe programu Microsoft Excel w programie Word

  9. Gdy zostanie otwarte okno dialogowe Adresaci korespondencji seryjnej, wybierz przycisk OK.

    Okno dialogowe Adresaci korespondencji seryjnej, w którym jest wyświetlana zawartość arkusza kalkulacyjnego programu Excel użytego jako źródło danych listy adresowej.

  10. Przejdź do scalania listu, wiadomości e-mail, etykiety lub koperty.

Porada: Możesz uniknąć wyświetlania monitu przez program Word za każdym razem, gdy otwierasz plik danych. Po nawiązaniu połączenia z listą adresową przejdź do pozycji Plik > Opcje > Zaawansowane. W obszarze Ogólne usuń zaznaczenie pola wyboru Potwierdź konwersję formatu podczas otwierania pliku.

Jeśli w arkuszu kalkulacyjnym programu Excel została utworzona lista kontaktów, ważne jest, aby sformatować dowolne kody pocztowe jako tekst w celu uniknięcia utraty danych. Jeśli importujesz kontakty z pliku tekstowego (txt) lub z pliku wartości rozdzielanych przecinkami (csv) do nowego arkusza kalkulacyjnego, Kreator importu tekstu może ułatwić Ci zaimportowanie i sformatowanie danych.

Krok 1. Konfigurowanie źródła danych w programie Excel

Jeśli korzystasz już z arkusza kalkulacyjnego programu Excel jako źródła danych dla korespondencji seryjnej w programie Word, przejdź do kroku 2 w tym temacie. Jeśli źródłem danych jest plik txt lub csv zawierający na przykład Twoje kontakty z usługi Gmail, skonfiguruj dane w programie Excel przy użyciu Kreatora importu tekstu.

  1. Otwórz program Excel, a następnie na karcie Dane wybierz pozycję Z tekstu.

    Wybieranie pozycji Z tekstu na karcie Dane

  2. Wybierz odpowiedni plik csv lub txt, a następnie wybierz pozycję Pobierz dane.

  3. W Kreatorze importu tekstu wybierz przycisk Dalej.

  4. W obszarze Ograniczniki zaznacz pole odpowiadające ogranicznikowi użytemu do rozdzielenia poszczególnych elementów danych (może to być na przykład tabulator lub przecinek). Następnie wybierz przycisk Dalej.

    Porada: W okienku Podgląd wybranych danych można zobaczyć, jak będą wyglądały wyniki w formacie tabeli.


    Krok 2 Kreatora importu tekstu
     

  5. W okienku Podgląd wybranych danych wybierz kolumnę zawierającą kody pocztowe. Następnie w obszarze Format danych w kolumnie wybierz pozycję Tekst.

    Kreator importu tekstu, krok 3
     

  6. W razie potrzeby powtórz krok 5, wybierając kolumnę, którą chcesz zmodyfikować, oraz format danych, który chcesz zastosować.

    Uwaga: Po każdorazowym zastosowaniu formatu danych do kolumny nazwa formatu pojawia się w nagłówku tabeli dla tej kolumny.

  7. Kliknij przycisk Zakończ.

  8. W oknie dialogowym Importowanie danych wybierz miejsce, w którym program Excel ma umieścić dane, a następnie kliknij przycisk OK.

    Uwaga: Zapisz arkusz kalkulacyjny z nową nazwą pliku.

Krok 2. Formatowanie danych liczbowych w arkuszu kalkulacyjnym programu Excel

Aby upewnić się, że w korespondencji seryjnej w kodach pocztowych nie są usuwane zera, sformatuj kolumnę zawierającą te kody jako tekst.

  1. Otwórz arkusz kalkulacyjny i wybierz kolumnę zawierającą kody pocztowe.

  2. Na karcie Narzędzia główne w polu Format wybierz pozycję Tekst.

    Na karcie Narzędzia główne w polu Format wybierz pozycję Tekst

Teraz można użyć tych danych na potrzeby korespondencji seryjnej.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×