Projektowanie widoku przeznaczonego do wydruku

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Utworzone szablony formularzy programu Microsoft Office InfoPath są przeznaczone do otwarto i wypełniać online w programie InfoPath, sam lub za pomocą przeglądarki sieci Web. Jednak użytkownicy mogą wybrać do wydrukowania kopii wypełniony formularz ich informacje osobiste lub archiwizacji. Z tego powodu jest dobrym pomysłem jest weryfikowanie szablonu formularza wygląda dopuszczalne, po wydrukowaniu. Można na przykład upewnij się, że formanty w szablonie formularza mieszczą się w obrębie marginesów wydruku i czy jest czytelny tekst w formularzu wydruku.

Oprócz tego okienka zadań Widoki umożliwia tworzenie specjalnych wersji szablonu formularza — nazywaną widokiem wydruku — przeznaczoną specjalnie na potrzeby drukowania.

W tym artykule wyjaśniono, jak zaprojektować widok wydruku dla szablonu formularza i inne metody tworzenia szablonów formularzy druku.

W tym artykule

Różnica między drukowanie szablonu formularza i formularza

Wprowadzenie do drukowania widoków

Projektowanie widoku wydruku opartego na podstawie istniejącego widoku

Projektowanie widoku wydruku dla programu Word

Różnica między drukowanie szablonu formularza i formularza

Szablon formularza, aby uzyskać ogólne zorientować się, jak formanty i inne obiekty są wyświetlane na stronie wydruku lub sprawdzić ustawienia drukowania, takie jak nagłówki lub stopki, można wydrukować. Podczas drukowania szablonu formularza z tryb projektowania, można zobaczyć określonych elementów w szablonie formularza drukowanego, takie jak przyciski, które nie pojawia się podczas drukowania formularza na podstawie szablonu formularza.

Użytkownicy drukowania formularz oparty na szablonie formularza, InfoPath sprawia, że zmiany w formularzu lub usuwa określonych elementów, które nie miały znaczenie w kontekście drukowanych. Na przykład tekst instruktażowy Wstaw element, który pojawia się domyślnie w obszarze powtarzających się tabel nie są wyświetlane w formie drukowanej. Zgodnie z ich znaczenie na drukowanej stronie utraty tych elementów, nie będzie przycisk kontrolki, pozycje w polu listy lub strzałki przewijania.

Początek strony

Wprowadzenie do drukowania widoków

Chociaż szablonów formularzy są przeznaczone do zbierania danych w formie elektronicznej, można utworzyć widok wydruku jest widok, w którym są zaprojektowane specjalnie do wydrukowania. Jest to przydatne, gdy użytkownicy, aby drukować formularze przy użyciu określonego układu lub wydrukować tylko niektórych części formularza.

Jeśli szablon formularza zawiera wiele widoków, można utworzyć widok wydruku dla każdego widoku. Ponadto można określić jeden widok wydruku, która dotyczy wszystkich widoków w szablonie formularza. Jeśli szablon formularza zawiera trzy różne widoki, może być na przykład utworzyć widok wydruku, który powoduje konsolidowanie najważniejsze informacje z poszczególnych widoków do jednej drukowanej stronie.

Za pomocą łącza Tworzenie wersji do druku tego widoku w okienku zadań Widoki, aby utworzyć i skojarzyć istniejącego widoku Podgląd wydruku. Kliknij to łącze, InfoPath wykonuje następujące czynności:

  • Tworzy nowy, pusty widok o nazwie nazwę wersji do druku, gdzie nazwa jest nazwą widoku, na którym jest oparty Podgląd wydruku.

  • Kojarzy Podgląd wydruku w widoku, na którym jest oparty. To skojarzenie w został zapisany w oknie dialogowym Właściwości widoku, na karcie Ustawienia wydruku. Załóżmy na przykład utworzony widok wydruku, który jest oparty na widok Zatwierdzanie w szablonie formularza. Po kliknięciu przycisku Drukuj w widoku zatwierdzenia, drukowany jako programu InfoPath, niezależnie od jest wyświetlany w widoku Wydruku zatwierdzenia wersji.

Po utworzeniu widoku wydruku, można zaprojektować go tak, aby odzwierciedlała sposób, który ma się znajdować po wydrukowaniu formularz. Wymaga to zazwyczaj, kopiując i wklejając formantów z innych widoków w szablonie formularza do widoku wydruku. W razie potrzeby można zastąpić niektórych formantów dla pozostałych kontrolek w widoku wydruku. Na przykład możesz zastąpić polu listy rozwijanej ukrywa pozycje w polu listy domyślnie pola standardowej listy wpisów są domyślnie wyświetlane. Dzięki temu wszystkie wpisy są wyświetlane w formularzu wydruku. W oknie dialogowym Właściwości widoku, takich jak nagłówki, stopki i marginesy strony można również określić niestandardowe opcje drukowania dla widoku wydruku.

Początek strony

Projektowanie widoku wydruku opartego na podstawie istniejącego widoku

Domyślnie podczas drukowania formularza, który nie ma określonego widoku wydruku skojarzone z nią drukowany widok, który jest obecnie wyświetlane na komputerze użytkownika. Jeśli tworzysz podgląd wydruku programu InfoPath umożliwia drukowanie tego widoku zamiast bieżącego widoku. Można ustawić dowolny istniejący widok jako widok wydruku. Poniższa procedura wyjaśniono, jak używać istniejący widok jako podstawy dla widoku wydruku.

  1. W menu Widok kliknij polecenie Zarządzaj widokami.

  2. Na liście Wybierz widok w okienku zadań Widoki kliknij widok, dla którego chcesz utworzyć widok wydruku.

  3. W obszarze Akcje kliknij przycisk Utwórz wersję drukowania tego widoku.

  4. W oknie dialogowym Tworzenie wersji do druku wpisz nazwę dla widoku wydruku, a następnie kliknij przycisk OK.

  5. W okienku zadań Widoki kliknij dwukrotnie Podgląd wydruku.

  6. W oknie dialogowym Właściwości widoku wybierz odpowiednie opcje na kartach Ustawienia wydruku i Ustawienia strony, a następnie kliknij przycisk OK. Na przykład możesz określić ustawienia marginesów domyślnych dla widoku wydruku, lub dodać nagłówki lub stopki.

  7. Aby przełączyć się do oryginalnego widoku w okienku zadań Widoki kliknij nazwę widoku na liście Wybierz widok.

  8. Aby zaznaczyć cały tekst w widoku, naciśnij klawisze CTRL + A.

  9. Aby skopiować zaznaczenie do Schowka, naciśnij klawisze CTRL + C.

  10. Aby przełączyć się do widoku wydruku, w okienku zadań Widoki kliknij nazwę widoku na liście Wybierz widok.

  11. Aby wkleić zaznaczenie z oryginalnego widoku do widoku wydruku, naciśnij klawisze CTRL + V.

  12. Usuń formanty i elementy układu, że nie potrzebujesz lub dodać dodatkowe funkcje kontroli.

    Porada: Aby szybko stwierdzić, czy formanty i inne elementy projektowe mieści się na drukowanej stronie, można wyświetlić prowadnicę szerokości strony wzdłuż prawej krawędzi szablonu formularza, klikając pozycję Prowadnica szerokości strony w menu Widok. Prowadnicę szerokości strony jest wyświetlany jako kreskowane pionową linię w szablonie formularza. Linia wskazuje, gdzie prawy margines drukowanej strony znajduje się, oparte na domyślnej drukarce dla Twojego komputera.

  13. Aby dodać podziały stron do widoku wydruku, kliknij miejsce, w którym ma się zaczynać się nowa strona, a następnie w menu Wstaw kliknij polecenie Podział strony.

    Uwaga: Podział strony jest wyświetlany jako kreskowane linii poziomej w szablonie formularza. Jeśli Podgląd szablonu formularza, nie będzie widoczna ta kreskowana linia lub inne wskazanie podziału strony. Aby zobaczyć, jak wpłyną na drukowane formularze, które są oparte na szablonie formularza podział strony, kliknij pozycję Podgląd wydruku Obraz przycisku na pasku narzędzi Standardowy.

Początek strony

Projektowanie widoku wydruku dla programu Word

Jeśli jesteś projektanta formularzy, kto rozumie technologii XML, można użyć dodawania widoku wydruku dla programu Word kreatora do tworzenia widoku wydruku opartego na programie Microsoft Office Word drukowanego danych formularza bezpośrednio z programu Word. Pozwala na korzystanie ze zakres drukowania funkcje, które są dostępne w programie Word. Aby to zrobić, musi mieć dostęp do istniejącego pliku przekształcenia XSL (XSLT) przekształcenia danych w szablonie formularza do formatu, który jest odpowiedni do drukowania w programie Word. Podczas drukowania formularza, który zawiera widoku wydruku opartego na programie Word, dane w tym formularzu wydrukuje bezpośrednio z poziomu programu Word. Plik XSLT musi być utworzony przy użyciu programu Microsoft Office Word 2003 lub Microsoft Office Word 2007.

Uwaga: Aby dowiedzieć się więcej na temat tworzenia pliku XSLT, odwołują się do programu Microsoft Office InfoPath 2003 Software Development Kit (SDK). Ten zestaw SDK zawiera narzędzia, o nazwie programu InfoPath do Kreatora programu Word, która umożliwia drukowanie danych formularzy programu InfoPath za pomocą programu Word 2003 lub Word 2007. Aby zlokalizować zestawu SDK programu InfoPath 2003, można znaleźć w sekcji Zobacz też.

  1. W menu Widok kliknij polecenie Zarządzaj widokami.

  2. W obszarze Akcje w okienku zadań Widoki kliknij Dodawania widoku wydruku dla programu Word.

  3. Postępuj zgodnie z instrukcjami dodawania widoku wydruku dla programu Word kreatora, aby określić plik XSLT, którego chcesz użyć dla widoku wydruku opartego na programie Word.

  4. Na liście Wybierz widok w okienku zadań Widoki kliknij widok, dla którego chcesz wyznaczyć widok wydruku opartego na programie Word, a następnie kliknij pozycję Wyświetl właściwości.

  5. Kliknij kartę Ustawienia wydruku.

  6. Na liście Wybierz istniejący widok do używania podczas drukowania tego widoku kliknij pozycję Podgląd wydruku opartego na programie Word.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×