Problemy ze zgodnością związane z sortowaniem i filtrowaniem

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Narzędzie sprawdzania zgodności wykryło co najmniej jeden problem ze zgodnością związany z sortowaniem i filtrowaniem.

Ważne: Przed zapisaniem skoroszytu w starszym formacie pliku należy rozwiązać problemy, które powodują znaczną utratę funkcjonalności, aby zapobiec trwałej utracie danych lub nieprawidłowemu działaniu.

Problemy powodujące nieznaczną utratę wierności mogą nie wymagać rozwiązania przed zapisaniem skoroszytu — dane ani funkcjonalność nie zostaną utracone, ale wygląd lub działanie skoroszytu mogą być nieco inne po otwarciu go w starszej wersji programu Microsoft Excel.

W tym artykule

Problemy powodujące znaczną utratę funkcjonalności

Problemy powodujące nieznaczną utratę wierności

Problemy powodujące znaczną utratę funkcjonalności

Problem

Rozwiązanie

W arkuszu w tym skoroszycie znajdują się informacje o stanie sortowania zawierające ponad trzy warunki sortowania. Te informacje zostaną utracone we wcześniejszych wersjach programu Excel.

Znaczenie    W Excel 2013 lub nowszym możesz zastosować sortowanie stany z maksymalnie 64 warunki sortowania, aby posortować dane według, ale obsługuje programu Excel 97 – 2003 sortować Państwa tylko maksymalnie trzy warunki. Aby uniknąć utraty stan sortowania informacji w programie Excel 97 – 2003, być może zechcesz Zmień stan sortowania do jednego, która korzysta z nie więcej niż trzy warunki. W programie Excel 97 – 2003 możesz również sortować dane ręcznie.

Jednak wszystkie informacje o stanie sortowania pozostaną dostępne w skoroszycie i zostaną zastosowane po ponownym otwarciu skoroszytu w Excel 2013 lub nowszym, o ile informacje o stanie sortowania nie były edytowane w programie Excel 97 – 2003.

Co należy zrobić    W narzędziu sprawdzania zgodności kliknij przycisk Znajdź, aby zlokalizować dane, które były sortowane za pomocą ponad trzech warunków, a następnie zmień stan sortowania, używając nie więcej niż trzech warunków.

W arkuszu w tym skoroszycie znajdują się informacje o stanie sortowania zawierające warunek sortowania z listą niestandardową. Te informacje zostaną utracone we wcześniejszych wersjach programu Excel.

Znaczenie    W Excel 2013 lub nowszym można sortować według listy niestandardowej. Aby uzyskać podobne wyniki sortowania w programie Excel 97 – 2003, można grupować dane, które chcesz posortować i ręcznie posortować dane.

Jednak wszystkie informacje o stanie sortowania pozostaną dostępne w skoroszycie i zostaną zastosowane po ponownym otwarciu skoroszytu w Excel 2013 lub nowszym, o ile informacje o stanie sortowania nie były edytowane w programie Excel 97 – 2003.

Co należy zrobić    W narzędziu sprawdzania zgodności kliknij przycisk Znajdź, aby zlokalizować dane, które były sortowane według listy niestandardowej, a następnie zmień stan sortowania, aby nie zawierał listy niestandardowej.

W arkuszu w tym skoroszycie znajdują się informacje o stanie sortowania zawierające warunek sortowania, który określa informacje o formatowaniu. Te informacje zostaną utracone we wcześniejszych wersjach programu Excel.

Znaczenie    W Excel 2013 lub nowszym można sortować dane według określonego formatu, takie jak kolor komórki, kolor czcionki lub zestawy ikon. W programie Excel 97 – 2003 można sortować tylko tekst.

Jednak wszystkie informacje o stanie sortowania pozostaną dostępne w skoroszycie i zostaną zastosowane po ponownym otwarciu skoroszytu w Excel 2013 lub nowszym, o ile informacje o stanie sortowania nie były edytowane w programie Excel 97 – 2003.

Co należy zrobić    W narzędziu sprawdzania zgodności kliknij przycisk Znajdź, aby zlokalizować dane, które były sortowane według określonego formatu, a następnie zmień stan sortowania, aby nie określał informacji o formatowaniu.

Początek strony

Problemy powodujące nieznaczną utratę wierności

Problem

Rozwiązanie

Niektóre dane w tym skoroszycie są filtrowane w sposób nieobsługiwany we wcześniejszych wersjach programu Excel. Wiersze ukryte przez filtr pozostaną ukryte, ale sam filtr nie będzie prawidłowo wyświetlany we wcześniejszych wersjach programu Excel.

Znaczenie    W Excel 2013 lub nowszym możesz zastosować filtr, które nie są obsługiwane w programie Excel 97 – 2003. Aby uniknąć utraty funkcji filtrowania, można wyczyścić filtr przed zapisaniem skoroszytu w starszym formacie pliku programu Excel. W programie Excel 97 – 2003 można następnie filtrować dane ręcznie.

Jednak wszystkie informacje o stanie filtrowania pozostaną dostępne w skoroszycie i zostaną zastosowane po ponownym otwarciu skoroszytu w Excel 2013 lub nowszym, o ile informacje o stanie filtrowania nie były edytowane w programie Excel 97 – 2003.

Co należy zrobić    W narzędziu sprawdzania zgodności kliknij przycisk Znajdź, aby zlokalizować filtrowane dane, a następnie wyczyść filtr, aby odkryć ukryte wiersze. Aby wyczyścić filtr, na karcie Narzędzia główne w grupie Edytowanie kliknij pozycję Sortuj i filtruj, a następnie kliknij pozycję Wyczyść.

Niektóre dane w tym skoroszycie są filtrowane według koloru komórki. Wiersze ukryte przez filtr pozostaną ukryte, ale sam filtr nie będzie prawidłowo wyświetlany we wcześniejszych wersjach programu Excel.

Znaczenie    W Excel 2013 lub nowszym można filtrować według koloru komórki, kolor czcionki lub zestawu ikon — te metody nie są obsługiwane w programie Excel 97 – 2003. Aby uniknąć utraty funkcji filtrowania, można wyczyścić filtr przed zapisaniem skoroszytu w starszym formacie pliku programu Excel. W programie Excel 97 – 2003 można następnie filtrować dane ręcznie.

Jednak wszystkie informacje o stanie filtrowania pozostaną dostępne w skoroszycie i zostaną zastosowane po ponownym otwarciu skoroszytu w Excel 2013 lub nowszym, o ile informacje o stanie filtrowania nie były edytowane w programie Excel 97 – 2003.

Co należy zrobić    W narzędziu sprawdzania zgodności kliknij przycisk Znajdź, aby zlokalizować filtrowane dane, a następnie wyczyść filtr, aby odkryć ukryte wiersze. Aby wyczyścić filtr, na karcie Narzędzia główne w grupie Edytowanie kliknij pozycję Sortuj i filtruj, a następnie kliknij pozycję Wyczyść.

Niektóre dane w tym skoroszycie są filtrowane według koloru czcionki. Wiersze ukryte przez filtr pozostaną ukryte, ale sam filtr nie będzie prawidłowo wyświetlany we wcześniejszych wersjach programu Excel.

Znaczenie    W Excel 2013 lub nowszym można filtrować według koloru komórki, kolor czcionki lub zestawu ikon — te metody nie są obsługiwane w programie Excel 97 – 2003. Aby uniknąć utraty funkcji filtrowania, można wyczyścić filtr przed zapisaniem skoroszytu w starszym formacie pliku programu Excel. W programie Excel 97 – 2003 można następnie filtrować dane ręcznie.

Jednak wszystkie informacje o stanie filtrowania pozostaną dostępne w skoroszycie i zostaną zastosowane po ponownym otwarciu skoroszytu w Excel 2013 lub nowszym, o ile informacje o stanie filtrowania nie były edytowane w programie Excel 97 – 2003.

Co należy zrobić    W narzędziu sprawdzania zgodności kliknij przycisk Znajdź, aby zlokalizować filtrowane dane, a następnie wyczyść filtr, aby odkryć ukryte wiersze. Aby wyczyścić filtr, na karcie Narzędzia główne w grupie Edytowanie kliknij pozycję Sortuj i filtruj, a następnie kliknij pozycję Wyczyść.

Niektóre dane w tym skoroszycie są filtrowane według ikony komórki. Wiersze ukryte przez filtr pozostaną ukryte, ale sam filtr nie będzie prawidłowo wyświetlany we wcześniejszych wersjach programu Excel.

Znaczenie    W Excel 2013 lub nowszym można filtrować według koloru komórki, kolor czcionki lub zestawu ikon — te metody nie są obsługiwane w programie Excel 97 – 2003. Aby uniknąć utraty funkcji filtrowania, można wyczyścić filtr przed zapisaniem skoroszytu w starszym formacie pliku programu Excel. W programie Excel 97 – 2003 można następnie filtrować dane ręcznie.

Jednak wszystkie informacje o stanie filtrowania pozostaną dostępne w skoroszycie i zostaną zastosowane po ponownym otwarciu skoroszytu w Excel 2013 lub nowszym, o ile informacje o stanie filtrowania nie były edytowane w programie Excel 97 – 2003.

Co należy zrobić    W narzędziu sprawdzania zgodności kliknij przycisk Znajdź, aby zlokalizować filtrowane dane, a następnie wyczyść filtr, aby odkryć ukryte wiersze. Aby wyczyścić filtr, na karcie Narzędzia główne w grupie Edytowanie kliknij pozycję Sortuj i filtruj, a następnie kliknij pozycję Wyczyść.

Niektóre dane w tym skoroszycie są filtrowane według ponad dwóch kryteriów. Wiersze ukryte przez filtr pozostaną ukryte, ale sam filtr nie będzie prawidłowo wyświetlany we wcześniejszych wersjach programu Excel.

Znaczenie    W Excel 2013 lub nowszym można filtrować dane według więcej niż dwóch kryteriów. Aby uniknąć utraty funkcji filtrowania, można wyczyścić filtr przed zapisaniem skoroszytu w starszym formacie pliku programu Excel. W programie Excel 97 – 2003 można następnie filtrować dane ręcznie.

Jednak wszystkie informacje o stanie filtrowania pozostaną dostępne w skoroszycie i zostaną zastosowane po ponownym otwarciu skoroszytu w Excel 2013 lub nowszym, o ile informacje o stanie filtrowania nie były edytowane w programie Excel 97 – 2003.

Co należy zrobić    W narzędziu sprawdzania zgodności kliknij przycisk Znajdź, aby zlokalizować filtrowane dane, a następnie wyczyść filtr, aby odkryć ukryte wiersze. Aby wyczyścić filtr, na karcie Narzędzia główne w grupie Edytowanie kliknij pozycję Sortuj i filtruj, a następnie kliknij pozycję Wyczyść.

Niektóre dane w tym skoroszycie są filtrowane według zgrupowanej hierarchii dat będącej wynikiem działania więcej niż dwóch kryteriów. Wiersze ukryte przez filtr pozostaną ukryte, ale sam filtr nie będzie prawidłowo wyświetlany we wcześniejszych wersjach programu Excel.

Znaczenie    W Excel 2013 lub nowszym można filtrować daty według zgrupowanej hierarchii. Ponieważ nie jest to obsługiwane w programie Excel 97 – 2003, być może zechcesz Rozgrupowywanie hierarchii dat. Aby uniknąć utraty funkcji filtrowania, można wyczyścić filtr przed zapisaniem skoroszytu w starszym formacie pliku programu Excel.

Jednak wszystkie informacje o stanie filtrowania pozostaną dostępne w skoroszycie i zostaną zastosowane po ponownym otwarciu skoroszytu w Excel 2013 lub nowszym, o ile informacje o stanie filtrowania nie były edytowane w programie Excel 97 – 2003.

Co należy zrobić    W narzędziu sprawdzania zgodności kliknij przycisk Znajdź, aby zlokalizować filtrowane dane, a następnie wyczyść filtr, aby odkryć ukryte wiersze. Aby wyczyścić filtr, na karcie Narzędzia główne w grupie Edytowanie kliknij pozycję Sortuj i filtruj, a następnie kliknij pozycję Wyczyść.

Grupowanie danych można też wyłączyć na karcie Zaawansowane w oknie dialogowym Opcje programu Excel (karta Plik, pozycja Opcje).

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×