POLE.WARTOŚĆ, funkcja

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Przy użyciu funkcji POLE.WARTOŚĆ można pobierać dane pól z połączonych typów danych, takich jak typy danych Akcje i Geografia. Istnieją łatwiejsze metody pisania formuł odwołujących się do typów danych, dlatego funkcja POLE.WARTOŚĆ powinna być używana głównie do tworzenia obliczeń warunkowych na podstawie połączonych typów danych.

Uwaga: 12 czerwca 2018: Ta funkcja jest obecnie funkcją beta i jest dostępny tylko do części wewnętrznych Pakietu Office w tej chwili. Będzie w dalszym zoptymalizować tę funkcję w następnych kilku miesięcy. Gdy jest gotowy, udostępnimy go do wszystkich wewnętrznych pakietu Office i subskrybentów usługi Office 365.

Szczegóły techniczne

Składnia

= POLE.WARTOŚĆ(wartość, nazwa_pola)

W składni funkcji POLE.WARTOŚĆ występują następujące argumenty:

  • wartość — adres komórki, kolumna tabeli lub nazwany zakres zawierający połączony typ danych. 

  • nazwa_pola — nazwa lub nazwy pól, które chcesz wyodrębnić z połączonego typu danych.

Opis

Przykłady

W poniższym podstawowym przykładzie formuła =POLE.WARTOŚĆ(A2,„Price”) wyodrębnia pole Price (Cena) z typu danych giełdowych dotyczących firmy JM Smucker Co.

Pobieranie ceny akcji firmy za pomocą formuły =POLE.WARTOŚĆ(A2,"Price")

Kolejny przykład jest bardziej typowym przykładem funkcji POLE.WARTOŚĆ. Tutaj używamy funkcji JEŻELI.BŁĄD do sprawdzania błędów. Jeśli w komórce A2 nie ma nazwy firmy, formuła POLE.WARTOŚĆ zwraca błąd, a w takim przypadku chcemy, aby nic nie było wyświetlane (""). Ale jeśli jest tam nazwa firmy, chcemy z typu danych w komórce A2 pobrać wartość Price (Cena), używając formuły =JEŻELI.BŁĄD(POLE.WARTOŚĆ($A2,B$1),"").

Pobieranie ceny akcji firmy i ignorowanie błędów za pomocą formuły =JEŻELI.BŁĄD(POLE.WARTOŚĆ($A2,B$1),"")

Zwróć uwagę, że funkcja POLE.WARTOŚĆ umożliwia uzyskiwanie argumentu nazwa_pola przez odwoływanie się do komórek arkusza, dlatego powyższa formuła odwołuje się do komórki B1 w celu uzyskania wartości Price (Cena), zamiast ręcznego wprowadzania tekstu „Price” w formule. 

Uwagi

Jeśli próbujesz pobrać dane z nieistniejącego pola typu danych, funkcja POLE.WARTOŚĆ zwraca błąd #POLE!. Na przykład możesz wprowadzić tekst „Prices” (Ceny), podczas gdy rzeczywiste pole typu danych nosi nazwę „Price” (Cena). Sprawdź dokładnie formułę, aby upewnić się, że używasz poprawnej nazwy pola. Jeśli chcesz wyświetlić listę nazw pól rekordu, zaznacz komórkę rekordu i naciśnij klawisze Ctrl+Shift+F2.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Typy danych giełdowych i geograficznych

Jak pisać formuły odwołujące się do typów danych

Błąd #POLE!

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×