Podstawowe zadania w programie Access 2010

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Poniżej przedstawiono kilka podstawowych zadań związanych z bazą danych, które pozwalają Ci dowiedzieć się, jak korzystać z usługi Microsoft Access 2010.

 

W tym artykule

Co to jest program Access?

Relacyjne bazy danych w programie Access

Po otwarciu programu Access

Znajdowanie i stosowanie szablonu

Tworzenie bazy danych od podstaw

Otwieranie istniejącej bazy danych programu Access

Wprowadzenie do korzystania z nowej bazy danych

Dodawanie tabeli

Wklejanie danych z innego źródła do tabeli programu Access

Importowanie danych z innego źródła lub łączenie z danymi

Następne kroki

Importowanie danych z arkusza kalkulacyjnego lub innego programu

Importowanie arkusza programu Excel do programu Access

Importowanie arkusza programu Excel jako tabeli w nowej bazie danych

Organizowanie danych za pomocą Kreatora analizatora tabel

Praca z danymi z innych programów

Używanie bazy danych we wcześniejszej wersji w kilku wersjach programu Access

Używanie pliku bazy danych programu Access w kilku wersjach programu Access

Krok 1. Tworzenie kopii istniejącej bazy danych i zapisywanie jej w nowym formacie

Krok 2: dzielenie kopii bazy danych i używanie oryginalnego pliku jako wewnętrznej bazy danych

Krok 3. Połącz nowy front-end z oryginalną bazą danych.

Korzystanie z aplikacji zewnętrznej/zaplecza w kilku wersjach programu Access

Co to jest program Access?

Program Access 2010 to narzędzie do projektowania i wdrażania aplikacji bazy danych , za pomocą którego można śledzić ważne informacje. Możesz przechowywać swoje dane na komputerze lub publikować w sieci Web, aby inne osoby mogły korzystać z tej bazy danych za pomocą przeglądarki sieci Web.

Wielu użytkowników rozpoczyna korzystanie z programu Access, gdy program, którego używają do śledzenia coraz większej liczby stopni, powoduje zmniejszenie rozmiaru zadania. Załóżmy na przykład, że jesteś terminarzem zdarzeń, a chcesz śledzić wszystkie szczegóły potrzebne do zarządzania zdarzeniami. Jeśli korzystasz z edytora tekstów lub programu obsługującego arkusze kalkulacyjne, możesz w łatwy sposób uruchamiać problemy ze zduplikowanymi i niespójnymi danymi. Możesz korzystać z oprogramowania kalendarza, ale śledzenie informacji finansowych w kalendarzu nie jest dobre.

Relacyjne bazy danych w programie Access

Czasami potrzebujesz relacyjnej bazy danych do śledzenia takich informacji — magazynu wiedzy danych, które zostały rozdzielone na mniejsze kolekcje danych (nazywanych tabelami), aby wyeliminować nadmiarowość, a następnie powiązana ze sobą w oparciu o typowe bity informacji (nazywane polami). . Na przykład relacyjna baza danych planowania wydarzeń może zawierać tabelę z informacjami o klientach, tabelę z informacjami o dostawcy oraz tabelę z informacjami o zdarzeniach. Tabela zawierająca informacje o zdarzeniu może zawierać pole umożliwiające powiązanie go z tabelą klientów oraz pole, które ma zostać powiązane z tabelą dostawcy. W ten sposób, na przykład w przypadku zmiany numeru telefonu dostawcy, informacje mogą być zmieniane w tabeli dostawcy, a nie w każdym przypadku, w którym dany dostawca jest zaangażowany.

Program Access to narzędzie, którego można używać do szybkiego i łatwego tworzenia relacyjnych aplikacji baz danych, które ułatwiają zarządzanie informacjami. Bazę danych można utworzyć, aby ułatwić śledzenie informacji o wszelkiego rodzaju informacjach, takich jak spis, kontakty profesjonalne lub procesy biznesowe. W programie Access są dostępne szablony, których można używać od razu w celu śledzenia różnych informacji, co ułatwia nawet dla początkujących.

Po otwarciu programu Access

Po uruchomieniu Access 2010 jest widoczny widok Microsoft Office Backstage, w którym można uzyskać informacje o bieżącej bazie danych, utworzyć nową bazę danych, otworzyć istniejącą bazę danych i wyświetlić polecaną zawartość z Office.com.

Widok Backstage w programie Access 2010

Widok Backstage zawiera również wiele innych poleceń, za pomocą których można dostosować, utrzymywać lub udostępnić bazy danych. Polecenia w widoku Backstage są zwykle stosowane do całych baz danych, a nie do obiektów należących do bazy danych.

Uwaga: W dowolnym momencie możesz przejść do widoku Backstage, klikając kartę plik .

Początek strony

Znajdowanie i stosowanie szablonu

Program Access oferuje szeroki wachlarz szablonów, których można użyć w celu przyspieszenia procesu tworzenia bazy danych. Szablon to gotowa do użycia baza danych zawierająca wszystkie tabele, zapytania, formularze i raporty potrzebne do wykonania określonego zadania. Na przykład istnieją szablony, za pomocą których można śledzić problemy, zarządzać kontaktami lub rejestrować wydatki. Niektóre szablony zawierają kilka przykładowych rekordów, które pomogą wykazać ich użycie. Szablony mogą być używane w takiej postaci, w jakiej są lub można je dostosować w celu dostosowania do własnych potrzeb.

Aby znaleźć i zastosować szablon do bazy danych, wykonaj następujące czynności:

  1. Na karcie Plik kliknij pozycję Nowy.

  2. W obszarze dostępne szablonywykonaj dowolną z następujących czynności:

    • Aby ponownie użyć ostatnio używanego szablonu, kliknij pozycję ostatnie szablony, a następnie wybierz odpowiedni szablon.

    • Aby użyć już zainstalowanego szablonu, kliknij pozycję Moje szablony, a następnie wybierz odpowiedni szablon.

    • Aby znaleźć szablon na Office.com, w obszarze Szablony Office.comkliknij kategorię szablonu, wybierz odpowiedni szablon, a następnie kliknij pozycję Pobierz , aby pobrać szablon z pakietu Office. com na komputer.

      Możesz również wyszukiwać szablony w witrynie Office.com w programie Access. W polu szukaj Office.com dla szablonów wpisz co najmniej jeden termin wyszukiwania, a następnie kliknij przycisk strzałki, aby wyszukać.

  3. Opcjonalnie kliknij ikonę folderu obok pola Nazwa pliku , aby przejść do lokalizacji, w której chcesz utworzyć bazę danych. Jeśli nie wskazano konkretnej lokalizacji, program Access utworzy bazę danych w domyślnej lokalizacji wyświetlonej poniżej pola Nazwa pliku .

  4. Kliknij przycisk Utwórz.

Program Access utworzy bazę danych i otworzy ją do użycia.

Początek strony

Tworzenie bazy danych od podstaw

Jeśli chcesz dokładniej zapoznać się z pojęciami dotyczącymi tworzenia bazy danych za pomocą programu Access, zobacz artykuł podstawowe informacje o projekcie bazy danych.

Jeśli żaden z szablonów nie odpowiada Twoim potrzebom lub dane w innym programie, których chcesz używać w programie Access, możesz zdecydować, że warto utworzyć bazę danych od podstaw. W programie Access 2010 można wybrać opcję: standardowa baza danych dla komputerów stacjonarnych lub baza danych sieci Web.

Aby uzyskać więcej informacji na temat baz danych sieci Web, zobacz artykuł Tworzenie bazy danych udostępnianej w sieci Web.

Aby utworzyć nową bazę danych, wykonaj następujące czynności:

  1. Uruchom program Access.

  2. Na karcie Nowy w widoku Backstage kliknij pozycję pusta baza danych lub pusta baza danych sieci Web.

    Ważne: Wybranie wprowadzone w tym miejscu określi, jakie funkcje są dostępne w bazie danych. Nie można publikować baz danych dla komputerów stacjonarnych w sieci Web, a bazy danych sieci Web nie obsługują funkcji pulpitu, takich jak sumy kwerend.

  3. Po prawej stronie wpisz nazwę bazy danych w polu Nazwa pliku .

    Aby zmienić lokalizację, w której tworzysz plik, kliknij pozycję Przeglądaj Obraz przycisku obok pola Nazwa pliku , przejdź do nowej lokalizacji i wybierz ją, a następnie kliknij przycisk OK.

  4. Kliknij przycisk Utwórz.

    Program Access utworzy bazę danych, a następnie otworzy pustą tabelę (o nazwie Tabela1) w widok arkusza danych.

  5. Program Access umieści kursor w pierwszej pustej komórce w kolumnie kliknij, aby dodać kolumnę nowej tabeli.

    Aby dodać dane, zacznij pisać — możesz też wkleić dane z innego źródła zgodnie z opisem w sekcji wklejanie danych z innego źródła do tabeli programu Accessw dalszej części tego artykułu.

    Uwagi: 

    • Wprowadzanie danych w widoku arkusza danych jest bardzo podobne do wprowadzania danych w arkuszu programu Excel. Głównym ograniczeniem jest to, że dane muszą być wprowadzane w ciągłych wierszach i kolumnach, zaczynając w lewym górnym rogu arkusza danych. Nie należy próbować formatować danych przez dołączanie pustych wierszy lub kolumn tak samo jak w przypadku arkusza programu Excel, ponieważ spowoduje to marnowanie miejsca w tabeli. Tabela tylko zawiera dane. Wszystkie wizualne prezentacje tych danych zostaną przeprowadzone w formularzach i raportach, które zostaną zaprojektowane później.

    • Struktura tabeli jest tworzona podczas wprowadzania danych. Ilekroć dodasz nową kolumnę do arkusza danych, w tabeli zostanie zdefiniowane nowe pole. Program Access ustawi typ danych pola na podstawie typu wprowadzonych danych. Jeśli na przykład masz kolumnę, w której wprowadzono tylko wartości dat, program Access ustawi typ danych tego pola na Data/godzina. Jeśli później spróbujesz wprowadzić nieaktualną wartość (na przykład nazwę lub numer telefonu) w tym polu, program Access wyświetli komunikat z informacją, że wartość nie jest zgodna z typem danych kolumny. Jeśli to możliwe, należy zaplanować tabelę, tak aby każda kolumna zawierała dane tego samego typu, niezależnie od tego, czy jest to tekst, daty, liczby czy inny typ. Ułatwia to tworzenie zapytań, formularzy i raportów, które wybierają tylko odpowiednie dane.

Jeśli nie chcesz jeszcze wprowadzać danych, kliknij pozycję Zamknij Obraz przycisku .

Uwaga: Program Access usunie tabelę Tabela1, jeśli została zamknięta bez zapisywania.

Początek strony

Otwieranie istniejącej bazy danych programu Access

Porada: Aby szybko otworzyć dowolną z kilku ostatnio otwieranych baz danych, na karcie plik kliknij pozycję ostatnie, a następnie kliknij nazwę pliku.

  1. Na karcie Plik kliknij pozycję Otwórz.

  2. Kliknij skrót w oknie dialogowym otwieranie — lub w polu Szukaj w kliknij dysk lub folder zawierający odpowiednią bazę danych.

  3. Na liście folderów klikaj dwukrotnie foldery, aż otworzysz folder zawierający bazę danych.

  4. Po znalezieniu bazy danych wykonaj dowolną z następujących czynności:

    • Aby otworzyć bazę danych w domyślnym trybie otwierania, kliknij ją dwukrotnie.

    • Aby otworzyć bazę danych z dostępem udostępnionym w środowisku wielodostępnym, aby zarówno ty, jak i inni użytkownicy mogli czytać i zapisywać dane w bazie danych, kliknij pozycję Otwórz.

    • Aby otworzyć bazę danych w trybie tylko do odczytu, aby można było ją wyświetlić, ale nie można jej edytować, kliknij strzałkę obok przycisku Otwórz , a następnie kliknij polecenie Otwórz tylko do odczytu.

    • Aby otworzyć bazę danych do wyłącznego dostępu, aby nikt inny nie mógł jej otworzyć, gdy jest otwarta, kliknij strzałkę obok przycisku Otwórz , a następnie kliknij polecenie Otwórzz wyłącznością.

    • Aby otworzyć bazę danych w trybie tylko do odczytu, kliknij strzałkę obok przycisku Otwórz , a następnie kliknij polecenie Otwórz z wyłącznością tylko do odczytu inni użytkownicy nadal będą mogli otworzyć bazę danych, ale mają tylko dostęp tylko do odczytu.

Jeśli nie możesz znaleźć bazy danych, którą chcesz otworzyć    

  1. W oknie dialogowym otwieranie kliknij skrót mój komputer — lub w polu Szukaj w kliknij pozycję mój komputer.

  2. Na liście dysków kliknij prawym przyciskiem myszy dysk, który może zawierać bazę danych, a następnie kliknij polecenie Wyszukaj.

  3. Wprowadź kryteria wyszukiwania, a następnie naciśnij klawisz ENTER, aby wyszukać bazę danych.

  4. Jeśli baza danych zostanie odnaleziona, otwórz ją, klikając dwukrotnie w oknie dialogowym wyniki wyszukiwania .

    Ponieważ wyszukiwanie zostało zainicjowane z poziomu okna dialogowego otwieranie , należy kliknąć przycisk Anuluj w tym oknie dialogowym, zanim zostanie otwarta baza danych.

Plik danych można otworzyć bezpośrednio w formacie pliku zewnętrznego (takim jak dBASE, Paradox, Microsoft Exchange lub Excel). Możesz również bezpośrednio otworzyć dowolne źródło danych ODBC, takie jak Microsoft SQL Server lub Microsoft FoxPro. Program Access automatycznie utworzy nową bazę danych programu Access w tym samym folderze, w którym znajduje się plik danych, i doda linki do każdej tabeli w zewnętrznej bazie danych.

Początek strony

Wprowadzenie do korzystania z nowej bazy danych

W zależności od użytego szablonu może być konieczne wykonanie co najmniej jednej z następujących czynności, aby rozpocząć pracę z nową bazą danych:

  • Jeśli w programie Access zostanie wyświetlone okno dialogowe Logowanie z pustą listą użytkowników, aby rozpocząć, wykonaj następujące czynności:

    1. Kliknij pozycję Nowy użytkownik.

    2. Wypełnij formularz Szczegóły użytkownika.

    3. Kliknij przycisk Zapisz i zamknij.

    4. Zaznacz wprowadzoną właśnie nazwę użytkownika i kliknij przycisk Zaloguj.

  • Jeśli program Access wyświetli pusty arkusz danych, możesz zacząć wpisywać dane bezpośrednio w tym arkuszu danych lub kliknąć inne przyciski i karty, aby eksplorować bazę danych.

  • Jeśli program Access wyświetli stronę wprowadzenie , możesz kliknąć łącze na tej stronie, aby dowiedzieć się więcej o bazie danych, lub kliknąć inne przyciski i karty, aby eksplorować bazę danych.

  • Jeśli na pasku komunikatów w programie Access zostanie wyświetlony komunikat Ostrzeżenie o zabezpieczeniach, a źródło szablonu jest zaufane, kliknij pozycję Włącz zawartość. Jeśli baza danych wymaga logowania, konieczne będzie ponowne zalogowanie się.

W przypadku baz danych dla komputerów stacjonarnych i internetowych warto również zacząć od jednej z następujących czynności:

Początek strony

Dodawanie tabeli

Nową tabelę można dodać do istniejącej bazy danych za pomocą narzędzi z grupy tabele na karcie Tworzenie .

Grupa Tabele na karcie Tworzenie

Uwaga: W bazie danych sieci Web w grupie tabele jest dostępne tylko polecenie tabela .

Niezależnie od tego, który widok został uruchomiony, możesz zawsze przełączać się do innego widoku za pomocą przycisków widoku na pasku stanu okna programu Access.

Tworzenie pustej tabeli w widoku arkusza danych    W widoku arkusza danych można wprowadzać dane natychmiast i umożliwić programowi Access utworzenie struktury tabeli w tle. Nazwy pól są przypisywane liczbowo (Pole1, Pole2 itd.), a program Access ustawia typ danych pola na podstawie typu wprowadzonych danych.

  1. Na karcie Tworzenie w grupie tabele kliknij pozycję tabela Obraz przycisku .

  2. Program Access utworzy tabelę, a następnie umieści kursor w pierwszej pustej komórce w kolumnie kliknij, aby dodać .

  3. Aby dodać dane, zacznij pisać w pierwszej pustej komórce lub wklej dane z innego źródła zgodnie z opisem w dalszej części tego artykułu.

    • Aby zmienić nazwę kolumny (pola), kliknij dwukrotnie nagłówek kolumny, a następnie wpisz nową nazwę.

      Porada: Nadaj zrozumiałą nazwę każdemu polu, aby można było powiedzieć, co zawiera, bez konieczności przeglądania danych.

    • Aby przenieść kolumnę, zaznacz ją, klikając nagłówek kolumny, a następnie przeciągnij w odpowiednie miejsce. Możesz również zaznaczyć kilka sąsiadujących kolumn i przeciągnąć je wszystkie do nowej lokalizacji razem.

      Aby dodać więcej pól do tabeli, możesz rozpocząć wpisywanie tekstu w kolumnie kliknij, aby dodać kolumnę w widoku arkusza danych, lub dodać nowe pola, korzystając z poleceń w grupie Dodawanie & usuwanie na karcie pola .

Tworzenie tabeli rozpoczynającej się w widoku projektu    W widoku projektu należy najpierw utworzyć strukturę nowej tabeli. Następnie wystarczy przełączyć się do widoku arkusza danych, aby wprowadzić dane, lub wprowadzić dane, korzystając z innej metody, takiej jak w przypadku formularza.

Widok projektu nie jest dostępny w przypadku tabel w bazie danych sieci Web.

  1. Na karcie Tworzenie w grupie tabele kliknij pozycję Projekt tabeli. Obraz przycisku

  2. W przypadku każdego pola w tabeli wpisz nazwę w kolumnie Nazwa pola , a następnie wybierz typ danych z listy Typ danych .

  3. Dodatkowe informacje dla każdego pola można wprowadzić w kolumnie Opis . Wprowadzony opis jest wyświetlany na pasku stanu, gdy punkt wstawiania znajduje się w tym polu, i jest on wykorzystywany jako tekst na pasku stanu dla kontrolek tworzonych przez przeciągnięcie pola z okienka Lista pól do formularza lub raportu. , a także dla wszystkich kontrolek utworzonych dla tego pola za pomocą Kreatora formularzy lub Kreatora raportów.

  4. Po dodaniu wszystkich pól Zapisz tabelę:

    • Na karcie Plik kliknij przycisk Zapisz.

  5. Możesz rozpocząć wprowadzanie danych w tabeli w dowolnej chwili, przechodząc do widoku arkusza danych, klikając pierwszą pustą komórkę i wpisując tekst. Możesz również wkleić dane z innego źródła zgodnie z opisem w następnej sekcji.

Tworzenie tabeli na podstawie listy programu SharePoint    Na liście programu SharePoint dane mogą być używane przez osoby, które nie mają programu Access. Ponadto dane listy są przechowywane na serwerze, co zwykle zapewnia lepszą ochronę przed utratą danych niż pliki przechowywane na komputerze stacjonarnym. Możesz rozpocząć od nowej listy lub utworzyć link do istniejącej listy. Musisz mieć wystarczające uprawnienia w witrynie programu SharePoint, w której chcesz utworzyć listę; może to się różnić w zależności od witryny, aby uzyskać szczegółowe informacje na temat dostępnych opcji.

Ta funkcja nie jest dostępna w bazie danych sieci Web.

  1. Na karcie Tworzenie w grupie Tabele kliknij pozycję Listy SharePoint.

  2. Za pomocą jednego z szablonów listy można utworzyć standardową listę programu SharePoint, taką jak kontakty lub wydarzenia.

    Możesz również utworzyć listę niestandardową lub połączyć lub zaimportować istniejącą listę. Kliknij odpowiednią opcję.

  3. W przypadku wybrania dowolnego szablonu listy lub utworzenia listy niestandardowej zostanie wyświetlone okno dialogowe Tworzenie nowej listy , które przeprowadzi Cię przez proces. Jeśli wybierzesz opcję używania istniejącej listy, zostanie wyświetlone okno dialogowe pobieranie danych zewnętrznych .

Aby uzyskać więcej informacji o tabelach, zobacz artykuł Wprowadzenie do tabel.

Początek strony

Wklejanie danych z innego źródła do tabeli programu Access

Jeśli dane są obecnie przechowywane w innym programie, na przykład w programie Excel, możesz skopiować i wkleić dane do tabeli programu Access. Zazwyczaj jest to najlepsze rozwiązanie, jeśli dane są już rozdzielone na kolumny, ponieważ znajdują się w arkuszu programu Excel. Jeśli dane są w programie do przetwarzania tekstu, należy najpierw podzielić kolumny danych przy użyciu kart lub przekonwertować je na tabelę w programie do przetwarzania tekstów, a następnie skopiować dane. Jeśli dane wymagają edycji lub manipulacji (na przykład oddzielaj imiona i nazwiska), warto to zrobić przed skopiowaniem danych, szczególnie jeśli nie znasz programu Access.

Po wklejeniu danych do pustej tabeli program Access ustawia typ danych każdego pola w zależności od tego, jakiego typu dane są tam znalezione. Jeśli na przykład pole "wkleine" nie zawiera wartości dat, w programie Access zostanie zastosowany typ danych Data/godzina do tego pola. Jeśli pole zawiera tylko wyrazy "tak" i "nie", program Access stosuje typ danych tak/nie do pola.

Program Access nadaje nazwy polom w zależności od tego, co znajduje się w pierwszym wierszu danych, które zostały wcześniej skopiowane. Jeśli pierwszy wiersz danych wklejenia jest podobny do poniższego tekstu, program Access ustali, że pierwszy wiersz jest częścią danych i przypisuje pola nazwy ogólne (Pole1, Pole2 itd.). Jeśli pierwszy wiersz wklejenia danych nie jest podobny do kolejnych wierszy, program Access użyje pierwszego wiersza jako nazw pól i wyklucza pierwszy wiersz danych.

Jeśli program Access przypisze nazwy pól ogólnych, należy jak najszybciej zmienić nazwy pól, aby uniknąć nieporozumień. Wykonaj następujące kroki:

  1. Na karcie plik kliknij pozycję Zapisz , aby zapisać tabelę.

  2. W widoku arkusza danych kliknij dwukrotnie każdy nagłówek kolumny, a następnie wpisz nazwę kolumny.

  3. Ponownie Zapisz tabelę.

Początek strony

Importowanie danych z innego źródła lub łączenie z danymi

Być może masz dane, które zostały przez Ciebie udostępnione w innym programie, którego chcesz użyć w programie Access. Być może pracujesz z osobami, które przechowują dane w innych programach i chcesz pracować z ich danymi w programie Access. Może też istnieć wiele różnych źródeł danych i potrzebna jest "podkładka", w której można z niej korzystać w celu dokładniejszej analizy.

Program Access ułatwia importowanie lub łączenie danych z innych programów. Możesz przenosić dane z arkusza programu Excel, z tabeli w innej bazie danych programu Access, z listy programu SharePoint lub z dowolnej różnych źródeł. Proces wygląda nieco inaczej w przypadku różnych źródeł danych, ale zacznij od wykonania następujących instrukcji:

  1. Na karcie dane zewnętrzne w grupie Importowanie & kliknij polecenie odpowiadające typowi importowanego pliku.

    Jeśli na przykład importujesz dane z arkusza programu Excel, kliknij pozycję Excel. Jeśli nie widzisz odpowiedniego typu programu, kliknij pozycję więcej.

    Uwaga: Jeśli nie możesz znaleźć odpowiedniego typu formatu w grupie łącze importowania & , może być konieczne uruchomienie programu, w którym dane zostały pierwotnie utworzone, a następnie użycie tego programu w celu zapisania danych w formacie obsługiwanym przez program Access (na przykład rozdzielany plik tekstowy ). , a następnie zaimportuj lub Utwórz link do danych.

  2. W oknie dialogowym pobieranie danych zewnętrznych kliknij przycisk Przeglądaj , aby przejść do pliku danych źródłowych, lub wpisz pełną ścieżkę pliku danych źródłowych w polu Nazwa pliku .

  3. Kliknij odpowiednią opcję w obszarze Określ sposób i miejsce przechowywania danych w bieżącej bazie danych. Nową tabelę można utworzyć przy użyciu zaimportowanych danych lub utworzyć tabelę połączoną z łączem do źródła danych.

  4. Kliknij przycisk OK.

    W zależności od dokonanego wyboru zostanie otwarte okno dialogowe łączenie obiektów lub okno dialogowe Importowanie obiektów .

  5. Użyj okna dialogowego, aby zakończyć proces. Dokładna procedura, którą należy wykonać, zależy od wybranej opcji importu lub łącza.

  6. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    W przypadku wybrania opcji importowania program Access wyświetli pytanie, czy chcesz zapisać szczegóły właśnie ukończonej operacji importowania.

  7. Jeśli uważasz, że ta sama operacja importowania będzie wykonywana ponownie, kliknij pozycję Zapisz kroki importowania, a następnie wprowadź szczegóły.

    Następnie możesz łatwo odtworzyć operację importowania, klikając pozycję zapisana Grupa w grupie Importowanie na karcie dane zewnętrzne , klikając pozycję Specyfikacja importu, a następnie pozycję Uruchom.

  8. Jeśli nie chcesz zapisywać szczegółów operacji, kliknij przycisk Zamknij.

Program Access zaimportuje dane do nowej tabeli, a następnie w okienku nawigacji zostanie wyświetlona tabela w obszarze tabele .

Aby dowiedzieć się więcej na temat importowania danych do programu Access, Skorzystaj z łączy w sekcji Zobacz też w tym artykule.

Początek strony

Następne kroki

Pozostała część procesu projektowania różni się w zależności od celów, ale warto zastanowić się nad tworzeniem kwerend, formularzy, raportów i makr. Ten artykuł nie zawiera informacji na temat tworzenia dodatkowych obiektów bazy danych.

Aby uzyskać więcej informacji, zobacz następujące artykuły:

Początek strony

Importowanie danych z arkusza kalkulacyjnego lub innego programu

Jeśli znasz inne bazy danych lub programy arkuszy kalkulacyjnych, zapoznaj się z podstawowymi informacjami na temat tego, jak działają te aplikacje oraz jakie bazy danych są używane. Program Access różni się od wielu innych aplikacji baz danych, umożliwiając tworzenie relacyjnych baz danych, a ponadto różni się od większości programów arkuszy kalkulacyjnych, oferując narzędzia do tworzenia zaawansowanych zapytań, formularzy i raportów. Program Access udostępnia także wiele opcji pracy z innymi programami baz danych, takimi jak program SQL Server.

Importowanie arkusza programu Excel do programu Access

Wielu osób rozpocznie Poznawanie programu Access po pierwszym utworzeniu listy w programie Excel. Program Excel to idealne miejsce do rozpoczynania listy, ale gdy lista powiększa się, więc jej organizowanie i aktualizowanie jest trudniejsze. Kolejnym logicznym krokiem jest przeniesienie listy do programu Access.

Tabela bazy danych jest podobna do struktury arkusza, a dane są przechowywane w wierszach i kolumnach. Z tego powodu zazwyczaj można łatwo zaimportować arkusz do tabeli bazy danych. Główna różnica między przechowywaniem danych w arkuszu i przechowywaniem ich w bazie danych polega na tym, jak są zorganizowane dane. Po prostu zaimportowanie całego arkusza jako nowej tabeli w bazie danych nie spowoduje rozwiązania problemów związanych z organizacją i aktualizowaniem danych, szczególnie jeśli arkusz zawiera nadmiarowe dane. Aby rozwiązać te problemy, należy podzielić dane arkusza kalkulacyjnego na osobne tabele, każdy z nich zawierający powiązane dane. Aby uzyskać więcej informacji na temat rozmieszczania danych w tabelach, zobacz artykuł podstawowe informacje o projekcie bazy danych.

Program Access oferuje Kreator analizatora tabel, który może ułatwić wykonanie tego procesu. Po zaimportowaniu danych do tabeli Kreator pomoże podzielić tabelę na osobne tabele, z których każda zawiera dane, które nie są zduplikowane w żadnej innej tabeli. Kreator tworzy również niezbędne relacje między tabelami.

Początek strony

Importowanie arkusza programu Excel jako tabeli w nowej bazie danych

  1. Na karcie plik kliknij pozycję Nowy, a następnie kliknij pozycję pusta baza danych.

  2. W polu Nazwa pliku wpisz nazwę nowej bazy danych, a następnie kliknij przycisk Utwórz.

    Zostanie otwarta nowa baza danych, a w programie Access zostanie utworzona nowa pusta tabela (Tabela1).

  3. Zamknij tabelę Tabela1.

    Gdy zostanie wyświetlone pytanie, czy chcesz zapisać zmiany w projekcie tabeli Tabela1, kliknij przycisk nie.

  4. Na karcie dane zewnętrzne w grupie Importowanie _AMP_ kliknij pozycję Excel. Obraz przycisku

  5. W oknie dialogowym pobieranie danych zewnętrznych kliknij przycisk Przeglądaj.

  6. Zlokalizuj plik, korzystając z okna dialogowego otwieranie pliku .

  7. Zaznacz plik, a następnie kliknij pozycję Otwórz.

  8. Upewnij się, że w oknie dialogowym pobieranie danych zewnętrznych jest zaznaczona opcja Importuj dane źródłowe do nowej tabeli w bieżącej bazie danych .

  9. Kliknij przycisk OK.

    Zostanie uruchomiony Kreator importu arkuszy i poprosi o podanie kilku pytań dotyczących danych.

  10. Postępuj zgodnie z instrukcjami, klikając przycisk dalej lub Wstecz w celu przechodzenia między stronami. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

    Uwaga: W programie Access zostanie wyświetlone pytanie o to, czy chcesz zapisać szczegóły właśnie ukończonej operacji importowania. Jeśli uważasz, że ta sama operacja importowania będzie wykonywana ponownie, kliknij przycisk tak, a następnie wprowadź szczegóły. W przyszłości możesz w łatwy sposób odtworzyć operację, klikając pozycję zapisane operacje importowania w grupie Importowanie na karcie dane zewnętrzne . Jeśli nie chcesz zapisywać szczegółów operacji, kliknij przycisk Zamknij.

Program Access zaimportuje dane do nowej tabeli, a następnie wyświetli je w obszarze wszystkie tabele w okienku nawigacji.

Początek strony

Organizowanie danych za pomocą Kreatora analizatora tabel

Po zaimportowaniu danych do tabeli programu Access można użyć Kreatora analizatora tabel, aby szybko identyfikować nadmiarowe dane. Kreator zapewnia prosty sposób organizowania danych w osobnych tabelach, dzięki czemu będzie on przechowywany w najbardziej efektywny sposób. Program Access zachowuje oryginalną tabelę jako kopię zapasową, a następnie tworzy nowe tabele, których można użyć jako podstawy dla aplikacji bazy danych.

  1. Otwórz bazę danych programu Access zawierającą tabelę, którą chcesz przeanalizować.

  2. Na karcie Narzędzia bazy danych w grupie Analizowanie kliknij pozycję Analizuj tabelę.

    Zostanie uruchomiony Kreator analizatora tabel.

    Pierwsze dwie strony kreatora zawierają krótki samouczek — ukończono za pomocą przycisków, które można klikać w celu wyświetlenia przykładów. Jeśli nie widzisz stron wprowadzenia, ale zamiast tego pojawi się pole wyboru o nazwie Pokaż strony wprowadzenia?, zaznacz to pole wyboru, a następnie kliknij dwukrotnie przycisk Wstecz , aby zobaczyć wprowadzenie. Jeśli nie chcesz, aby strony wprowadzające były ponownie wyświetlane po przeczytaniu wprowadzenia, możesz wyczyścić pole wyboru Pokaż strony wprowadzenia? .

  3. W której tabeli znajdują się pola, których wartości powtarzają się w wielu rekordach? wybierz tabelę, którą chcesz analizować, a następnie kliknij przycisk dalej.

  4. Możesz pozwolić kreatorowi zdecydować, które pola przejdą do których tabel, lub możesz samodzielnie wprowadzić tę decyzję. Jeśli korzystasz z sugestii kreatora, nadal możesz wprowadzić zmiany w układzie tabeli na następnej stronie kreatora.

    Uwaga: Jeśli Kreator zdecyduje, które pola mają zostać umieszczone w których tabelach, ich wybór może nie zawsze być odpowiedni dla danych, szczególnie jeśli nie ma dużo danych do pracy. Wyniki pracy kreatora należy dokładnie sprawdzić. Z drugiej strony Kreator może zasugerować wydajniejszą organizację, od której zastanawiasz się, więc warto co najmniej raz podjąć decyzje dotyczące tego kreatora. Jeśli nie podobają Ci się sugestie, nadal możesz ponownie rozmieścić pola ręcznie, a zawsze możesz kliknąć przycisk Wstecz i rozmieścić wszystkie pola samodzielnie.

  5. Kliknij przycisk Dalej. Na tej stronie określasz, które tabele zawierają pola. Jeśli zdecydujesz, że Kreator zdecyduje się na decyzję, należy wyświetlić wiele tabel połączonych liniami relacji. W przeciwnym razie w programie Access zostanie utworzona tylko jedna tabela zawierająca wszystkie pola. W obu przypadkach można wprowadzać zmiany na tej stronie.

    • Można przeciągać pola z tabeli do pustego obszaru na stronie, aby utworzyć nową tabelę zawierającą te pola. W programie Access zostanie wyświetlony monit o podanie nazwy tabeli.

    • Możesz przeciągać pola z jednej tabeli do drugiej, jeśli uważasz, że będą one w bardziej efektywny sposób przechowywać.

    • Większość tabel otrzyma Identyfikator lub pole Wygenerowano unikatowy identyfikator . Aby dowiedzieć się więcej o polach identyfikatorów, kliknij pozycję porady w prawym górnym rogu kreatora.

    • Aby cofnąć zmianę, kliknij przycisk Cofnij .

    • Aby zmienić nazwę tabeli, kliknij dwukrotnie jej pasek tytułu, wpisz nową nazwę, a następnie kliknij przycisk OK.

  6. Po ustawieniu pól w odpowiedni sposób kliknij przycisk dalej.

  7. Jeśli Kreator odnajdzie rekordy o bardzo podobnych wartościach, określi te wartości jako możliwe błędy typograficzne i wyświetli ekran, na którym można potwierdzić, co należy zrobić. Przewiń listę, aby znaleźć dowolną wartość w kolumnie storno , a następnie kliknij odpowiednią pozycję na liście rozwijanej. Wybierz pozycję (pozostaw jako-) , aby Kreator nie wprowadzał zmian w wartości. Po zakończeniu kliknij przycisk dalej.

  8. W kreatorze zostanie wyświetlone pytanie, czy chcesz utworzyć kwerendę przypominającą oryginalną tabelę. Jeśli już utworzono formularze i raporty oparte na oryginalnej tabeli, warto utworzyć takie zapytanie. Jeśli wybierzesz pozycję tak, Utwórz zapytanie, a Kreator ponownie nadaje nazwę oryginalnej tabeli, dodając "_OLD" do nazwy tabeli, a następnie nadaj nazwę nowej kwerendzie, używając nazwy oryginalnej tabeli. Formularze i raporty oparte na tabeli teraz używają kwerendy do ich danych i działają tak jak poprzednio.

  9. Kliknij przycisk Zakończ.

    Kreator utworzy nowe tabele w określony sposób, a następnie otworzy je. Po zakończeniu inspekcji wyników zamknij je.

Początek strony

Praca z danymi z innych programów

Program Access 2010 zawiera funkcje umożliwiające pracę z danymi przechowywanymi w innych programach.

Tworzenie nowej bazy danych programu Access z łączami do danych w innym formacie pliku    Za pomocą programu Access można otworzyć plik w innym formacie pliku, takim jak text, dBASE lub Spreadsheet. Program Access automatycznie utworzy bazę danych programu Access i połączy plik.

  1. Uruchom program Access.

  2. Na karcie Plik kliknij pozycję Otwórz.

  3. W oknie dialogowym otwieranie kliknij typ pliku, który chcesz otworzyć na liście. Jeśli nie masz pewności co do typu pliku, kliknij pozycję wszystkie pliki (*. *).

  4. W razie potrzeby przejdź do folderu zawierającego plik, który chcesz otworzyć. Po znalezieniu pliku kliknij go dwukrotnie, aby go otworzyć.

  5. Wykonaj instrukcje kreatora. Na ostatniej stronie kreatora kliknij przycisk Zakończ.

Importowanie lub łączenie danych z istniejącą bazą danych programu Access    Możesz zaimportować dane z innych Yródeł i programów do tabel programu Access, aby dane były zawarte w pliku programu Access, lub utworzyć link do danych z programu Access, tak aby dane pozostały w oryginalnym pliku (poza plikiem programu Access).

  1. Na karcie dane zewnętrzne w grupie Importowanie & kliknij format, w którym dane są przechowywane.

    Można importować dane z następujących źródeł lub łączyć się z tymi danymi:

    • Excel    Możesz wprowadzić dane z arkusza lub nazwanego zakresu w skoroszycie programu Excel. Każdy arkusz lub nazwany zakres należy zaimportować lub połączyć oddzielnie.

    • Access    Jest to bardzo przydatne do oddzielania procesu od danych, tworząc podzieloną bazę danych. Oznacza to, że można używać jednej bazy danych do przechowywania wszystkich formularzy, raportów i makr oraz przechowywać dane w innej bazie danych. Następnie możesz opracować usprawnienia bez zakłócania pracy wszystkich osób. Można też łączyć dane z wielu różnych baz danych programu Access w jednej z nich, co ułatwia podsumowywanie danych między działami lub partnerami biznesowymi.

    • baza danych ODBC    Wiele programów obsługuje ten format, w tym wiele produktów serwerowych. Ułatwia to tworzenie baz danych "Multiplekser PAD", w którym można łączyć dane z różnych systemów.

    • Plik tekstowy    Możesz połączyć się z prostym plikiem tekstowym i można nawet użyć programu Access, aby zmienić zawartość tego pliku. Może to ułatwić korzystanie z danych programu Access w szerokiej gamy programów.

    • Plik XML    Ten format zapewnia również zgodność z różnymi programami, w tym z niektórymi serwerami sieci Web.

    • lista programu SharePoint    Dzięki temu można korzystać z danych za pomocą przeglądarki internetowej, standardowego sposobu używania listy programu SharePoint.

    • Usługi danych    Możesz połączyć się z usługami danych sieci Web w przedsiębiorstwie.

    • Dokument HTML    

    • Folder programu Outlook    Możesz połączyć się z folderami programu Outlook, aby łatwiej zintegrować swoje informacje kontaktowe z pozostałymi danymi.

    • plik programu dBase    Program dBase jest popularnym alternatywnym systemem bazy danych obsługiwanym w programie Access

      Zostanie wyświetlone okno dialogowe pobieranie danych zewnętrznych .

  2. Postępuj zgodnie z instrukcjami wyświetlanymi w oknie dialogowym.

    Program Access zaimportuje lub połączy dane w bazie danych. W przypadku większości formatów należy określić lokalizację danych, a następnie zdecydować, jak mają być przechowywane dane w bazie danych.

Początek strony

Używanie bazy danych we wcześniejszej wersji w kilku wersjach programu Access

Jeśli w programie Access 2000 lub nowszym utworzono bazę danych programu Access lub projekt programu Access, można użyć bazy danych lub projektu w wersji programu Access, w której została utworzona, lub w dowolnej późniejszej wersji — nawet jeśli jest włączony zabezpieczenia pliku. Na przykład pliki programu Access 2000 mogą być używane w programie Access 2000, Access 2002, Access 2003, Access 2007 i Access 2010.

Może istnieć sytuacja, w której chcesz przechowywać dane we wcześniejszej wersji programu Access, ale masz użytkowników z nowszą wersją programu Access, które chcą połączyć się z tymi danymi, ale nadal korzystają z niektórych funkcji nowszej wersji. Rozwiązanie polega na utworzeniu nowej "frontonu" bazy danych w nowszej wersji (zawierającej formularze, raporty, zapytania, makra, ale bez tabel) i połączyć je z tabelami we wcześniejszej wersji pliku. Użyj jednej z poniższych procedur, zależnie od tego, czy Twoja baza danych znajduje się w jednym pliku, czy jest już podzielona na aplikacja zewnętrzna/wewnętrzna.

Używanie pliku bazy danych programu Access w kilku wersjach programu Access

Jeśli wszystkie tabele, formularze i inne obiekty w starszej wersji bazy danych programu Access znajdują się w jednym pliku i chcesz użyć tej bazy danych w kilku wersjach programu Access, możesz utworzyć nową zewnętrzną bazę danych w nowszej wersji i połączyć ją z plikiem oryginalnym. Użytkownicy, którzy mają wcześniejszą wersję programu Access, nadal mogą korzystać z oryginalnej bazy danych. Użytkownicy, którzy mają nowszą wersję, mogą łączyć się z tymi samymi danymi za pomocą nowej zewnętrznej bazy danych. Jeśli chcesz dostosować wiele wersji programu Access, możesz utworzyć kilka wersji frontonu.

Początek strony

Krok 1. Tworzenie kopii istniejącej bazy danych i zapisywanie jej w nowym formacie

Wykonaj poniższą procedurę, aby przekonwertować bazę danych na dowolne trzy ostatnie formaty: Access 2000, Access 2002-2003 lub Access 2007. To polecenie zachowuje pierwotną bazę danych w jej oryginalnym formacie i tworzy kopię w określonym formacie.

  1. Zamknij plik programu Access. Jeśli plik jest wielodostępną bazą danych programu Access znajdującą się na serwerze lub w folderze udostępnionym, upewnij się, że nikt inny nie jest otwarty.

  2. Uruchom program Access 2010.

  3. Na karcie Plik kliknij pozycję Otwórz.

  4. Przejdź do lokalizacji pliku, który chcesz przekonwertować, a następnie kliknij go dwukrotnie, aby go otworzyć.

    Jeśli zostanie wyświetlone okno dialogowe rozszerzaNie bazy danych z pytaniem, czy chcesz ulepszyć bazę danych, kliknij przycisk nie.

  5. Jeśli po uruchomieniu bazy danych zostanie otwarty formularz, zamknij formularz.

  6. Na karcie plik kliknij pozycję Zapisz bazę danych jako.

  7. W oknie dialogowym Zapisywanie jako wpisz nazwę nowej bazy danych.

    Uwaga: Jeśli nowa baza danych nie zostanie zapisana w innej lokalizacji, jej nazwa musi być inna niż w przypadku oryginalnej bazy danych. W obu przypadkach najlepiej jest użyć innej nazwy, aby łatwo odróżnić między zewnętrzną bazą danych a wewnętrzną bazą danych. Jeśli jednak konwertujesz na format programu Access 2007, rozszerzenie nazwy pliku zmieni się z mdb na accdb, aby można było użyć tej samej nazwy pliku.

  8. Kliknij przycisk Zapisz.

Początek strony

Krok 2: dzielenie kopii bazy danych i używanie oryginalnego pliku jako wewnętrznej bazy danych

Podziel przekonwertowaną bazę danych, wykonując poniższą procedurę:

  • Na karcie Narzędzia bazy danych w grupie przenoszenie danych kliknij pozycję baza danych programu Access. Obraz przycisku

  • W oknie dialogowym rozdzielacz bazy danych kliknij pozycję Podziel bazę danych.

    Jeśli chcesz, możesz wykonać kopię zapasową, ale możesz także odtworzyć kopię, korzystając z oryginalnej bazy danych.

  • Wpisz nazwę wewnętrznej bazy danych, a następnie kliknij pozycję Podziel.

Początek strony

Krok 3. Połącz nowy front-end z oryginalną bazą danych.

  1. Usuń wewnętrzną bazę danych utworzoną przez narzędzie rozdzielacz bazy danych — Uważaj, aby nie usunąć pierwotnej bazy danych.

  2. Połącz nową zewnętrzną bazę danych z tabelami w oryginalnej bazie danych: na karcie dane zewnętrzne w grupie Importowanie _AMP_ kliknij pozycję Menedżer tabel połączonych. Obraz przycisku

  3. Kliknij pozycję Zaznacz wszystko, a następnie zaznacz pole wyboru zawsze Monituj o nową lokalizację .

  4. Kliknij przycisk OK, przejdź do bazy danych w starszej wersji, a następnie kliknij ją dwukrotnie.

    Jeśli wszystko jest dobrze dostępne, program Access wyświetli komunikat informujący o tym, że wszystkie zaznaczone tabele połączone zostały pomyślnie odświeżone.

Teraz możesz ulepszyć nową zewnętrzną bazę danych, aby obsługiwać nowe funkcje dla użytkowników, którzy mają nowsze wersje programu Access. Użytkownicy, którzy mają wcześniejsze wersje, mogą nadal korzystać ze starszej wersji bazy danych.

Początek strony

Korzystanie z aplikacji zewnętrznej/zaplecza w kilku wersjach programu Access

Jeśli baza danych programu Access jest już aplikacja zewnętrzna/wewnętrzna, możesz przekonwertować fronton na nowy format pliku. W wewnętrznej bazie danych nie są potrzebne żadne zmiany.

W poniższej procedurze przedstawiono sposób konwertowania zewnętrznej bazy danych na jeden z trzech ostatnich formatów: Access 2000, Access 2002-2003 lub Access 2007, korzystając z polecenia Zapisz bazę danych jako . To polecenie zachowuje pierwotną bazę danych w jej oryginalnym formacie i tworzy kopię w określonym formacie.

  1. Zamknij zewnętrzną bazę danych. Jeśli plik jest wielodostępną bazą danych programu Access znajdującą się na serwerze lub w folderze udostępnionym, upewnij się, że nikt inny nie jest otwarty.

  2. Uruchom program Access 2010.

  3. Na karcie Plik kliknij pozycję Otwórz.

  4. Przejdź do lokalizacji zewnętrznej bazy danych, a następnie kliknij ją dwukrotnie, aby ją otworzyć.

    Jeśli zostanie wyświetlone okno dialogowe rozszerzaNie bazy danych z pytaniem, czy chcesz ulepszyć bazę danych, kliknij przycisk nie.

  5. Jeśli podczas otwierania bazy danych zostanie wyświetlony formularz, zamknij go.

  6. Na karcie plik kliknij pozycję Zapisz bazę danych jako.

  7. W oknie dialogowym Zapisywanie jako wpisz nazwę nowej bazy danych.

  8. Kliknij przycisk Zapisz.

Teraz możesz ulepszyć nową zewnętrzną bazę danych, aby obsługiwać nowe funkcje.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×