Plik programu Excel jest zablokowany do edycji przez innego użytkownika

Podczas próby otwarcia pliku programu Excel występuje błąd: „Plik w użyciu: Plik jest zablokowany do edycji przez innego użytkownika”. Czasami plik jest faktycznie zablokowany przez innego użytkownika, ale czasem ten „inny użytkownik” to Ty. Jeśli plik został zablokowany przez Ciebie, to może oznaczać, że jest on otwarty na innym urządzeniu lub że poprzednie wystąpienie pliku nie zostało poprawnie zamknięte.

Upewnij się, że plik został zamknięty na wszystkich Twoich urządzeniach. Jeśli błąd występuje nadal, zaczekaj kilka minut na zwolnienie blokady pliku przez serwer. Czasami serwer traktuje plik jako otwarty, ponieważ nie ma jeszcze najnowszych informacji o tym, co się dzieje.

Jeśli plik został zablokowany przez innego użytkownika, możesz zaczekać, aż ta osoba zakończy pracę i zamknie plik. Możesz także wyświetlić plik w trybie tylko do odczytu. Możesz też zwrócić się do tej drugiej osoby, aby zamknęła plik, zaewidencjonowała go lub przyznała Ci uprawnienia do edycji.

Jeśli chcesz pracować nad plikiem jednocześnie z innymi użytkownikami, upewnij się, że wszyscy korzystają z wersji programu Excel obsługującej współtworzenie. Podczas współtworzenia plik może być otwarty przez kilka osób jednocześnie i wszyscy szybko zobaczycie zmiany wprowadzone przez inne osoby — w ciągu kilku sekund.

Wersje programu Excel obsługujące współtworzenie:

  • Excel 2016 dla systemu Windows*

  • Excel 2016 dla komputerów Mac*

  • Excel Online

  • Excel dla systemu Android

  • Excel dla systemu iOS

  • Excel Mobile

* Aby korzystać ze współtworzenia w tej wersji, wymagane jest zainstalowanie najnowszej wersji programu Excel oraz zalogowanie się do pakietu Office przy użyciu konta subskrypcji usługi Office 365. Pamiętaj, że jeśli masz konto służbowe, możesz nie mieć wersji pakietu Office, która obsługuje współtworzenie. Może to być spowodowane tym, że administrator nie udostępnił najnowszej wersji do zainstalowania. Jeśli korzystasz z programu Excel 2016 dla systemu Windows, przyczyną może być to, że Twoja firma lub instytucja edukacyjna korzysta z półrocznego kanału aktualizacji. Możesz ustalić, czy korzystasz z tego kanału, przechodząc do obszaru Plik > Konto. Jeśli obok pozycji Excel — informacje jest widoczny tekst Półroczny kanał, funkcja współtworzenia nie jest jeszcze dostępna.

Jeśli choć jedna osoba używa wersji programu Excel bez obsługi współtworzenia, pozostali użytkownicy otrzymają komunikat o błędzie związanym z zablokowaniem pliku — nawet jeśli korzystają oni z wersji programu Excel, która obsługuje współtworzenie.

Jeśli ktoś nie ma pewności, z jakiej wersji aplikacji korzysta, poproś wszystkich o użycie aplikacji Excel Online, umożliwiającej współtworzenie w przeglądarce internetowej.

Jeśli chcesz uniknąć błędu, korzystając z funkcji współtworzenia z innymi użytkownikami, umieść plik w usłudze OneDrive lub OneDrive dla Firm bądź w programie SharePoint. Jeśli plik będzie zapisany w innej lokalizacji, nieobsługującej współtworzenia, będzie wyświetlany błąd „plik zablokowany”. Funkcja współtworzenia nie jest obsługiwana w przypadku następujących lokalizacji:

  • Ścieżki serwera, takie jak \\serwer\folder i smb://serwer/folder

  • Lokalizacje w chmurze, takie jak usługi DropBox, Box i Google Drive

  • Foldery lokalne na komputerze z systemem Windows lub na komputerze Mac

  • Biblioteki w lokalnych witrynach programu SharePoint. Jeśli korzystasz z witryny lokalnej i programu Excel 2016, spróbuj użyć do współtworzenia aplikacji Excel Online.

W przypadku komputera z systemem Windows: Jeśli chcesz użyć funkcji współtworzenia, sprawdź nazwę pliku i upewnij się, że ma on format xlsx, xlsm lub xlsb. Jeśli plik ma inny format, przejdź do pozycji Plik > Zapisz jako > Przeglądaj > Zapisz jako typ i wybierz format xlsx, xlsm lub xlsb.

W przypadku komputera Mac: Jeśli chcesz użyć funkcji współtworzenia, sprawdź nazwę pliku i upewnij się, że ma on format xlsx, xlsm lub xlsb. Jeśli plik ma inny format, przejdź do pozycji Plik > Zapisz jako i wybierz format xlsx, xlsm lub xlsb.

Jeśli używasz klienta synchronizacji OneDrive dla systemu Windows, upewnij się, że używasz najnowszej wersji. Upewnij się też, że klient synchronizacji nie został wstrzymany.

Błąd „plik zablokowany” podczas próby współtworzenia może wystąpić też w przypadku, gdy w pliku używana jest funkcja nieobsługiwana przez funkcję współtworzenia. Poproś osobę, która otworzyła plik, o wykonanie co najmniej jednej z następujących czynności: W pierwszej kolejności spróbuj wyłączyć funkcję skoroszytu udostępnionego. Ponadto, jeśli otwierasz migawkę z programu SharePoint, zamiast tego otwórz sam skoroszyt. Jeśli te dwa rozwiązania nie zadziałają, spróbuj wykonać co najmniej jedną z poniższych czynności.

Windows:

  • Usunięcie z pliku szyfrowania przy użyciu hasła lub ograniczeń dostępu, jeśli to możliwe: Przejdź do pozycji Plik > Informacje > Chroń skoroszyt i usuń wszelkie hasła lub ustawienia ograniczeń dostępu.

  • Wyłącz ustawienie Odśwież dane podczas otwierania pliku dla wszystkich tabel i tabel przestawnych w pliku. Zaznacz tabelę lub tabelę przestawną, a następnie wybierz pozycję Narzędzia tabel > Projektowanie > Odśwież > Właściwości połączenia. Następnie wyczyść pole wyboru Odśwież dane podczas otwierania pliku.

  • Dezaktywuj dodatek powodujący blokadę. Wybierz pozycję Plik > Opcje > Dodatki > Dodatki programu Excel > Przejdź, a następnie wyczyść pole wyboru dodatku.

Komputer Mac:

  • Usunięcie z pliku szyfrowania przy użyciu hasła, jeśli to możliwe: W tym celu przejdź do karty Recenzja. Jeśli opcja Chroń skoroszyt jest wyróżniona, kliknij ją, aby wyłączyć ochronę. Jeśli zostanie wyświetlony monit, wprowadź hasło.

  • Usunięcie ograniczeń dostępu, jeśli to możliwe: Przejdź do pozycji Plik > Ogranicz uprawnienia > Bez ograniczeń.

  • Wyłącz ustawienie Odśwież dane podczas otwierania pliku dla wszystkich tabel i tabel przestawnych w pliku. Zaznacz tabelę lub tabelę przestawną, a następnie przejdź do karty Tabela i wybierz pozycję Odśwież > Właściwości połączenia. Następnie wyczyść pole wyboru Odśwież dane podczas otwierania pliku.

  • Dezaktywuj dodatek powodujący blokadę. Wybierz pozycję Narzędzia > Dodatki programu Excel, a następnie wyczyść pole wyboru dodatku.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×