Otwieranie w Eksploratorze lub widoku za pomocą Eksploratora plików w programie SharePoint

Często zarządzanie plikami i folderami może być łatwiejsze, gdy pracujesz poza SharePoint, przy użyciu polecenia Otwórz w Eksploratorze, ale nie używaj polecenia Otwórz za pomocą Eksploratora, tym lepsza jest synchronizowanie plików programu SharePoint lub przenoszenie lub kopiowanie plików w programie SharePoint. Polecenie Otwórz w Eksploratorze plików umożliwia kopiowanie i przenoszenie wielu plików i folderów między folderami, tak jak na biurku.

Uwaga: SharePoint Polecenie Otwórz w programie Explorer używa technologii ActiveX, więc jest obsługiwana tylko w programie Internet Explorer. Polecenie Otwórz w Eksploratorze nie działa w systemie Windows z programem Microsoft Edge, Google Chrome ani Mozilla FireFox ani na platformie Mac.

Kontrolka ActiveX jest potrzebna tylko podczas pracy z plikami w Eksploratorze plików systemu Windows. Po zakończeniu korzystania z Eksploratora plików możesz korzystać z dowolnej obsługiwanej przeglądarki, korzystając z SharePoint.

  • Nie używasz przeglądarki, która obsługuje kontrolki ActiveX.    Otwieranie w programie Explorer działa tylko w programie Internet Explorer 10 lub 11. W przypadku systemu Windows 10 jest to ustawienie domyślne, ale program Internet Explorer 11 jest również instalowany. Polecenie Otwórz w Eksploratorze nie współpracuje z programem Edge, Chrome ani FireFox. Za pomocą programu Internet Explorer możesz wykonywać transfery plików, a następnie wrócić do korzystania z preferowanej przeglądarki (jeśli nie jest to program IE).

  • W programie Internet Explorer są blokowane kontrolki ActiveX lub dodatki.    W programie Internet Explorer 11 Naciśnij klawisz ALT+Tna klawiaturze. W menu Narzędzia , jeśli obok pozycji Filtrowanie ActiveXjest zaznaczone pole wyboru, naciśnij przycisk X Aby wyłączyć tę funkcję. Możesz również kliknąć pozycję Narzędzia, kliknąć pozycję zabezpieczenia, a następnie pozycję Filtrowanie ActiveX.

  • Korzystasz z 64-bitowej wersji programu Internet Explorer.    Kontrolki ActiveX to 32-bitowa technologia. Nie działają one w 64-bitowej wersji programu Internet Explorer. W programie Internet Explorer 11 jest tylko jedna przeglądarka, która powoduje automatyczne przełączenie na 32-bitowe kontrolek ActiveX. Jeśli jednak korzystasz z usługi 64-bitowego programu Internet Explorer 10, przejdź do wersji 32-bitowej. Aby sprawdzić wersję, naciśnij klawisz ALT+H, a następnie naciśnij klawisz A w przypadku programu Internet Explorer.

  • Nie zainstalowano dodatków SharePoint.    W programie Internet Explorer kliknij pozycję Narzędzia, a następnie kliknij pozycję Zarządzajdodatkami. Należy zainstalować te dodatki i włączyć je:

    Name (Nazwa)

    Publisher

    Status

    SharePoint Uruchamianie eksportowania bazy danych

    Microsoft Corporation

    Włączone

    SharePoint Klasa OpenDocument

    Microsoft Corporation

    Włączone

    SharePoint Obsługa stssync

    Microsoft Corporation

    Włączone

  • Klient programu Windows WebClient nie jest uruchomiony    Klient programu Windows WebClient zapewnia pomoc techniczną dla systemu Windows, a formant ActiveX porozmawia z SharePoint bibliotekami. Domyślnie jest on uruchomiony w systemie Windows. Jeśli nie jest uruchomiona, być może występują problemy z użyciem programu Open with Explorer. Klient WebClient jest częścią programu Internet Explorer. Aby sprawdzić klienta WebClient, wykonaj poniższe czynności.

    1. Naciśnij przycisk Klawisz systemu Windows + RWpisz ciąg Service. msc, a następnie naciśnij klawisz Enter.

    2. W oknie dialogowym usługi Znajdź pozycję WebClient. Jeśli nie możesz go znaleźć, kliknij pozycję Nazwa , aby posortować listę alfabetycznie.

    3. Zaznacz pole status , aby upewnić się, że jest ono uruchomione. Jeśli nie, kliknij prawym przyciskiem myszy pozycję WebClient, a następnie wybierz pozycję Uruchom.

    Okno dialogowe usługi systemu Windows z wyróżnioną pozycją WebClient

Uwaga: Historia wersji nie jest kopiowana podczas korzystania z synchronizacji lub otwierania za pomocą Eksploratora. Tylko najnowsza lub opublikowana wersja dokumentów jest kopiowana lub przenoszona. Aby uzyskać więcej informacji, zobacz dlaczego nie są synchronizowane ani otwierane w programie Explorer kopiowanie lub przenoszenie informacji o wersji?

Eksplorator plików to system zarządzania plikami systemu Windows, którego używasz na pulpicie. Możesz otwierać SharePoint biblioteki w Eksploratorze plików, a także przenosić lub kopiować pliki i foldery z folderów pulpitu do SharePoint. Możesz również otworzyć wiele bibliotek programu SharePoint w Eksploratorze plików, a między nimi kopiować lub przenosić między folderami.

Uwaga: Jeśli funkcja wymagane jest włączona, może być konieczne tymczasowe wyłączenie jej w celu pobrania wielu plików. Aby uzyskać więcej informacji, zobacz Konfigurowanie biblioteki do wymagania wyewidencjonowywania plików.

  1. W SharePoint Otwórz bibliotekę dokumentów zawierającą plik lub foldery, które chcesz przenieść lub skopiować.

  2. Wykonaj jedną z następujących czynności:

    • W SharePoint Online kliknij menu Widok , a następnie kliknij pozycję Wyświetl w Eksploratorze plików.

      Menu wszystkie dokumenty z wyróżnionym poleceniem Otwórz w Eksploratorze plików
    • W SharePoint Server 2016, SharePoint Server 2013 lub SharePoint Server 2010 kliknij kartę Biblioteka, a następnie kliknij pozycję Otwórz w Eksploratorze.

      SharePoint 2016 Otwórz w Eksploratorze w programie IE11
    • W SharePoint Server 2007 kliknij pozycję akcje Obraz menu , a następnie kliknij pozycję Otwórz w Eksploratorze Windows.

      Opcja menu Otwórz w Eksploratorze Windows w obszarze Akcje

    Uwaga: Wyświetlanie w Eksploratorze plików, otwieranie za pomocą Eksploratorai otwieranie w Eksploratorze Windows działa tylko w programie Internet Explorer 10 lub 11.

  3. Oprócz otwierania w Eksploratorze plików SharePoint Online może również otwierać bibliotekę na innej karcie w trybie klasycznym SharePoint. Możesz zignorować lub zamknąć to okno biblioteki.

    Jeśli wolisz zsynchronizować bibliotekę, możesz uzyskać komunikat podręczny. To wszystko. Po otwarciu biblioteki w Eksploratorze plików folder na pulpicie jest tymczasowy. Jeśli korzystasz z synchronizacji, otrzymasz folder trwały, który pozostanie zsynchronizowany z biblioteką dokumentów. Aby uzyskać więcej informacji, zobacz synchronizowanie plików programu SharePoint za pomocą aplikacji do synchronizacji usługi OneDrive.

  4. Jeśli pojawi się okno dialogowe zabezpieczenia programu Internet Explorer , kliknij pozycję Zezwalaj. Możesz również kliknąć pole wyboru nie pokazuj mi ostrzeżenia dla tego programu .

  5. Otwórz docelowy folder dokumentów i powtórz krok 2.

  6. Teraz, gdy obie biblioteki dokumentów są otwierane w Eksploratorze plików — źródło i miejsce docelowe — możesz kopiować lub przenosić pliki i foldery między nimi.

    Rozmieść dwa okna, aby można było je kopiować lub przenosić między nimi. Możesz wyświetlić oba na ekranie, wykonując następujące czynności:

    • Kliknij okno źródłowe, a następnie naciśnij klawisz Klawisz systemu Windows Przycisk Start w systemie Windows 10 + Strzałka w lewo. Okno powinno być zadokowane do lewej strony ekranu.

    • Powtórz tę czynność w oknie docelowym, a następnie naciśnij klawisz Klawisz systemu Windows Przycisk Start w systemie Windows 10 + Strzałka w prawo Aby zadokować go z prawej strony ekranu. Oba okna powinny być teraz widoczne.

      Umieszczanie folderów Eksploratora obok siebie

    Możesz również zmienić rozmiar okien i zachodzić na nie.

    Nakładające się foldery w systemie Windows
  7. Wykonaj jedną z następujących czynności:

    • Aby skopiować, zaznacz foldery i pliki w źródle, kliknij prawym przyciskiem myszy, a następnie wybierz polecenie Kopiujlub naciśnij klawisze CTRL + C, aby skopiować.

      Kliknij prawym przyciskiem myszy, wybierz polecenie Kopiuj
    • Aby przejść, zaznacz foldery i pliki w źródle, kliknij prawym przyciskiem myszy i wybierz polecenie Wytnijlub naciśnij klawisze Ctrl + X, aby wyciąć.

      Kliknij prawym przyciskiem myszy i wybierz polecenie Wytnij, aby przenieść plik

      Jeśli przenosisz pliki, możesz również zaznaczyć i przeciągnąć pliki z jednego okna Eksploratora plików do innego, zamiast używać funkcji Wytnij i wklej.

    Uwaga: Jeśli biblioteka jest używana do przechowywania wersji, możesz uzyskać dostęp do tylko opublikowanych lub najnowszych dokumentów. Nie można przenosić ani kopiować poprzednich wersji. Aby uzyskać więcej informacji, zobacz dlaczego nie są synchronizowane ani otwierane w programie Explorer kopiowanie lub przenoszenie informacji o wersji?

  8. W folderze docelowym kliknij prawym przyciskiem myszy i wybierz pozycję Wklejlub naciśnij klawisze CTRL + V..

    Kliknij prawym przyciskiem myszy i wybierz polecenie Wklej

    Uwaga: Jeśli nie widzisz opcji Wklej, Wróć do folderu źródłowego, zaznacz odpowiednie pliki i foldery, kliknij prawym przyciskiem myszy i wybierz polecenie Wytnij lub Kopiuj.

    Kopiowanie plików między dwoma oknami Eksploratora plików
  9. Po skopiowaniu lub przeniesieniu wszystkich żądanych plików zamknij oba okna Eksploratora plików. Wprowadzone zmiany plików lub folderów są automatycznie przekazywane do SharePoint.

  10. Powróć do biblioteki docelowej w SharePoint. Jeśli nowe pliki, foldery lub zmiany jeszcze nie pojawiły się, Odśwież stronę.

    Pusta Biblioteka

    Przed skopiowaniem plików

    Biblioteka z plikami skopiowanymi z Eksploratora plików

    Po skopiowaniu plików

Oprócz korzystania z programu Open with Explorermożesz również zsynchronizować bibliotekę z pulpitem. Po zsynchronizowaniu jest uzyskiwana trwała kopia biblioteki SharePoint owej na pulpicie. Pliki można zapisywać bezpośrednio w folderze synchronizowanym i są one automatycznie przekazywane do biblioteki SharePoint, do której jest synchronizowana.

Możesz synchronizować zarówno biblioteki źródłowe, jak i docelowe oraz pracować między nimi. Aby uzyskać więcej informacji, zobacz synchronizowanie plików programu SharePoint za pomocą aplikacji do synchronizacji usługi OneDrive.

Aby dowiedzieć się, jak przekazać pliki, zobacz Przekazywanie folderu lub plików do biblioteki dokumentów. Początek strony

Przechowywanie wersji jest częścią biblioteki SharePoint. Wersje i śledzenie są przechowywane w SharePoint danych, a nie w plikach. Zamiast zastępować starsze pliki podczas ewidencjonowania nowej wersji SharePoint są zachowywane starsze pliki, a także nowsze i odróżniane między nimi za pomocą numerów wersji. Pliki są nadal oddzielone i są śledzone w bibliotece, ale wersje są tylko w bibliotece SharePoint.

Diagram przechowywania wersji

Synchronizacja i otwieranie za pomocą programu Explorer praca z plikami, które zawierają tylko metadane potrzebne dla tego pojedynczego pliku, takie jak Data modyfikacji lub autor. Podczas kopiowania za pomocą programu Open with Explorermożna kopiować lub przenosić tylko pliki oraz ich natychmiastowe informacje. Dodatkowe informacje i inne pliki w SharePoint nie są uwzględniane.

Jeśli używasz SharePoint Online, polecenie Przenieś do powoduje przeniesienie historii przechowywania wersji, ponieważ pracuje on w bibliotece. Przenieś do zachowywania wersji, ponieważ istnieje tylko jedna kopia pliku i struktury. Gdy SharePoint Online przeniesie plik między folderami lub bibliotekami za pomocą funkcji Przenieś do, zawiera wersje i informacje o śledzeniu.

Jednak w SharePoint Online polecenia Kopiuj do jest kopiowany tylko najnowszy plik. Zapobiega to rozdzieleniu historii między dwiema lokalizacjami. Możesz wprowadzić aktualizacje do obu plików, ale zmiany są uwzględniane tylko w tym pliku.

Jeśli kopiujesz pliki, aby zachować kopię zapasową, i chcesz zachować przechowywanie wersji, warto pamiętać o użyciu kopii zapasowej opartej na serwerze SharePoint, a nie opcji ręcznego kopiowania. W ten sposób, jeśli coś się stanie z bieżącymi plikami, można pobrać kopię zapasową SharePoint.

Zarówno synchronizacja, jak i otwarta za pomocą programu Explorer , połącz bibliotekę SharePoint z folderem na pulpicie, mimo że występuje różnica. Otwórz w Eksploratorze korzysta z folderu tymczasowego, który jest otwierany w Eksploratorze plików. Ten folder obowiązuje dopiero po zamknięciu i zapisaniu zawartości w SharePoint. Używanie polecenia Otwórz w Eksploratorze jest dobrą metodą, gdy tylko chcesz wykonać jednorazowy plik lub kopię folderu, a nie potrzebujesz bieżącego folderu lokalnego.

Funkcja synchronizacji używa Aplikacja do synchronizacji usługi OneDrive do tworzenia bardziej trwałego folderu, którego można używać codziennie. Cała zawartość wprowadzona, edytowana lub usunięta z biblioteki lub folderu pulpit zostanie automatycznie zsynchronizowana z inną lokalizacją. Na przykład po zsynchronizowaniu biblioteki możesz zapisać ją bezpośrednio z programu Word lub Excel w folderze lokalnym, a wszystko jest automatycznie przekazywane do biblioteki SharePoint. Jeśli pracujesz w trybie offline, synchronizacja uaktualni SharePoint bibliotekę od razu po powrocie do trybu online.

Aby uzyskać więcej informacji na temat synchronizacji, zobacz synchronizowanie plików programu SharePoint z nową aplikacją do synchronizacji usługi OneDrive.

Więcej informacji

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×