ORAZ, funkcja

Użyj funkcji ORAZ, jednej z funkcji logicznych, aby sprawdzić, czy wszystkie warunki w teście mają wartość PRAWDA.

Przykład

Przykłady funkcji ORAZ

Funkcja ORAZ zwraca wartość PRAWDA, jeśli wszystkie jej argumenty mają wartość PRAWDA, lub FAŁSZ, jeśli choć jeden z jej argumentów ma wartość FAŁSZ.

Typowym zastosowaniem funkcji ORAZ jest rozszerzenie użyteczności innych funkcji służących do wykonywania testów logicznych. Na przykład funkcja JEŻELI wykonuje testy logiczne i zwraca jedną wartość, jeśli wynik testu ma wartość PRAWDA, a inną, jeśli wynikiem testu będzie FAŁSZ. Użycie funkcji ORAZ jako argumentu test_logiczny funkcji JEŻELI umożliwia testowanie wielu różnych warunków zamiast tylko jednego.

Składnia

ORAZ(wartość_logiczna1; [wartość_logiczna2];...)

W składni funkcji ORAZ występują następujące argumenty:

Argument

Opis

Wartość_logiczna1

Argument wymagany. Pierwszy warunek do sprawdzenia pod kątem PRAWDA czy FAŁSZ.

Wartość_logiczna2; ...

Argumenty opcjonalne. Dodatkowe warunki do sprawdzenia pod kątem PRAWDA czy FAŁSZ (maksymalnie do 255 warunków).

Uwagi

  • Argumenty powinny zwracać wartości logiczne (takie jak PRAWDA czy FAŁSZ) albo być tablicami lub odwołaniami zawierającymi wartości logiczne.

  • Jeśli którykolwiek z argumentów tablicowych lub odwołaniowych zawiera tekst lub puste komórki, wartości te są pomijane.

  • Jeśli określony zakres nie zawiera wartości logicznych, funkcja oraz zwraca wartość #VALUE! .

Przykłady

Oto kilka ogólnych przykładów użycia samej funkcji ORAZ, a także w połączeniu z funkcją JEŻELI.

Przykłady użycia funkcji JEŻELI z funkcją ORAZ

Formuła

Opis

=ORAZ(A2>1;A2<100)

Wyświetla wartość PRAWDA, jeśli wartość w komórce A2 jest większa niż 1 ORAZ mniejsza niż 100. W przeciwnym razie wyświetla wartość FAŁSZ.

=JEŻELI(ORAZ(A2<A3;A2<100);A2;"Wartość jest spoza zakresu")

Wyświetla wartość znajdującą się w komórce A2, jeśli jest ona mniejsza niż wartość znajdująca się w komórce A3 ORAZ mniejsza niż 100. W przeciwnym razie wyświetla komunikat „Wartość jest spoza zakresu”.

=JEŻELI(ORAZ(A3>1;A3<100);A3;"Wartość jest spoza zakresu")

Wyświetla wartość w komórce A3, jeśli jest większa niż 1 i mniejsza niż 100, w przeciwnym razie wyświetla komunikat. Możesz zastąpić dowolną wiadomość.

Obliczanie premii

Poniżej przedstawiono dość typowy scenariusz, w którym należy sprawdzić, czy sprzedawcy kwalifikują się do uzyskania premii, przy użyciu funkcji JEŻELI i ORAZ.

Przykłady obliczania premii za sprzedaż za pomocą funkcji JEŻELI i ORAZ.  Formuła w komórce E14: =JEŻELI(ORAZ(B14>=$B$7;C14>=$B$5);B14*$B$8;0)
  • =JEŻELI(ORAZ(B14>=$B$7,C14>=$B$5),B14*$B$8,0)JEŻELI wartość łącznej sprzedaży jest większa lub równa (>=) wartości docelowej sprzedaży ORAZ wartość kont jest większa lub równa (>=) wartości docelowej konta, pomnóż wartość łącznej sprzedaży przez % premii. W przeciwnym razie zwróć wartość 0.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Tematy pokrewne

Klip wideo: Zaawansowane funkcje
Jeżeli Dowiedz się, jak używać funkcji zagnieżdżonych w formule
,Jeśli funkcja
lub funkcja
nie działa
wzarysie formuł w programie Excel

Jak unikać formuł nieuszkodzonychwykrywa błędy w formułach
skróty klawiaturowe w
programie Excelfunkcje logiczne (odwołanie)
funkcje programu Excel (w kolejności alfabetycznej)Funkcje programu Excel (według kategorii)

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×