Odtwarzanie animacji programu Adobe Macromedia Flash w prezentacji

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Jeśli grafika animowana została utworzona za pomocą programu Adobe Macromedia Flash i zapisany jako plik z rozszerzeniem SWF Shockwave, można odtworzyć ten plik w prezentacji programu PowerPoint.

Dodawanie pliku Flash do prezentacji w programie PowerPoint 2010 i nowszym osadzanie lub pliku na slajdzie.

Uwagi: 

  • Mogą występować pewne ograniczenia w programie PowerPoint, łącznie z używaniem efekty specjalne (takie jak cienie, odbicia, efekty poświaty, krawędzie wygładzone, skosy i obrót 3-w), zanikanie i funkcji Usuń.zbędne.odstępy i możliwości Aby skompresować te pliki przy użyciu programu Flash Łatwiejsze udostępnianie i rozpowszechniania.

  • Program PowerPoint 2010 w wersji 64-bitowej wersji nie jest zgodny z 32-bitowej wersji programu QuickTime lub Flash. Należy zainstalować 64-bitowej wersji programu QuickTime lub Flash lub 32-bitowej wersji programu PowerPoint 2010.

Osadzanie pliku Flash

  1. W widoku Normalny kliknij slajd, w którym chcesz osadzić wideo.

  2. Na karcie Wstawianie w grupie Multimedia kliknij strzałkę pod pozycją wideo, a następnie kliknij pozycję wideo na moim komputerze lub klip wideo z pliku.

  3. W oknie dialogowym Wstawianie wideo Znajdź i kliknij plik wideo, który chcesz osadzić, a następnie kliknij przycisk Wstaw.

  4. Aby wyświetlić podgląd animacji Flash, na karcie Formatowanie w obszarze Narzędzia wideo kliknij przycisk Odtwórz.

Łącze do pliku Flash

  1. W widoku Normalny na karcie Slajdy kliknij slajd, do którego chcesz dodać klip wideo lub animowany plik GIF.

  2. Na karcie Wstawianie w grupie Multimedia kliknij strzałkę w obszarze Wideo.

  3. Kliknij pozycję wideo na moim komputerze lub klip wideo z pliku, Znajdź i kliknij plik, który ma zostać utworzone łącze.

  4. Kliknij strzałkę w dół na przycisku Wstaw, a następnie kliknij polecenie Łącze do pliku.

    Ważne: Aby zapobiec ewentualnym problemom z przerwanymi łączami, warto skopiować pliki wideo do tego samego folderu, w którym znajduje się prezentacja, i tworzyć łącza do tych plików.

  5. Aby wyświetlić podgląd animacji Flash, na karcie Formatowanie w obszarze Narzędzia wideo kliknij przycisk Odtwórz.

Aby dodać plik SWF w programie PowerPoint 2007, należy użyć formantu ActiveX o nazwie Shockwave Flash Object i programu Adobe Macromedia Flash Player. Aby odtworzyć plik Flash, dodać formant ActiveX do slajdu i utworzyć łącze z go na plik Flash.

Ustawienia zabezpieczeń formantów ActiveX znajdują się w Centrum zaufania, w którym można znaleźć ustawienia zabezpieczeń i prywatności dla programów Microsoft Office 2007. Może być konieczne dopasowanie ustawień zabezpieczeń, aby zezwolić na uruchamianie formantów ActiveX. Ustawienia kontrolek ActiveX w Centrum zaufania dotyczą wszystkich produktów Office 2007. Na przykład w programie PowerPoint, to ustawienie jest również zmiana dla innych programów pakietu Office, które za pomocą Centrum zaufania. Aby uzyskać więcej informacji o formantach ActiveX i zmienianie ustawień zobacz Włączanie lub wyłączanie ustawień kontrolek ActiveX w plikach pakietu Office.

Ważne: 

  • Shockwave Flash Object musi być zarejestrowany na komputerze można było odtworzyć plik Flash w prezentacji. Aby sprawdzić, czy Shockwave Flash Object jest zarejestrowany, na karcie Deweloper w grupie formanty kliknij przycisk Więcej formantów Obraz przycisku . Jeśli Shockwave Flash Object znajduje się na liście kontrolek, jest zarejestrowany na komputerze. Jeśli nie jest zarejestrowany, Pobierz najnowszą wersję programu Flash Player z sieci Web programu Adobe witryn do rejestrowania Shockwave Flash Object na komputerze.

  • W celu zagwarantowania prawidłowego działania złożonych animacji zainstaluj najnowszą wersję programu Flash Player, nawet jeśli na komputerze są zarejestrowane starsze wersje kontrolki Shockwave Flash Object.

Dodawanie pliku Flash do prezentacji

  1. Zainstaluj program Flash Player na komputerze.

  2. W widoku normalnym programu PowerPoint wyświetl slajd, na którym chcesz odtwarzać animację.

  3. Kliknij Przycisk pakietu Microsoft Office Obraz przycisku pakietu Office , a następnie kliknij polecenie Opcje programu PowerPoint.

  4. Kliknij pozycję Popularne, a następnie w obszarze Najczęściej używane opcje w pracy z programem PowerPoint zaznacz pole wyboru Pokaż kartę Deweloper na wstążce i kliknij przycisk OK.

  5. Na karcie Deweloper w grupie formanty kliknij przycisk Więcej formantów Obraz przycisku .

  6. Na liście kontrolek kliknij pozycję Shockwave Flash Object, kliknij przycisk OK, a następnie przeciągnij na slajd, aby narysować kontrolkę.

    Zmień rozmiar kontrolki, przeciągając uchwyty zmiany rozmiaru.

  7. Kliknij prawym przyciskiem myszy kontrolkę Shockwave Flash Object, a następnie kliknij polecenie Właściwości.

  8. Na karcie Alfabetyczne kliknij właściwość Film.

  9. W kolumnie wartości (pusta komórka obok właściwości Film) wpisz pełną ścieżkę wraz z nazwą pliku (na przykład C\:MojPlik.swf) lub adres URL pliku Flash, który chcesz odtworzyć.

  10. Aby ustawić szczegółowe opcje odtwarzania animacji, wykonaj poniższe czynności, a następnie zamknij okno dialogowe Właściwości:

    • Aby plik był odtwarzany automatycznie po wyświetleniu slajdu, zmień wartość właściwości Odtwarzanie na Prawda. Jeśli plik Flash ma wbudowaną kontrolkę Uruchom/Przewiń, można ustawić wartość właściwości Odtwarzanie na Fałsz.

    • Jeśli animacja powinna odtworzyć się tylko raz, zmień wartość właściwości Pętla na Fałsz.

Wyświetlanie podglądu animacji w widoku Pokaz slajdów

  • Na karcie Widok w grupie Widoki prezentacji kliknij przycisk Pokaz slajdów lub naciśnij klawisz F5.

    Aby zakończyć pokaz slajdów i powrócić do widoku normalnego, naciśnij klawisz ESC.

Uwagi: 

  • W przeciwieństwie do obrazów i rysunków pliki Flash są zawsze połączone z prezentacji w programie PowerPoint 2007, a nie osadzony w nim. Po wstawieniu połączonego pliku programu PowerPoint tworzy łącze do bieżącej lokalizacji tego pliku. Jeśli później plik zostanie przeniesiony do innej lokalizacji, nie zlokalizowanie go w celu odtworzenia w programie PowerPoint. Jest dobrym rozwiązaniem jest skopiować pliki Flash do tego samego folderu, w którym znajduje się prezentacja, zanim wstawisz Flash plików. Program PowerPoint tworzy łącze do pliku Flash i można znaleźć plik Flash, jak się pozostawienie jej w folderze prezentacji, nawet jeśli przenoszenie lub kopiowanie folderu na inny komputer. Innym sposobem upewnij się, że wszystkie pliki połączone będą w tym samym folderze, w którym znajduje się prezentacja jest użycie funkcji Spakuj na dysk CD. Ta funkcja skopiowanie wszystkich plików do jednej lokalizacji (dysku CD lub folderu) razem z prezentacją i automatyczne zaktualizowanie wszystkich łączy do plików. Jeśli prezentacja zawiera pliki połączone, należy skopiować pliki połączone, a także prezentacji Jeśli zamierzasz nadać prezentację na innym komputerze lub wysyłanie go pocztą e-mail.

  • Produkty innych firm omawiane w tym artykule są wytwarzane przez dostawców niezależnych od firmy Microsoft i firma Microsoft nie udziela jakichkolwiek gwarancji, dorozumianych ani innych, co do ich wydajności i niezawodności.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×