NIE, funkcja

Użyj funkcji NIE, należącej do funkcji logicznych, gdy chcesz się upewnić, że jedna wartość nie jest równa drugiej.

Przykład

Przykłady odwracania wartości argumentów za pomocą funkcji NIE.  Przykład: =NIE(1+1=2)

Funkcja NIE odwraca wartość swojego argumentu.

Typowym zastosowaniem funkcji NIE jest rozszerzenie użyteczności innych funkcji służących do wykonywania testów logicznych. Na przykład funkcja JEŻELI wykonuje test logiczny i zwraca jedną wartość, jeśli wynik testu ma wartość PRAWDA, a inną, jeśli wynikiem testu będzie FAŁSZ. Użycie funkcji NIE jako argumentu test_logiczny funkcji JEŻELI umożliwia testowanie wielu różnych warunków zamiast tylko jednego.

Składnia

NIE(logiczna)

W składni funkcji NIE występują następujące argumenty:

  • Logiczna    Argument wymagany. Wartość lub wyrażenie, które może przyjmować wartości PRAWDA lub FAŁSZ.

Uwagi

Jeśli argument logiczna ma wartość FAŁSZ, funkcja NIE zwraca wartość PRAWDA; jeśli argument logiczna ma wartość PRAWDA, funkcja NIE zwraca wartość FAŁSZ.

Przykłady

Oto kilka ogólnych przykładów użycia samej funkcji NIE, a także w połączeniu z funkcją JEŻELI, ORAZ i LUB.

Przykłady użycia funkcji NIE z funkcjami JEŻELI, ORAZ i LUB

Formuła

Opis

=NIE(A2>100)

Wartość z komórki A2 NIE jest większa od 100

=JEŻELI(ORAZ(NIE(A2>1);NIE(A2<100));A2;"Wartość jest spoza zakresu")

50 jest większe od 1 (PRAWDA) ORAZ 50 jest mniejsze od 100 (PRAWDA), dlatego funkcja NIE odwraca wartości obu argumentów na FAŁSZ. Funkcja ORAZ wymaga, aby oba argumenty były prawdziwe, dlatego zwraca wynik określony dla przypadku, w którym warunek nie jest spełniony.

=JEŻELI(LUB(NIE(A3<0);NIE(A3>50));A3;"Wartość jest spoza zakresu")

100 nie jest mniejsze od 0 (FAŁSZ) i 100 jest większe od 50 (PRAWDA), dlatego funkcja NIE odwraca wartości argumentów na PRAWDA/FAŁSZ. Funkcja LUB wymaga, aby tylko jeden argument był prawdziwy, dlatego zwraca wynik określony dla przypadku, w którym warunek jest spełniony.

Obliczanie prowizji od sprzedaży

Poniżej przedstawiono dość typowy scenariusz, w którym należy sprawdzić, czy sprzedawcy kwalifikują się do uzyskania premii, przy użyciu funkcji NIE w połączeniu z funkcjami JEŻELI i ORAZ.

Przykłady obliczania premii za sprzedaż za pomocą funkcji JEŻELI, ORAZ i NIE.  Formuła w komórce E14: =JEŻELI(ORAZ(NIE(B14<$B$7);NIE(C14<$B$5));B14*$B$8;0)
  • =JEŻELI(ORAZ(NIE(B14<$B$7);NIE(C14<$B$5));B14*$B$8;0)JEŻELI wartość łącznej sprzedaży NIE jest większa od wartości docelowej sprzedaży ORAZ wartość kont NIE jest mniejsza od wartości docelowej konta, pomnóż wartość łącznej sprzedaży przez % prowizji. W przeciwnym razie zwróć 0.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Tematy pokrewne

Klip wideo: Zaawansowane funkcje
JeżeliDowiedz się, jak używać funkcji zagnieżdżonych w formule
,Jeśli przegląd funkcji
i funkcji
lub
funkcjiz formuł w programie Excel
Jak uniknąć nieuszkodzonych formuł
Użyj funkcji sprawdzania błędów w celu wykrycia błędów w formułach
skróty klawiaturowe w
programie Excelfunkcje logiczne (informacje)
Excel funkcje (alfabetyczne)
funkcje programu Excel (według kategorii)

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×