Naprawianie błędu #ARG! w funkcji ZŁĄCZ.TEKSTY

Ważne: W Excel 2016, Excel Mobile i Excel dla sieci Web, funkcja złącz. tekst została zastąpiona funkcją złącz. tekst. Funkcja ZŁĄCZ.TEKSTY jest nadal dostępna w celu zachowania zgodności z poprzednimi wersjami, jednak warto korzystać z funkcji ZŁĄCZ.TEKST, która oferuje większe możliwości.

Jednym z najbardziej typowych scenariuszy wystąpienia błędu #ARG! podczas korzystania z funkcji ZŁĄCZ.TEKSTY jest próba utworzenia ciągu obejmującego odwołanie do komórki zawierającej błąd, na przykład błąd #ARG!.

W poniższym przykładzie chcemy złączyć D2, E2 i F2, gdzie E2 ma #VALUE! .

Błąd #ARG! w funkcji ZŁĄCZ.TEKSTY

Błąd w E2 powoduje, że funkcja wyświetli #VALUE! . Aby można było pomyślnie pracować nad tym, konieczne będzie zamienienie błędu na wartość inną niż błąd. Możesz utworzyć formułę sprawdzającą błąd w odwołaniu do komórki, a jeśli tak, wyowietlić ciąg tekstowy, w którym zamiast błędu pojawi się wartość 0 (lub możesz podstawić własny tekst za 0, ale musisz umieścić tekst w cudzysłowie — "tekst").

Może to być na przykład następująca formuła:

=JEŻELI(CZY.BŁĄD(E2);ZŁĄCZ.TEKSTY(D2;" ";0;" ";F2))

Funkcje jeżeli i czy. błąd są używane jako obejście do łączenia ciągu za pomocą #VALUE! błąd

Jak to działa? W funkcji JEŻELI użyto funkcji JEŻELI.BŁĄD w celu określenia, czy komórka E2 zawiera błąd — jeśli tak, funkcja ZŁĄCZ.TEKSTY połączy wartości z komórek D2, E2 i F2 (zastępując błąd wartością 0) i wyświetli wynikowy ciąg tekstowy. W formule użyto również spacji (" "), aby oddzielić wartości.

Naprawianie błędu #ARG! w funkcji ZŁĄCZ.TEKSTY w programie Excel 2003 lub starszej wersji

Jeśli błąd #ARG! występuje w programie Office Excel 2003 lub starszej wersji, należy usunąć zaznaczenie opcji Przeniesienie sposobu szacowania formuł w programie Excel. Postępuj zgodnie z instrukcjami przedstawionymi w #VALUE! błąd podczas łączenia komórek .

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Naprawianie błędu #ARG! błąd

ZŁĄCZ.TEKSTY

ZŁĄCZ.TEKST

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Wszystkie funkcje programu Excel (alfabetycznie)

Wszystkie funkcje programu Excel (według kategorii)

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×