Naprawianie błędu #ARG! w funkcji ZŁĄCZ.TEKSTY

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Ważne: W programie Excel 2016, aplikacji Excel Mobile i aplikacji Excel Online funkcja ZŁĄCZ.TEKSTY została zastąpiona przez funkcję ZŁĄCZ.TEKST. Funkcja ZŁĄCZ.TEKSTY jest nadal dostępna w celu zachowania zgodności z poprzednimi wersjami, jednak warto korzystać z funkcji ZŁĄCZ.TEKST, która oferuje większe możliwości.

Jednym z najbardziej typowych scenariuszy wystąpienia błędu #ARG! podczas korzystania z funkcji ZŁĄCZ.TEKSTY jest próba utworzenia ciągu obejmującego odwołanie do komórki zawierającej błąd, na przykład błąd #ARG!.

W poniższym przykładzie chcemy złączyć komórki D2, E2 i F2, a komórka E2 zawiera błąd #ARG!.

Błąd #ARG! w funkcji ZŁĄCZ.TEKSTY

Błąd w E2 powoduje, że funkcja wyświetlania #VALUE! błąd. Aby, aby działała pomyślnie należy zastąpić wartość niż błąd błąd. Można utworzyć formułę, która sprawdza, czy komunikat o błędzie w odwołaniu do komórki, a jeśli tak, Wyświetl ciąg tekstowy, gdzie 0 jest wyświetlana zamiast błędów (lub można zastąpić tekst 0, ale należy zawinąć tekst w cudzysłowie — "I tekst").

Może to być na przykład następująca formuła:

=JEŻELI(CZY.BŁĄD(E2);ZŁĄCZ.TEKSTY(D2;" ";0;" ";F2))

Funkcje JEŻELI i CZY.BŁĄD zastosowane jako obejście w celu złączenia ciągu w przypadku wystąpienia błędu !ARG#

Jak która działa? Funkcja Jeżeli funkcja Jeżeli.Błąd ustalić, czy występuje błąd w E2, a jeśli istnieje, funkcji ZŁĄCZ.teksty łączy wartości w D2, E2 i F2 (funkcja zamienia błąd 0) i wyświetlenie wyniku ciąg tekstowy. Uwaga formuła używa też spacji ("") ułatwiające oddzielanie wartości.

Naprawianie błędu #ARG! w funkcji ZŁĄCZ.TEKSTY w programie Excel 2003 lub starszej wersji

Jeśli występują #VALUE! Błąd Office Excel 2003 lub w starszych wersjach, będzie konieczne zaznaczenie opcji przejścia obliczeń przy użyciu formuły (TFE) w Excel. Postępuj zgodnie z instrukcjami podanymi w #VALUE! błąd podczas łączenia komórkach Aby rozwiązać ten problem.

Masz pytanie dotyczące konkretnej funkcji?

Zadaj pytanie na forum społeczności programu Excel

Pomoc w ulepszaniu programu Excel

Masz sugestie dotyczące możliwości ulepszenia następnej wersji programu Excel? Jeśli tak, zapoznaj się z tematami w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Naprawianie błędu #ARG!

ZŁĄCZ.TEKSTY

ZŁĄCZ.TEKST

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Wszystkie funkcje programu Excel (lista alfabetyczna)

Wszystkie funkcje programu Excel (według kategorii)

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×