Naprawianie błędu #ADR!

Naprawianie błędu #ADR!

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

#REF! błędu pokazuje, gdy formuła odwołuje się do komórki, która jest nieprawidłowy. Dzieje się tak najczęściej używane podczas komórki, które zostały odwołują się formuły uzyskiwanie usunięte lub wklejony nad.

Przykład — błąd #ADR! spowodowany przez usunięcie kolumny.

W poniższym przykładzie w kolumnie E jest używana formuła: =SUMA(B2;C2;D2).

Formuła używająca jawnego odwołania do komórki, taka jak =SUMA(B2;C2;D2), może powodować błąd #ADR!, jeśli kolumna zostanie usunięta.

W przypadku Usuń kolumnę B, C i D wyniku #REF! błąd. W tym przypadku zostanie usunięty kolumny C (2007 sprzedaż), a wzór otrzymuje teraz =SUM(B2,#REF!,C2). Kiedy używać jawnych odwołań do komórek tak (w przypadku, gdy odwołanie dotyczy pojedynczo każdej komórki, oddzielając je spacją) i usuwanie odwołania wiersza lub kolumny, program Excel nie może rozpoznać, więc zwraca #REF! błąd. To jest podstawowy powód, dlaczego używanie jawnych odwołań do komórek w funkcji nie jest zalecane.

Przykład błędu #ADR! spowodowanego przez usunięcie kolumny.

Rozwiązanie

  • W razie przypadkowego usunięcia wierszy lub kolumn możesz od razu kliknąć przycisk Cofnij na pasku narzędzi Szybki dostęp (lub nacisnąć klawisze CTRL+Z), aby je przywrócić.

  • Dostosowywanie formułę tak, aby korzystała odwołanie do zakresu zamiast pojedynczych komórek, na przykład =SUM(B2:D2). Teraz można usunąć dowolnej kolumny w zakresie Suma, a program Excel automatycznie dostosuje formułę. Można też użyć =SUM(B2:B5) sumy wierszy.

Przykład — funkcja WYSZUKAJ.PIONOWO z odwołaniami do nieprawidłowego zakresu

W poniższym przykładzie formuła =WYSZUKAJ.PIONOWO(A8;A2:D5;5;FAŁSZ) zwróci błąd #ADR!, ponieważ szuka zwracanej wartości w kolumnie 5, ale zakres odwołania to A:D, a więc obejmuje tylko 4 kolumny.

Przykład formuły WYSZUKAJ.PIONOWO z nieprawidłowym zakresem. Formuła ma postać: =WYSZUKAJ.PIONOWO(A8;A2:D5;5;FAŁSZ). W zakresie funkcji WYSZUKAJ.PIONOWO nie ma kolumny piątej, więc 5 powoduje błąd #ADR!.

Rozwiązanie

Dopasowywanie zakresu być większa lub zmniejsz wartość kolumny odnośnika w celu pasuje do zakresu odwołania. =VLOOKUP(a8,a2:E5,5,FALSE) jest prawidłowym odwołaniem zakresie, jak = VLOOKUP(A8,A2:D5,4,FALSE).

Przykład — funkcja INDEKS z nieprawidłowym odwołaniem do wiersza lub kolumny

W tym przykładzie formuła =INDEKS(B2:E5;5;5) zwraca błąd #ADR!, ponieważ zakres funkcji INDEKS to 4 wiersze na 4 kolumny, ale formuła próbuje zwrócić wartość z piątej kolumny i piątego wiersza.

Przykład formuły INDEKS z odwołaniem do nieprawidłowego zakresu. Formuła ma postać: =INDEKS(B2:E5;5;5), ale zakres to tylko 4 wiersze na 4 kolumny.

Rozwiązanie

Dostosowywanie odwołań wiersza lub kolumny, aby były w zakresie wyszukiwania INDEKSU. =INDEX(B2:E5,4,4) zwróci prawidłowej wartości w wyniku.

Przykład — odwołanie do zamkniętego skoroszytu za pomocą funkcji ADR.POŚR

W poniższym przykładzie funkcja ADR.POŚR próbuje odwołać się do skoroszytu, który jest zamknięty, co powoduje błąd #ADR!.

Przykład błędu #ADR! spowodowanego przez odwołanie ADR.POŚR do zamkniętego skoroszytu.

Rozwiązanie

Otwórz skoroszyt, której dotyczy odwołanie. Ten sam błąd będzie wystąpić, jeśli odwołanie dotyczy zamkniętym skoroszycie przy użyciu tablicy dynamicznej funkcji.

Problemy z OLE

Jeśli używasz linku OLE (Object Linking and Embedding, łączenie i osadzanie obiektów), który zwraca błąd #ADR!, uruchom program, który jest wywoływany tym linkiem.

Uwaga: OLE to technologia, która umożliwia współdzielenie informacji między programami.

Problemy z DDE

Jeśli użyto tematu dynamicznej wymiany danych (DDE, Dynamic Data Exchange), która zwraca #REF! błąd, sprawdź pierwszy, upewnij się, że masz odwoływanie się do poprawnego tematu. Jeśli nadal #REF! błąd, sprawdź Ustawienia Centrum zaufania dla zawartości zewnętrznej jako przedstawionych w Blokowanie lub odblokowywanie zawartości zewnętrznej w dokumentach pakietu Office.

Uwaga: Dynamicznej wymiany danych (DDE, Dynamic Data Exchange)jest protokołem wskazanych wymiany danych między programami systemu Microsoft.

Problemy dotyczące makr

Jeśli makro wprowadza w arkuszu, który odwołuje się do komórki powyżej funkcji, a komórka zawierająca funkcję znajduje się w wierszu 1, funkcja zwróci wartość #REF! ponieważ nie istnieje żadna z komórek powyżej wiersza 1. Sprawdź funkcję użytkownikom, jeśli argument odnosi się do komórki lub zakresu komórek, który jest nieprawidłowy. Może to wymagać edycji makra w języku Visual Basic Editor (VBE) podjęcie takiej sytuacji do konta.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach przy użyciu opcji sprawdzania błędów

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×