Korzystanie z funkcji SUMA.ILOCZYNÓW do sumowania iloczynów odpowiadających sobie wartości w jednej lub wielu tablicach

Uwaga:  Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Suma używa zakresów komórek (lub tablice) jako argumenty (części formuły ułatwiające pracy). Mnoży ze sobą elementów w tablicach, a następnie sumę wynik.

Niniejszy przykład to lista zakupów. Jedna z tablic zawiera cenę poszczególnych pozycji, a druga — liczbę pozycji do kupienia.

Ceny i ilości do pomnożenia, a następnie zsumowania

  1. Aby utworzyć formułę, wpisz ciąg = suma.iloczynów(B3:B6,C3:C6) , a następnie naciśnij klawisz Enter.

Każda komórka w kolumnie B zostanie pomnożona przez odpowiadającą jej komórkę w kolumnie C, a wyniki zostaną zsumowane. Łączna kwota zakupów wynosi 21,60 zł.

  1. Aby napisać dłuższą formułę, która zawiera ten sam wynik, wpisz = B3 * C3 + B4 * C4 + B5 * C5 + B6 * C6 i naciśnij klawisz Enter.

Po naciśnięciu klawisza Enter uzyskujemy ten sam wynik: 21,60 USD. Komórka B3 jest mnożona przez komórkę C3, a wynik jest dodawany do wyniku mnożenia komórki B4 przez C4 itd. Nietrudno sobie wyobrazić, o ile łatwiej jest skorzystać z funkcji SUMA.ILOCZYNÓW w przypadku tysięcy (czy nawet setek) wierszy.

Uwagi: 

  • Kolumny lub wiersze (tablice) muszą mieć jednakową długość.

  • Jeśli w komórce znajduje się tekst zamiast wartości liczbowej, przyjmowana jest wartość zerowa.

Przykład

Jeśli chcesz poeksperymentować z funkcją Suma.iloczynów i tablicami, Oto Excel Online skoroszytu zawierającego inne dane niż używane w tym artykule.

Skopiuj przykładowe dane do poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter. Jeśli to konieczne, możesz dostosować szerokości kolumn, aby wyświetlić pełne dane.

A

B

G

U

3

4

2

7

8

6

6

7

1

9

5

3

Formuła

Wynik

'=SUMA.ILOCZYNÓW(A2:B4;D2:E4)

=SUMA.ILOCZYNÓW(A2:B4;D2:E4)

Mnoży wszystkie składniki dwóch tablic (A2:B4 i D2:E4) i następnie dodaje iloczyny, czyli 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3 (156).

W celu pełniejszego środowiska pracy możesz otworzyć ten skoroszyt w programie Excel. Po prostu kliknij ikonę programu Excel w prawym dolnym rogu skoroszytu Ikona programu Excel w aplikacji Excel Web App , Zapisz plik w dogodnym miejscu na komputerze, a następnie otwórz go.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×