Korzystanie z funkcji JEŻELI z funkcjami ORAZ, LUB i NIE

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Funkcja JEŻELI umożliwia logiczne porównanie wartości z oczekiwanym wynikiem przez sprawdzenie, czy warunek jest spełniony, czy nie.

  • = JEŻELI (jakieś wyrażenie jest prawdziwe, to wykonaj określone działanie, a w przeciwnym razie wykonaj inne działanie)

Ale co jeśli musisz sprawdzić wiele warunków, gdzie Załóżmy, że wszystkie warunki, o których trzeba być wartość PRAWDA lub FAŁSZ (a) lub tylko jeden warunek musi być wartość PRAWDA lub FAŁSZ (lub) lub Jeśli chcesz sprawdzić, jeśli warunek nie spełnia kryteria ? Wszystkie funkcje 3 mogą być używane samodzielnie, ale bardziej często, aby wyświetlić ich skojarzone z funkcji Jeżeli.

Użyj funkcji JEŻELI wraz z funkcjami ORAZ, LUB i NIE, aby wykonać wiele obliczeń, czy warunki mają wartości Prawda, czy Fałsz.

Składnia

  • JEŻELI(ORAZ()) — JEŻELI(ORAZ(wartość_logiczna1; [wartość_logiczna2]; ...); wartość_jeżeli_prawda; [wartość_jeżeli_fałsz]))

  • JEŻELI(LUB()) — JEŻELI(LUB(wartość_logiczna1; [wartość_logiczna2]; ...); wartość_jeżeli_prawda; [wartość_jeżeli_fałsz]))

  • JEŻELI(NIE()) — JEŻELI(NIE(wartość_logiczna1); wartość_jeżeli_prawda; [wartość_jeżeli_fałsz]))

Nazwa argumentu

Opis

test_logiczny (wymagane)

Warunek, który ma zostać sprawdzony.

wartość_jeżeli_prawda (wymagane)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość PRAWDA.

wartość_jeżeli_fałsz (opcjonalne)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość FAŁSZ.

Poniżej przedstawiono omówienia struktury oraz, lub i nie funkcji pojedynczo. Połączenie każdego z nich ich za pomocą instrukcji Jeżeli czytać tak jak poniżej:

  • ORAZ — =JEŻELI(ORAZ(jakieś wyrażenie jest prawdziwe; jakieś inne wyrażenie jest prawdziwe); wartość jeśli prawda; wartość jeśli fałsz)

  • LUB — =JEŻELI(LUB(jakieś wyrażenie jest prawdziwe; jakieś inne wyrażenie jest prawdziwe); wartość jeśli prawda; wartość jeśli fałsz)

  • NIE — =JEŻELI(NIE(jakieś wyrażenie jest prawdziwe); wartość jeśli prawda; wartość jeśli fałsz)

Przykłady

Poniżej przedstawiono przykłady niektóre typowe zagnieżdżonej instrukcji IF(AND()), IF(OR()) i IF(NOT()). ORAZ i lub funkcji może obsługiwać maksymalnie 255 poszczególne warunki, ale nie jest dobrym rozwiązaniem jest użyć więcej niż kilku, ponieważ złożonych, zagnieżdżonych formuły można uzyskać bardzo trudne do tworzenia, testowanie i utrzymywania. Funkcja nie ma tylko jeden warunek.

Przykłady użycia funkcji JEŻELI z funkcjami ORAZ, LUB i NIE do szacowania wartości liczbowych i tekstowych

Oto formuły zapisane zgodnie z ich logiką:

Formuła

Opis

=JEŻELI(ORAZ(A2>0;B2<100);PRAWDA;FAŁSZ)

Jeśli w komórce A2 (25) jest większa niż 0, a B2 (75) jest mniejsza niż 100, a następnie zwraca wartość TRUE, w przeciwnym razie zwracana wartość FAŁSZ. W tym przypadku oba warunki są prawdziwe, dlatego zwracana jest wartość PRAWDA.

=JEŻELI(ORAZ(A3="Czerwony";B3="Zielony");PRAWDA;FAŁSZ)

Jeśli A3 ("niebieski") = "Czerwony", a B3 ("zielony") jest równa "Zielone" zwracany jest PRAWDA, w przeciwnym razie zwraca wartość FAŁSZ. W tym przypadku tylko pierwszy warunek jest prawdziwy, dlatego zwracana jest wartość FAŁSZ.

=JEŻELI(LUB (A4>0;B4<50);PRAWDA;FAŁSZ)

Jeżeli A4 (25) jest większa niż 0, lub B4 (75) jest mniejsza niż 50, a następnie zwraca wartość TRUE, w przeciwnym razie zwracana wartość FAŁSZ. W tym przypadku tylko pierwszy warunek ma wartość PRAWDA, ale ponieważ lub tylko wymaga jednego argumentu być wartość PRAWDA, formuła zwraca wartość PRAWDA.

=JEŻELI(LUB(A5="Czerwony";B5="Zielony");PRAWDA;FAŁSZ)

Jeżeli A5 ("niebieski") jest równe "Czerwony" lub B5 ("zielony") jest równa "Zielone" zwracany jest PRAWDA, w przeciwnym razie zwraca wartość FAŁSZ. W tym przypadku drugi argument ma wartość PRAWDA, więc formuła zwraca wartość PRAWDA.

=JEŻELI(NIE(A6>50);PRAWDA;FAŁSZ)

Jeżeli A6 (25) nie jest większa niż 50, a następnie zwracana wartość PRAWDA, w przeciwnym razie zwraca wartość FAŁSZ. W tym przypadku 25 nie jest większe niż 50, więc formuła zwraca wartość PRAWDA.

=JEŻELI(NIE(A7="Czerwony");PRAWDA;FAŁSZ)

JEŻELI wartość komórki A7 („Niebieski”) NIE równa się „Czerwony”, zwróć wartość PRAWDA, w przeciwnym razie zwróć wartość FAŁSZ.

Należy zauważyć, że wszystkie przykłady nawias zamykający po wprowadzeniu ich odpowiednich warunków. Następnie pozostają pozostałe argumenty PRAWDA i FAŁSZ jako części zewnętrzne instrukcji Jeżeli. Można także zastąpić wartości tekstowe lub liczbowe dla wartości PRAWDA i FAŁSZ mają zostać zwrócone w przykładach.

Oto kilka przykładów użycia funkcji ORAZ, LUB i NIE do obliczania dat.

Przykłady użycia funkcji JEŻELI z funkcjami ORAZ, LUB i NIE do szacowania dat

Oto formuły zapisane zgodnie z ich logiką:

Formuła

Opis

=JEŻELI(A2>B2;PRAWDA;FAŁSZ)

Jeśli A2 jest większa niż B2, zwracana wartość PRAWDA, w przeciwnym razie zwraca wartość FAŁSZ. 14-03-12 jest większa niż 14-01-01, więc formuła zwraca wartość PRAWDA.

=JEŻELI(ORAZ(A3>B2;A3<C2);PRAWDA;FAŁSZ)

Jeśli A3 jest większa niż B2 i A3 jest mniejsza niż C2, zwraca wartość TRUE, w przeciwnym razie zwraca wartość FALSE. W tym przypadku oba argumenty są prawdziwe, więc formuła zwraca wartość PRAWDA.

=JEŻELI(LUB(A4>B2;A4<B2+60);PRAWDA;FAŁSZ)

Jeśli A4 jest większa niż A4 lub B2 jest mniejsza niż B2 + 60, zwraca wartość TRUE, w przeciwnym razie zwracana wartość FAŁSZ. W tym przypadku pierwszy argument jest prawdziwe, ale drugi jest fałszywe. Ponieważ tylko lub jeden z argumentów jest PRAWDA, formuła zwraca wartość PRAWDA. Jeśli korzystasz z Kreatora Szacuj formułę na karcie formuły pojawi się, jak program Excel oblicza formuły.

=JEŻELI(NIE(A5>B2);PRAWDA;FAŁSZ)

Jeżeli A5 nie jest większa niż B2, zostanie zwrócona wartość TRUE, w przeciwnym razie zwracana wartość FAŁSZ. W tym przypadku A5 jest większa niż B2, więc formuła zwraca wartość FAŁSZ.

Przykład Kreatora Szacowanie formuły

Używanie funkcji ORAZ, LUB i NIE z formatowaniem warunkowym

Można również użyć AND, OR i nie zostaną ustawione kryteria formatowanie warunkowe z wybraną opcją formuły. Po wykonaniu tej można pominąć funkcji jeżeli i używanie AND, OR, a nie na własne.

Na karcie Narzędzia główne kliknij pozycję Formatowanie warunkowe > Nowa reguła. Następnie wybierz opcję ",Użyj formuły do określenia komórek, które należy sformatować", wprowadź formułę i zastosować format wybranych przez użytkownika.

Formatowanie warunkowe > Okno dialogowe Edytowanie reguły wyświetlające metodę formuły

Korzystając z wcześniejszego przykładu z datami, oto jak wyglądałyby te formuły.

Przykłady użycia funkcji ORAZ, LUB i NIE jako testów formatowania warunkowego

Formuła

Opis

=A2>B2

Jeśli wartość komórki A2 jest większa niż wartość komórki B2, sformatuj komórkę, w przeciwnym razie nic nie rób.

=ORAZ(A3>B2;A3<C2)

Jeśli wartość komórki A3 jest większa niż wartość komórki B2 ORAZ wartość komórki A3 jest mniejsza niż wartość komórki C2, sformatuj komórkę, w przeciwnym razie nic nie rób.

=LUB(A4>B2;A4<B2+60)

Jeśli wartość komórki A4 jest większa niż wartość komórki B2 LUB wartość komórki A4 jest mniejsza niż wartość komórki B2 plus 60 (dni), sformatuj komórkę, w przeciwnym razie nic nie rób.

=NIE(A5>B2)

Jeśli A5 nie jest większa niż B2, sformatuj komórkę, w przeciwnym razie nic. W tym przypadku A5 jest większa niż B2, tak więc wynik będzie zwracana wartość FAŁSZ. W przypadku Zmień formułę do =NOT(B2>A5) go zwraca wartość PRAWDA, a komórka będzie sformatowana.

Uwaga: Typowych błędów należy wprowadzić formułę do formatowania warunkowego bez znaku równości (=). W takim przypadku pojawi się, że okno dialogowe Formatowanie warunkowe spowoduje dodanie znaku równości i ofert do formuła — = "OR(A4>B2,A4<B2+60)", więc musisz usunąć cudzysłowu przed formuła będzie odpowiadał poprawnie.

Początek strony

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Zobacz klip wideo na temat korzystania z funkcji Jeżeli

Dowiedz się, jak używać zagnieżdżonych funkcji w formule

JEŻELI

ORAZ

LUB

NIE

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Skróty klawiaturowe w programie Excel dla systemu Windows

Skróty klawiaturowe w programie Excel dla komputerów Mac

Funkcje logiczne (informacje)

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×