Kopiowanie formuły przez przeciąganie uchwytu wypełniania w programie Excel dla komputerów Mac

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Formuły można szybko kopiować do przylegających komórek, używając uchwytu wypełniania.

Uchwyt wypełniania

Podczas przeciągania uchwytu do innych komórek program Excel wyświetla różne wyniki dla każdej komórki.

Kopiowanie formuły przez przeciąganie uchwytu wypełniania

Wykonaj następujące czynności:

  1. Zaznacz komórkę zawierającą formułę, którą chcesz wypełnić przylegające komórki.

  2. Zatrzymaj kursor w prawym dolnym rogu, tak aby zmienił się w znak plus (+):

    Kursor znajdujący się na uchwycie wypełniania

  3. Przeciągnij uchwyt wypełniania w dół, w górę lub przez komórki, które chcesz wypełnić. W tym przykładzie poniżej na rysunku pokazano, przeciągając uchwyt wypełniania w dół:

    Kursor, przy użyciu którego jest przeciągany w dół uchwyt wypełniania

  4. Po zwolnieniu przycisku formuła jest automatycznie wypełniana w innych komórkach:

    Pokazane są wartości komórek, które zostały wypełnione

  5. Aby zmienić sposób wypełniania komórek, kliknij przycisk Opcje Autowypełniania Przycisk Opcje Autowypełniania wyświetlany po zakończeniu przeciągania i wybierz odpowiednią opcję.

Aby uzyskać więcej informacji na temat kopiowania formuł, zobacz Kopiowanie i wklejanie formuły do innej komórki lub innego arkusza.

Porady: 

  • Można również nacisnąć klawisze Ctrl + D, aby wypełnić formułę w dół w kolumnie. Najpierw zaznacz komórkę zawierającą formułę, którą chcesz wypełnić, a następnie zaznacz komórki, znajdujących się pod nim, a następnie naciśnij klawisze Ctrl + D.

  • Można również nacisnąć klawisze Ctrl + R, aby wypełnić formułę w prawo w wierszu. Najpierw zaznacz komórkę zawierającą formułę, którą chcesz wypełnić, a następnie zaznacz komórki z prawej strony, a następnie naciśnij klawisze Ctrl + R.

Gdy wypełnianie nie działa

Czasami wypełnianie działa prawidłowo i innym czasie, które nie działa zgodnie z oczekiwaniami. Dlatego ważne jest, aby sprawdzić odwołań do komórek pierwszej komórki.

Odwołania do komórek są po prostu wskaźnikami do innych komórek. Załóżmy na przykład, że pierwsza komórka zawiera następującą formułę:


=SUMA(A1;B1)


A1 i B1 są odwołań względnych. Oznacza to wystarczy, że po wypełnić formułę w dół odwołania zmieni stopniowo z komórki A1, B1 A2, B2 itd., tak jak poniżej:

=SUM(A1,B1)

=SUMA(A2;B2)

=SUM(A3,B3)

Innych przypadkach nie może być z odwołaniami do innych komórek, aby zmienić. Na przykład załóżmy, że chcesz utworzyć odwołanie pierwszej, A1, aby pozostać stałe i B1, aby zmienić podczas przeciągania uchwytu wypełniania. Jeśli jest to możliwe, należy wpisać znak dolara ($) w pierwszym odwołaniu: =SUM($A$1,B1). Znak dolara wymusza zachować wskazująca A1 wypełnienie innych komórek w programie Excel. Oto co będzie wyglądał, takich jak:

=SUMA($A$1;B1)

=SUMA($A$1;B2)

=SUMA($A$1;B3)

Odwołania ze znakiem dolara ($) są nazywane odwołaniami bezwzględnymi. Podczas wypełniania w dół odwołanie do komórki A1 pozostaje stałe, ale program Excel zmienia odwołanie B1 na B2 i B3.

Masz problemy z wyświetleniem uchwytu wypełniania?

Jeśli nie widzisz uchwyt wypełnienia mogą być ukryte. Aby ją wyświetlić:

  1. W menu Excel kliknij polecenie Preferencje.

  2. Kliknij pozycję Edycja.

  3. W obszarze Opcje edycji zaznacz pole Zezwalaj na uchwyt wypełniania oraz przeciąganie i upuszczanie komórek.

Jeśli obliczanie skoroszytu automatyczne nie działa, formuły nie są obliczane podczas wypełniania komórek.

Poniżej przedstawiono sposób włączyć tę funkcję:

  1. W menu Excel kliknij polecenie Preferencje.

  2. Kliknij pozycję Obliczanie.

  3. W oknie dialogowym Opcje obliczania upewnij się, że Automatyczne jest zaznaczone.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×