Klip wideo: widoki przestawne danych w programie Access

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Przeglądarka nie obsługuje klipu wideo. Instalowanie dodatku Microsoft Silverlight, Adobe Flash Player lub programu Internet Explorer 9.

Oprócz widoki, takie jak widok Arkusz danych i formularz program Access udostępnia widoki tabeli przestawnej i wykresu przestawnego ułatwiające podsumowywania i wizualizowanie danych. W tym klipie wideo możemy tworzenie widoków przestawnych na nowe zapytanie, dodać widok wykresu przestawnego do formularza, a następnie dodaj tego formularza do formularza nawigacji tak, aby wykresu przestawnego można łatwo wyświetlać przez użytkowników bazy danych.

Uwaga: Widoki tabeli przestawnej i wykresu przestawnego nie są dostępne w bazach danych sieci web programu Access. Aby uzyskać więcej informacji o bazach danych sieci web zobacz artykuł Tworzenie bazy danych programu Access udostępnianej w sieci Web.

Zawartość klipu wideo

Omówienie

Włączanie tabeli przestawnej i wykresu przestawnego widoków w formularzu

Tworzenie widoku tabeli przestawnej

Wyświetlanie i dostosowywanie widoku wykresu przestawnego

Ustawianie domyślnego widoku obiektu

Wyświetlanie widoku diagramu przestawnego w formularzu lub raporcie

Dodawanie formularza lub raportu do formularza nawigacji

Omówienie

Można tworzyć widoki tabeli przestawnej i wykresu przestawnego na tabel, formularzy i kwerend. Wyświetlanie dostępnych dla danych w tabeli przestawnej lub widoku wykresu przestawnego w zależności od obiektu, dla którego tworzysz widoku.

  • Podczas tworzenia widoku diagramu przestawnego dla formularza w widoku można wyświetlać tylko dane z tego formularza źródła rekordów.

  • Podczas tworzenia widoku PowerPivot dla tabeli w widoku można wyświetlać tylko dane z tej tabeli.

  • Tworzenie widoków diagramu przestawnego w kwerendach oferuje największą elastyczność, ponieważ kwerendy się są bardzo elastyczne i mogą zawierać dane z wielu tabel.

Włączanie tabeli przestawnej i wykresu przestawnego widoków w formularzu

Widoki tabeli przestawnej i wykresu przestawnego nie są domyślnie włączone dla formularzy. Aby włączyć je, użyj następującej procedury:

  1. Kliknij prawym przyciskiem myszy formularz w okienku nawigacji, a następnie kliknij polecenie Widok projektu .

  2. Jeśli arkusz właściwości nie jest jeszcze wyświetlony, naciśnij klawisz F4, aby go wyświetlić.

  3. Na karcie Format arkusza właściwości ustaw właściwości Zezwalaj na widok wykresu przestawnego i Zezwalaj na widok tabeli przestawnej na wartość Tak.

Początek strony

Tworzenie widoku tabeli przestawnej

W tym klipie wideo możemy utworzyć kwerendę, a następnie Utwórz widoki tabeli przestawnej i wykresu przestawnego dla danej kwerendy. Jednak proces jest taki sam, niezależnie od tego, czy użytkownik tworzy widoki dla kwerendy, formularza lub tabelę. Widoki można utworzyć w dowolnej kolejności, ale w tym klipie wideo, możemy uruchomić z tabeli przestawnej.

  1. W okienku nawigacji kliknij dwukrotnie obiekt, dla którego chcesz utworzyć widoki przestawne.

  2. Na karcie Narzędzia główne kliknij pozycję Widok, a następnie kliknij pozycję Widok tabeli przestawnej.

  3. Jeśli lista pól tabeli przestawnej nie jest wyświetlane, na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij pozycję Lista pól.

  4. Określanie pole lub pola, które mają jako nagłówki wierszy w tabeli przestawnej, a następnie przeciągnij je z listy pól tabeli przestawnej do strefy upuszczania Upuść pola wierszy tutaj.

  5. Określanie pole lub pola, które mają jako nagłówków kolumn w tabeli przestawnej, a następnie przeciągnij je z listy pól tabeli przestawnej do strefy upuszczania Upuść pola kolumn tutaj.

  6. Jeśli chcesz mieć możliwość filtrowania danych według niektórych pól, przeciągnij te pola z listy pól tabeli przestawnej do strefy upuszczania Upuść pola filtru tutaj.

  7. Na koniec określić, które pole, dla którego chcesz wyświetlić szczegóły lub dane podsumowania, a następnie przeciągnij go do strefy upuszczania Upuść sum lub szczegółów tutaj pola.

Domyślnie program Access wyświetli rekordy szczegółów, chyba że tworzenie sum. Aby utworzyć sumy wierszy i kolumn:

  1. W tabeli przestawnej kliknij jedną z wartości szczegółów.

  2. Na karcie Projektowanie w grupie Narzędzia kliknij przycisk Autosumowanie, a następnie wybierz typ obliczeń.

Aby ukryć komórki szczegółów i wyświetlenia tylko sumy:

  1. Kliknij nagłówek kolumny dla pola szczegółów. Na przykład jeśli komórki danych szczegółowych są oparte na polu Kwota, kliknij nagłówek kolumny Kwota.

  2. Na karcie Projektowanie w grupie Pokazywanie/ukrywanie kliknij pozycję Ukryj szczegóły.

Aby usunąć pole z tabeli przestawnej:

  • Kliknij nagłówek wiersza lub pola nagłówka kolumny, a następnie na karcie Projektowanie w grupie Aktywne pole kliknij pozycję Usuń pole.

Wyświetlanie i dostosowywanie widoku wykresu przestawnego

Podczas tworzenia widoku tabeli przestawnej, również Trwa tworzenie widoku wykresu przestawnego w tle. Jednak prawdopodobnie będzie trzeba dostosować widok wykresu przestawnego umożliwia wyświetlanie danych, tak aby była łatwe do odczytania. Aby wyświetlić na wykresie przestawnym:

  • Na karcie Narzędzia główne kliknij pozycję Widok, a następnie kliknij polecenie Widok wykresu przestawnego.

Dostosuj wykres, korzystając z narzędzi na karcie Projektowanie. Firma Microsoft w tym klipie wideo, wykonaj następujące czynności:

  • Przełącznik wiersza i nagłówków kolumn    Na karcie Projektowanie w grupie Aktywne pole kliknij pozycję Przełącz wiersz/kolumnę.

  • Zmienianie typu wykresu   NaProjektowanietab wTypkliknij pozycjęZmienianie typu wykresu. Wybierz typ wykresu, a następnie zamknij okno dialogowe właściwości.

  • Wyświetlanie legendy   NaProjektowanietab wPokaż/Ukryjkliknij pozycjęLegendy.

  • Ukrywanie strefy upuszczania   NaProjektowanietab wPokaż/Ukryjkliknij pozycjęStrefy upuszczania.

  • Formatowanie elementów wykresu   elementy wykresu, należą między innymi kolor tła i tytuły osi.Wybierz element wykresu, który chcesz zmienić, a następnie naProjektowanietab wNarzędziakliknij pozycjęArkusz właściwości. Wprowadź odpowiednie zmiany, a następnie zamknij okna dialogowego właściwości.

Początek strony

Ustawianie domyślnego widoku obiektu

Po utworzeniu widoki przestawne obiektu, można ustawić właściwość widok domyślny jeden z widoków pivot pojawia się przy każdym otwarciu obiektu. Dzięki temu, że widoku PowerPivot jest wyświetlany, jeśli obiekt został dodany do formularza lub raportu.

  1. Kliknij prawym przyciskiem myszy obiekt w okienku nawigacji, a następnie kliknij polecenie Widok projektu.

  2. Jeśli arkusz właściwości nie jest jeszcze wyświetlony, naciśnij klawisz F4, aby go wyświetlić.

  3. Jeśli pracujesz z kwerendą, kliknij pusty obszar Konstruktora kwerend, aby Właściwości kwerendy zostanie wyświetlony arkusz właściwości.

  4. Ustaw właściwości Widok domyślnytabeli przestawnej lub wykresu przestawnego, w zależności od widoku, które mają być wyświetlane.

Początek strony

Wyświetlanie widoku diagramu przestawnego w formularzu lub raporcie

  1. W okienku nawigacji kliknij prawym przyciskiem myszy formularz lub raport, do którego chcesz dodać widok diagramu przestawnego, a następnie kliknij polecenie Widok układu.

  2. Przeciągnij obiekt, który zawiera widok diagramu przestawnego z okienka nawigacji do formularza lub raportu.

Uwaga: Jeśli nie jest wyświetlany w widoku diagramu przestawnego, upewnij się, została ustawiona jako widok domyślny dla obiektu (zobacz poprzedniej sekcji).

  1. Zmienianie rozmiaru widoku PowerPivot, aż wygląda tak jak chcesz.

  2. Zapisz i zamknij formularz lub raport.

Początek strony

Dodawanie formularza lub raportu do formularza nawigacji

W tym klipie wideo firma Microsoft dodanego widoku wykresu przestawnego do formularza, a następnie jest dodawana tego formularza do formularza nawigacji, który został utworzony wcześniej. Aby uzyskać więcej informacji na temat tworzenia formularza nawigacji zobacz artykuł Tworzenie formularza nawigacji.

Początek strony

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×