Formuły i funkcje

JEŻELI, funkcja

JEŻELI, funkcja

Uwaga: Staramy się udostępniać najnowszą zawartość Pomocy w Twoim języku tak szybko, jak to możliwe. Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Prosimy o powiadomienie nas, czy te informacje były pomocne, u dołu tej strony. Oto angielskojęzyczny artykuł do wglądu.

Funkcja JEŻELI jest jedną z najbardziej popularnych funkcji programu Excel, która umożliwia tworzenie logicznych porównań wartości z oczekiwanymi wynikami.

Instrukcja JEŻELI może zatem generować dwa wyniki. Pierwszy wynik otrzymamy, jeśli porównanie jest prawdziwe, a drugi — jeśli porównanie jest fałszywe.

Na przykład działanie formuły =JEŻELI(C2="Tak";1;2) jest następujące: JEŻELI(C2 = Tak, to zwróć wartość 1, a w przeciwnym razie zwróć wartość 2).

Przeglądarka nie obsługuje klipu wideo. Instalowanie dodatku Microsoft Silverlight, Adobe Flash Player lub programu Internet Explorer 9.

Użyj funkcji JEŻELI, jednej z funkcji logicznych, aby zwrócić jedną wartość, jeśli warunek jest prawdziwy, lub inną wartość, jeśli jest fałszywy.

JEŻELI(test_logiczny;wartość_jeżeli_prawda;[wartość_jeżeli_fałsz])

Na przykład:

  • =JEŻELI(A2>B2;"Budżet przekroczony";"OK")

  • =JEŻELI(A2=B2;B4-A4;"")

Nazwa argumentu

Opis

test_logiczny    (wymagane)

Warunek, który ma zostać sprawdzony.

wartość_jeżeli_prawda    (wymagane)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość PRAWDA.

wartość_jeżeli_fałsz    (opcjonalne)

Wartość, która ma zostać zwrócona, jeśli wynik argumentu test_logiczny ma wartość FAŁSZ.

Proste przykłady działania funkcji JEŻELI

Komórka D2 zawiera formułę =JEŻELI(C2="Tak";1;2)
  • =JEŻELI(C2="Tak";1;2)

W powyższym przykładzie działanie formuły w komórce D2 jest następujące: JEŻELI(C2 = Tak, to zwróć wartość 1, a w przeciwnym razie zwróć wartość 2)

Komórka D2 zawiera formułę =JEŻELI(C2=1;"Tak";"Nie")
  • =JEŻELI(C2=1;"Tak";"Nie")

W tym przykładzie formuła w komórce D2 jest następująca: Jeżeli (C2 = 1, a następnie zwracana jest wartość tak, w przeciwnym razie, w przeciwnym razie, zwrot niejest wyświetlany), można użyć funkcji jeżeli w celu oszacowania tekstu i wartości. Można jej również używać do oceny błędów. Oprócz porównywania wyrażeń i zwracania pojedynczych wyników można również używać operatorów matematycznych i wykonywać dodatkowe obliczenia w zależności od używanych kryteriów. Można również zagnieżdżać szereg funkcji JEŻELI w celu wykonywania wielokrotnych porównań.

Formuła w komórce D2: =JEŻELI(C2>B2;”Budżet przekroczony”;”W ramach budżetu”)
  • =JEŻELI(C2>B2;”Budżet przekroczony”;”W ramach budżetu”)

W powyższym przykładzie działanie funkcji JEŻELI w komórce D2 jest następujące: JEŻELI(wartość w komórce C2 jest większa niż wartość w komórce B2, to zwróć „Budżet przekroczony”, a w przeciwnym razie zwróć „W ramach budżetu”)

Formuła w komórce E2: =JEŻELI(C2>B2;C2-B2;"")
  • =JEŻELI(C2>B2;C2-B2;0)

Na powyższej ilustracji zamiast wyniku tekstowego zostanie zwrócone wyrażenie matematyczne. Działanie formuły w komórce E2 jest następujące: JEŻELI(wartość rzeczywista przekracza koszty według budżetu, to odejmij koszty według budżetu od wartości rzeczywistej, a w przeciwnym razie nic nie zwracaj).

Formuła w komórce F7: JEŻELI(E7="Tak";F5*0,0825;0)
  • =JEŻELI(E7="Tak";F5*0,0825;0)

W tym przykładzie działanie formuły w komórce F7 jest następujące: JEŻELI(E7 = "Tak", to przemnóż wartość łącznej kwoty w komórce F5 przez 8,25%, a w przeciwnym razie zwróć wartość 0, ponieważ podatek od sprzedaży nie jest naliczany)

Uwaga: Jeśli zamierzasz używać tekstu w formułach, musisz otoczyć tekst cudzysłowem (np. "tekst"). Jedynym wyjątkiem jest użycie wartości PRAWDA lub FAŁSZ, która program Excel automatycznie rozpoznaje.

Typowe problemy

Problem

Przyczyna

0 (zero) w komórce

Brak argumentu wartość_jeżeli_prawda lub wartość_jeżeli_fałsz. Aby była wyświetlana prawidłowa wartość, dodaj tekst argumentu do obu argumentów lub dodaj wartość PRAWDA lub FAŁSZ do argumentu.

#NAZWA? w komórce

Zazwyczaj oznacza to, że formuła jest błędnie wpisana.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Zobacz też

Operatory obliczeń i pierwszeństwo w programie Excel

Używanie w formule funkcji zagnieżdżonych

Korzystanie z funkcji JEŻELI w celu sprawdzenia, czy komórka jest pusta

Korzystanie z funkcji JEŻELI w celu sprawdzenia, czy komórka jest pusta

Klip wideo: zaawansowane funkcje JEŻELI

Funkcja WARUNKI (usługa Office 365, program Excel 2016 lub nowszy)

Zaawansowane funkcje Jeżeli — praca z zagnieżdżonymi formułami i Unikanie pułapek związanych

Szkoleniowe klipy wideo: Zaawansowane funkcje Jeżeli

Funkcja LICZ. Jeżeli zlicza wartości na podstawie pojedynczych kryteriów

Funkcja LICZ. Jeżeli zlicza wartości na podstawie wielu kryteriów

Funkcja suma. suma będzie sumować wartości na podstawie pojedynczych kryteriów

Funkcja suma. sumy będzie sumować wartości na podstawie wielu kryteriów

ORAZ

LUB

WYSZUKAJ.PIONOWO

Omówienie formuł w programie Excel

Jak unikać niepoprawnych formuł

Wykrywanie błędów w formułach

Funkcje logiczne

Funkcje programu Excel (lista alfabetyczna)

Funkcje programu Excel (według kategorii)

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×