JEŻELI.BŁĄD, funkcja

Funkcji jeżeli można używać do zalewkowania i obsługi błędów w formule. Jeżeli zwraca wartość określoną przez użytkownika, jeśli formuła zwraca błąd; w przeciwnym razie zwraca wynik formuły.

Składnia

JEŻELI.BŁĄD(wartość;wartość_jeżeli_błąd)

W składni funkcji JEŻELI.BŁĄD występują następujące argumenty:

  • wartość    Argument wymagany. Argument sprawdzany w poszukiwaniu błędu.

  • value_if_error    Argument wymagany. Wartość, która ma zostać zwrócona, jeśli formuła zwróci błąd. Następujące typy błędów są oceniane: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME? lub #NULL!.

Spostrzeżenia

  • Jeśli argument wartość lub value_if_error jest pustą komórką, jeżeli potraktuje go jako wartość ciągu pustego ("").

  • Jeśli wartość jest formułą tablicową, jeżeli zwraca tablicę wyników dla każdej komórki w zakresie określonym wartością. Zobacz drugi przykład poniżej.

Przykłady

Skopiuj przykładowe dane z poniższej tabeli i wklej je w komórce A1 nowego arkusza programu Excel. Aby formuły wyświetlały wyniki, zaznacz je, naciśnij klawisz F2, a następnie naciśnij klawisz Enter.

Przydział

Liczba sprzedanych sztuk

210

35

55

0

Będąc

Formuła

Opis

Wynik

=JEŻELI.BŁĄD(A2/B2;"Błąd w obliczeniach")

Sprawdza pierwszy argument formuły w poszukiwaniu błędu (dzielenie 210 przez 35), nie znajduje błędu, a następnie zwraca wynik formuły.

6

=JEŻELI.BŁĄD(A3/B3;"Błąd w obliczeniach")

Sprawdza pierwszy argument formuły w poszukiwaniu błędu (dzielenie 55 przez 0), znajduje błąd dzielenia przez 0, a następnie zwraca wartość argumentu wartość_jeżeli_błąd.

Błąd w obliczeniach

=JEŻELI.BŁĄD(A4/B4;"Błąd w obliczeniach")

Sprawdza pierwszy argument formuły w poszukiwaniu błędu (dzielenie "" przez 23), nie znajduje błędu, a następnie zwraca wynik formuły.

0

Przykład 2

Przydział

Liczba sprzedanych sztuk

Stosunek

210

35

6

55

0

Błąd w obliczeniach

Będąc

0

Formuła

Opis

Wynik

=C2

Sprawdza pierwszy argument formuły w pierwszym elemencie tablicy w poszukiwaniu błędu (A2/B2, czyli dzielenie 210 przez 35), nie znajduje błędu, a następnie zwraca wynik formuły.

6

=C3

Sprawdza pierwszy argument formuły w drugim elemencie tablicy w poszukiwaniu błędu (A3/B3, czyli dzielenie 55 przez 0), znajduje błąd dzielenia przez 0, a następnie zwraca wartość argumentu wartość_jeżeli_błąd.

Błąd w obliczeniach

=C4

Sprawdza pierwszy argument formuły w trzecim elemencie tablicy w poszukiwaniu błędu (A4/B4, czyli dzielenie "" przez 23), nie znajduje błędu, a następnie zwraca wynik formuły.

0

Uwaga: Jeśli masz aktualną wersję pakietu Office 365, możesz wprowadzić formułę w lewej części komórki zakresu wyjściowego, a następnie nacisnąć klawisz ENTER, aby potwierdzić formułę jako dynamiczną formułę tablicową. W przeciwnym razie formułę należy wprowadzić jako starszą formułę tablicową, wybierając zakres wyjściowy, wprowadź formułę w komórce znajdującej się w lewym rogu zakresu wyjściowego, a następnie naciśnij klawisze CTRL + SHIFT + ENTER, aby ją potwierdzić. Program Excel wstawia nawiasy klamrowe na początku i końcu formuły. Aby uzyskać więcej informacji na temat formuł tablicowych, zobacz Wskazówki i przykłady dotyczące formuł tablicowych.

Potrzebujesz dodatkowej pomocy?

Zawsze możesz zadać pytanie ekspertowi w społeczności technicznej programu Excel, uzyskać pomoc techniczną w społeczności witryny Answers bądź zasugerować nową funkcję lub ulepszenie w witrynie UserVoice dotyczącej programu Excel.

Uwaga:  Ta strona została przetłumaczona automatycznie i może zawierać błędy gramatyczne lub nieścisłości. Chcemy, aby ta zawartość była dla Ciebie przydatna. Czy możesz dać nam znać, czy te informacje były pomocne? Oto angielskojęzyczny artykuł do wglądu.

Rozwijaj umiejętności związane z pakietem Office
Poznaj szkolenia
Uzyskuj nowe funkcje w pierwszej kolejności
Dołącz do niejawnych testerów pakietu Office

Czy te informacje były pomocne?

Dziękujemy za opinię!

Dziękujemy za opinię! Wygląda na to, że połączenie Cię z jednym z naszych agentów pomocy technicznej pakietu Office może być pomocne.

×